User Manual

BSD speclink®e

Building Systems Design, Inc.
Acknowledgements
Table of Contents

Introducing SpecLink-E................................................................................................................................. 1
What is BSD SpecLink®-E?............................................................................................................................ 1
How is SpecLink-E Different from Word Processing?.................................................................................... 1
Differences between SpecLink-E and SpecLink+........................................................................................... 3
Organization of Content................................................................................................................................. 4
Major Productivity Features of the Software .................................................................................................. 11
Software Orientation.................................................................................................................................... 14
Changing the View ......................................................................................................................................... 25
Installation and Setup..................................................................................................................................... 28
Using SpecLink-E Effectively .......................................................................................................................... 35
Preparing Specifications................................................................................................................................. 35
Basic Steps..................................................................................................................................................... 35
Products First, Then Execution, Then General ............................................................................................... 36
Build the Structure First, Then Finish It........................................................................................................ 36
Re-Using Previous Projects........................................................................................................................... 37
How To........................................................................................................................................................... 39
Edit a Project.................................................................................................................................................. 50
Format Your Documents................................................................................................................................. 85
Print the Sections........................................................................................................................................... 103
Print the Table of Contents and Requirements Reports .............................................................................. 111
Export Your Documents................................................................................................................................. 116
Create a Short Form or Outline Spec........................................................................................................... 119
Manage Projects............................................................................................................................................ 124
Create an Office Master Project.................................................................................................................... 136
View and Build Links.................................................................................................................................... 146
Create Choices............................................................................................................................................. 153
Update a Project............................................................................................................................................. 157
Accessing and Using Help............................................................................................................................. 169
Technical Support.......................................................................................................................................... 174
Index............................................................................................................................................................... 175
Introducing SpecLink-E

What is BSD SpecLink-E?

Welcome to a new and better way of managing specifications production for all phases of a building construction project. BSD SpecLink-E is an innovative system for preparing and managing all types of specification documents for buildings. It can be used effectively for all phases of conventional design-bid-build projects, and it is the only specification product incorporating features designed especially for design-build projects. Special Text Type tags allow you to create and print Outline, Short Form or Full Spec specifications, all from the same project.

SpecLink-E comes with a Master database of specifications. When you create a new project, the Master database is the foundation for the new project, and the new project is an empty overlay over the Master database. When you open a project, imagine the project file as overlaying the master database and modifying your view of the contents. When you edit a project, you are editing the overlay, not the master. You can subsequently copy any project to create a new project. In SpecLink-E all information about a project, including all the sections in the project, is contained in a single project.

Because everything about the project is contained in a single project, global decisions such as page format and choice of units of measure can be made in one place. Links between sections are also easy to implement, so this single project structure results in better project coordination. In SpecLink-E you select the text you want from the master database, instead of deleting text you don’t want. Only selected, active text is assembled into the final document and printed; the other text is ignored by the Print and Preview functions. You can also edit master paragraphs and add your own paragraphs.

The major advantage of the SpecLink-E approach, however, is that all the master text is always available for use on future projects. Nothing is ever deleted. In SpecLink-E, when you copy a project for use on another project, you see the entire master as overlaid by the project information. Options not needed on the original project that might apply to the new one are still visible and available for selection, in contrast with the word processing alternative where deleted text is gone forever.

How is SpecLink-E Different from Word Processing?

Although it incorporates many word processing features, SpecLink-E is not a conventional word processor. All information about a project is contained in a unique project created for each new project. This project can be conceptualized as a transparent overlay sheet through which you can read everything in the database. As you select, edit, or add text, notations of these inclusions and deviations from the master are registered in the project file. Through the overlay, your view of the master database is modified to include your entries to the project, but the master database itself is never modified.

The main functional difference between SpecLink-E and word processing is that in SpecLink-E you select the text you want, instead of deleting text you don’t want. Only the selected text is assembled into the final document and printed; other text is ignored by the Print and Preview
functions. You can also edit master paragraphs (edited paragraphs are indicated by a turquoise icon in the Origin status column and a light blue background on the Sequence number column) and add your own paragraphs (indicated by a white icon with blue lines in the Origin column and a dark blue background in the Sequence column).

You can tell at a glance if a paragraph in the Document Panel is active (selected for inclusion, with valid parentage) or inactive (unselected, excluded, or with incomplete parentage). Inactive text appears with a gray background and its status columns are a darker gray. If auto numbering is toggled on, inactive paragraphs remain unnumbered. Selected text has a green square status box (indicating selection by a link), a checkmark in the status box, or both. If the parentage of the selected text is complete, selected text becomes active. It stays black on a white background and its status columns turn a lighter gray. If the style includes autonumbers, paragraph numbers are applied automatically. For most users, selecting text by clicking on its status box is slightly faster than the word processing alternative of blocking and then deleting unwanted text.

The major advantage of this approach is that all the master text is always available for use on future projects. Nothing is ever deleted. When you copy sections or a whole project for use on another project, you copy only the information in the project overlay. When you view the new project file, you see the entire master as overlayed by the project information. Options not needed on the original project that might apply to the new one are still visible and available for selection, in contrast with the word processing alternative. For final content review, you can choose Selected View or Print Preview, which hide any text not included in the project.

When you select text with a cross reference to other text, whether inside or outside that section, the program implements a link. These links are analogous to formulas in an electronic spreadsheet. Links may highlight text for your consideration, automatically include it in the project file, or exclude it as incompatible with an earlier choice. While thousands of these links are already embedded in the database, you can also make your own links to customize the sections to your own specific needs. Links between sections are as easy to build as links within a section, so this single file structure results in better project coordination.

Because all information is contained in a single project, you make decisions that apply to the whole project—page setup, formatting, numbering, headers and footers, and units of measure, for example—in one place. When you print the document, you can choose from standard page formats or create or customize one yourself. The format is applied automatically to each section in the project.

The working environment resembles a document in word processing, except that each paragraph is contained within a separate cell. The status columns to the left of the paragraphs contain additional information about each paragraph, such as its current status or the presence of a note.

Final printed output differs in appearance from the working environment. For instance, the database contains many embedded choices, which are indicated by the use of colored fonts in the Document Panel. Blue text indicates embedded multiple choices that are changed by clicking on the choice and selecting alternative text from the menu displayed. Green text indicates global options that can be changed in the Project Summary Information dialog box. Fill-ins are shown in red, within square brackets. Optional text is shown by means of a special indicator [<>]. When the document is printed, however, these color distinctions and markers disappear. Also, unlike a word processor, SpecLink-E prints only the active selected text. Inactive text (paragraphs that are unselected, excluded, or with incomplete parentage) does not appear in the final hard copy, even though it appears on screen.
Introducing SpecLink-E

Differences between SpecLink-E and SpecLink+

SpecLink-E is very similar to SpecLink+, as far as the output goes, but there are a number of significant differences.

Basic Differences

- SpecLink-E is an SQL application. This means that the server and the client each run a separate part of the application, although both parts can be installed on the same computer for a stand-alone application.
- SpecLink-E interfaces with LinkMan-E.
- Accessing your projects over a Wide Area Network or Virtual Private Network (VPN) is now much faster than it was with SpecLink+.
- All projects are now in one database, rather than each being a separate file. There is an option to send projects to the Archive Database.
- New Permissions Functionality -- There are now four levels of users. This feature is part of the Corporate Edition.
- You must check out a section to make changes to it.
- SpecLink-E uses the new 2010 Microsoft Office style ribbon bar menus.
- SpecLink-E is based on MasterFormat 2004/2012+ and does not support editing in the old MasterFormat 1995 format. See MF95 Output for information on printing using MasterFormat 95 section IDs and titles.
- SpecLink-E displays each section on its own tab in the Document Panel.

Enhancements to Functionality

- Corporate Edition allows the assignment of roles.
- Corporate Edition users can view and/or print editor names and dates in the Document Panel.
- Corporate Edition users can view and print a section listing with the last edit date.
- Corporate users can designate a project as an Office Master to prevent unwanted edits.
- Ability to link to Autodesk Revit via LinkMan-E.
- Ability to export a Submittals log.
- Ability to modify the choice list in a user version of a master paragraph, rather than having to copy the paragraph.
- User Defined Global Terms that can be inserted throughout all of your projects.
- User Defined Tags and reports to allow customized tagging of paragraphs.
- Outline and Short Form Modes allow you to begin with Outline specs and then build on them to create Short Form specs and continue to create the full specification.
- Unlimited number of styles and Project Templates that can be shared among all projects.
- Ability to override the Project Template on a per section basis.
- Ability to designate first page header and footers, as well as section specific headers and footers.
- Zoom view.
- New All Text Draft that differentiates selected from non-selected text.
- The ability to Spell Check the project.
- Enhancements to Find, including Replace All and ability to use Find in the project.
- Inserting images into paragraphs, as well as project notes.
- Inserting hyperlinks into paragraphs, as well as project notes.
- Exporting documents to PDF, Word, RTF, HTML or TXT files.
- Enhanced Table functionality.
Automatic Data Updates
Easier toggling back and forth between Master and User versions of your paragraph by clicking on the Sequence column in the Document Panel
Importing User-added sections from one project to another now places them in the same folder in the target project

Organization of Content

Project Tree

The SpecLink-E content is organized into Divisions based on the 2004/2012+ edition of CSI/CSC’s MasterFormat™. There are 5 main groups of Divisions, each shown on a tab at the left of the Project Tree panel. The tabs are:

- **Front End**, including Division 00 - Procurement and Contracting Requirements, Design Criteria, and Division 01 - General Requirements and Administration, containing the 3-Part Section Template and Unassigned user-created sections.
- **Divisions 02-14** - Facility Construction Subgroup
- **Divisions 21-28** - Facility Services Subgroup
- **Divisions 31-35** - Site and Infrastructure Subgroup
- **Divisions 40-48** - Process Equipment Subgroup (no SpecLink-E content)

Below each Division, the first level of MasterFormat titles are listed as folders to help organize the sections. Many folders are empty because SpecLink-E simply does not include content on those subjects. For more detailed information about the intended use of MasterFormat and a complete list of all its standard numbers and titles, get a copy of MasterFormat at www.masterformat.com.

The Project Tree allows you to navigate through the database and select a section you would like to review or edit. The tree operates exactly like Microsoft’s Windows Explorer. To open a branch, click on the plus sign adjacent to the folder. To close a branch, click on the minus sign. To open a
section in the document panel, single click (or double click depending on your Single Click to Open Setting) on the title of the section in the tree.

The boxes to the left of the section number and title indicate the status of the section in the project. To the right of the section title, the section acronym and catalogs are shown in parentheses. The last date and time the section was edited is shown last. To activate a section without checking it out (opening it) click on the status box in the Project Tree.

If you are selecting a number of sections in a row in the Project Tree, you might want to toggle on Expand on Refresh for the duration of this process.

Toggle the Project Tree on and off by clicking the Project Tree icon in the Panels group on the View tab.

**Folders**

SpecLink-E uses folders to categorize the sections in the master. The Project Tree contains 5 tabs, each with multiple folders for the divisions, subfolders for the Broadscope titles, and all the sections. To open a branch, click on the plus sign adjacent to the folder.

**Move to Folder**

The Move to Folder group in the Project Tree tab allows you to move to the first or last folder in the active branch of the Project Tree. You can also move to the Previous or Next folder at the same level as the current folder. Down One Level and Up One Level allow you to move down or up a level from the currently highlighted folder or section in the Project Tree.

**Expand to Show**

The Expand to Show group in the Project Tree tab allows you to expand all folders in the active branch of the Project Tree, one level of folders, two levels of folders or all folders in a single branch of the tree.

**Expand on Refresh**

Expand on Refresh is a toggle in the Project Tree tab | Expand to Show group that forces the tree to expand completely after changes are made that affect the tree, such as checking a section in or out. It is off by default. You might want to turn it on temporarily if you are going through a project and selecting section after section in the Project Tree.

**The MasterFormat 2004/2012+ Database**

The master specification database is divided into folders that correspond to CSI’s MasterFormat 2004/2012+, plus front end documents. These main folders in turn are divided into Broadscope Heading folders, each of which corresponds to a MasterFormat number and title. Available sections related to each heading are organized under each of these Broadscope folders. They are arrayed in numerical order, using a 6 or 8-digit section number and title based on the 2004/2012+ MasterFormat published by The Construction Specifications Institute (CSI).

The Division folders contain Broadscope Heading folders corresponding to all the broadscope listings in the 2004/2012+ MasterFormat.
The Broadscope Headings, in turn, are parents to the sections that relate to each heading.

**NOTE:** The specification sections, under their respective Broadscope Heading folder, are descriptive specifications organized according to CSI’s 2004/2012+ MasterFormat™. Each specification section is organized consistently using CSI’s three-part format: Part 1 - General, Part 2 - Products, and Part 3 - Execution. Articles under each of these major parts, in turn, are organized consistently with CSI’s SectionFormat™.

**NOTE:** Keep in mind that you cannot modify the SpecLink-E master database directly. You can modify it only by information you place in your project overlay. As a result, you always have a complete database foundation upon which to generate new projects. As you become proficient with the software, you may want to create your own master project file to use as the foundation for new projects.

### Unassigned Sections Folder

In the Administration folder (Front End tab) of the Project Tree, there is a folder called Unassigned Sections. When you Copy a project from SpecLink+, any sections not assigned to a MasterFormat 2004/2012+ folder will appear in the Unassigned Sections folder. You can move the sections from the Unassigned Sections folder to their correct folder.

### Section Titles

Section titles correspond to the titles in MasterFormat 2004/2012+™ for the corresponding section scopes. Where the scope of a section, as described in the title, would not correspond to any title listed in MasterFormat™, an appropriate title is used.

### Section IDs

Most section numbers consist of a number followed by an acronym. Section IDs in the Design Criteria folder consist of the letters DC followed by numbers or letters. Master section numbers in the MasterFormat 2004/2012+ hierarchy consist of 6 or 8 digits. The section ID assigned to each section in the master database is fixed and cannot be changed, except by copying the section to a user section.

To change the format of the section numbers on-screen and in reports, open the Summary Info dialog box and change the Section ID Format.

To change the MF95 Section ID for a user section, check the section in, right click on it in the Project Tree and click on Edit MF95 Section ID.

### CSI's three-part SectionFormat

Most sections are organized according to the Construction Specification Institute’s Three-Part SectionFormat. The Articles in each PART vary from section to section, based on the content of the section. Listed below are the Article titles used when appropriate. The PARTs are always used. The Articles marked with an asterisk * are almost always used. The Articles marked with two asterisks ** are SpecLink-E added titles, not in the 3-Part Format.

**PART 1 GENERAL**

SECTION INCLUDES*

SECTION INCLUDES*
Introducing SpecLink-E

RELATED REQUIREMENTS*
PRICE AND PAYMENT PROCEDURES
ABBREVIATIONS AND ACRONYMS
DEFINITIONS
REFERENCE STANDARDS*
ADMINISTRATIVE REQUIREMENTS
SUBMITTALS*
QUALITY ASSURANCE*
MOCK-UP
DELIVERY, STORAGE, AND HANDLING
FIELD CONDITIONS
WARRANTY

PART 2 PRODUCTS
OWNER-FURNISHED PRODUCTS
MANUFACTURERS*
BASE BID MANUFACTURER**
APPLICATIONS**
SYSTEM/ASSEMBLIES
PRODUCT TYPES
MATERIALS*
ACCESSORIES*
SOURCE QUALITY CONTROL

PART 3 EXECUTION
INSTALLERS
EXAMINATION*
PREPARATION*
INSTALLATION*
TOLERANCES
REPAIR
RESTORATION
RE-INSTALLATION
FIELD QUALITY CONTROL
SYSTEM STARTUP
ADJUSTING
CLEANING
COMMISSIONING**
CLOSEOUT ACTIVITIES
PROTECTION
MAINTENANCE
SCHEDULES
ATTACHMENTS

END OF SECTION

Proprietary Specs

The proprietary sections are free to all SpecLink-E subscribers because they are sponsored by the manufacturers whose products are included.

Except for the fact that proprietary sections are based on specific building products, the sections themselves are otherwise indistinguishable from the non-proprietary sections. All section titles and numbers conform to CSI’s 2004/2012+ MasterFormat™. Section organization follows CSI’s 3-part format. The proprietary sections also are linked within each section, to each other, and to the non-proprietary sections.

Proprietary sections can be identified in the Project Window by looking for section titles in black text, rather than blue, with an acronym (in parenthesis following the title) other than "BSD."

As mentioned previously, there are no obvious differences between the BSD non-proprietary sections and those that are proprietary, except for the fact that the latter are written around specific products. Users can choose to create totally proprietary sections by simply choosing the brand names desired and selecting the option "Substitutions are not acceptable."

On the other hand, virtually all of the proprietary sections include descriptive and performance requirements in addition to brand names. Users who want to use the proprietary sections without limiting bids to the named products can specify on the basis of descriptive or performance criteria
and can either add the names of other acceptable products or allow substitutions with the statement: "Substitutions: See Section 01 6000 - Product Requirements," under the MANUFACTURER article in Part 2.

Probably the best way to use these sections is to employ the sponsoring product as the basis of design, but to allow substitution of equivalent products. Of course, under this scenario, it is important to include enough relevant performance or descriptive information in the specification to help in subsequent evaluation of proposed substitutions. Also, it is very important to establish in Section 01 6000 exactly what procedures the bidders (or contractor) must follow in submitting alternatives to the products named in the specifications.

Subscriptions and Catalogs

Your license to SpecLink-E allows access to the data by Subscription Type, Subscription Mode and by Catalog. An annual subscription allows unlimited access and printing during the subscription period. Your subscription allows access to the catalogs or level of detail that you have purchased.

Subscription Type:

- **Professional** - includes Microsoft SQL Server 2008 R2 Express which is limited to use of 1 GB of memory and a maximum projects database size of 8 GB. Does not include security features that support named users and roles.
- **Corporate Edition** - includes Microsoft SQL Server R2 2008 which can use unlimited memory and unlimited database sizes providing superior performance and response times. Also includes support for named users and user roles, designated Office Masters and viewing of editors' Audit Trail, as well as a Section Listing with Last Edit Date.

Subscription Mode:

- **Short Form Mode** - includes Outline Mode and builds on its text to provide text suitable for the preparation of short form specifications useful early in the design phase and on smaller jobs as the complete specification.
- **Full Specifications Mode** - includes both Outline and Short Form Modes and allows preparation of all types of specifications.

Catalogs:

Each section is part of one or more "Catalogs" available by subscription. Non-proprietary sections are shown in the Tree Panel in blue, while proprietary sections are shown in black. Following the title of the section, the acronym (BSD for non-proprietary sections) and the catalog abbreviations appear in parenthesis.

Construction Specifications are for design-bid-build projects; CSI 3-Part Format specifications organized by CSI's MasterFormat™. All section numbers and titles conform to the 2004/2012+ edition of MasterFormat. The format of all sections conforms to recommendations of CSI's SectionFormat™. All catalogs include introductory information, bidding requirements, contract requirements, and General Requirements. The Comprehensive catalog includes all sections in all disciplines.

The sections are broken down into the following catalogs for subscription purposes:

- **Design Criteria Specifications (D)** - Design Criteria Specifications define building system requirements early in the project using performance and prescriptive statements as applicable to the subject matter.
- **Architectural (A)**
- **Structural (S)**
• Civil (C)
• Landscape Architecture (L)
• Mechanical/Electrical (ME)
Design Criteria

The Design Criteria sections are used to specify the design criteria for buildings of many types. These specs are often referred to as "whole-building" performance specs because they describe the performance of built elements (including the building as a whole) rather than the performance of individual materials or equipment.

Lists of Sections

Two documents that list all the sections in SpecLink-E are maintained on our Subscriber Page.

The catalog listing is available in Adobe Portable Document Format (PDF). Use Find in Adobe Acrobat to search this document for sections you are trying to locate in SpecLink-E.

The checklist document is available in Word format. This document includes a complete list of sections in SpecLink-E, plus includes blank lines for you to list your own sections. This document can be passed around the office at the beginning of a project for people to check off which sections are needed. Additional columns for checkmarks are available for use throughout the project. To open the checklist document, see our Subscriber Page.

Model Project

The model project helps reduce the time you spend getting started or creating a new project. If your project is reasonably similar to our model project, you can save a lot of time by using it as a starting point, instead of starting with a blank project.

In the model project, specifics relating to code requirements and structural loading have been left incomplete to avoid limiting the applicability of the project to one geographic area. Bidding and contract requirements and Division 1 general requirements have been included, based on the assumption that AIA A101 and A201 will be used as the forms of Agreement and General Conditions. No Supplementary Conditions are included. Users who choose to incorporate any or
all of the sections into their projects will need to verify that they are appropriate for their specific application and further edit the sections.

The following model project is installed with the software and is also available for download from our web page (http://wwwbsdsoftlinkcom/library/speclibrary_model_projects.htm):
Platinum School Model Project

**Platinum School Model Project**

A LEED Requirements section has been included to help the designer choose the LEED Credits and specify the products needed to achieve the highest LEED Certification possible. Where design features not properly specified in the project manual are required for certain LEED Credit, notes and other guidance on achieving those Credits are included in the LEED Credit Checklist. Sections most often used in institutional construction are pre-edited for the most common conditions. The edits have been made assuming the following prototypical building:

- A one-story elementary school building of approximately 45,000 square feet.
- Slab-on-grade floor, caisson foundation, and steel-framed roof construction.
- Brick veneer exterior over metal studs, with aluminum storefront framing and tinted insulating glazing.
- Vegetated system over single-ply membrane roofing.
- Metal-framed skylights for daylighting
- EIFS-clad canopy at the building entrance, topped with a metal-framed skylight and single-ply roofing.
- Interior finishes of painted drywall, fire-resistance-rated lay-in acoustical ceiling panels, carpet.
- Hollow metal door frames and flush wood doors.
- Acoustical ceilings
- Terrazzo and tile flooring.
- Site landscaping and sodding, drive and sidewalk paving.
- Typical HVAC, plumbing, and electrical.
- Gymnasium, playground and food service equipment.

**Major Productivity Features of the Software**

**Database Integrity**

Creating or editing a project does not affect the master database. Each project resides in the Projects database is like a transparent overlay containing your selections and changes. When you view or print a section, you are actually seeing the master as modified by the project overlay. Because the information for your project is kept isolated from the master database, it can never accidentally introduce errors into the master database. For the same reason, the information in your project is not affected when the master database is updated, so it can always be read accurately, regardless of age.
Productivity Features

While computerized databases are commonly used for construction scheduling and cost-estimating tasks, SpecLink-E's application of database functions to specification production is unique. Some of the benefits include the following:

- Database Integrity
- Visible Links
- Global Options
- Table of Contents
- Updating Options
- Word Processing Features
- Notes that Don't Get in the Way
- Compare Projects
- Electronic User Manual
- Submittals Log export
- User Defined Tags

Visible Links

Tens of thousands of links in the database make the master database "intelligent." As you select paragraphs for your project, green links add related text, red links exclude incompatible options, and yellow links highlight choices you may wish to make. All of these links are visible in the Links dialog box, so you can tell exactly why a particular paragraph has been included or excluded. You can even add your own links, making your office master project as intelligent as you wish.

Notes that Don't Get in the Way

Context-sensitive notes to the user are designed to give you additional information about choices in the text, helping you make decisions appropriate for your project. The notes do not affect your ability to read and understand the document text, because they appear in separate Notes panels that can be resized or closed. You can also attach notes of your own to any paragraph, including paragraphs you have added. Since notes will print only when you specifically request them, there is no danger that they will be added unexpectedly to a printed document.

Word Processing Features

SpecLink-E allows considerable flexibility in defining the appearance of the finished product. You can choose an automatic paragraph numbering scheme or design your own. You can add customized headers and footers, using optional keywords for variables such as division number, division name, section number, and section title. You can change the font and other text characteristics by paragraph level for your entire specification, using a custom Project Template. You can select portrait or landscape page orientation. A find/replace feature allows you to search for any word or phrase and replace it, if necessary. A spell checker allows you to find errors in any text you add.

Thesaurus

To access the Thesaurus:
- Click on the word you want to replace
• Click your right mouse button
• Choose Synonyms
• Choose one of the options there or
• Choose Thesaurus
• Select the appropriate meaning from the Meanings list
• Choose a word from the right column and click on Replace
• To see synonyms of a word in the Meanings column, click on it and then click on Look Up
• Click on Cancel to dismiss the dialog box without changing anything

Table of Contents

When all sections are complete, or when all sections to be completed have been added to the project, a Table of Contents can be generated.
There are two ways to make a Table of Contents:

• Use the automatically-generated Table of Contents option at the Print Dialog box.
• Use the Table of Content Section, found in the Division 00 folder of the Front End tab in the Project Tree (section 00 0110). This document is printed just like other sections, after you have selected the Sections to be included and added any external documents you need.

Outline, Short Form and Full Spec Mode

All of the paragraphs in the BSD Master belong to one of these three modes. You can change from one mode to the other (depending on your license) by clicking on the Mode group on the View tab. To see the Spec Type Tags, select Spec Type Tags from the Status Columns group on the View tab.

• Outline (OL or UO) - Paragraphs tagged as Outline are designed to be used as an Outline specification.
• Short Form (SF or US) - Paragraphs tagged as Short Form, along with the Outline paragraphs, are designed to be used as a Short Form specification.
• Full Spec (no tag) - All paragraphs are included in the Full Spec mode, including the Outline and the Short Form tagged paragraphs.

When you have switched to Outline or Short Form Mode, your Document report will display only the active paragraphs tagged as OL/UO (Outline) or OL/UO and SF/US (Short Form).

Note: If your section appears corrupt in either Outline or Short Form Mode, run Verify Spec Type Tags from the Tools tab.

Other views which can be combined with Outline, Short Form and Full Spec modes include: Normal View, Selected View, Zoom, Show Text Levels

Updating Options

When you receive updates, you are not required to update any of your projects. Your master will be automatically updated, based on your selected frequency however, so that your new projects will use the most up-to-date data. Archived projects and active projects approaching completion can be opened without updating, because the old master data is not discarded. Pointers in the
database continue to display the old information if you elect not to update a particular project. In the meantime, new projects use the latest data.

**Multi-user Considerations**

You can have as many users with checked-out sections as you have licenses of SpecLink-E.

You can have multiple users working in the same project. However if two users are adding sections or selecting sections at the same time that would result in a change to the Project Tree, you may receive a notice to try your change again later. Upon occasion, the hierarchy can become locked and you may need to use Unlock Documents to release the hierarchy lock.

- Only one user can check out and edit a particular section at a time.
- Only one project can be compared to the master at one time.
- The following functions can only be used by one person at a time in any individual project:
  - Summary Info Dialog Box
  - Edit Project Template (This function can only be used by one person at a time within the entire projects database.)
  - Edit Header/Footer
  - Page Setup

Certain functions, such as Copy from SpecLink+ and Load Project from File (if the project has not been opened against the current master) can impact other users and are best done when other users are not using SLE.

**Electronic User Manual**

The User Manual is available in electronic format and may be downloaded from our Download Center (http://www.bsdsoftlink.com/downloadcenter/userspage.htm) and then printed or loaded onto your hard drive. Using the "find" feature in the PDF Reader edit menu offers you a quick way to "thumb through" the manual electronically, to find something you might remember reading but cannot find in the paper version.

**Software Orientation**

**2010 Microsoft Office Ribbon Bar Menus**

SpecLink-E uses the 2010 Microsoft Office ribbon bar menus. The primary components are:

- **Application Icon** -- SpecLink-E logo, on the top left of the application window. The standard Windows functions of Restore, Move, Size, Minimize, Maximize and Close are accessed from this icon.
- **File Menu** -- Includes global commands and a listing of recent projects, as well as About SpecLink-E.
• **Ribbon** -- This is the primary placement for menus and toolbars. The Ribbon can be minimized by right-clicking on the ribbon, double-clicking on any tab name or using the Minimize icon next to the Help icon on the top right of the application. When minimized, the ribbon bar will reappear when you click on a tab and select a function. Once you have done that, it will disappear again until you click on another tab.

• **Tabs** -- are used to organize controls in the Ribbon. An example is the Home tab, where many commonly used commands are placed. We have 7 tabs including Home, Insert, View, Project Tree, Documents, Format and Tools.

• **Groups** -- Each tab contains one or more groups. (Status Columns is a group on the View tab.)

• **Quick Access Toolbar** -- The Quick Access Toolbar is a row of small icons at the top of the application. You can right-click on any command to add it to the Quick Access Toolbar. Click on the arrow to the right of the Quick Access Toolbar to:
  - Edit the icon positions.
  - Show the Quick Access Toolbar above or below the Ribbon.
  - Minimize or Maximize the Ribbon.

• **Help** -- The Help is accessed by clicking on the small light blue circle with the question mark on the top right corner of the application or by pressing F1.

### About Box

The SpecLink-E About Box has several links and pieces of information. To access the About box, click on the File menu and then on About SpecLink-E.

The following information is available in this box:

- **Server Location** - This will say STANDALONE or will display the name of the server where the Projects Database resides.
- **View Log Files** - Click here to see the various log files created by the client or standalone application.
- **Database Size**: This is the current size of the Projects Database.
- **Total Memory**: This is the total memory on the client or standalone machine running SLE.
- **Available Memory**: This is the available memory on the client or standalone machine.
- **The current version of Windows that the client or standalone machine is running.**
- **Your version of SLE is also listed on this screen. This can be compared to the currently available version displayed on the SLE Start Page.**

### Project Window

When you create a new project or open an existing project file, the Project Window opens. The window has a ribbon bar with tabs and groups across the top and the project tree panel and document panel filling most of the screen.

In the Project Window, both the tree panel and the document panel are open in default view. When a project is first opened, the document panel displays My Start Page, which shows our Specifier’s Library page. As you open sections, they share the Document Panel with My Start Page. You can toggle from one to the other by clicking on the tabs at the top of the Document Panel. You can change this view at any time by closing either panel using the menu choices on the View tab / Panels group.
**Project Tree**
The Project Tree tab includes navigation icons for the tree panel: Up one level, Down one level in the Move to Folder group and Expand To Show One Level, Two Levels, All Levels or Branch in the Expand to Show group. Holding your mouse pointer over the icons will display a brief description of each icon.

**Document Panel**
On the Home tab / Move to Paragraph group are navigation icons for the document panel: move to first paragraph, move to previous paragraph at current level, move to next paragraph at current level, and move to last paragraph. Again, hold your mouse pointer over the icons to identify them. On the View tab / Show Text group are Show Text icons including All Levels, To Level 1, To Level 2 and To Level 3.

You can also adjust the view by resizing the panels. To do so, move the cursor to the vertical bar separating the two panels. When the cursor changes to a vertical bar with left and right arrows, press and hold the left mouse button to "grab" the vertical bar, then drag it left or right to suit your needs.

**Left Side Panels**

The left side of the application window has sub-panels, each of which can be toggled on and off independently using the commands on the View tab:

- Project Tree
- Master Notes
- Project Notes

The panels can also be resized by dragging the gray splitter bars with your mouse.

The entire Left Panel can be turned off and on by clicking the Left Panels button on the View tab | Panels group.

**Auto-hiding and Undocking**

**Auto-hiding**
The Project Tree, The Master Notes and the Project Notes windows can all be hidden so that they disappear to the left of the screen and reappear when you let the cursor hover over the desired tab on the left side of the application window.

- To hide a panel click on the pushpin icon in the top right of that panel.
- To view that panel, let your cursor rest on the desired tab and it will slide into view.
- To keep the panel in view, click on the pushpin icon again.

Note that the Master Notes and the Project Notes hide together.

**Undocking**
To separate the Master Notes and/or Project Notes into an individual window

- Either double-click on the panel or drag them from the tab to the desired location on your desktop.
- To drag them individually, drag from the tab.
- To drag them together, drag from the title bar.
- To reattach them to your application, it is best to double-click on the window title bar.
- To reattach them in a tabbed window after they have been separated, watch for the tab outline before dropping back in place.
Introducing SpecLink-E

Document Panel

The Document Panel shows the text of the current section. To change the number of levels of text that are displayed, click the Show Text buttons on the View tab/Show Text group.

In addition to the text, the Document Panel contains Status columns. Some of the status columns can be toggled on and off by toggling the choice on the View tab/Status Columns group. All columns are listed below in the order they would display from left to right when all are turned on. The letters or character in parentheses is what displays at the top of each column:

- **Sequence Number (#)**: Sequential numbering for each paragraph in the text. (Can be turned on and off. The default is on.) If the sequence number has a colored background, let your mouse hover over it to read the tooltip.
- **Paragraph Level (LVL)**: Indicates the hierarchical level of the paragraph by the number of dots on the die. One is the highest level and eight is the lowest. The hierarchical level determines automatic formatting and parentage. (Can be turned on and off. The default is on.) You can change the Paragraph Level by using Demote or Promote.
- **Notes (N)**: Indicates whether a paragraph has a Master Note and/or a Project Note.
- **Origin (O)**: Indicates whether the paragraph is a master paragraph or a user-added paragraph, and if a master paragraph whether it has been edited or not.
- **Spec Type Tags (T)**: Indicates whether this paragraph is part of the Full Spec, Short Form or Outline Spec Mode (Can be turned on and off. The default is off.)
- **Requirements Tags (R)**: Requirements Tags label paragraphs for various purposes including requirements reports, checklist documents (NP and NS), and summary information dialog box settings. (Can be turned on and off. The default is off.)
- **User Defined Tags (U)**: Users may add as many User Defined Tags as needed. (Can be turned on and off. The default is off.)
- **Status (S)**: Indicates whether any links are active to a paragraph, whether or not the paragraph is active, and is where the user clicks to make a paragraph active or inactive.
Master Notes

The Master Notes panel displays any notes in the master for the paragraph that is clicked on in the Document Panel. The Notes column (N) in the Document panel displays a yellow notebook on the left for every paragraph that has a master note. Master notes can also include hyperlinks to manufacturer's websites, manufacturer's logos, and pictures and diagrams of products.

Toggle the Master Notes panel on and off by clicking on Master Notes in the View tab / Panels group.

Tip: Master notes can be printed with a specification section by selecting the Print Master Notes option in the Print dialog box. When selected to print, the text of each master note prints just before its paragraph in italics with a bold line of asterisks preceding and following each note. It is helpful to print master notes with Draft and Master Text copies.

To copy a Master Note into another paragraph, use Copy Note.

Reference Standards on Demand

BSD has entered into an agreement with another organization -- IHS, Inc. -- which is in the business of gathering information from disparate sources and making it available to various industries, including the construction industry. Under our agreement with IHS, we have provided links to all documents that are available through their IHS Standards Store.

To access the hyperlink for a particular standard, find the citation in Part 1 of the section or any place where the standard is referenced, open the master notes panel, and then click on the
hyperlink. In a few cases, the document itself is available online at no cost. In most cases, however, at least a synopsis of the standard is available, and the document itself can be purchased online. Once purchased, most documents can be viewed or downloaded immediately. A minority of the reference standards will have to be shipped.

**Project Notes**

The Project Notes panel displays any user-added notes for the paragraph that is clicked on in the Document Panel. The Notes column (N) in the Document panel displays a cyan notebook on the right for every paragraph that has a project note.

Toggle the Project Notes panel on and off by clicking the Project Notes icon in the Panels group of the View tab.

**Tip:** Project notes can be printed with a specification section by selecting the *Print Project Notes* option in the Print dialog box. When selected to print, each project note prints just before its paragraph in italics with a bold line of asterisks preceding and following each note. It is helpful to print project notes with Draft copies.

**Adding a Project Note**

When you click in a Project Note, the Project Note Editor opens. Using this editor you have the option of:

- Adding, deleting or editing text in a note.
• Formatting your text with a different font, applying Bold, Italic or Underlining. Note that this formatting will appear in the Project Note while editing the spec, but the text in the note will print using the font and formatting specified in your selected Project Template.
• Inserting or removing a hyperlink.
• Inserting or removing an image.

Inserting or removing a hyperlink in a Project Note

To insert a hyperlink into a Project Note:
• Click on the Project Note for the desired paragraph. The Project Note Editor opens.
• Click on the Insert Hyperlink icon.
• In the Text to Display field type what you want to appear in the Project Note.
• In the Address field, type the web address for the hyperlink.
• Click OK.
• Click on the Save button to save the hyperlink and to continue editing the Project Note.
• Click OK to close the form, which also saves your work.
• Once the hyperlink is in the Project Note, a single click on the hyperlink will bring up the desired web page.
• Note: Hyperlinks will print and export if you have selected Print Project Notes on the Print dialog box. When exporting to PDF, doc, rtf, and html, your hyperlinks will display only the displayed text, but the path is embedded in the hyperlink.

To remove or edit an existing hyperlink:
• Click beside the hyperlink in the Project Note to bring up the Project Note Editor.
• Click on the hyperlink in the Project Note Editor.
• Click on the Insert Hyperlink icon.
• Make any necessary changes, including removing the hyperlink.
• Click on the Save button to save the deletion and to continue editing the Project Note.
• Click OK to close the form, which also saves your work.

Inserting or removing an image in a Project Note

To add an image to a Project Note:
• Click on the Project Note for the desired paragraph. The Project Note Editor opens.
• Place your cursor in the location where the image should be. Images will generally look best when placed on the left side of the dialog box.
• Click on the Insert Image icon.
• The Notes Image dialog box appears.
• If you want to see the images that have been inserted into the BSD Master, click on Load Images from SLE Master.
• If the Image you want to insert is in the list, click on it and click on Insert.
• Note: Images are stored in the database only once, no matter how many times they are referenced in the Project Notes.
• If the Image you want to insert is not in the list, click on Create New.
• When the Open dialog box appears, navigate to the folder where the image is.
• Note that images must be 100K or less. If the image appears too large in the Project Note, it must be re-sized in another application and re-added to the list.
• If necessary, change the file type in the file type drop down box.
• Double click on the image to bring it into the list of images.
• Click on Insert once the image is in the list.
Introducing SpecLink-E

- Click on the Save button to save the inserted image and to continue editing the Project Note.
- Click OK to close the form, which also saves your work.

The following file types may be inserted:
- Windows Bitmap (.bmp)
- Windows Metafile (.wmf)
- Portable Network Graphics (.png)
- JPEG File Interchange Format (.jpg, .jpeg)
- Graphics Interchange Format (.gif)

Note: Images will print and export if you have selected Print Project Notes and Print Note Images on the Print dialog box.

To remove an existing image from a Project Note:
- Click beside the image in the Project Note to bring up the Project Note Editor.
- Click on the image in the Project Note Editor.
- Press the Delete key to remove the image.
- Click on the Save button to save the deletion and to continue editing the Project Note.
- Click OK to close the form, which also saves your work.

To remove an image from the list of Images that may be inserted into a Project Note:
- Click in a Project Note to bring up the Project Note Editor.
- Click on the Insert Image icon.
- Find the image in the list on the left.
- Click on the white box to the left of the image name so that the entire line is highlighted.
- Click on the Delete button to remove the image.
- Click OK to the confirmation.
- If the image is in use, you must remove it from all Project Notes before deleting it.

Note that if you remove an image that is in use in an Archived project, it will not be reinstated when you activate the project.

Copy Note

To copy a note from one paragraph to another paragraph:
Copy Note is in the Notes group on the Home tab. Use Copy Note and then Paste Note to copy a note from one paragraph to another paragraph. You do not have to open the Notes dialog box or click on the Note to use this feature. The Copy Note button is only enabled if you are on a paragraph with at least one note. If there is a master note only, that will be copied. If both notes are present you will be prompted to choose Master, Project, or Cancel. The Paste Note button will be enabled when the clipboard contains a note. Click on the target paragraph and click Paste Note. The note will be copied as a project note on the target paragraph. If the target paragraph has an existing project note it will be replaced. In that case you will receive a confirmation prompt. You can paste a copied note multiple times. You can paste a copied note into any paragraph, section, or project in the database. This feature is also available on the right-click context menu. If you are using the context menu, you need to left-click into the paragraph first and then right-click to bring up the menu. CTRL+N can also be used for Copy Note and CTRL+M can be used for Paste Note.

Delete Note

To delete a note from a paragraph:
Delete Note is in the Notes group on the Home tab. Use Delete Note to delete a Project note from any paragraph. You do not have to open the Notes dialog box or click on the Note to use this feature. The Delete Note button is only enabled if you are on a paragraph with a Project note. Click on the target paragraph and click Delete Note. You will receive a confirmation prompt. This feature is also available on the right-click context menu. If you are using the context menu, you need to left-click into the paragraph first and then right-click to bring up the menu. CTRL+K can also be used for Delete Note.

**Start Page**

When you open the software, the Document Panel is populated by My Start Page, which opens the Building Systems Design SpecLink-E page. This page include links to information on the most recent changes to SpecLink-E, Specifier Resources, etc. When you click on a link within this page, if you want to go back to the previous page, use the Back icon in the Start Page group of the View tab. Use the Forward icon to go in the other direction.

To close My Start Page, click on the X on the top right corner of the page. To re-open the Start Page, click on the Start Page icon in the Start Page group, on the View tab.

**Back Button**

When you have clicked on a hyperlink in our Start Page, and wish to go back to the previous web page, using the View tab, Start Page group, click on Back. Use Forward to go in the opposite direction.

**Forward Button**

When you have clicked on a hyperlink in our Start Page, and then gone back to the previous web page, use the View tab, Start Page group, and click on Forward to go in the opposite direction.
Colors in Project Tree

BSD (non-proprietary) sections appear Blue in the Project Tree.

Proprietary (manufacturer specific) sections appear Black in the Project Tree.

User added or copied sections appear Green in the Project Tree.

Sections that have paragraphs affected by an update are Magenta in the Project Tree.

Right mouse button menu in the Tree Panel

The right mouse button in the Tree Panel includes the following choices, depending on the situation.

- **New Section from Template** - Choosing New Section from Template will add a new section from the section template under the currently highlighted folder or section in the Project Tree.
- **New Section from .DOC** - Choosing New Section From DOC will add a new section from your selected DOC or DOCX file under the currently highlighted folder or section in the Project Tree.
- **New Section from .RTF** - Choosing New Section From RTF will add a new section from your selected RTF file under the currently highlighted folder or section in the Project Tree.
- **Cut Section** - Cut Section will select the currently highlighted (User Added) section in the Project Tree and allow you to follow it with the Paste Section Into command, as a way to move your section to another folder in your project.
- **Copy Section** - Copy Section will select the currently highlighted section in the Project Tree and allow you to follow it with the Paste Section Into command, as a way to copy this section in your project.
- **Paste Section** - Paste Section will paste the previously Cut or Copied Section under the currently highlighted folder or section in the Project Tree.
- **Delete Section** - Delete Selected Section will remove the currently highlighted user added or copied section in the Project Tree.
• **Edit MF95 Section ID** - Available for User added or copied sections only. Enter or edit the MF95 Section ID and/or Section title if you plan to use the MF95 Output option.
• **Check Out Section** - This command will check out the currently selected section.
• **Check In and Close Section** - This command will check in the currently selected section.

**Right mouse button menu in the Document Panel**

The right mouse button in the Document Panel includes the following choices, depending on the situation.

• **Compare to Update** – If this paragraph has a more recent master version, there will be a rust color background in the S column. If you want to apply the master updated paragraph, choose Update, Insert or Remove. Otherwise, choose Close.
• **Copy** - This command copies the current paragraph (and any subparagraphs) and puts it on the Clipboard, with all embedded choices. If you have blocked text in a paragraph, Copy places a copy of only the blocked text on the Clipboard.
• **Cut** - Cut applies only to user-added paragraphs or to text that is blocked in a paragraph. Select the user-added paragraph you want to cut or block the text to remove, and then choose Cut to place it on the Clipboard. This is generally used in conjunction with Paste to move text or a paragraph.
• **Paste** - Paste inserts contents from the Clipboard at the designated position. This can be complete paragraphs or blocked text, depending in where your cursor is positioned.
• **Delete** - If the cursor is blinking in a paragraph, this menu choice deletes a user-added or a user-edited paragraph. In the case of an edited master paragraph, the master text is restored. In the case of an added paragraph, any user-added subparagraphs are also deleted. You are asked to verify the deletion before proceeding. If text is blocked prior to clicking this button, the blocked text is deleted.
• **Copy Note** - Use this (followed by Paste Note) to copy the Master or Project Note from the current paragraph to another paragraph.
• **Paste Note** - Use this (after Copy Note) to paste a Master or Project Note as a Project Note into the current paragraph.
• **Delete Note** - Use this to delete the Project Note from the current paragraph.
• **No Autonumber** - Clicking on a paragraph or highlighting a group of paragraphs, and then choosing this command will suppress the auto-numbers for these paragraphs.
• **Add Paragraph** - Choosing Add Paragraph will insert a new paragraph above the currently highlighted paragraph.
• **Demote** - Use Demote to decrease the hierarchy level by one – from 2 to 3, or from 3 to 4, for example -- moving the text to the right.
• **Demote Branch** - Use Demote Branch to decrease the hierarchy level of a branch of paragraphs.
• **Promote** - Use Promote to increase the hierarchy level by one—from 4 to 3, or from 3 to 2, for example – moving the text to the left.
• **Promote Branch** - Use Promote Branch to increase the hierarchy level of a branch of paragraphs.
• **Insert Table** - Use Insert Table to insert a table above the currently highlighted paragraph.
• **Synonyms** - See Thesaurus
Changing the View

Views

There are a number of different ways to view your documents:
- To view all paragraphs use Normal View and Full Spec View.
- To view by paragraph level, use Show Text Levels.
- To view only active paragraphs, use Selected View.
- To change the size of the document on-screen only, use Zoom.
- To view different columns in the Document Panel, see Status Columns.

Normal View

Normal View is the standard editing view. All paragraphs, whether active or not are displayed. Active paragraphs are displayed with a white background, while inactive paragraphs are displayed with a gray background.

Other views or modes may also be in effect, including:
- Show Text Levels
- Outline, Short Form or Full Spec Mode

Using Show Text Levels

Use Show Text Levels to expand or collapse the text outline format within the Document Panel. Click the "Show Text" buttons in the Show Text group on the View tab to change the number of levels visible. The image above is showing the first 2 levels only.
Selected View

Selected View displays only the active paragraphs, and also excludes non-printing paragraphs tagged as NP or NS. To change from Normal View to Selected View, click on the Selected View icon in the Document group of the View tab.

While in Selected View, you can:

- Add new paragraphs
- Delete paragraphs
- Edit paragraphs
- Make choices
- Insert Page Breaks
- Insert Images
- Edit the Header/Footer

Note that you cannot Cut, Copy or Paste paragraphs or branches in Selected View.
Zoom View

Zoom View (Document group, View tab) allows you to temporarily change the size of the font in your section in the Document Panel. It is designed to help users see the text in a larger or smaller view on screen and does not affect printing. An alternative to Zoom View is to create a Project Template with an extra-large font. Use this Project Template while editing and then switch back to another Project Template for printing.
Installation and Setup

Installation

For the most current installation instructions see the updated installation document on our Download Center.

We recommend that all users apply all important Windows updates on both server and client machines.

Hardware and Software Requirements

- SpecLink-E runs on 32-bit and 64-bit Microsoft Windows environments on Intel-based personal computers. The following describes the hardware and software requirements to operate the software.
- As with any Windows-based application, faster system components and more system memory enable faster performance.
- The speed of the server disk drive is important since the server portion of SpecLink-E is a database-based system.
- Use of a higher resolution video card and monitor enables more information to be displayed on the screen.
- Printers with higher resolution typically do a better job of printing your specifications and often print faster as well.

Recommended server configuration

- Intel-compatible dual- or quad-core processor, 2 GHz or better
- Windows™ Server 2012, 2008 or 2003 SP 2
- 4 GB of memory recommended, with one or more high performance disk drives
- 10 GB minimum of available disk space
- XGA or higher resolution monitor
- DVD reader (only required for Corporate Edition installation)

Note: Preferred Server configuration: 64-bit operating system, and a dual core or equivalent processor. For our Corporate users we have found that 4 GB of RAM on the server devoted to SpecLink-E is sufficient for 2 concurrent users. To maintain performance we recommend that an additional 2 GB of RAM be installed for each additional concurrent user.

Recommended client configuration

- Intel-compatible processor, 2 GHz or better
- Windows™ 8 or 7
- 2 GB of RAM
- 1 GB of available disk space
- XGA or higher resolution monitor
- Laser printer
- Internet Explorer 8.0 or higher

Recommended laptop or standalone configuration (which will run both server and client applications)

- Intel-compatible processor, 2 GHz or better
- Windows™ 8 or 7
Introducing SpecLink-E

• 4 GB of RAM recommended
• 10 GB minimum of available disk space
• XGA or higher resolution monitor
• Laser printer
• Internet Explorer 8.0 or higher

No other software is required. Formatting and printing of sections, project table of contents, and many reports on project requirements all can be accomplished from within the program. If desired, SpecLink-E files may be exported to a word processor, but all intelligence associated with the files is lost when this step is taken. SpecLink-E may be used on a local area network (LAN) or a Wide Area Network (WAN), but the number of users who can have sections checked out is limited by the subscriber’s license agreement.

Running SpecLink-E over a Wide Area Network (WAN)

As a SQL application, SpecLink-E allows you to access the server part of the application over a Wide Area Network (WAN) or a Virtual Private Network (VPN). See the installation instructions on our web page for instructions on configuring your computer to run SpecLink-E over a WAN or a VPN.

Downloading the software

Updates may be downloaded from our web page at our For Customers Page.

1. Click on For Customers from our home page.
2. Click on Download Center (http://www.bsdsoftlink.com/downloadcenter/userspage.htm).
3. Click on Download Now under the SpecLink-E column.
4. Save the file to a temporary folder on your computer.
5. Be sure to download the current Release Notes also as these change every release and will explain the changes for the current release.
6. Once downloaded to your computer, close all open applications.
7. Double click on the downloaded file to start the installation.
8. Follow the instructions on-screen.

Note: The download file will be large and may take some time, depending on the speed of your connection to the Internet.

For more information on installing the software, download the Installation Instructions file from the same location or call Technical Support at 800-266-7732.

Sections available for evaluation

You can open the Free Sections project in SpecLink-E without an access key. There are several sections available for evaluation purposes:

• 00 0110 - Table of Contents
• DC B2 - Exterior Enclosure Criteria
• 07 6200 - Sheet Metal Flashing and Trim
• 09 3000 - Tiling
• 23 7413 - Packaged Outdoor Central-Station Air-Handling Units
• 26 2200 - Low-Voltage Transformers
Access to the master database is limited to subscribers by Subscription, and depends on the number of concurrent users who have sections checked out. If you are installing SpecLink-E for the first time, you need to input an Electronic Invoice ID (EID). Access to the information is based on your license. If you are installing an update to the same location as a previous version of SpecLink-E, you will not need a new EID.

If you will be moving the software, you will need to click on Remove Access Key to unpermit your original installation prior to uninstalling the software.

For a Subscription, to set up or change access:

1. Close your project.
2. Click on the Tools tab and select Register Product Online from the System Manager group.
3. Click on Register Product Online in the Registration dialog box.
4. Enter your EID and click OK.

Note: To see your SLE Renewal Date, click on Show System Monitor on the right side of the Home tab. The Renewal Date displays the date on which your SLE subscription expires. It is best to renew your SLE subscription before this date. Once your subscription has expired, you can no longer access the sections in your projects. You can print or export your active sections only.

Registration Definitions

- **Register Here**: Click on Register Product Online to enter your Electronic Invoice ID.
- **Access Key**: Unique number generated once the software has been registered.
Introducing SpecLink-E

- **Access ID**: Unique number determined for your current hardware and installation configuration.
- **Subscription Effective Dates**: The date your subscription started and the date it will expire.
- **Last Database Update**: The date of the most recent master.

**User Count**: The number of users who may have sections checked out simultaneously.

**Account**

**Subscription Length**: Your access key determines the length of your subscription.

**License Type**: (in conjunction with available catalogs) License Type dictates which features are available to the license holder.

- **No License** - Can open the model project and edit a handful of free sections
- **Trial** - Can perform all functions of a Standard user, but for a limited time
- **Professional** - Can perform all editing and reporting functions
- **Corporate** - Has all functionality of Standard user, plus System Roles, Office Master protection, Audit Trail and allows a larger projects database

**Subscription Number**: This will be filled in if you have a subscription and used in the Online Registration.

**Remove Access Key** - If you are moving the Server part of the application to a new location, please email support at support@bsdsoftlink.com or call 800-266-7732 between 8:30 AM and 5:30 PM ET Monday through Friday.

You must first remove the access key as described below:

- You must be a SpecLink-E System Manager.
- Open SpecLink-E, but do not open a project.
- From the Tools tab/System Manager group, choose Register Product Online. The Registration dialog box opens.
- Click on Remove Access Key.
- Fill in the reason for the removal of the access key.
  A confirmation message will open asking, "Are you sure you want to REMOVE this application’s Access Key?"
- Click OK.

**LinkMan-E**

**License Type** - Currently either Standard or Trial.

**Enter Trial Key** - Use this to enter a Trial Key.

**Info** - Click on this button to see the License Type, Period, Effective Dates, User Count and Subscription Number for the LinkMan-E license.

**Catalogs**: May be either Full Specs or Short Form.

See Catalogs for licensing differentiation of sections.

**Note**: After the end date of your subscription, the standard document for active sections in a project may be printed and exported only.

**Register Product Online**

You register your SpecLink-E software and receive your initial access key via the Internet, after having received an Electronic Invoice ID. When you start SpecLink-E for the first time, you will be presented with the Registration dialog box. Registering is as easy as providing your Electronic Invoice ID. If you need to move the software from one computer to another, you will need to call
Technical Support at 800-266-7732 or 404-365-8900 to Unpermit the original computer/server before getting an access key for the new computer/server.

Moving the Software

- For Network Server or Standalone installations, Remove the Access Key in the Registration dialog box.
- Uninstall the server portion of SpecLink-E and delete files not removed by uninstall. This process will automatically make a backup of the Projects Database.
- Uninstall the client portion of the software for all clients.
- Install SpecLink-E in its new location, and for a Network Server or Standalone installation, call BSD Technical Support for a new Electronic Invoice ID.
- Redo the Client Installation for all clients from the new location.
- Restore the databases to the new location.

Note: You cannot move the server part of the application by simply moving the files from one server to another. You must follow the procedures listed above.

See our Download Center for complete Installation Instructions.

If you are changing from the Professional version to the Corporate version, contact BSD Support for detailed instructions.

Working from home or on the road

As an SQL application SpecLink-E works well running as a client over a VPN (Virtual Private Network) or Wide Area Network. To do this, simply connect to the server where the SLE server installation has been performed and do a Client Installation. For more information see our Installation Instructions on our web page.

Installing Updates

After the initial install of the client software by the end user, updates are handled automatically. Each client software instance checks its installation package location each time it starts. When an update arrives from BSD either by download or DVD, it can be installed to the network server at the system manager’s discretion but must be installed within 30 days of receiving the update. This update installation begins by backing up the current databases before installing new ones. If the update installation includes modifications to the master, when you open each project you will be presented by a dialog box asking you to compare the project to the new master. Note that if you have used Online Data Updating to update your BSD Master, resulting in a more current master than what is included in the software update, your BSD Master will not be reverted to a previous state.

When the client software discovers the new package on its next startup, it basically replaces itself with the new version and restarts. Even on slow networks this update is typically completed in one to two minutes. No administrator login or other support is required and the process is virtually transparent since no input is required of the user on either initial or subsequent installs.
Electronic Invoice ID

The Electronic Invoice ID is a code, typically emailed from BSD, that automatically registers the software allowing you access to the sections to which you have subscribed. It is entered in the Registration dialog box after clicking on Register Product Online.

Uninstalling the Software

SpecLink-E is comprised of two separate applications: The Server application and the Client application. A standalone installation, such as a laptop, will have both installations, and therefore will need to perform both of the following instructions for Uninstalling.

For instructions on Uninstalling the software, see our Installation Instructions available from our Download Center.
Using SpecLink-E Effectively

Making the Transition from Word Processing

SpecLink-E is not just a word processor. That fact is likely to change the way specifications are produced in your office in ways that are not immediately apparent. The most important thing to realize is that the best person to use SpecLink-E is the project professional who knows the most about the project, not a clerical person. Selecting paragraphs and making choices is analogous to red-marking a draft copy of a word processing file; you are making decisions that the word processing person cannot or should not make.

Red-Marking Drafts

If you have been accustomed to red-marking draft copies, it’s not actually necessary to change at all. You can have Master Text Only Draft or All Text Draft Copies of the required sections printed out, red-mark them, and then have the edits done in SpecLink-E by a word processing person. This works but is highly inefficient, since the links are ignored and in some cases may have to be overridden.

Reviewing Other People’s Work

If specifications in your office are prepared by project personnel and reviewed by a specialist or expert, the review can take place directly on screen. If the project personnel are encouraged to use the notes to record the basis for decision-making, the reviewer is better able to evaluate the result.

Preparing Specifications

- The basic steps
- Define the products first...
- Build the structure first...
- Re-using previous projects

Basic Steps

The basic steps to producing a project specification are as follows:

1. Start a new project or open an existing project.
2. Open each section and select the text to be included. Review the notes and links, if necessary, for information on the section text.
3. Add text as required.
4. Review the Tree Panel or Table of Contents for sections automatically included by links made by other sections -- marked with green or yellow in the status box.
5. Review each section for text automatically included by other sections -- marked with green status box without a checkmark. Confirm the appropriateness of added text.
6. When all sections are complete, modify the page format if necessary.
7. Preview each section.
8. Print all sections.
9. Print the Table of Contents.
Products First, Then Execution, Then General

Each specification section is organized in the same way, according to the Construction Specifications Institute’s (CSI) Three-Part Section Format. All similar topics are grouped into 3 parts of the specification:

- PART 1 - GENERAL,
- PART 2 - PRODUCTS, and
- PART 3 - EXECUTION.

However, even though GENERAL is the first part of the specification, the topics in it are relevant only to the particular products specified in PART 2 and installation or application requirements specified in PART 3. Therefore, it might make sense to begin the editing of the section in PART 2 - PRODUCTS, rather than at the beginning of the section. In PART 2, the products are usually organized into primary materials and accessories, and occasionally other topics such as fabrication and finishes. The first decision is which major products to include. The second decision is what method is to be used to specify them. After that, it may be useful to edit PART 3 to identify the types of applications involved, in order to determine whether that affects the choice of accessories, fabrication, or finishes. It may be necessary to switch back and forth between PART 3 and PART 2 several times until all decisions on products and execution are resolved.

Once the scope of the section is clear, and the details of the products and execution worked out, the general requirements issues are usually simple and are based on the needs of the project. Each Article (level 2) in PART 1 covers a different type of provision, from the scope of the section (Section Includes) to the warranty required. Each article usually can be edited independently of the others, and many are completely optional.

**EXAMPLE** In Section 073129 - Wood Shingles and Shakes, the first choice is whether you want "shingles" or "shakes," or both, and then what species of wood they are to be. After that, the remaining products in PART 2 are various types of accessory products, such as underlayment, eave protection membrane, flashings, etc., the proper selection of which is dependent on the needs of the project, the slope of the roof, and the application.

Links in the sections, connecting related provisions, are most helpful when editing is begun in PART 2. For instance, in Section 073129, there are multiple types of underlayment available in PART 2. The selection of any one type automatically determines that installation of underlayment is required. If editing begins in PART 3, however, and underlayment installation is specified, the links merely highlight all the types of underlayment for the user’s selection.

Build the Structure First, Then Finish It

There is no need to finish each section before starting a new one. In fact, that may be counterproductive, resulting in changes due to decisions made too early. Because all the sections in a project are in the same database, they can all be linked together for coordination. This makes it logical to select all the products required, adding all the sections needed for the project, before going on to details of submittals, quality assurance, etc.

You may want to follow these steps:

1. Add all the sections you think you’ll need to the project by selecting them.
2. Edit PART 2 of each section.
3. Check each section for related products that need to be specified in other sections and add them. Use the RELATED REQUIREMENTS article in PART 1 as a partial checklist.
4. Scan PARTs 2 and 3 for cross references to other sections, particularly references that say something like "...work specified in this section is to be done according to provisions in ....... [another] section."
5. Review the Table of Contents for other products you may not originally have anticipated needing.
6. Review the 2004/2012+ edition of MasterFormat for products not included in the master database. Make new sections and add those products.
7. Finally, determine the level of detail required for such things as submittals, quality assurance, etc., and finish the sections. If you concentrate on one PART 1 topic at a time, all the sections will be more consistent. Remember that you can have more than one section open at a time; that helps a lot when reviewing.

Re-Using Previous Projects

In an office where a lot of projects are in the works simultaneously, using an office master project is a well-established procedure. Since nothing is actually ever deleted from the SpecLink-E master database, a project copied to a new project contains all the master text available for use on the new project.

Creating a new project, using your office master.
- Create a new project to use as a template for all new projects.
- Apply your desired Project Template for formatting.
- Edit the header and footer in your desired style.
- Save this project and name it so that all users know to use it for new projects. Do not check out any sections in this project.
- Copy this empty formatted project each time you need to create a new project.
- Use Import from Project to import sections from your Office Master or any project that has your edited sections in it.

If your project is in the old SpecLink+ format, you must first use the Copy from SpecLink+ function before copying the project.
How To....

Start a New Project

To start a new project:

1. From the File menu choose New Project. The New Project dialog box opens.
2. Enter a Project Name for your new project and click OK.
3. The new project will be created and the Summary Information dialog box will open.

The most efficient way to start a new project:

1. Create a Format Master by creating a brand new project, editing your headers and footers, and creating or applying your customized Project Template to it. You must have a section open in the Document Panel to change the applied Project Template. Do not edit sections in the Format Master. Name it Format Master, or something similar.
2. Each time you need to start a new project, copy the Format Master. Your new project will be small and your formatting will already be applied.
3. From the Insert tab, Use Import from Project. Import sections from your office master or from any existing projects. If you have created user links from one section to another, the user added links will be imported whether you are importing the link target or not. You will not see them in the Links Dialog Box until the section that is the target of the link has been imported.

Tip:

- Importing selected sections gives you a "jump start" on a new project because you can reuse your previous work. Keep in mind that you did not modify the Master, so don’t worry about losing any of that information.

New Project Dialog Box

To create a new specification project, click New Project from the File menu. The New Project dialog box opens.
Type in the name for your new project and then click OK.
The Project Window for the new project opens and the Summary Information dialog box opens. Once you complete the Summary Information dialog box and click OK, you have created a new project.

Projects Database

All projects are stored in a single database. In a multi-user situation, this database will be on a server to which all users have access. The database location is determined during the installation process.

Size: The maximum size of the Projects Database in the Professional Edition is 10 GB, 2 GB of which is reserved for a temporary database workspace. When your Projects Database reaches 7.5 GB, you will receive a warning, and when your database reaches 8 GB, you will need to archive or delete some of the projects in your database before you can create any new projects or copy any existing projects. To see the current size of your Projects Database, click on the File
menu, and then on About SpecLink-E. The database size is displayed on the left part of the window below the trademark information. For additional information see the SLE System Monitor.

- To increase the size of the Projects Database, you must upgrade to the Corporate Edition of SpecLink-E.
- To free space in the Projects Database, send projects that you are not currently using to the Archive Database.
- To move your projects database to a new server, you will need to Backup and Restore the Databases as well as uninstall and reinstall the software.
- To remove projects from the database permanently, use Delete Project. To see the reduction in the database size, follow this with Server Maintenance.
- To save a single project to a compressed file, use Save Project to File.
- If running standalone, periodically run Server Maintenance.

Using a Separate Projects Database

If you are working in one Projects Database and need to share your projects with those using another Projects Database, there are a number of considerations. You must pay attention to the following functions and issues:

- You must be very careful about not making changes in two versions of the same project at the same time. If one user is working in one projects database and another user is changing the same project in another projects database, then you will have to import the changed sections into one project, making sure to get the correct version of each changed section.
- All users need to be on the same version of SLE.
- It is best not to make changes to Project Templates while running in a separate projects database. Loading a project from file will load the project template if it does not already exist in the second projects database, but changes made to the existing styles will not be transferred to the second database if the project template already exists.
- User added global terms: Do not add User Added Global Terms in a projects database if the project using them is to be transferred to another projects database.
- If you add a new image to your project notes while in a separate projects database, when you load from file, it will get added to the second projects database. If the image already exists there, it will be duplicated.
- Adding to the custom dictionary. If you add words to the custom dictionary on one computer and then switch to a different computer, the words that you added will not be added to the other computer. The custom dictionary is in each user’s Documents\SpecLink-E folder. The file is called SLEUserDict.txt. You can replace that file with a newly edited one or append to it by opening it in Notepad and using Copy and Paste to add new words.

Opening a Project

To open an existing project:

1. From the File menu choose Open Project, or select the name of the project from the list of Recent Projects that appears to the right of the menu. Projects that have been opened on this computer are listed. If the project file you want to open is not listed, click the Open Project from the File menu button to find it.
2. When the Project Selection dialog box opens, you can view the projects using Large Icons, Small Icons, List View or by Details. If you view by Details, you can sort the
projects by Project Title, Project ID, Customer ID (Project ID you assign), number of
Documents or Last Change Date.
3. When the Project Selection dialog box opens, click on the name of the project and click
Open.
4. The project will be compared to the current BSD Master and if there are changes to be
marked you will have the option to Open for Editing, Open Read-Only or Cancel.
5. If the "Update Reminder" dialog box appears after selection of the project that means that
there are paragraphs in your project that are not updated to the current master. See How
to Update a Project.

Tips:

• If you are not sure which project you want to open, click the Details option on the right.
The Project Title, Project ID, Customer ID, the number of active documents, and last
edited date will appear for all projects. You can sort by any of these columns by clicking
on the column label at the top. If you leave the Details option selected, the next time you
open the Project Selection dialog box, it will be in details view.
• To open two projects at the same time, see Opening Two Projects.

Marking a project

When you open a project for the first time after updating the BSD Master, your project needs to
be compared to the new master to mark the possible changes. At the opening dialog box, you
have the option to click on Open for Editing or Open Read-Only. Click Open for Editing to mark
and display the possible changes in your project. Marking your project does not change your
edited sections. It does allow you to see the newly added sections in the master and it does
update the sections in your Project Tree that have no selections or edits. If you want to simply
check something in a finished project, you can click on Open Read-Only. Note that only one
project may be compared and marked at a time. If another project is being marked and you try to
open a second project, you will need to Open it Read-Only or click Cancel to open the project
later.

Opening a project for Editing

When your version of the BSD master has been updated, your project must be compared to the
latest master to determine if there are any possible changes. This process must occur before you
can make changes to the project. To make changes in your project, click on Open for Editing. To
simply view or print your project, you can click on Open Read-Only.

Opening a project in Read-Only Mode

When your version of the BSD master has been updated, your project must be compared to the
latest master to determine if there are any possible changes. If you are in a hurry to open a
project that needs to be compared and marked, you can click on Open Read-Only. You may
check out sections for viewing, as well as print/export your project, in Read-Only mode. You can
open a project in Read-Only mode as many times as you want. If you want to make changes to
your project, click on Open for Editing.

Closing a project

To close the project without exiting the program:
1. Click on the File menu.
2. Choose Close Project.

To close the project and exit the software at the same time:

1. Click on the X in the top right corner of the application.

Note: If you have any sections checked out, you will be presented with the Pending Check-Ins dialog box.

Copy from SpecLink+

You can import your SpecLink+ projects into SpecLink-E, including all user added sections, paragraphs, links and choices.

Follow these steps:

- You can import any SpecLink+ project from fall 2004.
- Have SpecLink-E open, but do not have a project open.
- From the File menu, click on Copy from SpecLink+.
- Navigate to your SpecLink+ project and select it.
- Due to changes in the master data, some sections are not able to be Copied into SpecLink+. When this is the case, the rest of the project will be imported, and the problem section(s) will be reverted to the current unedited master version. A list of the sections that are not being imported will be displayed onscreen and in the server trace log file.
- Before opening, the project will be compared to the current BSD Master and if there are changes to be marked, SLE will mark those changes. This process happens each time you open the project. If you have not opened this project against the current master, the first time you open it will take longer than subsequent openings.
- If the "Update Reminder" dialog box appears after the project opens that means that there are paragraphs in your project that are not updated to the current master. See How to Update a Project.

Your original SpecLink+ project will remain as it was, and a new version will be created in SpecLink-E format within your projects database. Any customized style, header/footer and/or fonts applied in SpecLink+ will not be copied into SpecLink-E and will need to be recreated in SpecLink-E. See creating a project template.

Notes:

- The name of your SpecLink-E project comes from the Project Name field in the Summary Info Dialog Box in SpecLink+, not the file name from SpecLink+.
- Because the format has changed completely, sections from the PerSpective and Short Form tabs in SpecLink+ will not be copied into SpecLink-E.
- The larger your SpecLink+ project is, the longer the process will take. Extremely large projects can take a significant amount of time, depending on your hardware and software configuration. They can also affect the work of others in a multi-user situation. It may be best to import large SpecLink+ projects when other users are not working in SpecLink-E.
• If your SpecLink+ project was using MasterFormat 95, it will be switched automatically to MasterFormat 2004. See Differences between MasterFormat 95 and MasterFormat 2004. In addition to having different section numbers, some of the section titles will be different also. These changes will be made automatically for master sections. If you like, you can use the MF95 Output toggle to print your section in the MasterFormat 95 hierarchy.
• User added folders will not be copied into SLE. Any sections added under user added folders will be moved to the closest appropriate folder or the Unassigned folder.
• Sections that were added at a level below another section in SL+ will be moved to the same level (3) as the other sections.
• After your project is copied in from SpecLink+, SLE will rebuild all links. If Rebuild Project Links takes as long as 10 minutes, the process may have timed out, even if you receive a message that the process is complete. A possible solution is to run Server Maintenance or restart Windows if you have a standalone version of SLE, or have your IT Manager restart the SQL Server (BSDSOFTLINK$DATA) on the server where the SLE server installation resides. If that does not resolve the issue contact BSD Technical Support.

What happens if you import a non-updated SpecLink+ project

Every effort has been made to ensure that your SpecLink+ project prints exactly the same in SpecLink-E as it did in SpecLink+, while updating the master versions of text that is not selected in the project.

However, if your SpecLink+ project has not been updated to a recent edition of SpecLink+, you may not be able to automatically delete some removed master paragraphs, or completely rely on the updating tools like Update Publication References, Update Manufacturer References, or Compare to Update. In addition, some updates other than new paragraphs may not be marked in rust for easy identification. All the new and old data is still there, but the longer it has been since the project was updated, the longer it will take to review the pending changes.

Older SpecLink+ Projects:

If the SpecLink+ project has not been updated since before the Fall of 2004, the Copy From SpecLink+ function will perform an update process similar to the SpecLink+ update process, with the following exceptions:
• Older master paragraphs that did not have a user-modification will now consist of a user-modified master paragraph with the old text as the user modification over the new master text. These will not be marked in rust -- they will be identifiable only by their blue user-modified icon in the O column.

Some examples are:
• Reference standards citations that have changed since your last update.
• Manufacturer name listings that have changed since your last update.
• Other text modifications since your last update.

Deleted master paragraphs will be converted to user paragraphs, but will not be marked in rust. As usual, if they were selected in the project, they will still be selected, and vice versa. However, they will now be highlighted by an olive green color in the status columns for your review of their continuing relevance.
If your SpecLink+ project won’t import into SpecLink-E

SpecLink+ has been around for many years, resulting in many older, possibly non-standard projects. If your SpecLink+ project will not import into SpecLink-E, there are a few things you can try before contacting us.

Note that none of these steps require a SpecLink+ license. If you do not have the current version of SpecLink+ on your machine, you can download it from our Download Center.

- Open the SpecLink+ project in the current version of SpecLink+. Sometimes that is all that is required.
- If opening the project in SL+ is not enough, try updating the project to the current SL+ master.
- If your project still won’t import, follow these steps in SL+.
  - Start a brand new project in SL+.
  - Click on the Unassigned folder in your new project.
  - From the Tools menu, click on Import from Project.
  - Select the SL+ project that you are trying to import into SLE.
  - Deselect the Verify Before Overwriting Existing Sections checkbox.
  - Import only the sections that you need. If you only need one section, just import that one. The fewer sections you have in your project, the quicker the import into SLE will be and the more likely it is to succeed.
- Retry Copy from SpecLink+ in SLE.
- If none of these procedures work send your SL+ project to Technical Support.

Project Summary Info

The Project Summary Information dialog box opens automatically when you create a new project. To open at any other time choose Summary Info from the File menu or click the Summary Info icon on the Quick Access toolbar. Note that when a project is opened in Read-Only Mode, the Summary Info dialog box will not open.

Here you can view or enter the:
• Project name **
• Project ID **
• Project Access Level - Select Office Master to restrict access to the project. (Corporate Edition)
• Number of active Documents (filled in by the software)
• System Project ID (a unique project ID filled in by the software)
• Project Location - City and State where the project is located
• Facility Type - Select closest option from the pull-down menu
• Project Type - Select closest option from the pull-down menu
• Gross Floor Area *
• Construction Cost
• Date Specification Last Modified (This is the date of the most recent user change to the project, filled in by the software)
• Date of last Master update (This is the date of the most recent change in the master data, filled in by the software)

* These fields are also Global Master Terms and can be used anywhere in the specification documents. To insert a Global Master Term within your spec, see Adding Choices.
** These fields are both Global Master Terms and Header/Footer keywords

You may also change the default settings for:

• References
• Section ID format
• Unit of measurement

**Project Name**

The project name entered in the Project Summary Info dialog box will be the one used in the header or footer if the project name keyword is used.

**System Project ID**

Each time you create a new project, the software assigns a unique System Project ID, which can help you to distinguish between projects with the same or a similar name. In many cases, this System Project ID follows the Project Title to help you identify your project. Note that if you Archive and then activate a project, the project will be assigned a new System Project ID at activation.

**Project Number and Project ID**

The project number entered in the Project Summary Info dialog box will be the one used in the header or footer if the project ID keyword is used. This may be changed at any time, as opposed to the System Project ID that is automatically assigned to each project.

**Enhance Competitive Bidding**

This checkbox on the Project Summary Info Dialog Box defaults to being checked when you create a new project or when you copy an existing project. For information about what this checkbox means, see our Privacy Policy.
Privacy Policy

Enhanced Competitive Bidding
If this box is checked, you give BSD permission to identify the name of this project and your organization's name and phone number in communications with building product manufacturers, thereby encouraging competitive bidding by contractors, manufacturers, and suppliers.

Privacy Policy
In accordance with BSD SpecLink® E and BSD LinkMan-E™ Terms and Conditions of License, BSD has the right to gather information from users about users' use of SLE and LME and to make commercial use of statistical usage data without identification of specific data sources and has the right to make use of specific project data with permission of the user. This means that:

BSD does not:
- Collect the full text of your specifications.
- Give anyone the text of your specifications, other than specific excerpts mentioned below.
- Identify project names or firm names unless specifically permitted by the user for a particular project.

BSD may and does:
- Collect certain specific information about your projects, including project name and other identification that you provide, the sections used and the generic products, manufacturers, and brand name products specified.
- Accumulate and combine your data with data from other users to inform building product manufacturers about the generic products, manufacturers, and brand name products that have been specified as acceptable during a particular time period, without identifying project names or firm names.
- Collect information about your computer hardware and operating systems for the sole purpose of providing technical support.

Global Master Terms

The terms entered on the Global Master Terms tab of the Project Summary Info will be substituted for coded identifications in the text wherever they appear.

Any words can be used, but keep in mind that the sentence syntax and punctuation assume that nouns or proper nouns will be used, and that possessives and other structures may be appropriate.

Example: The use of the term "Adams Brothers Company" instead of "Owner" for the Owner's Spec Term may result in an awkward sentence structure when combined with phrases like "...instruct Adams Brothers Company's personnel...".

Example: Substitution of the term Contracting Officer for the Owner may not adequately express the contractual conditions, particularly if the Contracting Officer's duties do not include all duties of the Owner as a legal entity. (For government agencies, the use of the term The Government may be necessary, with a user-added legal definition.)

The sections in General Requirements assume a relationship between an Owner and a Contractor, with a Design-Professional as the Owner's agent, and include language expressing that relationship. If another relationship is necessary the language of those sections should be thoroughly reviewed.

Sections in Divisions 2 through 49 only occasionally mention any of the contractual entities but nevertheless assume a similar relationship. The language of all divisions is addressed to the Contractor in the imperative mood.
You can replace the Global Master Terms throughout your project by terms of your choice -- automatically.

- Project Name
- Project ID
- Owner’s Spec Term
- Owner’s Actual Name
- Design Professional’s Spec Term
- Design Professional’s Actual Name
- Design-Build’s Spec Term
- Design-Build’s Actual Name
- Contractor’s Spec Term
- Contractor’s Actual Name
- Delegated Design Engineers To Be Licensed In
- Project Completion Date
- Bid date
- Contract Documents Due Date
- Specs Due Date
- Construction Cost
- Gross Floor Area

In addition to the provided global terms you can add User-Defined Global Terms.

With one mouse click, you can also establish the Section ID Format and the units of measure used throughout the project.

References

The references choices in the Summary Information dialog box relate to external standards documents and other sections that you refer to within a section.

The options are as follows:

Print Reference Edition Dates: When selected, the edition dates of each reference print when the document report is printed. Edition Dates always appear in the Master Text Only and All Text Draft reports, no matter what the selected setting is in the Summary Info dialog box. Whether selected or not, the edition dates always show onscreen while the section is being edited. The edition dates will appear onscreen in green text. To print the dates only in the consolidated list, check this box only when printing Section 01 4219.

Consolidated List of Citations: SpecLink-E includes a single reference document -- Section 01 4219 -- that includes a consolidated list of reference standards for the entire project. This list includes the acronym, the document number, the full title, and the current edition date (optional using the previous option) of each standard. If you choose to include this section, links automatically include only the reference standards that are relevant to your project. This option turns on the reference citation in Section 01 4219 whenever there is a reference included by links or selected by the user in any section of the project. To produce the consolidated list, it is necessary to include Section 01 4219 in the project. You need to run Rebuild Project Links to see the effects of the links.

Note: If the reference standards (in both section 01 4219 and in the sections where the references are) have not been updated to the current master, the links to un-updated references
in the Consolidated List of Citations will not work. You can update only the References by choosing Update Publication References on the Tools tab. After updating the Publication References, use Rebuild Project Links.

**Include Citations in Each Section:** Selecting this option will automatically select the *Reference Standards* heading in Part 1 General and list cited standards documents for that section if any standards documents are referenced.

**Include Related Requirements:** Selecting this option will automatically select the *Related Requirements* heading in Part 1 General and list any related sections for that section if any other sections are referred to.

**Tips:**

- See User-Added Choices for adding edition date "choices" to new reference paragraphs.
- See Tags for linking user-added references to the consolidated list in Section 01 4219, and for creating your own *Reference Standards* and *Related Requirements* paragraphs.

**Reference Standards and Related Requirements Tags**

Reference Standards and Related Requirements: In Part 1 General of each BSD master section the Reference Standards and Related Requirements articles are tagged "RT" and "ST" respectively. Subparagraphs under these articles are tagged "RS" and "RE" respectively. These tags interact with the options in the Summary Information dialog box, "Include Citations in Each Section" and "Include Related Requirements." Based on the selection of these options, if a subparagraph of Reference Standards or Related Requirements is active, the article (Reference Standards or Related Requirements) will or will not become active by a green link. This allows you to choose to include those articles in every section, but only when there actually is a Reference or a Related Requirement in the section.

**Section ID Format**

Section IDs normally appear in the Document panel in a green font, indicating that the format is set globally in the Summary Info dialog box. However, where you are allowed to input your own section number, they appear in a blue font. The blue choice type allows you to use a fill-in the blank choice type when you want to input your own section number and title.

**Section ID Format**

You can choose how the section numbers will be displayed, both on-screen and in the reports. The choices are:

- 99 9999
- 999999
- 99 999
- 99 99

Optional Separator - Input any character to insert into spaces within the section ID. See Adding Choices for more information on this choice type.

See also MasterFormat Version choice type.
Units of Measure

Select the preferred units of measure presentation for the entire project under Summary Info at the File menu:

- English (Metric) -- Inch-Pound with SI in parenthesis
- Metric (English) -- SI with Inch-Pound in parenthesis
- English -- Inch-Pound
- Metric -- SI

The units displayed may be changed at any time.

Where dimensions are entered by the user in fill-in-the-blanks, the software does not convert them to the other forms of units -- if there is any likelihood of using a different form of units, each filled-in dimension should be filled-in under each display option. Simply change the display and enter the converted units.

Global User Terms

In addition to the predefined global terms already defined in SpecLink-E, you can define as many Global Terms as you like.

To create a Global Term:

1. Click on the Insert tab and select Define Global Term from the Choice Fields group. You can do this with a project open or without a project open since User Defined Global Terms can be accessed from any project within the Projects Database.
2. Click on Add.
3. In the Term Name column, type in the name of your term.
4. In the Default Value column add the default value for new projects.
5. If you have a project open you can fill in the Project Value which is what will be used for this term in this project. If nothing is added as a Project Value, the Default Value will be used.
6. To add more Global Terms, continue to add rows at the bottom of the list.
7. Click OK when done.

To modify the Project Value for a specific project:

1. Have the project open
2. Open the Summary Info Dialog Box
3. Click on the Global User Terms tab
   (Alternatively you can click on the Define Global Term from the Insert tab)
4. Modify the Project Value that you want to change

To insert the Global Term into a paragraph, follow the directions to insert a choice.

1. Choose Global Term as the Choice Group Type.
2. Select your newly added Global Term from the Global Term list at the bottom.
3. Click OK.

To remove a User Defined Global Term from the list of Global terms:
• The Global Term cannot be in use in any section.
• Have all users check in all sections.
• Click on the Insert Tab.
• Click on Define Global Term.
• Click on the term you want to remove.
• Click the Remove button.
• If the term is in use, you will get a message asking you to remove the term from all sections.
• If the term is not in use in any sections, it will be removed from the list.
• Note that if you remove a User Defined Global Term that is in use in an Archived project, it will not be reinstated in the list when you activate that project.

**Edit a Project**

**Identifying the Current Section**

The current section is the one that is open (visible) in the Document panel. The section number of the current section will be displayed in a blue font on the active tab in the Document Panel.

**Selecting and Deselecting Sections**

**Opening a Section**

To open a section, go to the Tree Panel and single or double click (depending on how you have set the Single Click to Open option) on the title of the section. You will be asked if you want to check out the section. If you have deselected Ask Before Checkout, your section will automatically be checked out. Once open, the text of the current section shows in the Document Panel.

To open a second section at the same time, repeat the same process. You can have as many sections checked out simultaneously as you want, but you can only have 10 sections open in the Document Panel at one time.

**Tip:** You can switch from one section to the other by simply clicking on the appropriate tab to make the section active. To view multiple sections at the same time, you can create a new vertical or horizontal tab group.
Single Click to Open

The Single Click to Open option is in the Check In and Close group on the Documents tab. This setting allows you to check out a document with a single click, rather a double click. Single Click to Open is the default setting (as shown by the light orange background on the menu choice) when the software is installed. Click on the command to change to using a double-click to open a section.

Ask Before Checkout

This setting is available in the Check In and Close group on the Documents tab. When it is on (as shown by the orange background on the menu choice) you will be prompted to either check out the section or cancel the action. When it is off, single or double clicking (depending on your setting of Single Click to Open) will automatically check out the section.

Check Out

You must check out a section to make any edits. While checked out, a temporary copy of the section is stored on your local drive, separate from the project file. Any other users who open the project see your computer name on the section indicating that you have the section checked out. Other users can check-out and edit other sections in the same project. Checking out one or more sections uses one of your available licenses for SpecLink-E.

To check-out a section:
1. Open the project that contains the section that you want to check out.
2. Use one of these methods to check the section out:
   • In the Tree panel single click (or double click, depending on whether you have changed the Single Click to Open option) on the name of the section to be checked out, or
   • Right click on the section name in the Project Tree and choose Check Out Section from the right mouse button menu.
3. You will be asked whether you want to check the section out (Yes) or cancel the operation (No), unless you have deselected Ask Before Checkout in the Check In and Close group on the Documents tab, in which case the section will be checked out.
4. If prompted, click Yes to check out the section.

The section is opened in the Document Panel.

Section Check-Out Results
When a project with checked-out sections is opened by another user the sections that are checked out display a message identifying who has the section checked out.

Pending Check-Ins

![Pending Check-Ins](image)
To see the list of sections that are checked out by you in your current project, click on Pending Check-Ins in the Check In and Close group on the Documents tab. All checked out sections are on the list, and have a checkmark by default. To check in all checked out sections, click OK. Uncheck any sections that you do not want to check in.

When you close a project with sections still checked out, you will be presented with the Pending Check-Ins dialog box at that time.
- To check in all checked out sections, just leave all sections checked and click OK.
- To leave a section checked out to you, deselect it and click OK.
- Click Cancel to leave the project open.

Checking Out Additional Sections
You can check out as many sections as you like, although you can only have 10 sections open in the Document Panel at one time. All open sections will appear in the Document Panel, with the section number and acronym in the tab on the top of the Document Panel. To switch from one section to another, simply click on the tab for the section you want to view. To view multiple sections at the same time see Vertical and Horizontal Tab Groups.

Selecting a Section
To add a section to a project, the section does not need to be checked out.

1. Find the section in the Tree Panel.
2. Click in the status box to the left of the section ID in the Project Tree.

A checkmark will appear in the box and the section title will become bold to indicate that it is active.

If you are selecting a number of sections in a row in the Project Tree, you might want to toggle on Expand on Refresh for the duration of this process.

You can also select a section after checking it out, by selecting the top paragraph in the Document Panel.

Clicking on a Section in the Project Tree
Clicking on a section in the Project Tree does two different things, depending on where you click.

- If you click on the status box, it will change the status of the section without checking it out. If the status box is grey, a click on the status box will add a check-mark which will select the section. If there is already a check-mark, then a click on the status box will change that to an X which will exclude the section.
- If you click on the section title, it will check the section out. It may take two clicks, depending on how you have your setting for Single Click to Open.

Removing a Section from a Project
To remove a section from the project:

1. Find the section in the Tree Panel.
2. Click in the status box to the left of the section title until the status is neutral. This "de-selects" the section -- it will not print.

Sometimes, after you have deselected a section, the status box remains yellow, green, or red. If the box is yellow or red, the section is not in the project. If it is green, that means the section was selected by links as well as by the user, so it is still in the project.

**Section Recommended by Links**

The yellow status box indicates that this section is relevant to the project in some way - it has been recommended by at least one link from another section. It is not necessary to do anything about the yellow link but if you want to identify the reason and resolve it:

1. Open the section.
2. View the link sources for the section title.
3. Identify the section and the paragraph that includes the link to the section title.
4. You can now either:

   - Ignore the link -- the section will not print.
   - Change the section that includes the link.
   - Select the recommended section.
If a Section is Selected by Links

The green status box indicates that this section is very important to the project in some way – it has been selected by at least one link from another section. This section will print in the project unless you do something about the green link. If you do not want the section to be in the project: You can exclude it (change its status to excluded) by doing the following:

1. Check out the section in question.
2. Click twice in the status box of the title in the Document Panel, until the box looks like this

Alternatively, you can counteract the link that selected it:

1. Open the section.
2. View the link sources for the section title.
3. Identify the section and the paragraph that includes the link to the section title.
4. If the paragraph that includes the link was selected by the user, de-select it.
5. If the paragraph was selected by a link, either exclude it or identify the source of that link and remove it.

New Window

To open a second instance of the same section within the same project, click on the View tab, Windows group and choose New Window. This is helpful when creating links from one part of a section to another part of the same section.

Vertical and Horizontal Tab Groups

To separate two or more sections into separate windows so you can see both (or more) at the same time, create a new Vertical or Horizontal Tab Group.

- Right click on the Section Tab of one of the sections and choose New Vertical Tab Group or New Horizontal Tab Group. (You can also use the commands in the window group on the View tab.)
- Each group can contain multiple sections.
• You can create a number of groups, but are limited to having 5 sections open at the same time.
• To move a section from one group to the next, right-click on it and choose Move to Previous Tab Group or Move to Next Tab Group.

**NOTE:** To open a second instance of the same section within the same project, click on the View tab, Windows group and choose New Window.

**Opening Two Projects at the Same Time**

To open two different projects at the same time, you must start another instance of the software. Once the second instance of the software has been started, you can open a second project. You cannot open the same project in two different instances of SpecLink-E. If you need to do that, use New Window instead.
Creating and Managing New Sections

User Added Sections

No matter how many sections are in the master database, there may be a need for additional sections. These are referred to as “User-Added” sections. There are three ways to create a new section:

- **New Section from Template** -- this creates a new section built on a template organized into CSI's Three Part Format, with all major article headings and standard, "boilerplate" text for many articles in Part 1.
- **New Section from RTF or New Section from DOC** -- this creates a new section using a rich text format (RTF) file or a Word document.
- **Copy an existing section.** The new section will be a user-added section just like the one created using Add New Section, except that it will contain the entire contents of the section copied instead of the template text only.

Note: User Added Sections are displayed in green in the Project Tree.

Ways to add a new section

There are a number of ways to create a new section within your project.

- If you have the section information in a word processing file, use Add New Section from RTF file or Add New section from doc.
- If you have the section information in another SpecLink-E project, use Import from Project.
- If you have the section information in a SpecLink+ project, use Copy from SpecLink+ and then Import from Project.
- If you need a section that is similar to an existing section, use Copy a Section.
- If you want to type all new information into your section, use Add new Section from Template.

New Section from Template

To add a new section using the template:

1. Position your cursor in the tree panel on the folder that will contain your new section. New sections can only be added below the lowest folder level.
2. From the Insert Tab, New Section Group, select From Template. (Or right click on the folder name and choose New Section from Template)
3. The Add Section to dialog box appears.
4. Enter a section number and section name
5. If you will be using the MF95 Output feature, fill in the MF95 Section ID and Section Name.
6. Click OK. You may also change the acronym, or you can leave it as USER for easy identification. The new section is added to the Tree Panel in the appropriate location, based on the number and acronym assigned.

Note: To be consistent with the other sections, use upper and lower case for the Section Name.
Your new section will be checked out to you automatically, so you can begin editing immediately.

Notes:

- The software will not allow you to add a section number/acronym combination already in use in the master database. Sections in SpecLink-E are numbered and titled in accordance with the 2004/2012+ edition of CSI's MasterFormat™ -- Master List of Numbers and Titles for the Construction Industry. To be consistent with this numbering scheme, we strongly suggest you acquire a copy of the appropriate document from CSI.
- To add a section from template in the Design Criteria tab, you might want to copy the DC Section Template DC 999, rather than use New Section from Template.
- If you add a section in the wrong place, you can move it.
- Another way to create a new section is to copy the Section Template, Section 9 99999 (in the Front End tab of the Project Tree), to a new section number. In addition, you can copy text from the Section Template to other master sections, by opening the Section Template without selecting it for inclusion in your project. You can customize Section 9 99999 just as you would edit any other section.

New Section from RTF

New Section from RTF allows you to create a new section by importing a rich text format (RTF) file, without first creating the section in SpecLink-E. (RTF stands for Rich Text Format, which is readable by multiple applications. To make an RTF file, open the Word document and in Word from the File menu choose Save As. Change the Save as Type dropdown to Rich Text Format (RTF).) If you have a file you can import, you don’t need to start the section in SpecLink-E first.

This function also allows you to import choices and notes. There are specific rules for how the RTF file needs to be constructed, and if you follow the rules, you will be able to create new sections from existing documents quickly. See Preparation of .doc or RTF file for importing into SpecLink-E.

There are two settings that need to be set correctly before you use New Section from RTF. If you have Auto Select New turned on, then all paragraphs imported during the Add New Section from RTF will be selected with a checkmark. There is a command on the Insert tab, New Section group, called Look for Choice Fields. If this is turned on (reflected by an orange background around the command) then the import will create choices within the section, based on the correct formatting for choice fields. If the Look for Choice Fields is not turned on, then the software will not create choices in your section and brackets will import as brackets, for example.

Note: Hidden text will import when using Add New Section from RTF file, but not when using Add New Section from DOC file. To import hidden text as project notes, rather than individual paragraphs, see Preparation of RTF or DOC file for Add New Section from RTF File.

Steps:
1. Click in the Project Tree on the folder where the new section should be. New sections can only be added under the lowest folder level.
2. From the Insert tab, New Section group, choose From RTF.
3. Navigate to the location of the RTF file and double-click on it.
4. You can change the Section ID, Acronym and Section Name.
   Note: To be consistent with the other sections, use upper and lower case for the Section Name.
5. If you will be using the MF95 Output feature, fill in the MF95 Section ID and Section Name.
6. Click OK to proceed.
Note: If you are in Short Form or Outline Mode when you add a new section from an .rtf file, all paragraphs in the new section will be tagged as US or UO depending on your mode.

**New Section from .doc**

New Section from .doc allows you to create a new section by importing a Word document (.doc or .docx) file, without first creating the section in SpecLink-E. If you have a file you can import, you don’t need to start the section in SpecLink-E first.

This function also allows you to import choices and notes. There are specific rules for how the doc file needs to be constructed, and if you follow the rules, you will be able to create new sections from existing documents quickly. See Preparation of .doc or RTF file for importing into SpecLink-E.

There are two settings that need to be set correctly before you use New Section from .doc. If you have Auto Select New turned on, then all paragraphs imported during the New Section from .doc will be selected with a checkmark. There is a command on the Insert tab, New Section group, called Look for Choice Fields. If this is turned on (reflected by an orange background around the command) then the import will create choices within the section, based on the formatting outlined below. If the Look for Choice Fields is not turned on, then the software will not create choices in your section and brackets will import as brackets, for example.

**Note:** Hidden text will import when using Add New Section from RTF file, but not when using Add New Section from DOC.

**Steps:**

1. Click in the Project Tree on the folder where the new section should be. New sections can only be added below the lowest folder level.
2. From the Insert tab, New Section group, choose From .doc. Alternatively, right click on the folder where the new section should be and choose New Section from .DOC.
3. Navigate to the location of the .doc or .docx file and double-click on it.
   Note: If you are importing a .docx file, change the file type to be .docx.
4. You can change the Section ID, Acronym and Section Name.
   Note: To be consistent with the other sections, use upper and lower case for the Section Name.
5. If you will be using the MF95 Output feature, fill in the MF95 Section ID and Section Name.
6. Click OK to proceed.

**Note:** If you are in Short Form or Outline Mode when you add a new section from a .doc file, all paragraphs in the new section will be tagged as SF or OL depending on your mode.

**Preparation of RTF or DOC file for New Section from RTF or DOC**

Use the following steps to prepare your RTF or Doc file for creating a new section in SpecLink-E.

1. The word “Section” must be in the first non-blank line in the document.
2. This word must be followed by one or more spaces followed by the Section ID number. Up to 15 characters are allowed
3. The number may be followed without space by an acronym (If no acronym is discovered the acronym will default to “USER”).
4. The Section Title is expected to be the second non-blank line in the document. A properly delimited note may precede the Section Title (but not the Section ID); the note will be assigned to the Section Title.
5. The document filename is irrelevant; it is not used to determine either the number, the acronym or the title.
6. Any or all of the above information can be edited in the dialog box following file selection.

Example of first two lines of an RTF or doc file:
Section 075200
Modified Bituminous Membrane Roofing

7. Paragraphs beginning with the word "Part" and one of the words "General", "Products" or "Execution" will import at Level 1. The test is not case-sensitive.
8. Other levels (hierarchy) are determined basically by the amount of space between the left margin and the first printable character on the line, regardless of how the space was created.
9. Since SpecLink-E has its own auto-numbering system, the import from RTF attempts to remove numbers and letters from the beginning of a line. From the beginning of a line up to five characters followed by a tab will be recognized as an auto-number to be removed.
10. When a paragraph is indented 2 or more levels below its parent it will be promoted until it is only one level below its parent.
11. Lines beginning with 10 or more asterisks will be recognized as the boundary beginning or ending text that should be treated as a Note to the following paragraph. To import a note on a paragraph, it should be formatted like this:

**********
This is the project note for Paragraph One
**********

Paragraph One

12. Blank paragraphs in specification text are discarded; blank lines within notes are maintained.
13. The phrase "End of Section" is assigned to Level 1. If there is no End of Section at the end, it will be added by SpecLink-E.

Note: If you experience any difficulties importing a document, open it in Word Pad, save it as a Rich Text Format (RTF) file and try importing it again.

Importing Hidden Text

Hidden text will import when using Add New Section from RTF file, but not when using Add New Section from DOC file. To import hidden text from a .doc file, open the file in Word and save the file as a .rtf file. To import hidden text as project notes, rather than individual paragraphs, see Preparation of RTF or DOC file for Add New Section from RTF File.

Auto-Select New Paragraphs

This command is a toggle on the Home tab in the Paragraph group. When selected (default setting, denoted by an orange background on the ribbon), when you add new paragraphs they will automatically be selected by a checkmark. Also, any paragraphs pasted into your section from another application will also be selected. When using New Section from RTF or New Section from Doc, if this selection is on, than all paragraphs in the newly added section will be selected with a checkmark.
Look for Choice Fields on Import

This command is a toggle on the Insert tab/New Section group. If toggled on, when using New Section From RTF File, New Section from Doc File, or when pasting text from Word, brackets and greater than and less than signs will be used to create new choices in the imported text.

Rules for Importing Choices

Following are the ways choices must be formatted to import correctly into SpecLink-E. Note that these conventions will be honored only if you have the Insert tab choice of Look for Choice Fields turned on. Also note that if this choice is active, choices will be imported using New Section from RTF, New Section from DOC, as well as using the Paste Command.

<table>
<thead>
<tr>
<th>Description</th>
<th>Marker</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exclusive Choice List</td>
<td>[[apple] [orange] [banana]] or [[apple] [orange] [_____]]</td>
<td>Used as selection for no optional text</td>
</tr>
<tr>
<td>Optional Text</td>
<td>&lt;&lt;apple&gt;&gt;</td>
<td>User can select text or None</td>
</tr>
<tr>
<td>Optional, One required, AND</td>
<td><del>and&lt;&lt;apple&gt;&gt;&lt;&lt;orange&gt;&gt;&lt;&lt;banana&gt;&gt;</del></td>
<td>Must pick at least one, can pick more, AND connector</td>
</tr>
<tr>
<td>Optional, One required, OR</td>
<td><del>or&lt;&lt;apple&gt;&gt;&lt;&lt;orange&gt;&gt;&lt;&lt;banana&gt;&gt;</del></td>
<td>Must pick at least one, can pick more, OR connector</td>
</tr>
<tr>
<td>User Defined Fill-in</td>
<td>[_______________]</td>
<td>User fills in</td>
</tr>
<tr>
<td>Reference Date</td>
<td></td>
<td>&lt;date&gt;</td>
</tr>
<tr>
<td>Owner</td>
<td>#O#</td>
<td>Globally defined term for Owner</td>
</tr>
<tr>
<td>Design Builder</td>
<td>#D#</td>
<td>Globally defined term for Design Builder</td>
</tr>
<tr>
<td>Design Prof</td>
<td>#A#</td>
<td>Globally defined term for Design Prof</td>
</tr>
<tr>
<td>Contractor</td>
<td>#C#</td>
<td>Globally defined term for Contractor</td>
</tr>
<tr>
<td>Project Location</td>
<td>#S#</td>
<td>Globally defined Project Location</td>
</tr>
<tr>
<td>Unit of Measure</td>
<td>{{cubic feet (cubic meters)}} or {{[inch][foot]<a href="%5Bcm%5D%5Bmeter%5D%5Bmeter%5D">yard</a>}}</td>
<td>Globally defined unit of measure</td>
</tr>
</tbody>
</table>

Copying Sections

There are times when you may want to copy an entire section either within a single project or from one project to another. This is helpful when you:
• Copy customized provisions from the section in which they were originally prepared to other similar sections.
• Copy a section from your office master project to a new project. All the choices and selections are copied.
• Copy a new section made with the Add New Section function to your office master project.
• Make two variations of the same section in the same project. Copy the section to a new number and title, then edit the second section differently.

Copying Sections Within A Single Project

To copy an entire section within a single project, you must be connected to the Projects database.

1. In the Tree, click on the section you want to copy. (If the section is checked out to someone, you will be notified and given the option to continue, which will copy the version that has most recently been saved to the database.)
2. Using the right mouse button menu, click on Copy Section.
   The Copy Section for Pasting dialog box appears. The current section ID and acronym are displayed.
3. Verify that this is the section you want to copy, and then click OK.
4. Position your cursor in the tree on the folder that will contain the pasted copy.
5. Using the right mouse button menu click on Paste Section.
   The Paste Section Into dialog box appears.
6. The Copy Section To portion of the dialog box defaults to the current section data. Change the Section number and/or the acronym and title if desired.
7. If necessary, fill in the MF95 Section ID and Section Name.
8. Then click OK. The copied section appears in the tree (in green) with its new section number and/or title.

Importing Sections from Another Project

Use this dialog box to copy sections from one project to another. You must be connected to the Projects Database to import a section from another project.

1. Open the project you want to copy sections into.
2. From the Insert tab / New Section group choose Import From Project.
3. Click on the project you want to copy the section(s) from.
4. The active sections in the project are displayed in the lower window.
5. To see all of the sections that are available for import, unclick the Active Sections Only checkbox. When you show all sections, sections that are currently active in the project you are importing from are listed in a bold font; other sections that are listed may have links or edited content but are not active.

6. From the list of sections click on the checkbox to the left of the section(s) you want to import. You can also highlight a section and press the spacebar on your keyboard to select sections for import.

7. Alternatively, you can click on the Select All button.

8. If you have checked out a section in your current project, you will not be able to import another version of that section until you check it in.

9. By default, if you are importing multiple master sections, once you click Import, SpecLink-E will prompt you to verify that you actually want to import each section. To overwrite all sections, click Yes to all. Deselect the Verify Before Overwriting Existing Sections checkbox in order to import without getting that prompt.

10. Click the Import button.

11. User added sections will be imported into the folder that they were in, in the originating project.

12. Master sections replace the existing master sections in the project. All edits, selections, notes, and target links are copied over the existing master sections.

Tips:

- When creating a new project, if there is another project that is very similar to the new project, but you do not need all the sections in the existing project, rather than copying the existing project, create a new project and then use Import From Project to copy only those sections that you need. This will save time and space as opposed to copying the entire project. You can also import sections from several different projects into your new project.
- If, for some reason, you need to stop the process, you can click on Stop Now and it will only import the sections it has already processed.
- Note that if the section you are importing has user added links to other sections, they will be imported during this process. If the Link Target is not being imported at this time, the links will not be visible. If you later import the section that includes the link target, the links will be enabled and visible.
- If you are importing from a project that has not been compared to the current master, the next time you open the target project, you will be asked to compare it to the master.
- If you are importing from a project that has not been updated to the current master, the next time you open the target project, you will see the Update Reminder dialog box.

Revert to Master

Revert to Master is available on the Documents tab in the Refresh Group. Using Revert to Master will remove all user edits, additions and selections, returning the section to an unedited state, reflecting the current master status for the currently highlighted section in the Document Panel. Revert to Master is only available for edited master sections. If you have made selections but no edits, and want to revert to Master, make an edit on a paragraph to enable this function. When you click on Revert to Master, you will receive a confirmation. Be sure that you are reverting the correct section and then click Yes to proceed. The section will be checked in, reverted to the master and then checked out again. There is no Undo for this action.
Moving a Section

You can move, rename, or renumber a user-added or copied section. You cannot move or renumber a section from the master database, although you can copy a master section and give the copy a new number. To move or renumber a user-added section:

1. The section to be moved must not be checked out.
2. In the Project Tree right-click on the section to be moved and select Cut Section. The Cut Section for Pasting dialog box opens.
3. Verify that this is the section you want to move, then click OK (Otherwise, click Cancel).
4. Position your cursor in the tree on the folder that will contain the moved section.
5. Using the right mouse button menu, select Paste Section Into or from the Project Tree tab / Edit Section group click on Paste Into. The Paste Section into dialog box appears.
6. Change the section number and/or the acronym, if desired. You can also change the section name, as well as the MF95 section ID and MF95 section title.
7. When all desired changes have been made, click OK. The section is moved to its new location in the Tree Panel.

NOTE:

- To rename a section (master or user-added), just change the name in the title paragraph in the document panel by double-clicking on it and retyping it. The tree will update to the new name, and the new name will print in the header or footer.

Deleting a Section

You can delete a user-added or copied section. You cannot delete a section from the master database. To delete a user-added section:

1. Make sure that the section is not checked out to you or anyone else.
2. Right-click on the section title in the Project Tree and select Delete Section.
3. You will be asked to confirm the deletion.

NOTE: Be certain you wish to delete the section before clicking OK, because it is not possible to UNDO this process.

Navigation in Sections

To view the text of a section, click on the title of the section in the Tree Panel and single or double click (depending on your setting of Single Click to Open) to Check it out. The first part of the section text will appear in the Document Panel.

The principal way to move around in the section is by scrolling the text up and down the screen, using the scroll bar or a scrolling mouse. Click on the scroll bar to move one page at a time. Drag the scroll button to move through large portions of the section quickly.

Other aids to navigation are:

- "Show Levels"
- "Move to First" and "Move to Last"
- Skip to "Next at Current Level" or "Previous at Current Level"
- The bookmark
- "Find"
Using Show Text Levels

Use Show Text Levels to expand or collapse the text outline format within the Document Panel. Click the "Show Text" buttons in the Show Text group on the View tab to change the number of levels visible.

Moving to the first paragraph or last

The "First" and "Last" buttons in the Move To Paragraph group on the Home tab move the cursor quickly to the beginning or end of the section.

Move to Next Paragraph at Current Level

The "Move to Next Paragraph at Current Level" and "Move to Previous Paragraph at Current Level" can be used to quickly move the cursor between major headings or parts of a section. For example, to quickly get from Part 1 General (which is a level 1 paragraph) to Part 2 Products (which is the next Level 1 paragraph), click to place your cursor in Part 1 General and then click the Next Paragraph at Current Level button from the Move To Paragraph group on the Home tab.

Using the Bookmark to Aid Navigation (Mark Place)

If you know that you will wish to return to your original position in the text of a section, press the Mark Place icon from the Manage group on the Documents tab before you move. The bookmark is now set to the paragraph that the cursor was on when you pressed the icon. When you finish reviewing other text, press the Return To Mark icon. The screen will move to the bookmarked paragraph. If it doesn’t, that may be because the marked paragraph is at a level that is not visible. Just show all levels and press the Return To Mark button again.

Note:
The bookmark feature only works in one section at a time. If you mark a paragraph and then change to a different section, Return to Mark will not return you to the previous section.
Shortcut Keys

SpecLink-E uses several of the standard Windows keyboard shortcut keys:
- **Control+X** - Cut - Use this to cut text or paragraphs for moving to a new location
- **Control+C** - Copy - Use this to copy text or paragraphs for moving to a new location
- **Control+V** - Paste - Use this to paste copied or cut text or paragraphs to a new location
- **Control+A** - Select All - Use this to select all text in the current tab of the header/footer dialog box

In addition, if you use the **Alt** key followed by the first letter of a tab (such as **Alt and then D** for documents tab) the shortcut key abbreviations for the commands on that tab appear on the menus. Type the key for the command you want. Do not hold the **Alt** key down when you type the key for the desired command.

Selecting and Excluding Text

Selecting, de-selecting, and excluding paragraphs

A paragraph must be active before it will print in the project.
All active paragraphs will print. For a paragraph to become active, its parent must also be active.
Paragraphs are made active by changing their status -- both the user and the system can change status.
To select a paragraph
To de-select a paragraph
To exclude a paragraph

Status

The status of each section and paragraph is visually displayed in the box in the status column to the left of the title/text using colors. There are 2 types of status: **user status**—reflecting actions taken by the user—and **system status**—reflecting links made by the system.

The status box of an active paragraph will look like one of the following:
- Selected by user (checkmark), neutral by system
- Neutral by user, selected by system (green)
- Selected by user (checkmark), selected by system (green)

**Note:** The checkmark on the green box is actually redundant. It is not necessary to check a green status box in order for the paragraph to be active.

- Selected by user (checkmark), but also indicates that there is an updated version of this paragraph available.
- A dark blue background in the Sequence Number indicates that this is a user paragraph.
- A bright green background on the Sequence Number and Tag column indicates a manufacturer listing that includes additional information about their products in the master note
- An olive green background on the Sequence Number indicates that this paragraph was previously a master paragraph but was removed from the master. Since it was in use in the project, it was copied as a user paragraph.

**Note:** When an paragraph is highlighted by the system, in order to make it active the user must put a checkmark in the triangle.
Selected by user (checkmark), excluded by system (red stop sign)

Note: The system excludes conflicting options, but if for some reason both are needed, the user can override the exclusion by putting a checkmark in the stop sign.

The status box of an inactive paragraph will look like one of the following:

- Neutral by user, neutral by system
  Note: To make the paragraph active click in the box.

- Selected by user (checkmark), neutral by system
  Note: The gray background of the status box indicates that the paragraph is not active.
  Check the parentage of the paragraph.

- Excluded by user (X), neutral by system
  Note: The X on the gray box is unnecessary.

- Neutral by user, highlighted by system (yellow triangle)
  Note: To make the paragraph active click in the triangle.

- Excluded by user (X), highlighted by system (yellow triangle)
  Note: The X on the yellow triangle is unnecessary.

- Neutral by user, excluded by system (red stop sign)
  Note: Override the system exclusion by clicking in the stop sign.

- Excluded by user (X), selected by system (green box)
  Note: If a system selection is inappropriate, override it by clicking once in the box to get a checkmark, and clicking a second time to get an X.

- Excluded by user (X), excluded by system (red stop sign)
  Note: The X on the red stop sign is redundant.

Note:

- The Status Column cannot be toggled off.

Active versus Inactive Paragraphs

Text that will appear in printed document is considered active -- all other text is inactive.
To be active, text must have been selected either by system or user and have complete active parentage up to the title of the section.

Active text is indicated in the Document panel in 4 ways:

- The text is black on a white background, rather than black on a grey background.
- The background of the status columns to the left of the text is light gray rather than dark gray.
- The status box appears pushed in.
- If using a Project Template with autonumbers, active paragraphs have paragraph numbers and inactive paragraphs do not.

Tip: Click on Selected View in the View tab/Document group to see only the active paragraphs.

Parentage

Each paragraph has a parent -- the first paragraph above it that is at a paragraph level with a lower level number than its own.

Complete active parentage refers to a paragraph having an active parent whose parent is also active, and so on, all the way up to the section title.
The hierarchical arrangement of text prevents "child" text from becoming active until its parent is active. In addition, text cannot be "orphaned" -- a sub-paragraph is always subordinate to another paragraph (regardless of whether that subordination makes sense in the context). When a user-added paragraph is deleted, all its "children" are also deleted, because they no longer have a parent.

Selecting a paragraph

Click in the status box to the left of the text -- a checkmark appears in the status box: ☑ or ☑ or ☑. If the status box is green ☑, there is no need to select the paragraph manually -- just be sure that its parents are selected. If the status box is not blank, you will need to click twice, first to return the status to "neutral," then to selected. Whenever the status is changed, the relevant changes to the links are executed.

Deselecting a paragraph

Click in the status box to the left of the text until the status box is empty: ☐, ☑, or ☑. If the box remains green ☑, the paragraph is still active and will print. To remove it from the project, you can exclude it. You can also view the link sources to identify the reason the software selected it.

Excluding a paragraph

Click in the status box to the left of the text cell until the status box has an X: ☒, ☑, ☒, or ☒. Note that you do not need to exclude a paragraph unless it is active because of a green link and you do not want it to be active.

Modifying Text

Adding a new paragraph

The three easiest ways to add a new paragraph:

- Position your cursor at the end of a paragraph and press enter. A new paragraph will open below the original one.
- Position your cursor at the beginning of a paragraph and press enter. A new paragraph will open above the original one.
- Right click on any paragraph and choose Add Paragraph from the right mouse button menu to insert a paragraph above the original one. A white and blue square appears in the Origin column, indicating a user-added paragraph. Then just type your text in the new blank paragraph, or use Copy/Paste to paste text from another application or similar paragraph.

Or if you'd rather do it the long way:

1. Position the cursor on the paragraph that is located below where you want the new paragraph to be located.
2. From the Home tab, Paragraphs group, choose Add Paragraph.
3. Type your text in the new blank paragraph, or use Copy/Paste to paste text from another application.

Note that user added paragraphs have a white and blue icon in the Origin column.

**Note:** When you insert new paragraphs while in Outline or Short Form mode, your new paragraph will inherit the Spec Type Tag of the mode that you are in.

### Deleting a Paragraph

To delete a user-added or copied paragraph or the modified version of a user-modified paragraph:

1. In the Document Panel, click on the paragraph to be deleted. Make sure your cursor is blinking in the paragraph.
2. Using your right mouse button menu, click on Delete, or from the Home tab/Clipboard group, choose Delete, or choose Remove Paragraph from the Home tab/Paragraph group.
3. You are prompted to confirm the deletion. Choose Yes to delete the paragraph, or choose No to maintain the paragraph.

If the paragraph was user-added or copied, the whole paragraph and any subparagraphs it may have had are deleted. If the paragraph was user-modified, the modified version is gone and the Origin (O) column is blank.

**Tips:**

- You can also just delete text, not the entire paragraph (which includes choices, target links, subparagraphs, and notes) by dragging across the text you want to delete with your mouse to highlight or block it. Then do one of the following: Home tab/Clipboard group > Delete, right mouse button > Delete, or press the Delete key on your keyboard. If the paragraph was originally a master paragraph (the O column was blank) this will result in a modified paragraph (the O column will have a light-blue rectangle across the bottom) and can be restored.
- You can delete user-added paragraphs only. To keep a master paragraph from printing first deselect it, then exclude it if it is selected by links.
- Sub-paragraphs ("children") are automatically deleted when the parent is deleted. To delete a paragraph without deleting subparagraphs, first demote the paragraph.
- When a paragraph is deleted, all notes and links attached to the paragraph or its sub-paragraphs are also deleted.
- If you get a message that the current selection includes one or more Master Paragraphs that cannot be deleted, first demote the paragraph.

### Editing a paragraph

To edit a paragraph:

1. Click on the correct paragraph.
2. Edit the paragraph by typing new text, deleting text, or pasting text from anywhere that you can copy text.
3. Once a master paragraph has become a user version (which you can do by simply adding a space) you can edit the choices.
If you modify a Master paragraph, a light blue rectangle appears on the bottom half of the Origin column, indicating user-modified text.

**Tips:**

- To undo your changes, press the Undo button.
- To undo your changes at a later time, delete the user-modified version and start over.
- To switch back to the original text, choose Restore Paragraph From Master.

**Changing the section title**

To change the name of a section, follow these steps:
- Check out the section.
- Double click on the section title in the Document Panel.
- When the Change Title dialog box opens, type the new section title.
- Click OK.

The section title will be changed in the Document Panel, the Project Tree and all other places where the section titles appear.

**Restore Paragraph From Master/Project**

When a master paragraph has been modified by the user, it is possible to switch back to the original text, to review it or to make it active in the project.

1. In the Document Panel, position the cursor on the edited paragraph you want to restore to the master text.
2. Click on the Sequence Number on the left side of the paragraph.
3. Alternatively, from the Home tab, Paragraph group, choose Restore Paragraph From Master.
   The original master text is restored, and a yellow rectangle appears on the top half of the Origin column and the background of the Sequence column turns yellow, indicating that this is master text for which a user-edited version is available.
4. To return to the paragraph you edited, reverse the process by clicking on the sequence field again. Your edited project text reappears, and a light blue rectangle appears on the bottom half of the Origin column, indicating that this is an edited version of the master text.

You can toggle between the two versions as much as you wish. If you decide that the user version is unnecessary, rather than leaving the master version displaying with a yellow icon in O column, delete your version.

**Copying a Paragraph**

**To copy a paragraph including choices, target links, subparagraphs, and notes:**

1. Click on the paragraph to be copied and with your cursor blinking in the paragraph, do one of the following:

   - Press the Copy button on the Home tab, or
   - Press Ctrl+C, or
   - Use the right mouse button and select Copy.
2. Position the cursor on the paragraph that is located below where you want to paste the copy.
   Do one of the following:

   • Press the Paste button on the Home tab, or
   • Press Ctrl+V, or
   • Use the right mouse button and select Paste.

   The paragraph and all its subparagraphs (the whole branch) will be pasted into the new location and a dark blue icon will appear in the Origin column next to each copied paragraph.

To copy just the text of a paragraph (without choices, target links, subparagraphs, and notes):
With your mouse, highlight or block the text that you want to copy and do one of the following:

   • Press the Copy button on the Home tab, or
   • Press Ctrl+C, or
   • Use the right mouse button and select Copy.

Add a paragraph where you want the copied text, or click in an existing paragraph where you want the text.
Do one of the following:

   • Press the Paste button on the Home tab, or
   • Press Ctrl+V, or
   • Use the right mouse button and select Paste.

Tips:

   • When you copy a whole paragraph (using the first method above), the pasted paragraph or branch pushes down the original paragraph at the pasted location. The paragraph at the top of the branch is given the level of the paragraph at which it was pasted. If this inherited level is incorrect, you can adjust it using Promote or Demote.
   • To paste text from one section into another, first open two windows and display the two sections. Then copy from one and paste to the other.
   • To copy a paragraph or branch from another project, you will need to start another instance of SpecLink-E to open a different project.

Promoting and Demoting

Use Promote to increase the hierarchy level by one -- from 4 to 3, or from 3 to 2, for example -- moving the text to the left.
Use Demote to decrease the hierarchy level by one -- from 2 to 3, or from 3 to 4, for example -- moving the text to right.
To promote or demote a single paragraph or group of paragraphs at the same level:
1. Click on the paragraph or highlight the group to be promoted or demoted.
2. On the Home tab, Paragraph group, click the Demote Paragraph or Promote button or use the right mouse button menu to choose Promote or Demote.

To promote or demote a whole branch:

1. Click on the first paragraph of the branch to be promoted or demoted.
2. On the Home tab, Paragraph group, click the Demote Branch or Promote Branch button or use the right mouse button menu to choose Promote Branch or Demote Branch.

**Tip:** Promote and demote will only move text to appropriate levels -- the software prevents you from making "illegal" promotions or demotions that would produce gaps in the hierarchy levels between parent and child text.

**Note:** Promoting or demoting a paragraph will remove any formatting that has been applied to the paragraph.

### Copying Text from the Clipboard

To copy text from another file, such as a word processing document, you must first copy the text to the Windows clipboard.

1. Open the project you wish to paste into and check out the appropriate section.
2. Start or switch to your word processing program and open the file containing the text to be imported.
3. Mark the text to be copied and select the Copy function from the applicable menu or press Ctrl-C.
4. Switch back to the project section and position the cursor on the paragraph above which you wish to paste the imported text.
5. Paste the text by using the right mouse button menu and selecting Paste. You can also click on the Paste icon on the Home tab or press Ctrl-V.
6. If the imported text is at the wrong level, use Promote/Demote to adjust the levels.

The text from the Clipboard is imported and pasted into new paragraphs. Notice that the indents in the original document are maintained as Levels.

**IMPORTANT:**

- Prepare the text in your word processor first, to eliminate inconsistencies in indenting or other formatting attributes -- you will save much time that would be otherwise spent cleaning up the imported text.
- If the text you are pasting does not include a carriage return, it will be pasted as text within the current paragraph, rather than as a new paragraph.
- If you are in Outline or Short Form Mode when you paste new paragraphs, they will automatically be tagged for the mode you are in.

### Preparing Text for Importing

The Paste function uses the current contents of the Windows clipboard and makes certain assumptions about the contents. To make importing more reliable, prepare the text to be imported in your word processor first. Any word processor or text editor that will copy to the clipboard may be used.
**Paragraphs:** Each paragraph in the original text will be pasted consecutively into a separate new paragraph in the section. A hard return (WordPerfect) or a paragraph mark (Word) is used to determine the end of a paragraph. If there are too many “end of paragraph” marks or codes, you will find that the text is broken up into too many individual paragraphs. If you are uncertain about where paragraphs end, turn on whatever function is used to display the paragraph marks or codes and view them.

**Levels:** The first paragraph is inserted at the level of the paragraph that the cursor is on, just like an ordinary copy and paste. However, if there are any tabs or indents in the original text, they will be used to demote subsequent paragraphs appropriately, keeping the original hierarchical arrangement. These tabs and indents must appear at the beginning of the line.

**Paragraph Numbering:** If the imported text contains paragraph numbers made using either text characters or word processor codes, you do not need to delete them as SpecLink-E will usually remove them during the import.

**Other Characters:** The text imported from the clipboard is ASCII text. Besides letters and numbers, and tabs and carriage returns, the only characters that will be imported are those in the standard ASCII character set -- those on a standard keyboard.

**Note:** If you experience any difficulties importing a Word document, open it in Word Pad, save it as a Rich Text Format (RTF) file and try importing it again.

**Choices**

Many paragraphs in the master database include embedded choices. Embedded choices are indicated by words in **colors** or marked with brackets. The three basic choice types are multiple choices, global options and fill-in-the-blanks.

- **Blue** text indicates a multiple choice .
- **Green** text indicates a global option set at the Summary Info dialog.
- **Red** text indicates a fill-in-the-blank, filled in. When the fill-in is blank it is just red underscores with brackets.

Each embedded choice has a default value, which may or may not be appropriate for your project.

**Multiple Choices**

Multiple choices are marked in **blue**. They can include fill-in-the-blanks .

- **Exclusive** multiple choices include 2 or more options, *one of which must be selected, but only one*. They sometimes include a “None - N/A” option, which allows all to be omitted.
- **Inclusive** multiple choices include 2 or more options, *one or more of which must be selected*. These options are automatically punctuated properly and joined with the word “and” or “or” as appropriate. They sometimes include a “None - N/A” option, which allows all to be omitted.
Optional text is a variation of exclusive multiple choice, where there are only 2 options one of which is None - N/A. The text option is either in the project or not.

When a "None - N/A" option is current it appears in the text as [<>] but does not print.

To view and change multiple choice options:

1. Click on the blue text - a choice list will open. There may be a scroll bar on the right if there are too many options to fit in one screen.
2. Select the option(s) you want by clicking on the open circles or boxes opposite the choice options. Exclusive multiple choices have circles ○, inclusive multiple choices have boxes □.
3. To finish, click outside the choice menu box to close it.

Fill-in-the-blanks

Fill-in-the-blanks are shown in the text as [______]. The user must enter a word, phrase, or number to make the text complete. Fill-ins can stand alone -- as the only option of the group -- or they can occur as one of the options in multiple choice groups.

To enter text in a fill-in:

1. If the fill-in you wish to use is one of a multiple choice group, first select the fill-in as you would any other choice, so that it appears as a blank in the text. (It will show as a blue blank [_____], to distinguish it from a simple fill-in-the-blank.)
2. Click between the brackets. A small entry box will pop up into which you type your text. The underscores are automatically removed. If the Fill-in is a part of a blue choice list, you will have to click once to bring up the list of choices, click again to dismiss it and then click a third time to bring up the entry box for the fill in the blank. Clicking in a blue fill-in alternates between bringing up the other available choices and bringing up the entry box to fill in your text.
3. When you are finished typing, you can press the Enter key to dismiss the box, or you can click anywhere outside of the box.

If you don’t want or need to enter anything in a blank, you can hide it:

1. Enter the words None - N/A in the blank.
2. Click outside the brackets. When you print, the fill-in will not print, and the spaces around it will close appropriately. (For example, if the fill-in is between two words and there is a space to either side of the fill-in, if you put None - N/A in the blank the blank will not print and only one space will print between the two words.)

NOTES:

• Be sure to enter the words exactly as spelled and capitalized above, using a space-hyphen-space between them and a slash between N and A. (This is the same format as for optional choices.)
• In most cases, you will also have to edit the text outside the blank, since the blank existed to complete some thought or concept.
• If the blank is part of a choice option, with other text, this technique will not effectively hide the choice, because the choice text is not editable. In that case, you must edit the paragraph to make a user version of the master paragraph and then you can edit the choice list.

NOTE:
There is a limit of 255 characters in a fill-in-the-blank. If you need more text than that, simply type the text in the body of the paragraph to the right or the left of the fill-in-the-blank choice.

**More Editing Tools**

**Refresh Document**

This command is available from the Quick Access Toolbar, as well as from the Refresh group on the Documents tab. It is available when a document is checked out and displayed in the Document Panel. This will display the accurate status of the document in the Document Panel.

**Refresh Tree**

This command is available on the Project Tree tab, in the Refresh group. Use this command to retrieve the current status of the Project Tree. If multiple users are working in the same project, changes made to the status of sections and folders in the Project Tree will be visible by using Refresh Tree, or by closing and reopening the project.

**Spell Checking**

To check spelling for the **active section**, click on the Home tab and choose Spelling from the Editing group.

To check spelling for the **entire project**, click on the Tools tab and choose Spell Check Project from the Projects group.

Most words in the BSD Master are in the spell checker's dictionary. Manufacturer names and product names often are not, since many times the spellings of those words would be considered misspellings anywhere else. Single characters, like c, d, and e that would be used in paragraph numbering are also not usually in the dictionary so that if you accidentally type one of those letters within a paragraph the spell checker will find it. The Spell checker does not replace misspelled words in choices, including fill-ins.

**Ignore Words in Upper Case:** This is on by default. If you want SLE to spell check words that are in upper case, uncheck this setting. This setting affects spell checking individual sections, as well as the entire project. To change the default for yourself, with a project open, click on the Tools tab and select Spell Check Project. Select or deselect Ignore words in upper case. This setting is saved individually for each user.

When the speller finds a word not in its dictionary or in your custom dictionary, it presents the following options:
• **Ignore** -- Select this if the word is all right but you don’t wish to add it to the dictionary.
• **Ignore All** -- Select this to ignore all other occurrences of this word in this section.
• **Add** -- Select this to add the word found to the custom dictionary. It will be used when checking spelling thereafter.
• **Replace** -- If the spell checker found an alternative word or words, they are displayed and the first one is suggested. If the spell checker does not offer an appropriate suggestion, you can change the spelling in the top “Not in Dictionary” box yourself, and click on Replace.
• **Replace All** -- Select this to replace all instances of this word in this section.
• **Cancel** - Use this to close the dialog box.

**Tips:**

• The custom dictionary file is a plain text file located in the My Documents\SpecLink-E folder, called SLEUserDict.txt. If you accidentally add a misspelled word, you can edit the SLEUserDict.txt file to delete it. Close SpecLink-E prior to opening the SLEUserDict.txt file. This file can be edited using Notepad. In a multi-user situation, the file may be copied to user’s computer, or each user can append to it by opening it in Notepad and using Copy and Paste to add new words.

**Undo**

The Undo function allows you to undo typing and certain other changes to your section. To undo your edits, choose Undo from the Quick Access Toolbar. The software maintains a separate Undo Stack for each open section that remains in effect until you close the section. Creating, editing or deleting a choice or a hyperlink will kill the Undo Stack for the section you are in. If your section has been closed, or the Undo Stack has been otherwise killed since the edit was made, you can Restore Paragraph From Master/Project or use Delete to remove your edits.

If you edit a master paragraph, there are 2 levels of Undo. The first Undo will remove the most recent edit. The second Undo will remove all edits to the master paragraph, removing the turquoise icon from the O (Origin) column.

What undo will do:
• Will remove typing from a paragraph
• Will remove a newly added paragraph
• Will remove a newly inserted image
• Will remove a newly inserted table
• Will undo a change made by the spell checker
• Will undo a change made by Find/Replace
• Will undo a Demote or Promote
• Will undo moving paragraphs/branches within a section
• Will reinstate a deleted paragraph or branch
• Will remove a pasted paragraph or a branch

What undo will not do:
• Will not undo changes in status (selection/deselection)
• Will not undo the changing of a choice
• Will not undo the insertion or deletion of a hyperlink or choice

Find/Replace in a Single Section

To open the Find dialog box, display the section that you want to search in the Document panel. Then from the Home tab / Editing group choose Find/Replace, or press Ctrl+F on your keyboard. If you are not showing all levels of text, Find will notify you that it can only search text that is displaying and will ask if you want to Show All Levels. If you click Yes, it will Show All Levels and open the Find and Replace dialog box. If you click No, it will leave the display as it is, and open the Find and Replace dialog box. When it searches for text, it will not search the paragraphs that are not displayed.

1. Enter the text to search for in the Find What field.
2. If you want to replace found text with other text, click on the Replace tab and type that text in the Replace With field.
3. Select Match Case if desired.
4. Click on Search Up if desired.
5. Click Find Next. If the text exists in the section, it is highlighted in the background and the Find box remains open.
6. If you want to replace the found text with what you typed in Replace With, click Replace (you can also add text to, or edit the text in Replace With before you click Replace).
7. If this is not the occurrence of the text that you were looking for, click Find Next.
8. If this is the right text and you do not want to replace it, click Cancel.
9. To replace all occurrences of the text, click on Replace All.

Note: Find/Replace will not replace text in choices or fill-in the blanks.

Find/Replace in Project

To open the Find dialog box, from the Home tab / Editing group choose Find/Replace, or press Ctrl+F on your keyboard.

1. To search for multiple sections in the project, change the Look in drop down box from Current Section to Current Project.
2. The sections that are checked out to you will be selected automatically.
3. Check any additional sections you want to search.
4. Uncheck any sections that you do not want to search.
5. Enter the text to search for in the Find What field.
6. For any open sections:
   • If you want to replace found text with other text, click on the Replace tab and type that text in the Replace With field.
   • Select Match Case if desired.
   • Click Find Next. If the text exists in the section, it is highlighted in the background and the Find box remains open.
• If you want to replace the found text with what you typed in Replace With, click Replace (you can also add text to, or edit the text in Replace With before you click Replace).
• If this is not the occurrence of the text that you were looking for, click Find Next.
• If this is the right text and you do not want to replace it, click Cancel.

7. To replace all occurrences of the text, click on Replace All.

Note: Find/Replace will not replace text in choices or fill-in the blanks.

Notes

Notes can help you make decisions about what to include in your project. Paragraphs that have notes are marked with an icon in the Notes (N) status column in the Document Panel. To view the notes, click within the paragraph and the notes will display in the Master and Project Notes panels on the left side of the screen. (If you cannot see one or both notes panels, choose them from the View tab.

Master Notes: Notes that are part of the master database and not user-editable; marked with a yellow note icon on the left side of the N column.
Project Notes: Notes that are inserted by the user; marked with a cyan icon on the right side of the N column.

Tips:
• If a paragraph has both Master and Project notes, both the yellow and cyan note icons display in the N column.

Copy/Paste

Copy and Paste work nearly the same way they do in most Windows-based programs. The Copy and Paste commands on the Home tab/Clipboard group, on the right mouse button menu, and using the standard windows shortcut keys (Ctrl+C and Ctrl+V) are for copying and pasting text within paragraphs and notes, and for copying and pasting entire paragraphs including target links, choices, and subparagraphs. These commands will not work for copying or pasting sections.
To copy text (not the entire paragraph) drag across the text and then use one of the Copy methods listed above. Click to place your cursor where you want to paste the text and use one of the Paste methods listed above.
To copy an entire paragraph, leave your cursor blinking in the paragraph and choose Copy. Then click in the paragraph below where you want the new paragraph and paste. For more information and more detailed instructions see Copying a Paragraph.

Note: When working in some dialog boxes, such as the Header/Footer dialog box, to copy a footer from one tab to another, you must use Control+C for Copy and Control+V for Paste, rather than the menus.
Note: When you paste text in from a word processing document while in Outline or Short Form Mode, your pasted paragraphs will inherit the Spec Type Tag of the mode that you are in.

Cut/Delete

Cut and Delete work nearly the same way they do in most Windows-based programs. The Cut command is available from the Home tab/Clipboard group, the right mouse button menu, or the standard Windows shortcut key - Ctrl+X. Delete is available from the Home tab/Clipboard group and the right mouse button menu. One function of Delete (explained below) can also be performed by using the Delete button on your keyboard.

Both Cut and Delete are only for cutting and deleting text and paragraphs. They will not work for cutting sections or deleting sections.

Use Cut to move text or paragraphs to a new location using Paste. Use Delete to permanently remove text or paragraphs.

What will be cut or deleted depends on your cursor location. To cut or delete text, drag across the text with your mouse and then use one of the Cut or Delete methods listed above. To cut or delete an entire paragraph, leave your cursor blinking in the paragraph and then choose Cut or Delete. You will only be able to Cut user-added paragraphs. Delete will delete user-added paragraphs or user-modifications to master paragraphs. You cannot cut or delete master paragraphs - if you don't want a master paragraph to print, don't select it.

The Delete key on your keyboard will only delete text you have dragged across, or the character to the right of your cursor.

Adding Tables

There are two kinds of tables in SpecLink-E:

- Tabbed Text - which can be imported from another application, but does not support borders or text wrapping within individual cells.
- True Tables - which must be created in SpecLink-E. True tables do support borders and text wrapping in individual cells.

Inserting a Table

Inserting a table directly into SpecLink-E will allow you to incorporate text that wraps within a cell. Borders on inserted tables can also be printed, if desired. If you want to create a table in SpecLink-E, do the following:

1. Click on the paragraph that will be below the new table.
2. Be at the correct level for the table, demoting or promoting as necessary.
3. From the Insert tab / Tables group choose Table and then Insert. Or use the right mouse button and choose Insert Table.
4. The Insert Table dialog box opens.
5. Input the number of columns and rows desired for this table and then click on OK.
NOTE: The maximum number of rows in a table is 50. The maximum number of columns is 16.

The table is inserted into the section at the same level as and above the paragraph you originally highlighted. The left edge of the table will be at the left indent of the assigned level. If you promote or demote the table, the left margin of the table will not change. The initial width of columns will be the width between the left indent and the right indent divided by the number of columns. A table will never be wider than the margin created by the right indent.

Note on working with large tables:
- Large tables can be jumpy when selecting, adding or pasting text. We realize this and are working with the control to try to minimize this issue.
- Be careful to avoid pasting text into the space above or below the cells in any table. If you do this by mistake, click on the Undo icon.

6. To make adjustments, use the other commands in the Tables group:
  - **Table** - Use this to insert another table or to remove the current table.
  - **Row** - Use these commands to insert an additional row into the table above or below the current row. You can also delete a row.
  - **Column** - Use these commands to insert or delete columns, or to align the contents of the column left, center or right.
  - **Make Header Row** – Use this to designate the top row as a Header Row. See below for more information on Make Header Row.
  - **Using Mouse to drag borders** - You can use your mouse to drag the borders of the columns to the right and left to make columns wider or narrower. Note that you can also use the font and alignment buttons on the Format tab to change the attributes of a single table cell.
  - **Select** - Use this to select a table, row or cell to apply text formatting.
  - **Split** - Use this to split the table into two separate paragraphs.
  - **Gridlines** - Use this command to add or remove a border for the table.

**Make Header Row**

The Make Header Row feature allows you to designate one or more table rows as the Header for this table. This means that if the table spans more than one page, the Header Row will be repeated at the top of the second and subsequent pages on which this table appears.

To use Make Header Row:

1. While in the table, click on the top row and then click on the Make Header Row function in the Tables Group (Insert tab). Note that if the functions in the Tables Group are not available, click in the table again.
2. Once a row has been designated as a Header Row, when you click in that row, the Make Header Row menu choice will have an orange background, indicating that it is a Header Row.
3. If this table is spanning multiple pages, then this row will appear at the top of each page.

Notes on using this function:

- If the Header Row is the last row to print on a page, then it will not appear on subsequent pages. If this happens, you need to add a page break above the table so that it starts on the next page. See the next bullet on adding a page break before a table.
- To add a page break before a table, do the following:
1. Insert an empty paragraph above the table.
2. Be sure that the empty paragraph is active.
3. Select No Autonumber from the Format tab, so that the empty paragraph does not have a printed number.
   - It is possible to include more than one row as Header Rows. Any additional header rows must be directly below the top row, which is designated as a Header Row. You must select both rows at the same time and click on Make Header Row. Note that only the first row will display the orange background (when you click on it) indicating that it is a Header Row.

**Resize Table Columns**

When a table in inserted, it takes the whole width of the Document Panel by default and allocates the allotted space equally between the columns. You can change the width of individual columns. To make one column wider, you will need to make another column narrower.

To change the width of a column:
- Click within the table.
- Drag the grey box in the ruler either to the right or left to change the width of the column.
- To insert a column on the far right, make the existing columns narrower to allow for an additional column.
- Click outside of the table to save the change.

**Table borders**

Tables that you create in SpecLink-E can have borders. To add a border to a table use Gridlines.

**Importing a Table from Word**

To copy a table as tabbed text from a Word document into a section, do the following:

Note that to end up with a table that can display a border and include text that wraps, you will need to insert the table directly into SpecLink-E without importing it.

**NOTE:** Be certain the margin settings in SpecLink-E are the same or wider than the document in Word. Otherwise, the table will not fit properly and line breaks will occur at inappropriate locations.

1. Verify that Auto-Select New Paragraphs and Look For Choice Fields are turned off or on as you want them.
2. Select the table in Word.
3. In Word, from the Table menu, choose Convert, and then choose Table to Text.
4. Use the option to separate with tabs.
5. Once complete, select all the text in the table, and Copy (from the Edit menu, or the toolbar, or use Ctrl+C).
6. Open the appropriate section in SpecLink-E and place the cursor in the paragraph that is below where you want the table, then from the Home tab, Clipboard group, choose Paste.
   - The paragraphs are added above the paragraph you clicked on.
7. If the text does not line up in columns, click to place your cursor where more space is needed and press tab on your keyboard. Continue doing this until all the columns line up.
   - It is best to line up the columns from left to right.
8. If you do not want the rows of the table to be numbered, drag across all the text in the table to highlight it, and then from the Documents tab, Manage group choose No AutoNumber.

9. To add a page break before the table, click in the paragraph that you want to have at the top of the page, and from the Documents tab, Page Setup group, choose Insert Page Break. A dark line will appear above the paragraph, representing the page break. The paragraph must be active and not be tagged NS or NP in order for the page break to work.

**NOTE:** To remove a page break, click in the paragraph that has the dark line above it and from the Documents tab, Page Setup group, choose Remove Page Break.

**Tabs dialog box**

On the Format tab, Alignment group, is a selection called Tabs. The Tabs dialog box allows you to use tabs within a selected area of your document. This feature can be used when you want columns to be aligned but do not need to create a table. This feature is not available when you are in a table.

**Using the Tabs Dialog Box**

Use the Tabs dialog box to align text in a columnar format. The tabs set or cleared in the Tab Dialog box are applied to all paragraphs that are selected at the time that the Tabs dialog box is opened. Tab stops for the currently highlighted paragraph are indicated in the ruler bar above the text panel using angle marks.

1. Within your document, select the paragraph or group of paragraphs that are to have the tabs applied. To select one paragraph, simply click anywhere on that paragraph. To select a group, click on the first one and then drag your mouse over the remaining paragraphs. When selected, they will have a black background in the document panel.
2. While the paragraphs are selected, click on the Format tab / Alignment group and select Tabs.
3. To set all new tabs, first click on Clear All.
4. To remove one individual tab stop, click on it and then click on Clear.
5. To set a new tab, click on the Tab stop position field and input the width of the tab stop in inches. Note that the first tab stop is automatically set by the software based on the style of the level you are in, and if you remove it, the software will put it back. If the Set button is grayed out, then the option you have selected is not appropriate.
   - A Left Tab stop sets the start position of text that will then run to the right as you type.
   - A Center Tab stop sets the position of the middle of the text. The text centers on this position as you type.
• A Right Tab stop sets the right end of the text. As you type, the text moves to the left.
• A Decimal Tab stop aligns numbers around a decimal point. Independent of the number of digits, the decimal point will be in the same position.
• Right most tab - The tab is positioned at the right hand border and the text is displayed at the left of this position. The tab position set with the Tab Stop Positions property is ignored. Only one tab of this kind is possible in a paragraph.

6. Click on the Set button.
7. To add additional tab stops, click on the Tab stop position and enter another number.
8. If you need to change the position for an existing tab, click on it and then click the Clear button. Re-add the Tab stop position as desired. Use the Clear All command to clear all tabs settings.
9. When finished, click on OK to implement the tabs within the selected paragraphs.

NOTE: Note that the Tables capability is sometimes a more effective way to arrange multiple data columns.

Setting Tabs with the Ruler

You can add, delete and move tabs without opening the Tabs dialog box.
• Drag across the paragraphs for which you want to change the tab settings.
• The tabs are indicated in the ruler (directly above the Document Panel) as small black L’s on the lower part of the ruler.
• To move a tab, click on it and drag it either right or left.
• To remove a tab, click on it and drag it downward off the ruler.
• To add a tab, click on the ruler where you want the new tab to be.
• Click on another paragraph to save your changes.

Inserting and Removing Hyperlinks in a Paragraph

You can insert a hyperlink into a user added paragraph and an edited master paragraph, except the section title.

• If in a master paragraph, make an edit so that the O column has a turquoise icon.
• Click in the location where the hyperlink should be.
• Choose Hyperlink from the Links group on the Insert tab.
• Fill in the text you want to appear within the paragraph in the Text to Display field.
• Fill in the path of the hyperlink in the Address field.
• Click OK.

The hyperlink is inserted into the paragraph. To follow the link, press the Ctrl key while clicking on the hyperlink. The web page will open in a separate window.
Removing a hyperlink from a paragraph:

There are 2 ways to remove a user-added hyperlink.

- Click on the center of the hyperlink and then press your Delete key.
- Click on the center of the hyperlink, click on the Hyperlink button in the Links group of the Insert tab. With this method you can remove the entire hyperlink, or you can choose to remove the link and leave the text.

With either method, you will receive a question confirming the deletion. Click on Yes to remove it.

Inserting and Removing Images in your Section

You can insert an image within your section.

- Click on the paragraph that should be below your inserted image.
- From the Insert tab / Illustrations group, click on Image.
- Navigate to the folder containing your image.
- Note that the image may not be larger than 100K.
- If necessary, change the file type in the file type drop down box.
- Double-click on the image file.

Your image will be inserted above the current paragraph. Inserted images will appear in printed reports, except in a Comparison report. If your image is too large to be inserted, you will need to resize it in another application.

The following file types may be inserted:

- Windows Bitmap (.bmp)
- Windows Metafile (.wmf)
- Portable Network Graphics (.png)
- JPEG File Interchange Format (.jpg, .jpeg)
- Graphics Interchange Format (.gif)

To remove an image:

- Click on the image in the Document Panel.
- Click on the X in the Clipboard Group on the Home Tab.
- You will be asked to confirm the deletion.
Saving your work

While you are working with a project, your work is being saved after every action you perform. If you make an unintentional change, use Undo to reverse it.

- If you have finished your project and want an archive, use Save Project to File or add it to the Archive Database.
- If you want a complete backup of all projects, use Backup Project Database.

Autosave

As you work in a section, your changes are being saved to the Projects Database continuously.

Check In and Close

When you have finished editing a checked-out section, you will need to check the section in before anyone else can access it. To check in a section:

- In the Document Panel, click on the checked-out section, then on the Documents tab, Check In and Close group, click on Check In and Close.
  Your section will be available for check out by someone else.

Pending Check-Ins

To see the list of sections that are checked out by you in your current project, click on Pending Check-Ins in the Check In and Close group on the Documents tab. All checked out sections are on the list, and have a checkmark by default. To check in all checked out sections, click OK. Uncheck any sections that you do not want to check in. To see which sections are checked out by other users, use the Unlock Documents dialog box.

When you close a project with sections still checked out, you will be presented with the Pending Check-Ins dialog box at that time.

- To check in all checked out sections, just leave all sections checked and click OK.
- To leave a section checked out to you, deselect it and click OK. See Close and Lock.
- To leave all sections checked out to you, click on Deselect All.
- Click Cancel to leave the project open.

Close and Lock

Close and Lock, available in the Check In and Close group on the Documents tab, allows you to close the section, but leave it checked out to you, so that nobody else can edit the section. If you want to close the project and leave one or more sections checked out to you, click on Deselect All (or just deselect some) when you close the project. Note that leaving a section checked out uses
one of your SLE licenses whether you are working in it or not. When you reopen a project where sections are checked out by you, SLE will automatically open up to 5 of those sections for you.

**Closing a section**

When you close a section, you can check it in so others can access it, or you can leave it checked out to yourself. To close a section, do one of the following:

- Click on the X on the top right corner of the section window.
- Right Click on the Section tab in the Document Panel and choose Close.
- On the Documents tab, Check In and Close group, click on Check In and Close. This command is also available on the right mouse button menu in the Project Tree panel.
- On the Documents tab, Check In and Close group, click on Close and Lock. This will leave the section checked out so that others cannot open or edit this section.
- To Check In and Close all open sections at once, use the Pending Check-Ins dialog box in the Check In and Close group.

**Closing the software**

Click on the X in the top right corner of the application. If you have a project open, it will be closed automatically. If you have any sections checked out, you will see the Pending Checkins dialog box and will have the opportunity to check them in, leave them checked out or Cancel to leave the application open.

**Format Your Documents**

**Predefined Project Templates**

**About the Predefined Project Templates**

Four commonly used templates are provided.

- **CSI Format**: CSI PageFormat™, recommended by the Construction Specifications Institute.
- **Military Format**: Decimal paragraph numbering, resembling the format used for US Army Corps of Engineers and NAVFAC specifications in the SPECSINTACT program.
- **Block Format**: No paragraph numbering, basic indentation, and double-spacing.
- **Sequential Numbering Format**: Same as the Block Style with sequential numbers in the left margin.

All styles have 1 inch margins top, bottom, and sides, and use 10 point Arial font. The default layout is CSI Format. If that is acceptable, no changes to the Project Template or Styles are required.

If one of the other predefined layouts is desired:

1. Have at least one section open in the Document Panel.
2. From the Format tab, Document Templates group, click the drop-down menu for Project Template.
3. Select the template you want.
4. All active sections in your project will use the newly selected template.
5. This is also where you can change the first page Section Title Format.
To change the template for the current section only, click the drop-down menu for Use for Section. The selected template will be used for this section only.

Tip:

- You can also create as many User Defined Templates as you want.

AutoNumbers

If you use one of the pre-defined templates, then your paragraphs will be automatically numbered and lettered if dictated by the style. If you have certain paragraphs or sections that you do not want numbered, use No AutoNumber. To remove all AutoNumbers from an entire section, it is best to use a specific Project Template for this section only.

CSI-Style Style Set

**SECTION 000000** (Level 0) {centered}
{skipped line}
**SECTION TITLE** (Level 0) {centered}
{skipped line}
**PART 1 GENERAL** (Level 1)
{skipped line}

1. **01 ARTICLE TITLES** (Level 2)

{skipped line}
**A. Text of the first paragraph.** (Level 3)

1. **Text of the first subparagraph.** (Level 4)
2. **Text of the second subparagraph.**

**a. Text of the first subparagraph.** (Level 5)

1. **Text of the first sub-subparagraph.** (Level 6)

{skipped line}
**B. Text of the second paragraph.**

etc.

**END OF SECTION** (Level 0) {centered}

Tips:

- Level 2 numbers start over after each Level 1 paragraph.
- This format is called CSI-style because it is very similar to the format recommended by the Manual of Practice of the Construction Specifications Institute for traditional construction specifications.
- There are several variations as to the arrangement of the Section Number and Title.
Military Style Set

SECTION 000000 (Level 0) {centered}
{skipped line}
SECTION TITLE (Level 0) {centered}
{skipped line}
PART 1 GENERAL (Level 1)
{skipped line}

1. 1 ARTICLE TITLES (Level 2)
{skipped line}

1. 1.1 Text of the first paragraph. (Level 3)

a. Text of the first subparagraph. (Level 4)
b. Text of the second subparagraph.
(1) Text of the first subparagraph. (Level 5)
(a) Text of the first sub-subparagraph. (Level 6)
{skipped line}

1. 1.2 Text of the second paragraph.
{skipped line}

etc.
END OF SECTION (Level 0) {centered}

Tips:

• Level 2 and 3 numbers always start with the number of the immediately preceding Level 1; i.e. 1, 2, or 3.
• This style set is called military style because it conforms as closely as possible to the format used for US Corps of Engineers and NAVFAC specifications in the Specs-In-Tact program.
• To use Military style, click on the Format tab / Document Templates group and click the drop down to the right of Project Template.

Block Format Style Set

SECTION 000000 - SECTION TITLE (Level 0)
{skipped line}
PART 1 GENERAL (Level 1)
{skipped line}
ARTICLE TITLES (Level 2)
{skipped line}
Text of the first paragraph. (Level 3)
{skipped line}
Text of the first subparagraph. (Level 4)
{skipped line}
Text of the second subparagraph.
{skipped line}
Text of the first subparagraph. (Level 5)
{skipped line}
Text of the first sub-subparagraph. (Level 6)
Text of the second paragraph.

etc.

END OF SECTION (Level 0)

Note:

- All paragraphs are double-spaced.
- The Sequential Numbering Style may be better if you need to identify specific paragraphs for addendum purposes.
- Select Block style by clicking on the Format tab, Document Templates group, and then the drop down menu to the right of Project Template.

Sequential Numbering Format

SECTION 00 0000 - SECTION TITLE (Level 0)

1. PART 1 GENERAL (Level 1)

2. Article Heading: (Level 2)

3. Text of the first paragraph. (Level 3)

4. Text of the first subparagraph. (Level 4)

5. Text of the second subparagraph.

6. Text of the first subparagraph. (Level 5)

7. Text of the first sub-subparagraph. (Level 6)

8. Text of the second paragraph.

etc.

9. END OF SECTION (Level 0)

Note:

- All paragraphs are double-spaced.
• To use Sequential Numbering Format, click on the Format tab / Document Templates group, and then select Sequential Numbering Format as the Project Template.

Project Templates and Styles

Project Templates

When you create your first project, it uses the CSI Format by default. You can change this to one of the other predefined Project Templates or you can create your own Project Template. You can create as many Project Templates as you like. Any Project Template that you create is available to all projects in your database. A Project Template can be applied to your entire project or to any number of individual sections. A Project Template is comprised of 9 Styles, each style associated with a paragraph level.

To switch your entire project from one Project Template to another:

1. Have at least one section open in the Document Panel.
2. From the Format tab, Document Templates group, click on the drop down to the right of Project Template.
3. Select from the available list.

Your entire project will be changed to use the selected Project Template.

To switch your current section from one Project Template to another:

1. Make sure that you have checked out the section that you want to change.
2. From the Format tab, Document Templates group, click on the drop down to the right of Use for Section.
3. Select from the available list.

Your section will be changed to use the selected Project Template.

Note: To change the font of the header or footer, customize the header and footer.

Use for Section

On the Format tab / Document Templates group, use this drop-down to select a Project Template for use on this section only. The section must be checked out to you, in order to assign a Project Template to it.

Section Title Format

There are several options for the Section Title on the first page of each section. They are:

•  <Section #> - <Section Title>
•  <Section #> Skip Line <Section Title>
•  <Section Title>
•  (none)

To modify this setting, click on Edit Templates in the Document Templates group of the Format tab. Select the Project Template that you are using from the Templates drop-down list. Select the desired format for the Section Number/Title. Click OK. This setting is saved with the Project Template and will be used whenever you select the Project Template.

**Creating a new Project Template (for formatting)**

![Project Templates](image)

To create a new Project Template:

1. From the Format tab, Document Templates group, click on Edit Templates.
2. In the Templates drop-down list, select the template that most closely matches what you want.
3. Click on the New button on the bottom of the window.
4. Name your new template, keeping in mind that it will be available to all users in all projects.
5. The software will make a copy of all styles used in the Project Template that you originally highlighted.
6. Click on the Styles button to modify the Styles associated with this new Project Template.
7. Click on Close and OK when finished.

Your new Project Template will now be available for selection as the Project Template for the entire project, or for use on an individual section.

**Note:** To change the font of the header or footer, customize the header and footer.

**To remove a user defined project template:**

- Make sure that the project template is not in use by any projects.
- Click on Edit Templates in the Document Templates group on the Format tab.
- Select the Template that you want to remove.
- Click on Delete. (If Delete is not available, then the template is in use.)
• The template and its associated Styles will be removed.

Note that if the template is in use by a project in the Archive Database, the template will not be restored when the project is activated.

Edit Templates

The Project Templates dialog box allows you to view and create new Project Templates, and to view, edit and add Styles.

Styles

A Style is a group of formatting characteristics that are assigned at the paragraph level. Each Project Template includes 9 styles, one for each paragraph level, including the 0 level. The following information is included in a style:

• **Style Name**
• **Font**
  • Name - Select from the drop-down list. Type the beginning letter of the desired font to select it more quickly.
  • Font Size - Select the size from the drop-down list.
  • Font Characteristics of Bold, Underlining, and Italic.
• **Number Style** (for auto-number)
  • Format - Click the drop-down list to select a format, such as A or 1.
  • Character Before and After the Number - Select either a period or parentheses to appear before or after the number.
  • Include Numbers from Previous Level - If selected, then the number for the previous level will appear along with the current level number, such as 1.01 on CSI Style Level 2.
  • Show Number Format - If this is not selected, then the number for this style will not display or print, such as CSI Style Level 1.
• **Paragraph Style**
  • Alignment: Choose Left, Right or Center - For all predefined templates the title and end of section are centered; all other levels are aligned to the left
  • First Line Indent - This is the space in inches between the left margin and the beginning of the auto-number.
Modifying Styles

Each paragraph level has an associated style. The style dictates the font, font size and other font attributes, as well as the auto-number style, alignment, etc. You cannot make modifications to the Styles associated with the predefined Project Templates, but you can make a copy of those styles and modify them.

To copy and modify a style:

1. From the Format tab, Document Templates group, click on Edit Templates.
2. Click on the Styles button on the bottom of the window.
3. Select the style that is closest to your desired style.
4. Click on New.
5. Give the style a name. You might want to use the intended Project Template name in the style name, as well as the intended level of the new style.
6. Make any necessary changes to the style, including font style, font size, bold, underline, italic, etc.
7. You do not need to click on Close when done. Just highlight the next style to be copied and click on New to create another new style.
8. When finished, click Close.

To associate the newly copied or modified style with a project template:

1. Select that template from the Templates drop down list at the top of the Project Templates dialog box.
2. Click on the drop down to the right of the appropriate Level Style and select the newly copied or modified style
3. Click OK

Note that when you create a new Project Template, the software automatically creates associated Styles for your new Project Template, so it is easier to create your Project Template first and then modify the Styles that get created automatically.
Eliminating Paragraph Numbers

To eliminate paragraph numbers from a single paragraph, or group of paragraphs:

1. In the Document Panel, select the paragraphs that you don't want numbered. (If just a single paragraph, click on the paragraph. If multiple paragraphs, drag across them with your mouse.)
2. Using your right mouse button menu, click on No Autonumber, or click on the Format tab / No Autonumber group and select No Autonumber.

To eliminate paragraph numbers from an entire section:

1. Create a Project Template that does not use autonumbers.
2. Have the section checked out and open in the Document Panel.
3. From the Format tab/Document Templates group click the dropdown next to Use for Section and change the template for this section to the newly created Project Template.

To eliminate paragraph numbers from all paragraphs in all sections:

1. From the Format tab/Project Templates group, click the dropdown to the right of Project Template and select Block Format or a user created Project Template.

Changing the Format of a Single Paragraph or group of Paragraphs

Normally, each paragraph of a particular hierarchy level has the same format: font, numbering, indents, spacing, etc. If you wish to override that format, you can change some of the formatting for the currently highlighted paragraph(s) only.

To change the style for a single paragraph or group of paragraphs:

1. Block the text that you want to format by dragging across it with your mouse. You can drag across a group of paragraphs in a row.
2. Use the Format tab, Font and Alignment groups to change the settings. You can add bold, italics, underline or strike through to one or more paragraphs, and change the
left/right/center alignment for one paragraph at a time. The font type and size is currently
for display only.
3. When the settings are correct, click outside the paragraph to save the settings. If you
have modified a master paragraph, a blue rectangle will appear across the bottom half of
the O column indicating that it is a user-modified paragraph.
4. To return the paragraph to its original format, delete the user-modified version of the
paragraph.

Tips:

• Remember that if all the paragraphs of a certain level need to be changed, it is much
more efficient to change the style using Edit Templates on the Format tab, Document
Templates group.
• It is possible to eliminate paragraph numbers from a single paragraph without changing
the style for all paragraphs of that level.
• If you are using the Strike through function to show changes from one version to another,
consider using the Compare feature instead, because the Compare feature preserves
both versions of the project and displays the differences.

Headers and Footers

The header and footer dialog box is available if nobody else is currently editing it for this project.
The header and footer are formatted with any number of lines each in three locations: Left,
Center, and Right.

1. From the Format tab / Page Setup group click on Header/Footer, or click the
   Header/Footer button in the Print dialog box.
2. From the first drop-down list, select whether you would like to customize the header and
   footer for your project specifications, requirements reports, automatic table of contents, or
   this individual section.
3. Click the appropriate Body Footer or Body Header tab.

Note: If you want to be sure that long Section Titles don’t cause the header or
footer line to push other text to the next line, you should probably use a table. See
Tips on using Tables in Headers and Footers (below) for instructions on using a
table in the header or footer.

To create a header or footer without using a table:
1. Position the mouse cursor in the appropriate tab. Your first click will be in the left justified location. Use the Tab key to move to the Center location. Use the Tab key again to move to the right justified location.
2. Use the Enter Key to move to the next line of the header/footer.
3. Using the "keyword" pull-down menu on the Header/Footer Toolbar, insert the appropriate keyword codes into the appropriate location.
4. Insert any other text required. You can type text or paste text from the clipboard.
5. To delete a keyword, click anywhere within the word and then press the Delete key on your keyboard.
6. To change the font, or apply bold, italic, or underline formatting, drag across the text with your mouse, and then choose the appropriate option from the top of the header/footer window.
7. To add a border below the header, click in any header section and then from the Borders button choose Bottom border. To add a border above the footer, click in any footer section then from the Borders button choose Top border. Choose the same option again to turn it off.
8. Click OK when finished.

Selecting all text in the header/footer dialog box

1. To copy the text from the Body Footer tab to the First Page Footer tab (for example), click anywhere in the footer and hold the Control Key down and press A. This selects all lines in the footer.
2. Use Control+C to copy all lines to the Windows clipboard.
3. Click on the First Page Footer tab and click within the footer area.
4. Use Control+V to paste the footer into this dialog box.
5. Make any necessary changes.
6. This same process can be used to assign a different font to all text in any tab in the dialog box.

Tips on Using Tables in Headers and Footers

Tables can be very useful in headers and footers as a way to control the length of the field for long section titles. When placed in a table, the section title will wrap within the confines of the cell in which it is placed. Here are a few tips to make working with tables in the header/footer dialog box more efficient.

To insert a table in a header or footer:

- You should be on a blank line. If you are at the beginning of a line with text or keywords, you will receive a message that you need to insert a blank line first. If you are in the middle of a line, it will place the table below the first field of the current line and above the last field in the current line. You can use Remove Header/Footer to start from scratch.
- To insert a table, be in the header/footer dialog box:
  - Select the appropriate tab and report.
  - Click on the Table menu and choose Insert Table.
Choose the number of Rows and Columns. Note that you can use a single row table, and still have multiple lines per table by using the Enter Key within a cell.

You can insert Keywords using the Keyword drop-down menu, as well as typing plain text, within each cell or each line of a cell.

Use the Align Left, Align Center or Align Right icon to align the text within the cells.

- **The best way to add a top or bottom border to a table is to follow these steps:**
  - Click on the Table Menu and use Select and then Table, so that the entire table is selected.

Click on the Table menu and then Format.

- In the Frame area of the Table Properties dialog box, select Box.
- Deselect the Left and Right side in the Frame image, and if applicable, the top or bottom.

- Adjust the Line width and Cell Margins as desired. To add more space between the top or bottom border and the text of the header/footer, increase the Top and Bottom Cell Margins.

- To copy a header or footer with a table from one tab to another, click on the Table menu and choose Select Table. (Alternatively, you can use Control-A to select the whole footer or header.) Once the table is selected, use Control-C to copy it and then click on the next tab, and choose Control-V to paste it into the desired tab. The table along with any Frame formatting will be copied into the next tab.

- You can use the Borders menu with tables (rather than the Frame feature) but you must insert a blank line before and after the table for the borders to work, which may add more space to the header or footer than desired.

Additional Notes:

- To make formatting changes on the entire table, use the Table menu, choosing Select | Table. To format a single cell or row, use the Table menu, choosing Select | Cell or Row.
- If your section title exceeds the width of the cell, it will wrap within that cell, pushing anything below it down a line:
- If you make a mistake while working in your header/footer, just click on the Cancel button to abort the changes.
• The Table menu can also be used to insert columns and rows, as well as deleting tables, columns and rows, and splitting a table.

For additional options see the Table Properties Dialog Box.

**Header/Footer Table Properties Dialog Box**

Once you have inserted a table into a header or footer, you can select the table, row or cell and then click on Format. This will bring up the Table Properties dialog box.

**Frame and Color tab:**

**Frame:** The Frame area allows you to add top, bottom and/or side gridlines to your table, row or cell.
- **None:** The default is none, which means that there will be no lines around or within the table.
- **Box:** Click on this to have a line on all sides of either the table, row or cell, depending on what you selected before opening the dialog box.
- **All:** If you select the entire table and then select All, there will be same width gridlines surrounding all cells in the table.
- **Grid:** If you select the entire table and then select Grid, and also make a change to the Line Width, you can have a darker line around the outside of the table, with a less dark line on the interior lines.
- **Line Width:** The default line width is .75 point. You can change it to the desired width.
- **Line Color:** The color can be changed, but note that it will not print in color in the Document Report.
- **Frame Image:** Click on the left and right side (for example) to eliminate the left and right side of the frame, leaving a top and bottom border.

**Background:**
The background color of the table, row or cell can be changed here, but note that it will not print in color in the Document Report.

**Cell Margins:**
Change the measurement here to allow more or less space between the border of the table, row or cell and the text within the table.

**Size and Formatting Tab:**

**Cell Height:** The default is Auto. You can set a minimum height, if desired.

**Formatting:**

**Vertical Alignment:** The default is Top. This may be changed to Centered, or Bottom, if desired.

**Options:**

Allow row to break across pages, or Repeat row at the top of each page. Do not use this option, as it is designed for tables within a larger document.

**Alternate Header/Footer**

By default, the header and footer are identical on each page, although you must also designate the header and/or footer for the first page. If you input a header or footer in the Alternate Header or Alternate Footer tab, that will be used on even pages only. This is useful in two-sided printing, to keep the page number or other important information on the outside corner of the page. To create a header or footer for the even pages, click on the Alternate Header and/or Alternate Footer tab and make the necessary entries there. The presence of text in either tab will automatically generate a separate header or footer for the even pages.

Note: If you input text into the Alternate Footer, the Alternate Header will also be used, so if it is left blank, no header will print on the even pages. Likewise, if you input text into the Alternate Header, the Alternate Footer will also be used.

**First Page Header or Footer**

To create a header or footer for the first page only, click on the First Page Header or First Page Footer tab and make the changes there. The presence of text in either tab will automatically generate a first page header or footer. If nothing is entered into this tab, then the first page of each section will not have a header or footer. You can select and copy the entire header or footer from the Body header or footer dialog box into the First Page header or footer dialog box.

**Individual Section Header/Footer**

**Note:** To customize the header or footer for one section only, you must have the section checked out and you must access the Header/Footer dialog box from the Page Setup Group in the Format tab.

1. To customize a header or footer for an individual section, you must have the section checked out.
2. Select the section number from the drop down menu on the top left of the dialog box.
3. Make whatever changes are required in the appropriate tab.
4. To revert this section back to using the Project header/footer, select Use Project Header and Footer on the bottom left part of the dialog box. Say Yes to deleting the Section header/footer.
Header/Footer Keywords

Keywords insert the appropriate words or numbers into the header or footer whenever the document is printed. For some keywords, like the Project Name, the inserted words are obtained from the information recorded under Project Summary Info, and do not change from section to section. Other keywords change depending on which section is being printed, such as the Section ID (number) and the Section Title. Keywords are shown in blue in the Customize Header/Footer windows. Any other text can also be entered, provided it does not interfere with the keywords.

- **Division ID:** The number of the division of the section being printed.
- **Division Name:** The name of the division of the section being printed.
- **Section ID:** The section number of the particular section being printed.
- **Section Name:** The title as it appears in the section.
- **Project ID:** Entered under Summary Info.
- **Delegated Design Engineers to be Licensed in:** Entered under Summary Info.
- **Project Location:** Entered in the Summary Info dialog box.
- **Project Name:** Entered under Summary Info.
- **Page Number:** Starts at 1 for each new section, incremented by 1.
- **Page Count:** Inserts total number of pages in current document.
- **Date:** Today’s date, from computer clock. Select Short or Long Date format on the lower part of the Header/Footer dialog box. The Long and Short Date format will be taken from your current settings in Windows.
- **Time:** From computer clock. Select Short or Long Time format on the lower part of the Header/Footer dialog box. The Long and Short Time format will be taken from your current settings in Windows.

Other Page Layout Variables

The following layout characteristics are defined for the document as a whole:

- Margin widths
- Mirror margins
- From Edge
- Paper orientation
- Alternate Left/Right Header/Footer

The following layout characteristics are set at the time of printing:

- Print Master Notes or Project Notes
- Print in color
To modify the page layout:

1. From the Format tab choose Page Setup.
2. In the Page Setup dialog box, change the settings as required.

Page Setup

Open the Page Setup dialog box by choosing Page Setup from the Format Tab / Page Setup Group, or by clicking the Page Setup button in the Print dialog box.

The following layout characteristics are defined for the document as a whole:

- Margins
- From Edge
- Paper orientation
- Mirror margins
- Start document on odd page

Margins

Margins are set from the edge of the paper. The default margins are 1 inch for top, bottom, right, and left.

To change the margins, at the Page Setup dialog box use the up and down arrows to the right of each margin field or enter the margin dimension in inches.

**Top Margin**: This is the distance from the top of the page to the top of the first paragraph in the specification. If there is a header, it must fit within this space.

**Bottom Margin**: This is the distance from the bottom of the page to the bottom of the last paragraph in the specification. If there is a footer, it must fit within this space. Note that due to widow/orphan settings, the bottom margin that you set is the smallest distance for the margin, and that it will frequently be greater than the bottom margin that you set. If there is not enough space for the header or footer, you will receive a message to let you know.

**Left and Right Margins**: This is the distance from the left and right of the page to the specification.
Note: The top margin must be large enough to include the header and the distance set in the From edge setting. The bottom margin must be large enough to include the footer and the distance set in the From edge setting. If you are getting a message that your header or footer will not fit, you may need to reduce the distance in the From edge setting, or increase the margin.

**From Edge**

The distance that headers and footers are from the edge of the paper can be set separately from the top and bottom margins. The default values are 0.5 inch, each.

To change the setting, at the Page Setup dialog box use the up and down arrows to the right of each "From Edge" field or enter the dimension in inches.

**From edge Header**: This is the distance from the top of the page to the top of the header.

**From edge Footer**: This is the distance from the bottom of the page to the bottom of the footer.

Increasing this setting leaves less room for your headers and footers. If you are getting a message that your header or footer will not fit, decrease the From edge setting.

**Mirror Margins**

When Mirror Margins is selected (Page Setup on Format tab or Print dialog box), the Left and Right margins turn to Inside and Outside, to alternate margin widths on successive pages.

Note that the Mirror Margins setting will export to PDF but not to .RTF, .DOC or any other format.

**Widow/Orphan Protection**

The widow/orphan setting prevents a single line of a paragraph from printing alone at the top or bottom of a page.

To change the setting, click the box at the Print Reports dialog box.

**Tips:**

- All print formats assume that text levels 1 and 2 are never desired as the last line of a page. Regardless of whether this box is checked, a Keep with Next function always prevents level 2 and 3 paragraphs (the PARTS and Articles) from appearing alone at the bottom of a page.
- **END OF SECTION** should never appear alone on a page -- if possible, it will be pushed back onto the previous page. If there is no blank line on the previous page, the last paragraph will be pulled forward to print on the last page with **END OF SECTION**.
- If your section is not formatting as desired, you can use Insert Page Break.

**Paper Orientation**

The paper orientation may be either portrait, standard 8-1/2" by 11" (upright) or landscape, 11" by 8-1/2 (sideways).

To change the orientation, click on the option you want on the Paper Info tab of the Page Setup dialog box.
Printing to A4 Paper

To export to PDF or Word for A4 paper size, you only need to change the paper size in Page Setup from the Format tab. To print to A4 paper size on an actual printer, you will need to change the paper size in the Printer Properties outside of SLE.

Start document on odd page

To print or copy your specifications double-sided there is a checkbox on the Page Setup dialog box called "Start document on odd page." If this option is selected (the default is Off), a blank page will be added at the end of each section or chapter with an odd number of pages. This means that when you are printing or copying multiple documents, every section will begin on the right.

Headers and footers will appear on blank pages created by using Start document on odd page. Blank pages will be included in the Page Count in the Automatic Table of Contents.

See also: Duplex printing selection on the Print dialog box.

Note: This feature does not work with the Outline Report.

Insert Page Break

To keep a group of paragraphs, perhaps for a table, together on the same page, insert a page break before them.

To insert a page break:

1. Click to place your cursor in the paragraph that should be at the top of the page following the page break.
   NOTE: In order for the page break to work, the paragraph you click in must be active and not have an NS or NP tag.
2. From the Format tab, choose Page Break from the Page Setup Group.

A dark line will appear above the paragraph, representing the page break. To remove the page break, repeat the steps, choosing Page Break again.

Print the Sections

Before Printing

Before you print you may wish to check or change the:

- Project settings
- Page layout variables
• Formatting
• Header or Footer
• You may also wish to preview on-screen.
• Check all available options in the Print dialog box.
• If using MF95 Output, see Preparing a Project for Printing with MF95 Output.

Printing

The Print dialog box is used to print, preview, or export your documents. SpecLink-E uses these settings to determine which documents will be assembled. Open the Print dialog box by choosing Print from the File menu. Make your document selection and click on the appropriate button to print, preview, or export the documents.

**Reports Printer:** Select the printer you want to use.

**Documents** tab: Select the Documents tab to print your final documents. The Documents tab prints the actual edited document, active text only. Select Project, Branch or Single Document.

**Scope of Report:** Choose one of the three options:

- Print Project: This option assembles all the active documents in the project for printing or exporting (not previewing)
- Print Branch: This option assembles all the active documents in the selected branch for printing or exporting (not previewing)
- Print Document: This is the default option, which assembles only the selected document for printing, previewing, or exporting.
**Document Drafts** tab: Select the Document Drafts tab to print your choice of three draft reports.

- Master Text Only prints all master text (but no user-added text), regardless of what is active. All possible choices are displayed (in the appropriate color if Print in Color is selected), no matter which choices are selected. Selected choices are underlined. All master sections included in your subscription are available for this report.
- All Text Draft prints all the master text and all user-added text, regardless of what is active. All possible choices are displayed (in the appropriate color if Print in Color is selected), no matter which choices are selected. Selected choices are underlined. Active text is differentiated from inactive text. Sections included in the project are available for this draft.
- Selected Text Draft prints only active text, like the Document report. Sections included in the project are available for this draft.

**Project Reports** tab: Select the Project Reports tab to print your choice of three project reports.

- Requirements Reports are reports listing sections in which selected provisions are specified.
• The Table of Contents lists all sections in the project.
• Print User Defined Tag Reports.

Page Range: If desired, specify the pages you want to print. (This setting is for output to a printer only.)

No. of Copies: Click the up and down arrows, or type the number of copies you want to print. (This setting is for output to a printer only.)

Collate: When selecting more than one copy, you can check Collate so that each copy is printed before the next copy is started. (This setting is for output to a printer only.)

Duplex: If supported by your selected printer, you can select to print on both the front and back of each page. Duplexed documents can be printed as if to be bound on either the short edge (open to top) or the long edge (open to left).

Reports Options:

• Widow/Orphan: If selected, the widow/orphan protection option prevents a paragraph from being split at a page break in such a way that a single line of the paragraph prints at the bottom of the page or at the top of the following page.
• Print in Color: This option, if selected, prints the draft documents with colors as viewed in the Documents Panel (embedded choices in blue, fill-ins in red, global choices in green) if the selected printer has color printing capabilities. This option may be helpful when printing All Text Draft or Master Text Only copies.
• Output MF-95: Use this to print your documents using MasterFormat 95 section IDs and section titles. See Preparing a Project for Printing with MF95 Output.
• Print Master Notes: If selected, this option causes all relevant master notes to be embedded in the text and printed. If Document or Selected Text Draft is the report selected to print, only master notes attached to selected and active paragraphs are included. If All Text Draft or Master Text Only is the report selected to print, all master notes in the section are printed.
• Print Project Notes: This option causes all relevant project notes to be embedded in the text and printed. If Document or Selected Text Draft is the report selected to print, only project notes attached to selected and active paragraphs are included. If All Text Draft Copy is the report selected to print, all project notes in the section are printed. Project notes are not printed if Master Text Copy is the report selected to print.
• Include End of Section ID: Check this to include the Section ID in the End of Section line within each section. This setting is stored individually for each user and will stay selected until deselected.
• Print Notes Images - Check this to print the images within the Master or Project Notes when printing documents or drafts with Master Notes or Project Notes on.
• Reports Cover Sheet: Un-check this to suppress the Report Cover Sheet when printing a Requirements Report.
• Include Page Count in TOC Report: This option applies to the Table of Contents report only. When selected, the total number of pages in each section (including blank pages if using Start document on odd page) will print. If the page count is printing as 0, you need to print, export or preview the section to populate the page count.
• Print IHS Logo: Check this to print the IHS logos when printing documents or drafts with Master Notes or Project Notes on.
• Show All Choices in Selected Text Draft - Check this to see all possible choice options in the active text when printing the Selected Text Draft.
• **Show Editors**: (Corporate Edition only) Select this to print the editor and last edit date for paragraphs that have editor information.

**Buttons:**
- **Print Button**: Click this button to send the selected document or documents to the selected printer.
- **Print to PDF button**: Click this button to send the selected document or documents to PDF files. See Exporting your Documents.
- **Preview Button**: Click this button to preview the selected document.
- **Export Button**: See Exporting your Documents.
- **File Names**: See File Name Formats, after Exporting.
- **Header/Footer Button**: Click to open the Header/Footer dialog box.
- **Page Setup Button**: Click to open the Page Setup dialog box.

**Notes:**
- You can only preview one section at a time, unless you are in Outline Mode.
- Draft and Master Text Only copies can only be previewed or printed one section at a time. They cannot be exported.

**MasterFormat 95 Output**

While all SLE projects are structured according to MasterFormat 2004/12+, you have the ability to print your documents using MasterFormat 1995 section IDs and section titles. When using MF95 Output, your headers and footers will also reflect the MasterFormat 95 Section ID and Section titles.

To print using MF95 Output, click the check box in the Print dialog box that says Output MF-95. This check box must be re-selected each time you want to use it.

The following guidelines reflect what is and is not possible:
- The following documents may be printed in MF95 output: Single document, branch, and entire project, Master Text, All Text and Selected Text Drafts, Requirements Reports and the automated Table of Contents. There is a MF95 Table of Contents section (00 0111) that displays all master sections in MF95 under the appropriate MF95 folders.
- MF95 output will not be supported using Outline View, the User Defined Tag reports or the Compare report under the Tools tab.
- BSD Master sections will reflect the MF95 section ID and section title automatically.
- BSD Master paragraphs that reference sections using the Global Section ID choice (in green) will automatically reflect the MF95 section ID in the MF95 output.
- As of the Spring 2013 release and going forward, copies of BSD master paragraphs that reference a Section ID will reflect the MF95 Section ID automatically, but older copies of BSD master paragraphs will not.
- User sections that are already in your projects database will need to have the MF95 Section ID filled in individually. Newly copied master sections will default to the MF95 Section ID of the master section. Projects that are Copied from SL+ (from now on) will include the MF95 Section ID when that information is available.
Preparing a project for printing with MF 95 Output

The following steps should be taken to prepare a project for printing using the MF95 output option.

2. Click on the top of each tab in the project tree (Front End, etc.), click on the Project Tree tab and choose Expand to Show Branch. Scan the project tree for sections in green. These are all of the user added sections.
3. With the sections closed, right click on each user added section and select the option to Edit the MF95 Section ID. Check the MF95 Section ID and MF95 title. All user-added sections need to have the appropriate MF95 Section ID and title filled in. If the MF95 Section title is not filled in, or needs to be changed, change it here.
   
   Note: Any MF95 Section ID higher than 16800 will use the highest valid MF95 folder for the Table of Contents and Requirements Reports, which is 16800 Sound and Video.
4. Check out all sections that have any user edits in them. Scan each section for references to Section IDs and titles. Any user added paragraph or user edited master paragraph (with a turquoise icon in the O column) that references a section ID and/or title may need to be edited to reflect the MF95 section ID and section title. One way to scan the section is to use the Find function for the word section.
5. To change the referenced section ID and title within paragraphs:
   - **Non-edited master paragraphs:** These will print the correct MF95 Section ID automatically.
   - **Newly edited master paragraphs (spring 2013 and going forward):** These will print the correct MF95 Section ID automatically.
   - **Older modified master paragraphs (pre spring 2013) and user paragraphs with Global Choice Section IDs:** To edit a Global Choice Section ID (in green) click on the Insert tab, click on the choice, and then click on Edit from the Choice Fields group. See MasterFormat Version Choice Type for information on this choice type.
   - Follow the same process for blue choice section titles.
6. If you use the Table of Contents Section, rather than the Automated Table of Contents, you will need to check that section out (Section 00 0111) and add any of your user added section titles to that section.
7. Once complete, click on the Print button to open the Print dialog box. Select the Output MF-95 checkbox before printing your project. Note that you must select that option each time you open the Print dialog box.

Printer Setup

To change the selected printer for your printed specifications, choose Print from the File menu. You can change the selected printer in the top part of the dialog box.

Printing a Draft Copy

There are three types of draft reports:

- Master Text Only
- All Text Draft
- Selected Text Draft
A Master Text Only is the complete text of the master whether the text has been selected for the project or not. Master Text Only is intended for review and manual mark-up and does not indicate which text is selected for the project.

- Multiple choice options are set off from the text by carets, with the options separated by semicolons: text << first option; second >> more text
- Other choices are printed in bold text and italics.
- Choices which are currently selected are underlined.
- All master sections that are part of your subscription should be available for this report.

An All Text Draft is the complete text of the master and all the changes made to it by the user, whether the text has been selected for the project or not. Selected text is distinguishable from non-selected text. All Text Draft is intended for review and manual mark-up.

- Multiple choice options are set off from the text by carets, with the options separated by semicolons: text << first option; second >> more text
- Other choices are printed in bold text and italics.
- Choices which are currently selected are underlined
- Only sections that have been selected are available for this report

A Selected Text Draft consists of only the active, or selected, text including the changes made to it by the user. Selected Text Draft looks just like the Document Report, with a watermark on the top to indicate that it is a draft.

There is an option to display all possible choices, rather than just the selected choices. On the Print dialog box, select Show All Choices in Selected Text Draft to see all possible choices in this report.

To print any draft:

1. From the File menu choose Print.
2. Click on the Document Drafts tab.
3. Select the Draft type to be printed.
4. Select the section to be printed.
5. Check either of the boxes for Print Master Notes or Print Project Notes, if desired.
6. Click on the Print or Preview button.

Tips:

- Only one section at a time can be printed in draft.
- Project Notes do not print in Master Text Copy.
- Draft reports cannot be exported.

Previewing Final Copy

It is not necessary to preview your documents before printing them. To verify content, you can use Selected View from the View tab to see exactly what text is set to print. You can also use Print Preview to see exactly how your documents will look, with all formatting
applied. It is a good idea, for example, to use Print Preview if you make a change to the page format, before you print multiple documents. Print Preview also allows you to verify the number of pages in each document before printing.

To preview the current section:

1. Click on Print Preview button from the File menu or
2. Choose the Preview button from the Print dialog box.

Tips:

- The default Page Setup, headers and footers, styles, and printer setup will be used.
- You can only preview one section at a time.
- In Outline mode, you can preview a branch or the entire project.

Preview Window

- Use the Printer button on the top left to print the currently previewed document.
- Click on the down arrow to the right of the magnifying glass to zoom in or out.
- Use the One Page, Two Pages, Three Pages, Four Pages or Six Pages icon to view multiple pages at one time.
- Use the up and down arrow buttons on the top right side of the window to page through the document.
- Note that you can also use the Page Down and Page Up keys to page through the document.
- You can use Control+Home to get to the first page and Control+End to get to the last page.
• Close the preview using the Close button.

Printing the Specifications

1. From the File menu, click on Print.
2. Click on the Documents tab.
3. Under Scope of Report, select Print Document, Print Branch or Print Project.
4. From the drop-down box select the Document or Branch to be printed.
5. Press the Print or Print to PDF button.

Tip: In addition to your Document, there are many types of reports you can choose to print, including Requirements Reports, Document Drafts, and a Table of Contents. Be sure to choose the correct tab for the report you want to print.

Print the Table of Contents and Requirements Reports

Printing the Automatic Table of Contents

1. Change the headers or footers if necessary.
2. From the File menu choose Print.
3. Click on the Project Reports tab.
4. Under Scope of Report, select Print Table of Contents.
5. Under Report Options select or deselect Include Page Count in TOC Report as desired. Note that sections must be printed, exported or previewed before printing the Automatic Table of Contents for the Page Count to be filled in in the report.
6. Set the printing options, including page setup options.
7. Set the printer options.
8. Press the Print or Preview button.

Note: If your sections are in Outline or Short Form Mode, the Automatic Table of Contents will include only sections that would print when printing a project in Outline or Short Form Mode. If your Sections are in Outline or Short Form Mode, the Page Count option is not available.

Tip: If some sections are being prepared using word processing, rather than SpecLink-E, they will not appear on the automatic Table of Contents. To prepare a Table of Contents including such sections, either export and edit the Automatic Table of Contents, or use the Table of Contents section instead.

Automatic Table of Contents Format

The printed Table of Contents includes all active sections in the project and can optionally list the number of pages in each section. To print this:

• Click on the Print from the File menu.
• Select the Project Reports tab.
• Select Print Table of Contents.
• The checkbox to include the page count is on the lower part of this tab.
Zeroes in Table of Contents

If there are zeroes in the system generated Table of Contents where the page count should be, that means that the section has changed since the last time that it was printed, exported or previewed. To replace the zero(s) with the actual page count(s), you must either Print, Export or Print Preview that section or sections.

Printing the Table of Contents Section

If there are documents that are not in SpecLink-E that you would like listed in your table of contents, like drawings or room schedules, you have three options.

- Export the automatic table of contents to a word processor and edit it there.
- Add sections in SpecLink-E with the numbers and titles of the documents that are not in SpecLink-E and select the sections. Don't add any content to the sections. Then when you print the automatic table of contents, deselect the option to Include Page Count on TOC.
- Use the Table of Contents section 00 0110 (or 00 0111 if using MF95 Output).

The Table of Contents section is a hierarchical list of all the divisions and sections included in the SpecLink-E master database, and it can be edited like any other section. When you activate sections in your project, green links select the corresponding paragraphs in the table of contents section. If you add your own sections to the project, you will need to add corresponding paragraphs to section 00 0110 or 00 0111, and either create links or manually select those paragraphs when you use your sections. Likewise, you will need to add paragraphs for the documents outside of SpecLink-E that you want listed in the Table of Contents.

Section 00 0111 – Table of Contents (MasterFormat 1995) has been “hard-coded” to display the Section IDs in MF95 format. This is the only section that will display in MF95 format. Any MFV choices that you add to this section will display in MF 2004 format, but will print as MF 95 when Output MF-95 is selected in the Print dialog box. Since it is only used with MF95, you can simply type in the MF95 Section ID, rather than create Section ID choices.

Unlike the automatic table of contents, the table of contents section does not have ability to list the page counts of the sections, nor is it automatically formatted like a table of contents - for example, the paragraphs will be numbered like every other section in your project. You may want to select the Block Format in the Use for Section drop down in the Document Templates group on the Format tab. You can also create your own Project Template for use with the Table of Contents section.

1. Activate the Table of Contents section (00 0110 or 00 0111) by checking it out and selecting the first paragraph in the section.
2. Add paragraphs for any user-added sections and for any documents outside of SpecLink-E that you want listed in your table of contents.
3. Select the paragraphs that you added, and, if necessary, select higher level paragraphs so that your paragraphs become active.
4. From the Format tab, Document Templates group, select Block Format as your "Use for Section" style.
5. Customize the header and footer if necessary.
6. Preview and make any necessary formatting changes.
7. Print using the following settings:
   Click on the Documents tab.
   Scope of Report: Print Document, 00 0110 or 00 0111 BSD - Table of Contents
NOTES:
Try the System generated Table of Contents Report before using the table of contents section. If your intent in using the Table of Contents section is just to get a list of available sections, print the catalog listing or section checklist from the Subscriber web page, which were designed for this purpose.

Printing Requirements Reports

Certain provisions that are of interest during the construction phase, such as shop drawing submittals or mock-ups, commonly appear in many different specification sections. The Requirements Reports list all the sections in which these provisions appear. The layout of the reports is fixed.

To print reports:

1. Modify the Header or Footer if desired.
2. From the File menu, click on Print.
3. Click on the Project Reports tab.
4. Click on Print Requirements.
5. Select the type of report desired from the drop down list.
6. Press the Print, Preview or Export button.

Note: If your sections are in Short Form Mode the Requirements Reports will only include sections that include paragraphs tagged OL and/or SF. Requirements Reports are not available if your project is in Outline Mode.

Tags Used For Requirements Reports

The following tags displayed in the Requirements Tags status column determine what sections will be listed in the Requirements Reports. If a section includes an active paragraph with one of these tags, it will be listed in the appropriate Requirements Report.

In addition to the individual tag reports, there is a combined Submittals Report, which lists all sections that include requirements for Product Data, Shop Drawings and Samples.

For a complete listing of all Tags see Complete List of Tags.

Certificate (CT) A submittal consisting of the manufacturer's or contractor's certification. Usually used to certify that the products furnished meet the specification criteria. PART 1, Submittals.

Design Calculations (DC) A submittal consisting of the calculations performed to design a particular element. Used to show that products designed by the contractor or manufacturer meet the project criteria. PART 1, Submittals.

Extra Materials (XM) Additional quantities of the materials installed, usually furnished for maintenance purposes. Usually limited to products that would be hard to match or acquire in the future. PART 1, Extra Materials.

Field Report (FR) A report to be submitted by the contractor or a manufacturer's representative describing the status of something on the project site. PART 3, Field Quality Control.

Independent Agency Field Testing (FT) Provisions requiring a testing or inspection laboratory or agency to test or inspect the work in place. The section may require the agency to be hired by either the owner or the contractor, and the testing varies according to the type of product involved. PART 3, Field Quality Control.

Installation Instructions (II) Manufacturer's printed installation instructions. Submittal for information only, for the project record. PART 1, Submittals.
<table>
<thead>
<tr>
<th>Installer Qualifications (IQ)</th>
<th>This includes “applicators” and other similar functions. Part 1, Quality Assurance.</th>
</tr>
</thead>
<tbody>
<tr>
<td>LEED Report (LR)</td>
<td>This lists all sections with active LEED submittal requirements.</td>
</tr>
<tr>
<td>Manufacturer Listing (ML)</td>
<td>Manufacturers listed in a specification. This requirements report is different from the others. In addition to listing the section number, it lists the text in the tagged paragraph (the manufacturer’s name) and the text of the parent paragraph (the product type).</td>
</tr>
<tr>
<td>Manufacturer Qualifications (MQ)</td>
<td>This includes “fabricators” if the product is more likely to be shop-fabricated than factory-made. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Mock-Up (MO)</td>
<td>A mock-up built during construction for evaluation of workmanship or performance. Another term for this is “field sample” when that refers to a full-scale portion of the work evaluated in place. Mock-ups for testing prior to approval of products are not included in this category. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Operation and Maintenance Data (OM)</td>
<td>Specific items that may not be obvious from the general requirements for operation and maintenance data in Division 1. Includes both standard pre-printed data and documentation prepared specifically for the project. Part 1, Submittals.</td>
</tr>
<tr>
<td>Pre-Installation Meeting (PI)</td>
<td>A special meeting, usually specified with particular attendees and topics to be covered. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Product Data Submittals (PD)</td>
<td>Manufacturers’ catalog data, not prepared specifically for the project. PART 1, Submittals.</td>
</tr>
<tr>
<td>Professional Engineer Design (PE)</td>
<td>If major components are commonly designed by an engineer other than the engineer of record, the section may include that requirement as an option. If so, the actual text depends on the products involved. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Project Record Documents (PR)</td>
<td>Specific items for the project record that may not be obvious from the general requirements for project record documents in Division 1. PART 1, Submittals.</td>
</tr>
<tr>
<td>Qualifications Statement (QS)</td>
<td>Actual submission of qualifications of manufacturer, installer, or designer. Part 1, Submittals. Qualifications required are specified in Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Samples (SA)</td>
<td>Actual products to be furnished, for approval of colors, finishes, etc. Not used for testing purposes or for evaluation of performance. PART 1, Submittals.</td>
</tr>
<tr>
<td>Shop Drawings (SD)</td>
<td>Drawings prepared specifically for the project, to complete the design or to illustrate details left up to the contractor. PART 1, Submittals.</td>
</tr>
<tr>
<td>Special Warranty Provisions (WT)</td>
<td>Any warranty provision that involves a term longer than one year or entities other than the (prime) contractor. The actual terms vary according to the type of product involved. Part 1, Warranty.</td>
</tr>
<tr>
<td>Test Report (TR)</td>
<td>Any report of a test. May be pre-construction, showing performance of a proposed product; during construction, testing samples of materials installed; or post-construction, testing actual installation in place. Pre-construction is in Part 1, Submittals. During and post-construction is in Part 3, Field Quality Control.</td>
</tr>
<tr>
<td>Warranty, Executed (WE)</td>
<td>Actual copy of the warranty signed by the warranting entity. Warranty provisions are in Part 1, Warranty. Submission of executed warranty is in Part 1, Submittals (if mentioned at all).</td>
</tr>
<tr>
<td>Warranty, Specimen (WS)</td>
<td>Sample of proposed warranty, for review. Part 1, Submittals (if mentioned at all).</td>
</tr>
<tr>
<td>Phase</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Proposal Phase (S1)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
<tr>
<td>Preliminary Design Phase (S2)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
<tr>
<td>Design Development Phase (S3)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
<tr>
<td>Construction Documents Phase (S4)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
<tr>
<td>Construction Phase (S5)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
<tr>
<td>Closeout Phase (S6)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
<tr>
<td>Occupancy Phase (S7)</td>
<td>This tag is for substantiation reports for the Design Criteria sections in the database.</td>
</tr>
</tbody>
</table>

**Submittals Log (export)**

The Submittals Log is an export from your project. It is different than the Submittals report (which line lists each section and indicates whether there are submittals required for Product Data, Shop Drawings and Samples.) The Submittals log is a listing of the active paragraphs that have Requirement Tags and are under the Submittals title in the spec section. The paragraphs include the entire text of the paragraph, as well as any active subparagraphs. If paragraphs are missing from this export, be sure that they have been tagged correctly and that they are under a title that starts with the word Submittals.

To create the Submittals log:

- Make sure all checked out sections have been saved to database.
- Select Print from the File menu.
- Click on the Project Reports tab.
- Click on Print Requirements as Scope of Report.
- Select Submittals Log (Export to Excel only).
- Click on Export.
- Navigate to the folder where you want the file.
- Change the name of the exported file, if desired.
- Click on Save.
- Click OK to the confirmation telling you that the file has been created.
- In Windows Explorer, navigate to the file and double click on it to open it in Excel.

You can modify the Page Setup and header/footer in Excel, if desired.

**Manufacturers Listed in Project Report**

This report, available as a Requirements Report, lists all of the manufacturers listed in active paragraphs in the project. It differs from the other Requirements Reports in that it lists the text of the paragraphs that are tagged with the ML Tag, as well as their parent paragraphs. Manufacturers in the BSD Master are already tagged as ML. To apply the tag to your user added paragraphs, see Applying Tags.
Report Cover Sheet

There are fields on the General and Global Master Terms tabs of the Project Summary Info Dialog Box that are printed on a Reports Cover Sheet.

The fields include:

- the name of the Owner
- the name of the Design-Builder
- the name of the Design Professional
- the name of the Contractor
- Project Location (city and state)
- Facility Type
- Project Type
- Approx. Square Footage
- Approx. Construction Cost
- Date Specification Last Modified (updated by the software)
- Specification's Master Date (updated by the software)
- Specification Due Date
- Contract Documents Due Date
- Bid date
- Approx. Completion Date

The Report Cover Sheet can be printed when you print any Requirement Report by clicking the Reports Cover Sheet option in the Print dialog box. This report defaults to on in new projects, but can be turned off by unclicking the option.

Export Your Documents

Why export?

Although a word processor is not required when you use SpecLink-E, there are times when it is useful to export the documents or reports to a PDF or word processing file. The principal reasons are:

- To send your documents in electronic format to someone who does not have SpecLink-E available.
- To take a printable file to a printer not accessible to a computer that SpecLink-E is installed on.
- To "freeze" the project as a bidding or contract document. This prevents inadvertent changes and clearly limits changes to those made deliberately. Addenda and change order modifications can be annotated using "redline/overstrike" markings.
- To reduce the size of archive files. The exported files take up much less disk space than the project files. If the project is no longer needed in its SpecLink-E form, exporting the documents creates a record of the work without the extra space overhead.
- To add special formats or use special features that are not available in SpecLink-E.

You can export files to an editable format - Word or Rich Text Format (RTF) or to a PDF format, a text file or an HTML file.
**File Name Formats**

When exporting your documents or Printing to PDF, you can determine the components of the file names with the following options:

- **Identifier** - This is an optional field which can be used to identify the files. Possibilities are project name, phase name, etc. This can be set separately for the Documents tab and the Project Reports tab.
- **Section ID** - This displays the Section ID. Available only in the For Documents tab, when exporting each section as a separate file.
- **Include Author** - Click the checkbox to include the acronym (BSD, USER, etc.) for each section ID.
- **Title** - This displays the Section title in the Documents tab and the report title in the Projects Reports tab. When exporting a branch or the entire project, the branch name or the project name will be used.
- **Date** - This will add the Windows system date to the file names.
- **Field Separator** - Add a character here to separate the fields in the file names. Add a space to include a space between each field. The following characters will be switched to an underscore: `\/:@#$%^&*()+=<?><`$.

**Example**: This field shows you a preview of how the file name will be exported.

**Move Up, Move Down** - Use the Move Up and Move Down buttons to change the order of the fields.

When finished click OK. Your settings will be used in all projects until you change the settings again. This setting is saved locally for each user.

**Print to PDF**

The Print to PDF button is available on the Documents and Project Reports tabs of the Print dialog box. Print to PDF allows you to print the Document, Branch or Project, as well as the
Project Reports, to PDF files, rather than the printer. It is the same as clicking on the Export button. The separate button has been added to encourage users to export to PDF, rather than using an outside PDF Writer, over which SLE has no control.

Exporting your Documents

Documents can be exported to 5 different formats:
- MS Word
- Adobe PDF
- Rich Text Format
- HTML Format
- Plain Text

If you will be exporting multiple documents, you may want to create an empty folder in Windows Explorer that you will export the files to. Each section exports as a separate file named after the section number, acronym and section title (depending on how you have set the File Names dialog box), unless you choose to export a branch or project to a single PDF file. Creating a folder to export to will help you keep all the exported files for this project together, and help prevent you from accidentally overwriting other exported sections (if there is an existing file with the same name in the folder you are exporting to, you will be prompted that it exists and asked if you want to overwrite it).

To export:

1. From the File menu, choose Print.
2. Click on the File Names button to determine the format of the exported files.
3. From the Documents tab, select what you would like to export as if you were going to print it.
4. Click the Export button.

When exporting a Branch or the Project to PDF, you can choose to export to a single file or to separate files. Otherwise, each section will be exported as a separate file to the location you specify.

5. In the Export report to window, click on the arrow to the right of the Save as field to select the format you want your results to be.
6. Click Save.
7. In the Browse for Folder window, navigate to the folder where the exported file(s) should go.
8. Click OK.
9. If you selected Adobe PDF, you will be asked whether you want to export the branch or project to a single file.
10. If you want to export to a single file, click Yes to the question.
11. If you want each section to export as an individual file, click No to the question.
12. You will receive a confirmation when the export is complete.

Notes:

- The Mirror Margins setting will not be exported to RTF or Doc.
- Once a section has been exported, changes made to it cannot be brought back into SpecLink-E except by re-entering the changes in SpecLink-E.
- The Requirements Reports and automatic Table of Contents can be exported as well. However, Draft and Master Text copies cannot be exported.

Creating PDF Files

PDF files of the Document reports may be created whether you have a PDF Writer or not.

- From the Print dialog box, click on the Documents tab.
- Select the section or branch from the drop-down menu, or select Print Project to create PDF files for all active sections.
- Select the Print to PDF button from the right side.
- Navigate to the correct folder destination.
- Click on OK.
- If you are exporting a branch or the entire project, you have the option of creating a single file or separate files for each section.

- Click Yes to create the branch or project in a single file. Click No to create individual files for each section.

Your PDF file(s) will be saved in the selected folder.

Create a Short Form or Outline Spec

Outline, Short Form and Full Spec Mode

All of the paragraphs in the BSD Master belong to one of these three modes. You can change from one mode to the other (depending on your license) by clicking on the Mode group on the
View tab. To see the Spec Type Tags, select Spec Type Tags from the Status Columns group on the View tab. Outline paragraphs are tagged as OL or UO. Short Form paragraphs are tagged as SF or US. Full Spec paragraphs have no Spec Type Tag.

- **Outline (OL or UO)** - Paragraphs tagged as Outline are designed to be used as an Outline specification.
- **Short Form (SF or US)** - Paragraphs tagged as Short Form, along with the Outline paragraphs, are designed to be used as a Short Form specification.
- **Full Spec** (no tag) - All paragraphs are included in the Full Spec mode, including the Outline and the Short Form tagged paragraphs.

When you have switched to Outline or Short Form Mode, your Document report will display only the active paragraphs tagged as OL/UO (Outline) or OL/UO and SF/US (Short Form). See Printing in Outline or Short Form.

Other views which can be combined with Outline, Short Form and Full Spec modes include:
Normal View, Selected View, Zoom, Show Text Levels

**Outline Specification**

Outline specifications are most useful for schematic design and/or design development documents. In other words, they are primarily intended to establish with the owner the project’s material and systems palette and the overall quality level. They are not intended to be used for construction. As such, they consist primarily of the key Part 2 paragraphs that identify and establish quality levels for major systems and materials. Part 1 paragraphs are almost never used; the exceptions would include situations in which compliance with a broad quality standard is included under the Article “Quality Assurance.” Similarly, it would be unusual to include any Part 3 paragraphs in an outline spec. The exceptions would include situations where a crucial installation standard or other quality consideration is specified.

Because Parts 1 and 3 are frequently not present, the standard numbering schemes look awkward. Since the sections are so short you can refer people to the page or to the section number.

Only paragraphs tagged as OL (Outline) or UO (User Outline) will appear in the document when you select to print while in Outline Mode.

**Short Form Specification**

Short Form specifications may be used for design development submittals. On the other hand, they may be used as construction documents on very simple, uncomplicated projects where the contractor is a known entity. Unlike the Outline specifications, Short Form specifications are three-part specs that will typically include both general information such as submittal requirements and fairly simple installation requirements. In addition, there will be more detail under the Part 2 product descriptions, including accessories and minor products that may not have been included in the Outline specs.

Only paragraphs tagged as OL or UO (Outline), or SF or US (Short Form) will appear in the document when you select to print while in Short Form Mode.
Tagging paragraphs as OL or SF

- You may tag master or user added paragraphs as UO (Outline) or US (Short Form).
- You may not change the existing Spec Type Tags (OL or SF) on master paragraphs.
- Display the Spec Type tags column from the Status Columns group on the View tab.
- Right click on the T column for the paragraph you want to tag. Select UO (Outline) or US (Short Form).
- A paragraph may be tagged as UO if it is a top level paragraph or its parent is tagged OL or UO.
- A paragraph may be tagged as SF if it is a top level paragraph or its parent is tagged OL/UO or SF/US.
- If you are highlighted on a paragraph tagged as OL or UO and you insert a new paragraph, it will be tagged as UO.
- If you are highlighted on a paragraph tagged as SF or US and you insert a new paragraph, it will be tagged as US.
- All paragraphs belong to Full Spec. Outline is a subset of Short Form and Short Form is a subset of Full Spec.

Notes:
- If you are in Outline or Short Form Mode when you Add New section from RTF or DOC, all of the paragraphs in the added section will be automatically tagged to match the current mode.
- If you are in Outline or Short Form mode and you paste text from a word processor, the new paragraphs will inherit the Spec Type Tag of the mode you are in. If you insert a new paragraph, it will inherit the tag from the paragraph you are highlighting.
- When copying, moving, demoting or promoting paragraphs in Outline or Short Form mode, SLE will check to be sure that Outline or Short Form paragraphs are placed under parents that are tagged as Outline or Short Form, as appropriate.

Other views which can be combined with Outline, Short Form and Full Spec modes include: Normal View, Selected View, Zoom, Show Text Levels

Changing existing UO and US tags

- You may change the UO and US tags on master and user paragraphs, following the rules outlined above.
- Right click on the spec type tag and left click to change the tag.
- You may change a tag in Outline or Short Form view, but must be in Full Spec View to remove a tag.

Removing tags you have added
- Change to Full Spec Mode.
- To remove an existing UO or US tag, right click on the existing tag and then left click on Remove Tag.
- You cannot change or remove the OL or SF tags on master paragraphs.

**Note:** If your section appears corrupt in either Outline or Short Form Mode, run VerifySpec Type Tags from the Tools tab.

### Printing in Outline or Short Form Mode

When you select to print while in Outline or Short Form Mode, only the paragraphs tagged as Outline and/or Short Form will be printed. To print in Outline or Short Form, open a section, change to Outline or Short Form Mode from the View tab and then click on Print from the File menu.

If in Outline mode: Only those paragraphs tagged as Outline (OL or UO) will print.
- You can print either a branch or the entire project.
- The output is one continuous report with the Section titles acting as dividers between Sections.
- There are no auto-numbers in the Outline report.
- Each Division will start a new page.
• If the header or footer displays the Section ID in Full Spec Mode, that will be changed to the Division ID in Outline Mode. The Section name will be changed to the Division name.
• Although they are displayed in the Document Panel, PARTs 1, 2, 3 (including any other level 1 paragraphs) and END OF SECTION will not print.
• The automated Table of Contents will only list the sections that have paragraphs tagged as OL or UO.
• The Page Count Option is not available on the Automated Table of Contents.
• Requirements Reports are not available in Outline Mode.
• Start document on odd page does not work in Outline Mode.
• Using the MF95 Output option is not available in Outline Mode.

If in Short Form Mode: The reports are the same as the standard reports, except that only paragraphs tagged as Outline and Short Form will print.
• The automated Table of Contents will only list the sections that have paragraphs tagged as OL/UO or SF/US.
• The Page Count Option is not available on the Automated Table of Contents.

Comparing Two Projects

There are a number of reasons to compare project documents electronically. One of the reasons for a comparison might include a need to see how documents produced for a recent project differ from those for a similar project produced earlier. A project comparison can also be submitted as addenda.

To create a project comparison, you must have two separate projects. The original (the older project) would be the base document, and the one you have more recently edited is the compared document. The comparison results in a black-lined document that can be previewed, printed to hard copy, or exported to word processing.

When two projects are compared, text that is identical in both documents appears normal. Other changes show up as follows:

• Text in the base document but not in the compared document is stricken through.
• Text not in the base document but in the compared document is underlined.
• Text in the base document that has been edited in the compared document may have a combination of underlining and strike-throughs

Tips:

• The Compare Projects feature works only with SpecLink-E projects in native file format. Documents created in a word processor or exported to a word processor format cannot be compared using SpecLink-E.
• You can compare user-added sections only if the user added section is a result of the project being copied (the same section is in the original and the copy) or if the section was imported into both projects from the same SLE source project.
• The Compare Projects feature compares only the active text in the two projects. It does not compare any text, whether in the master or user-added, that has been excluded or that has not been selected.
• Images inserted into either document will not be included in the Comparison report.

Note: If you have only minor changes and do not want to use the Compare feature, you can use the Strikethrough function found on the Format tab.
Generating a Project Comparison File

1. Open the project that contains the more recent edits.
2. From the Tools tab/Projects group, select Compare Projects. The Project Comparison dialog box opens.
3. To the right of the Compare To field, click the icon. The Project Selection dialog box opens.
4. Open the project you want to compare to (the original or base file).
5. Select Compare Project, Compare Branch, or Compare Section.
6. If you select Compare Branch or Compare Section, click the drop-down arrow to select the branch or section you want to compare. The control defaults to the section you navigated to prior to opening the Project Comparison dialog box.
7. Click on Print, Preview, or Export.
8. If you click Export, select the format that you want the exported file(s) to be.
9. The Browse for Folder dialog box opens. Choose the network or local drive you want to export to and then double-click on the folders to choose the folder where you want the comparison file(s) located.

The comparison process may take several minutes, depending on the size of the projects and the speed of your computer.

At the conclusion of the comparison, the Print, Preview, or Export process will begin.

Note:

- Only one compared section can be previewed at a time. If you choose to compare project or branch, you will only be able to choose Print or Export.

Manage Projects

Project Naming

The name of the project (the name you enter in the New Project dialog box when you first create the project) should be a meaningful name that is easily recognized by other team members. Once
the project is created, you can change the Project Name or enter the Project ID for the project in the Summary Information dialog box, which will change it in all places. The Project Name and Project ID are keywords that are available for use in headers and footers. The project name is visible to others using the same projects database that you are.

A project name can be up to 128 characters and can contain any Unicode character, including /, \, *, ?, <, >, or |.

**Renaming a Project**

1. Open the project that you want to rename.
2. From the File menu choose Summary Info.
3. On the General tab, input the new name in the Project Name field.
4. Click OK to save the change.

Your new name will be reflected in the application title bar, the Open Project dialog box and the Recent Projects list.

**Copying a Project**

It is safe to copy an existing project in order to re-use previous work because all the master text and options are still there, even though they may not have been used on that project. To copy a project:

1. Close your project if you have one open.
2. From the File menu choose Copy Project.
3. When the Project Selection for Copy dialog box opens, select the project to be copied.
4. In the Specify a name field, input the name for the new project.
5. Then click Copy.
6. Click Yes at the confirmation.

Your newly copied project will open, as will the General tab of the Summary Info Dialog Box.

**TIP:** After you copy a project, it is a good idea to modify the project settings.

**Project Settings for an Existing Project**

You can change the project settings at any time. Whenever you copy an existing project you will probably need to modify the project settings. Also, you may wish to confirm the settings before printing.

1. Open the project.
2. Click on the File menu and choose Summary Info.
3. The Summary Information dialog box appears.
4. Make the necessary changes and click OK.

**Archiving a Project**

When you have completed a project and no longer need to edit it or print it from SpecLink-E, you should remove it from the drive where it is saved so that you can reclaim the drive space the
project is taking up. However, you will want to keep an archive copy of the project. In addition to a hard copy printout, there are a couple of electronic ways to archive project work:

- Export it to RTF, .DOC or PDF format. RTF, DOC and PDF files take up considerably less space than SpecLink-E projects. The drawback is that you cannot easily reuse a project if it only exists in RTF, DOC or PDF format.
- Save the project to a file. When needed you can load the project from file.
- Send the project to the Archive Database and activate it when needed.

**Save Project to File**

![Save Project to File, Load Project from File, Archive]

Use this command on the Tools tab, Copy and Archive group when you want to save a single SpecLink-E project to a file.

**To save a project to a file:**

1. Close any open project.
2. Choose Save Project to File from the Tools tab, Copy and Archive group. The Save Project to File dialog box opens.
3. Click on the field name in the top row to sort the list by that field.
4. Click on the project to be saved.
5. Click on the Browse button to select the location where the project will be saved.
6. Navigate to the desired folder and click Save.
7. If you want to remove the project from the current projects database, click on Remove the project from the Projects database.
8. Click Save to File.

SpecLink-E saves the database and informs you when the process is complete. This file can only be used by SLE.

If you are saving your project to file as a way of archiving it, consider adding it to your Archive Database.

**Load Project from File**

To load a project that was saved to a file in SpecLink-E:

1. Close any open project.
2. From the Tools tab, Copy and Archive group, choose Load Project from File. The Load Project From File dialog box opens.
3. Click on Browse to select the project you want to load. Click Open.
4. If the project already exists in the projects database, you can replace it by clicking on Replace existing project, or you can enter a new name for the project.
5. Click on Load From File.
6. After the project is loaded from file, you may be presented with the dialog box asking to compare your project to the current master.
7. If your project has possible updates, you will be presented with the Update Reminder dialog box.
8. The Summary Info dialog box opens.

Notes:
- If the project that you are Loading from File is using a Project Template that is not currently in your Projects Database, that Project Template will be added to your Projects Database and will be automatically assigned to the project that you are loading.
- Load from File will also add any User Defined Tags, Project Note Images and User Added Global Terms that are not already in your Projects Database.
- If the project you are trying to load was saved in a later version of SLE, or using more up to date master data than you have, you will need to update your master data or SLE version before you can load the project.

Making Backups of your Projects

One of the most important things you can do to safeguard the work you have put into creating specification projects is to make regular backups of the projects database. While the SpecLink-E software and master database files can be replaced by reinstalling, the only copies of the projects file you create are the ones you make.

Unlikely though it may be, files can be deleted accidentally or hardware problems with your computer can serve to make your databases unusable. Recreating the project files can require a significant amount of work, even if hard copy printouts exist. You can avoid losing the file by making frequent backup copies that can be used to restore the data.

Ideally, backup copies should be created each day that work is done on your specification files. It may even be desirable to keep backups at a site other than the one where you normally work.

SLE Support Utilities

SLE Support Utilities is a small application that is installed with the Server or Standalone installation. It is used for Backing up the Databases, Restoring the Databases, Running Server Maintenance, setting up Auto Check-ins, running Repair Data and updating your BSD Master data.

To run this utility:
- In Windows, click on Start | All Programs | Building Systems Design, Inc.
- Right click on SLE Support Utilities and choose Run as administrator.
From this utility you can:

- Schedule or Back up the Databases
- Restore the Databases
- Schedule or Run Server Database Maintenance
- Enable Auto Checkins
- Use the Repair Data script
- Schedule or run online updating of your BSD Master (See Updating section for information on updating your BSD Master.)

**Back up the Databases**

A backup of the databases includes the entire Projects Database, the Archive Database, the BSD master and the Security database (access key and System Roles). If you have LinkMan-E installed, the LinkMan-E master and groups database are also backed up. Backups can be scheduled to occur daily or weekly, or can be created on demand. Note that the update installation automatically creates a backup of all databases.

Note on checked out sections during a backup. If you are doing a manual backup and there are checked out sections, you will see a message with a listing of the sections that are checked out. This is so that you can check those sections in before running the backup, if you want to. The scheduled backups will not generate a warning if sections are checked out. This is because the scheduled backups usually run at night when nobody is there to see the message.

**Scheduled Backups**

To schedule a recurring backup, perform the following steps:

- Be at the server or standalone machine.
- Click on Start | All Programs | Building Systems Design, Inc. | SLE Support Utilities. (Right click to run as Administrator.)
- The form initializes and then will display information.
- In the Schedule Backup tab, you will see the following fields:
Last scheduled backup: This displays the date and time when the last scheduled backup was performed. It does not include the manual backups in this field.

Next scheduled backup: This displays the date and time when the next backup is scheduled to be performed.

- Recurrence - Use this field to schedule the frequency and start time for the scheduled backups.

- Number of backups set to retain: The range is from 0 to 5. If you set the number at 5, once you have 5 backups the next backup will overwrite the oldest backup. To prevent a backup from being overwritten you can move the file to a different location, but you must move it back to the Backup Directory displayed below before you can restore it. If you set the Number of backups to 0, you are disabling the scheduled backups.

- Backup Directory – You can select a different drive for your Projects Database backups. It must be a valid local hard drive on the server or standalone machine. You cannot choose an external hard drive. To make a change click on the browse button at the end of the Backup Directory line. Click on the drop down arrow to select a local drive. Your valid choices will be displayed. You can only select a different drive. The software will determine the folder name. When you select a new drive, click on Apply and then Close. If you need to restore a database that was backed up to a different folder than the one now references, the backup file must be copied to the new location. The BackupInfo.dat file must remain in the default location, however.

- Saving Changes - Once you have made changes in this form, click on Apply to save them. Click Cancel to discard any changes you have made. Click Close to close the form after clicking Apply.

- To determine if your scheduled backup has run, check the Event Viewer in Windows.

- Note that you must access the Schedule Backup dialog box once before any scheduled backups can begin.

Manual Backups

To backup the databases manually:
- Close SpecLink-E and make sure that all sections have been checked in, if desired.
- Click on Start | All Programs | Building Systems Design, Inc. | SLE Support Utilities, running as Administrator.
- Click on Backup Now.
- Once the databases have been backed up, you will see a message on the bottom left of the form.
- Click on Close to close the form.
- Note that the form must be closed in between each activity, such as a Backup and a Restore.

Shrink Now - Click on this if you want to Shrink the Projects Database now.

Additional notes:
- You can only make one change in the SLE Support Utilities dialog box at a time. You must click on Close after any change, and restart SLE Support Utilities to perform an additional task.
- The format of the backed up file is only usable after it is restored to SpecLink-E format. See Restore Databases.
- Backup files may be moved to a different folder so that they are not overwritten, but they must be moved back to the default folder before you can restore them.
- Backup files will not work if they are renamed.
**Shrink Database**

In the Schedule Backup tab of the SLE Support Utilities, there is an option to Shrink database during scheduled backup. There is also a button called Shrink Now. If you check the option to Shrink the database during the scheduled backup, or if you click on Shrink Now, a process will run to recover as much space as possible in your Projects Database. All requests from SLE go to SQL Server which creates and maintains all data files and ultimately controls the size of the Projects database files.

If you shrink a database repeatedly and notice that the database size grows again, this indicates that the space that was shrunk is required for regular operations. In these cases, repeatedly shrinking the database is a wasted operation.

It is not recommended that you select to Shrink the database each time the scheduled backup is run.

**Restore Databases**

Once the Databases have been backed up using the SpecLink-E function of Backup Databases, to make use of it, it must be restored. Restoring must be done using SLE Support Utilities.

To restore the databases:

- Make sure that nobody is using SpecLink-E or LinkMan-E.
- Sit at the server (or standalone machine) where the server part of SpecLink-E has been installed.
- Click on your Start Menu | All Programs | Building Systems Design, Inc. | SLE Support Utilities.
- Note that you need to right click and choose Run as administrator.

**Restoring backups.**

- If you are restoring a database that was backed up in the fall 2011 version or later, click on the Restore tab.
- After a few seconds, the list of backups will display the available backups. As you click on each one, information about that backup will be displayed in the box below.
- If you need to restore a database that was backed up to a different folder than the one now referenced, it must be copied to the current backup location.
- Click on the backup that you want to restore.
- Make sure that the bottom left prompt says Backup is ready.
- Deselect Restore Archive DB if you do not want to replace your current Archive Database with the version that was backed up with the Projects Database that you are restoring.
- See below for Restoring System Roles.
- Click on Restore.
- When you see the confirmation that the databases have been restored, click on Close.

**Restoring older backups.**

- If you are restoring a database that was backed up prior to the fall 2011 release, click on the Restore Old tab.
- Click on the Browse box to select the database file to be restored.
- When you locate the file, click on Open or double click on the file to select it.
- Verify that you have selected the correct database to be restored.
- Make sure the bottom left prompt says Backup is ready.
- See below for Restoring System Roles.
• Click on Restore.
• When you see the confirmation that the databases have been restored, click on Close.

If you have LinkMan-E installed, that projects database will be restored also.

To include the System Roles (Corporate Edition) check the Restore System Roles check box. This would be appropriate for a Corporate Edition user who is moving the application from one server to another.

Notes:
• If any sections are checked out to users, you will receive a warning. If you continue, the user who has the section checked out will not be able to check her changes in.
• You cannot restore a database from a version later (higher) than the version you are restoring in.
• If you have renamed a backup, you need to change the name back to the original name to restore it.
• If you need to restore a database that was backed up to a different folder than the one now referenced, it must be copied to the new location. The BackupInfo.dat file must remain in the default location, however.

**Restore System Roles**

Restoring System Roles will restore the information from the Assign System Roles screen (Corporate edition), the Define System Roles screen (Corporate edition), as well as licensing information.

If you restore the System Roles, they will be restored to the state that they were in when the backup was created.

If you restore the System Roles, any changes made to your access key will be restored to the state it was in when the backup was created. If you restore to a new location, the access key will be invalidated and you will require a new one. See Moving the Software.

**Archive Database**

On the Tools tab, in the Copy and Archive Group, click on Project Archive to send one or more projects to the Archive Database. Up to 5 projects can be archived or activated at a time. Projects may be moved to the Archive Database to free space in the Projects Database. They must be retrieved from the Archive Database to be opened in SLE again. The Archive Database can grow
to 10 GB in the Professional version: the size is unlimited in the Corporate version. Archiving differs from Save to File in that the projects are archived to one database, so archived projects are not designed for sending projects to other offices. Project Archive is available on the Tools menu when no projects are open. The Project Archive database will be automatically backed up when your Projects Database is backed up. When you restore your Projects Database you have the option of restoring the Archive database or not.

Do not move your Archive Database.

To archive or activate one or more projects:

- Close all open projects.
- Click on the Tools tab and select Project Archive.
- The list of active projects in your Projects Database is displayed on the left side.
- The list of archived projects in your Archive Database is displayed on the right side.
- To send active projects to the Archive Database, check them in the left side and then click on Archive.
- You can archive up to 5 projects at one time.
- You will receive a confirmation when the process is complete.
- To activate archived projects, check them in the list on the right side and then click on Activate.
- You can activate up to 5 projects at one time.
- You will receive a confirmation when the process is complete.
- Click Close when done.

Notes on Activated projects:

- Note that projects will not preserve their former system generated Project ID when activated, If an activated project was formerly linked to a LinkMan-E group, you will need to reconnect it in LinkMan-E.
- If you delete user added images used in Project Notes in an archived project, they will not be re-added when you activate the project.
- If you delete User Defined Tags from the list of User Defined Tags that are used by an archived project, they will not be re-added when you activate the project.
- If you delete Global User Terms from the list of Global User Terms that are used in an archived project, they will not be re-added to the list of Global User Terms when you activate the project.
- If you delete a custom Project Template, it will not be re-added when you activate the project that was using it.

Server Database Maintenance

A process runs automatically during the night, if the server or standalone computer is running. This process is designed to optimize the SpecLink-E and LinkMan-E databases. To verify that the process has run, you can check the event log by running the Event Viewer in Windows. The description will be that the SLE Maintenance was invoked. There will be no event log generated if you start the process manually as outlined below.

When running in standalone mode, it is possible to invoke this process at any time. To run this in a multi-user situation, you must make sure that all users have exited the software. To run this in a multi-user situation you must be sitting at the server.

To run the Server Maintenance:
1. Close all instances of SLE.
2. Click on your Start Menu | All Programs | Building Systems Design, Inc. | SLE Support Utilities. Note that you need to right click and choose Run as Administrator.
3. Click on the Maintenance tab.
4. Choose Run Now.
5. Click OK to the confirmation.
6. When complete, you will see "Database maintenance has completed successfully." on the bottom left corner of the application window.
7. Click Close.

To change the time of the automatic Server Maintenance:

1. Click on your Start Menu | All Programs | Building Systems Design, Inc. | SLE Support Utilities.
2. Note that you need to right click and choose Run as Administrator.
3. Click on the Maintenance tab.
4. Under Daily Recurrence change the start time to the desired time.
5. Click Apply.
6. Click Close.

**Auto Check-ins**

The Auto Check-ins feature allows you to automatically check in sections that have not been worked on for a specified amount of time. A dormant section is a section that is checked out but has not been edited within a specified interval of time. Since changes are saved to the projects database immediately, no work will be lost by being automatically checked in. The purpose of this feature is to prevent licenses from being tied up when users unintentionally leave a section checked out. The SLE Server will check for dormant sections every 15 minutes, so if the interval is set to 15 minutes, it can be up to 30 minutes before a dormant section is checked in.

To enable this feature:
- Run SLE Support Utilities (using Run as Administrator) from the server or standalone computer.
- Click on the Auto Check-ins tab.
- Check Enable Auto Check-ins.
- Set the Interval that constitutes the length of time that SLE should wait before checking in a dormant section.
- Click Apply and then Close.

You can click on Check In Now to check in any sections that are dormant. If a section is still open on a user’s machine, but it has been checked in by the Auto Check-in process, the next time they try to work in it they will receive a message that it has been checked in by another process. The section is then read-only. The user must close the section and then reopen it to work on it again.

Uncheck Enable Auto Check-ins to disable this feature:

**Repair Data**

Repair Data is designed to fix sections that will not display in the Document Panel, as well as some issues that have surfaced when marking the updates in projects.

To use Repair Data:
- Ask all users to close all open projects.
• Start the SLE Support Utilities (on the server or standalone computer) by right clicking and choosing Run as administrator.
• Click on the Repair Data tab and then click on Repair data.
• Allow this to finish before users open projects. It can take up to a half hour or more for large Projects Databases.

**Update BSD Master**

See the Updating section of this document for information about online updating of your BSD Master.

**Deleting a Project**

To permanently remove a project from your projects database:

1. With your project closed, from the File menu choose Delete Project.
2. When the Project Selection for Delete dialog box opens, select the project to delete.
3. Click Delete.
4. You will be asked to confirm the deletion.

Note that if any sections are currently checked out in the project that you are trying to delete, you must either check them in or release them using Unlock Documents.

**Note:** If you are trying to reduce the size of your Projects Database, you may want to follow deleting projects with running the Server Database Maintenance.

**Unlock Documents**

Unlock Documents, available from the System Manager group on the Tools tab, allows you to view all checked out sections in the Projects Database. It lists the Project Name, system assigned Project ID, Section ID and acronym, Section Name, the name of the user who has the section checked out, their computer name, the date that it was last checked out, as well as the date and time it was last edited. To release a section, so that it is no longer checked out to that user, click in the checkbox before the section(s), and then click on Undo Document Checkout. This function should only be used when there is an issue that prevents the user from checking his or her section in.

Unlock Documents is not designed to check in any sections that you have checked out yourself. To check in your own sections use Pending Check-Ins.

**Other Locks**
The Unlock Documents dialog box can also be used to unlock the Project Templates, the Project Hierarchy (changes to the Project Tree) and the Summary Info dialog box. Unlocking these would only be necessary if they were locked by a user who is unable to unlock them.
LinkMan-E

BSD LinkMan-E (short for “link manager”) is a linking software product that allows you to easily create, monitor and modify relationships between various representations of a building design project -- as drawn using Autodesk Revit and as specified using BSD SpecLink-E. This linking software is referred to as LinkMan-E or LME. The LME user interface is a set of “Dashboards,” together constituting a monitoring station that allows the user to identify, control and coordinate relevant discrepancies between the two software applications. In short, LME is a tool for coordinating the Revit building model (the BIM) and its specifications.

LinkMan-E can also be used as a keynote editor, organizer, and assignment tool. Think of Revit as a keynote placement and updating tool. Together, they comprise a coordinated system for keynoting.

For more information go to LinkMan-E on our web page.
Create an Office Master Project

Office Master Project Concepts

Creating an Office Master Project is as simple as creating a new project or copying an existing one, naming it something that identifies it as a Master, and then editing the project. An Office Master Project is actually a normal project, saved and kept aside for this purpose. A master contains any and all changes you would make for the types of projects normally encountered. These “pre- edits” can consist of pre- selections of sections and/or paragraphs that are commonly used, as well as preferred language.

More than one master project can be developed for different building types, different owners, or different code jurisdictions. You can take advantage of the concepts of Office Master Projects by creating multiple master projects that reflect the type of projects your firm typically designs.

Methods Of Developing Masters

Developing the master that contains the sections can be a deliberate effort or it can be done piecemeal over time. If you have a specifications specialist you may decide to devote time to developing a master project or projects, because it saves the project team’s time and reduces errors. Or you can build a master over time by making a note of relevant sections done in representative projects and copying those sections to an Office Master Project made for that purpose.

Whether you choose to dedicate time to creating an Office Master Project or use multiple Master Projects, the concept is an exceptionally effective method for saving time and reducing errors.

Tip: Keep in mind that the process of creating an office master is exactly the same as when you are creating a project.

Creating a new project, using your office master.

- Create a new project to use as a template for all new projects.
- Apply your desired Project Template for formatting.
- Edit the header and footer in your desired style.
- Save this project and name it so that all users know to use it for new projects. Do not check out any sections in this project.
- Copy this empty formatted project each time you need to create a new project.
- Use Import from Project to import sections from your Office Master or any project that has your edited sections in it.

Some Types of Office Masters

The most common type of office master project is one based on a single building type, such as a high-rise office building, a hospital, or a parking garage.

You can also prepare:

- Master projects containing only a few sections for highly specialized work. In this case, the master project is not used to start a new project. Instead, its sections are imported into relevant projects.
• Master projects containing only one section, edited for particular systems. Especially
useful would be sections that are highly dependent on brand name product
specifications, such as paint, door hardware, or high performance products of any type.
• The entire master edited for a particular code jurisdiction.
• Divisions 0 and 1 only, selected and edited for particular contract types.

NOTE:
When deciding what kinds of masters you will have, keep in mind that you should update your
masters when new master data is received. To streamline the process of reviewing updates, you
may not want to include the same section in more than one master. If you do, you will have to
review the updates twice for the same section.

Tactics for Creating Office Master Project Files

1. Decide what the master project will cover: building type, location criteria, size, etc.
2. Start a new project, with a name that makes it easily identifiable as a master project file.
3. Select the sections that are normally used on such a project. There is no need to select
every section that might theoretically be used -- all will be available for use on a real
project.
4. In each section selected, select the options that would be used on most of these projects.
Again, don't select everything, just what is most common. Select appropriate paragraphs
and choose the preferred option for choices embedded in paragraphs.
5. In each section, select provisions to the level of completeness that you normally specify
on projects of this type. For instance, if this is a small Master Project, you may not
normally include the full range of Quality Assurance provisions that are available; if so, do
not select those paragraphs.
6. Exclude paragraphs that involve products or procedures that you never want to use (or
want no one else to use) on projects. An "excluded" paragraph status box in a newly
started section will quickly become a "flag" indicating a policy decision prohibiting its use.
You can also add a note in the Notes panel, explaining your reasons for excluding the
paragraph.

NOTE: Use exclude as a "flag" where it will be helpful, but do not exclude every section
or paragraph that will not be used.

7. If there are language changes needed or additional provisions that are very common,
make them. Also, additional provisions can be added without selecting them, making it
possible to create options for lower probability occurrences without having them
automatically included in new projects.
8. Add any links that would make editing the sections for a real project more efficient. For
instance, if you add new text that should always be included under certain circumstances,
add links that automatically select it under those circumstances.
9. Finally, make notes in the section to yourself or project team members that explain office
procedures and policy relating to specific paragraphs, product requirements or limitations,
or explanations of added provisions. The fact that you have added a project note will be
indicated by a blue icon in the Notes column to the left of the paragraph text in the
Document Window.
10. If using the Corporate Edition, you can restrict access to your office master using the
Summary Info Dialog Box.

You may also consider creating checklists using Non-Printing Text that would have links
to sections, paragraphs, and choices.
Tips and Tricks for Making a Master Project File

If you currently have an office master, you can incorporate the knowledge it contains into a SpecLink-E Master Project File. You can pre-edit each section to include your preferred language, notes, and additional provisions.

- Manufacturer Names and Brand Names: Whenever you research and approve a manufacturer for a project, add the name to the appropriate list in the appropriate section. If you want the manufacturer always to be on the list for that product category, select the paragraph. If the manufacturer is not approved for all instances but would be acceptable for some, don’t select the paragraph. Include a note indicating which product was researched and its acceptable applications.
- Add Reference Standard Citations If You Use Them: If you use Section 01 4219 to print a Consolidated List Of Citations, when you add text that includes a reference to another document such as an ASTM or ANSI standard, add the corresponding reference citation to Section 01 4219.
- Add and Edit Notes: Notes are a great way to explain office procedures and policy relating to specific paragraphs, product usage or limitations, or explanations of added provisions.
- Don’t Copy Text Just To Move It: If you do, updates that would otherwise apply to the text do not take effect.
- Importing from other applications: The use of New Section from RTF or New Section from DOC can be a valuable, time-saving feature. You can take previous work from a word processor and import it into SpecLink-E.
- Copy and Paste: SpecLink-E takes advantage of the hierarchical nature of the standard document format and the paragraph relationships in the Copy and Paste functions.
- Promote and Demote: Once you have imported text or copied and pasted text, you might find that the paragraphs are not at the hierarchical level that you want. Use the Promote and Demote commands from the Home tab, Paragraph group, to change the paragraphs to the correct level.
- Add Links and Choices: Add links to automatically select relevant options. Add choices that list common options and have fill-ins for users to enter information that is different for a particular project.
- Apply Tags: If you use the requirements reports, apply tags to paragraphs in new sections that you would like listed in the requirements reports.
- Apply Outline and Short Form tags: If you want to use your office master for Outline and Short Form specifications, you can apply those tags to your user added sections and paragraphs.
- Add Checklists: Add checklists to your master project so that users can "check off" what is required for a project. Create links from the items in the checklists to automatically select, highlight, and exclude appropriate information. Apply the non-printing tags to the checklist so that it will not print in the final documents. You can add checklists as separate sections in the master, and/or within existing sections.
- Project Settings: Set the printing format and project defaults to those most commonly used. This includes all the Project Summary Information settings (except the project name and project ID) and printing formats. Use the header/footer keywords so the header/footer content doesn't have to be changed for every project.
- Protect Your Master(s) From Accidental Edits: See Restricting Access to your Office Master in the Corporate Edition section.
- Review the Updates To The Master: When you receive updated master data, open the master project file and review and accept the updates before starting a new project.
Adding Reference Citations

To handle reference citations for added paragraphs in the same manner as references are treated in the master, add them this way:

1. Add a paragraph in the body of the section that contains a new reference.
2. Add a paragraph under the Reference Standards heading in Part 1 General with the full text of the citation (you may find it easier to copy an existing reference paragraph and edit it).
3. If you want to be able to print the paragraph without the reference date, but want to see the date on screen while you are editing, then add the reference date as a choice, and make the proper selection in the Summary Information dialog box.
4. Tag the paragraph under Reference Standards with RS. (This will make the Reference Standards heading turn on automatically when this paragraph becomes active if you have selected that choice in the Summary Information dialog box).
5. Create a Yes link from the paragraph in the body of the section to the citation paragraph under the Reference Standards heading.
6. If you want to be able to print a consolidated list of citations, then if this is a brand new reference, copy the paragraph you added under Reference Standards in step 2 and paste it in the appropriate location in Section 01-4219.
7. Using the Link function, add a yes link from the new paragraph citing the reference to the citation in Section 01-4219.

Now when you select the new paragraph containing the reference, and you have any of the references options checked in the Project Summary Information dialog box, the appropriate citations and/or edition dates are automatically included.

Preparing Text for Importing

The Paste function uses the current contents of the Windows clipboard and makes certain assumptions about the contents. To make importing more reliable, prepare the text to be imported in your word processor first. Any word processor or text editor that will copy to the clipboard may be used.

For additional information see New Section from RTF and New Section from DOC.

**Paragraphs:** Each paragraph in the original text will be pasted consecutively into a separate new paragraph in the section. A hard return (WordPerfect) or a paragraph mark (Word) is used to determine the end of a paragraph. If there are too many "end of paragraph" marks or codes, you will find that the text is broken up into too many individual paragraphs. If you are uncertain about where paragraphs end, turn on whatever function is used to display the paragraph marks or codes and view them.

**Levels:** The first paragraph is inserted at the level of the paragraph that the cursor is on, just like an ordinary copy and paste. However, if there are any tabs or indents in the original text, they will be used to demote subsequent paragraphs appropriately, keeping the original hierarchical arrangement. These tabs and indents must appear at the beginning of the line.

**Paragraph Numbering:** If the imported text contains paragraph numbers made using either text characters or word processor codes, you do not need to delete them as SpecLink-E will usually remove them during the import.

**Other Characters:** The text imported from the clipboard is ASCII text. Besides letters and numbers, and tabs and carriage returns, the only characters that will be imported are those in the standard ASCII character set -- those on a standard keyboard.
**Note:** If you experience any difficulties importing a Word document, open it in Word Pad, save it as a Rich Text Format (RTF) file and try importing it again.

## Handling Updates in an Office Master

If you have one or more Master Project Files, someone in your office should be assigned the responsibility for updating them before any new projects are started. If you start a new project by copying the Master Project File before it has been updated, the new project will have to be updated subsequently in a separate operation.

In most cases, you want to say Ignore Updates to updating a Master Project File project, followed by the process of reviewing the updated master paragraphs and ending up with a Master that is up to date.

If you choose Ignore Updates at the update dialog box, all changes in the master database are indicated in your Master Project File by means of magenta text in the section title in the Project Tree.

When your project is compared to the master for the first time after an update, SLE generates a report of all the paragraphs in your project that are affected by changes. This log is saved by project name in a folder that includes the date when the updates were marked in the project such as `C:\ProgramData\BuildingSystemsDesign\SLE\logs\updates20130615`.

Once you have located each affected section, you can open the section completely and scan for rust in the Document Panel, or you can use the report to locate each affected paragraph. Then, from the Tools tab, Update to Master group, choose Compare to Update to see the specific changes. In each instance, you can decide whether or not to include the change in your Master Project File. Alternatively, once you have viewed the changes, you can choose Update Project from the Update to Master group on the Tools tab. To speed up this process see Update Publication References and Update Manufacturer References.

## Applying Paragraph Tags

The SpecLink-E master database employs Paragraph Tags on certain types of information, for both reporting, viewing and linking purposes. You can apply tags to user added paragraphs for those reasons as well as for Non-Printing Text. You cannot change tags on master paragraphs although you can apply the NP, NS or PL tags from the User Defined Tag column to a master paragraph.

To see what tags are already applied to paragraphs, click on the View tab and select the appropriate column from the Status Columns group. There are three types of tags, each with its own column:

- Spec Type Tags (for Outline and Short Form Modes)
- Requirements Tags (including NP - Non-Printing and NS - Non-Selectable)
- User Defined Tags

To apply a different tag to a paragraph:

1. Click in the user added paragraph.
2. Right click in the appropriate tag column.
3. Select the appropriate tag.
4. You can simply left click on the R column to tag additional paragraphs with the same tag.
Once you have attached the appropriate tag to a new paragraph, SpecLink-E treats the added information in the same way it treats the master data.

To remove a tag:

1. Click in the user added paragraph.
2. Right click on the existing tag to remove it.
3. Or right click and choose NA from the list of tags.

**Spec Type Tags**

The Spec Type Tags column displays a tag based on whether the paragraph is part of the Outline, Short Form or Full Spec mode. To view the Spec Type Tags column, which is one of the Status Columns in the Document Panel, from the View tab, Status Columns group, select Spec Type Tags. The tags are:

- OL or UO - Outline Spec
- SF or US - Short Form Spec
- Blank - Full Spec

You can tag user added and master paragraphs, but you cannot change the OL or SF tags on a Master paragraph.

Note: If your section appears corrupt in either Outline or Short Form Mode, run Verify Spec Type Tags from the Tools tab.

**User Defined Tags**

One use of User Defined Tags is to allow LinkMan-E users to tag both master and user paragraphs as PL (Product List) to enable additional paragraphs to be displayed in LME. Users may also add as many user tags as desired. One use for this feature is a way to tag paragraphs as IN - Incomplete and then generate a list of paragraphs that need to be finished. User Defined Tags can be used for a number of reasons.

Note: NP (Non Printing) and NS (Non Selectable) tags are included in the User Defined Tag list so that you can designate Master paragraphs as NP or NS. See Non Printing Text for more information about the NP and NS tags.

Creating User Defined Tags:

- To create your list of User Defined Tags, click on the Insert tab and select Define User Tag in the Tags group.
- Click on the last row and input the Tag and the Tag description.
- Tags must be 2 uppercase characters.
- Use the Up and Down arrows to rearrange the order of your tags.
- Click OK when you are done adding tags.
- All user defined tags are available in all projects.

Applying User Defined Tags:
• To tag master or user added paragraphs, click on the View tab and select User Defined Tags in the Status Column group.
• Once the column is visible, tag paragraphs by right clicking on the U column and selecting the desired tag.
• Once a paragraph has been tagged this way, additional paragraphs can be tagged with the same tag by a left click on the U column for those paragraphs.
• Right click on the U column and choose Remove Tag to remove a tag from a paragraph.

To Delete a User Defined Tag from the list of User Tags:

(Note that the NS, NP and PL tags may not be removed from the list of user defined tags.)

• Check in all sections that use the User Defined Tag.
• On the Insert Tab, select Define User Tag.
• Click on the box to the left of the Tag you wish to remove.
• Click on Remove.
• You will see a confirmation saying that you will remove the tag from this list and from all tagged paragraphs in all projects. You must click on Yes to proceed.
• If any of the sections using this tag are checked out, a list of the checked out sections will be displayed on screen and also in a log file.
• You must close this dialog box, check in the sections listed, and then retry this command.
• Note that if you delete a User Defined Tag that is used in one or more projects in your Archive Database, they will not be re-added to your list of User Defined Tags automatically when you activate the project(s). You can re-add them to the list and the activated project will include them in the User Defined Tag Report.

User Defined Tag Reports

Once you have created and applied any User Defined Tags, you can print a report displaying the active paragraphs with these tags. The report lists the text of each tagged paragraph, as well as the text of the parents to the tagged paragraphs.

To print a User Defined Tag Report:

1. Click on the File menu and choose Print.
2. Select the Project Reports tab.
3. Select Print User Defined Tag Reports as the Scope of Report.
4. To print a report for a single tag, select that tag from the dropdown list of tags.
5. To print a report for each User Defined Tag, select All User Tags.
6. Click on Print, Print to PDF, Preview or Export.

Note that the header and/or footer for this report is using the entries made in the Requirements header and footer dialog box.

Images do not currently print in this report.

Complete List of Available Tags

The following tags displayed in the Requirements Tags status column determine what sections will be listed in the Requirements Reports. If a section includes an active paragraph with one of these tags, it will be listed in the appropriate Requirements Report.
Tags can also be used to create Non-Printing and Non-Selectable paragraphs.

**Note:** You may see two or three additional tags in the Tags status column that are not listed in the Tags button. Tags that are not listed on the Tags button are ones that are used just by BSD for our master database. KW means keyword, MT is for manufacturer list titles, and UM is an obsolete tag that has been replaced by the ML tag.

<table>
<thead>
<tr>
<th>Tag</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Certificate (CT)</td>
<td>A submittal consisting of the manufacturer's or contractor's certification. Usually used to certify that the products furnished meet the specification criteria. PART 1, Submittals.</td>
</tr>
<tr>
<td>Design Calculations (DC)</td>
<td>A submittal consisting of the calculations performed to design a particular element. Used to show that products designed by the contractor or manufacturer meet the project criteria. PART 1, Submittals.</td>
</tr>
<tr>
<td>Field Report (FR)</td>
<td>A report to be submitted by the contractor or a manufacturer's representative describing the status of something on the project site. PART 3, Field Quality Control.</td>
</tr>
<tr>
<td>Independent Agency Field Testing (FT)</td>
<td>Provisions requiring a testing or inspection laboratory or agency to test or inspect the work in place. The section may require the agency to be hired by either the owner or the contractor, and the testing varies according to the type of product involved. PART 3, Field Quality Control.</td>
</tr>
<tr>
<td>Installation Instructions (II)</td>
<td>Manufacturer's printed installation instructions. Submittal for information only, for the project record. PART 1, Submittals.</td>
</tr>
<tr>
<td>Installer Qualifications (IQ)</td>
<td>This includes &quot;applicators&quot; and other similar functions. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Keyword (KW)</td>
<td>BSD Internal Use.</td>
</tr>
<tr>
<td>LEED Report (LR)</td>
<td>This lists all sections with active LEED submittal requirements.</td>
</tr>
<tr>
<td>Maintenance Materials (XM)</td>
<td>Additional quantities of the materials installed, usually furnished for maintenance purposes. Usually limited to products that would be hard to match or acquire in the future. PART 1, Extra Materials.</td>
</tr>
<tr>
<td>Manufacturer Listing (ML)</td>
<td>Manufacturers listed in a specification. This requirements report is different from the others. In addition to listing the section number, it lists the text in the tagged paragraph (the manufacturer's name) and the text of the parent paragraph (the product type).</td>
</tr>
<tr>
<td>Manufacturer Qualifications (MQ)</td>
<td>This includes “fabricators” if the product is more likely to be shop-fabricated than factory-made. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>Mock-Up (MO)</td>
<td>A mock-up built during construction for evaluation of workmanship or performance. Another term for this is &quot;field sample&quot; when that refers to a full-scale portion of the work evaluated in place. Mock-ups for testing prior to approval of products are not included in this category. Part 1, Quality Assurance.</td>
</tr>
<tr>
<td>None (NA)</td>
<td>Choose this to change a tagged paragraph to have no tag.</td>
</tr>
<tr>
<td>Non Printing (NP)</td>
<td>When combined with links, the &quot;NP&quot; (Non-Printing) tag allows you to add checklists to your projects that select, highlight, or exclude appropriate information.</td>
</tr>
<tr>
<td>Non-Selectable (NS)</td>
<td>When combined with links, the &quot;NS&quot; (Non-Selectable) tag allows you to add checklists to your projects that select, highlight, or exclude appropriate information.</td>
</tr>
<tr>
<td>Operation and Maintenance Data (OM)</td>
<td>Specific items that may not be obvious from the general requirements for operation and maintenance data in Division 1. Includes both standard pre-printed data and documentation prepared specifically for the project. Part 1, Submittals.</td>
</tr>
<tr>
<td>Pre-Installation</td>
<td>A special meeting, usually specified with particular attendees and topics to</td>
</tr>
</tbody>
</table>
### Meeting (PI)
Meeting to be covered. Part 1, Quality Assurance.

### Product Data Submittals (PD)
Manufacturers' catalog data, not prepared specifically for the project. PART 1, Submittals.

### Professional Engineer Design (PE)
If major components are commonly designed by an engineer other than the engineer of record, the section may include that requirement as an option. If so, the actual text depends on the products involved. Part 1, Quality Assurance.

### Product (PL)
Product listing. This tag enables paragraphs to be visible in LinkMan-E.

### Project Record Documents (PR)
Specific items for the project record that may not be obvious from the general requirements for project record documents in Division 1. PART 1, Submittals.

### Property (PY)
BSD Internal Use.

### Qualifications Statement (QS)
Actual submission of qualifications of manufacturer, installer, or designer. Part 1, Submittals. Qualifications required are specified in Part 1, Quality Assurance.

### Reference Text Segment (RS)
See References and Related Sections Tags.

### References Title (RT)
See References and Related Sections Tags.

### Related Sections Segment (RE)
See References and Related Sections Tags.

### Related Section Title (ST)
See References and Related Sections Tags.

### Samples (SA)
Actual products to be furnished, for approval of colors, finishes, etc. Not used for testing purposes or for evaluation of performance. PART 1, Submittals.

### Shop Drawings (SD)
Drawings prepared specifically for the project, to complete the design or to illustrate details left up to the contractor. PART 1, Submittals.

### Source Quality Control (SQ)
Source Quality Control paragraphs. Usually near the end of Part 2.

### Special Warranty Provisions (WT)
Any warranty provision that involves a term longer than one year or entities other than the (prime) contractor. The actual terms vary according to the type of product involved. Part 1, Warranty.

### Test Report (TR)
Any report of a test. May be pre-construction, showing performance of a proposed product; during construction, testing samples of materials installed; or post-construction, testing actual installation in place. Pre-construction is in Part 1, Submittals. During and post-construction is in Part 3, Field Quality Control.

### Warranty, Executed (WE)
Actual copy of the warranty signed by the warranting entity. Warranty provisions are in Part 1, Warranty. Submission of executed warranty is in Part 1, Submittals (if mentioned at all).

### Warranty, Specimen (WS)
Sample of proposed warranty, for review. Part 1, Submittals (if mentioned at all).

### Proposal Phase (S1)
This tag is for substantiation reports for the Design Criteria sections in the database.

### Preliminary Design Phase (S2)
This tag is for substantiation reports for the Design Criteria sections in the database.

### Design Development Phase (S3)
This tag is for substantiation reports for the Design Criteria sections in the database.

### Construction Documents Phase (S4)
This tag is for substantiation reports for the Design Criteria sections in the database.
**Construction Phase (S5)**  
This tag is for substantiation reports for the Design Criteria sections in the database.

**Closeout Phase (S6)**  
This tag is for substantiation reports for the Design Criteria sections in the database.

**Occupancy Phase (S7)**  
This tag is for substantiation reports for the Design Criteria sections in the database.

---

**Non-Printing Text**

A checklist document is one in which links from paragraphs or choices select or exclude other paragraphs or sections. The checklist can be at the beginning of the section and contain links to paragraphs within the section or it can also be a separate section that has links to other sections. Checklist paragraphs typically do not print, but they need to be active paragraphs so that the links within them will activate. To create this situation, use Non Printing Text, combined with links. You can add paragraphs with questions and answers to specification sections, and then add links from the answers to the appropriate paragraphs, sections, and choices. You would make the questions and answers non-printing text so that they could be active (otherwise they wouldn't be able to activate the links), yet not print.

Where you put the non-printing text is entirely up to you. If you want the questions to apply to the entire project, you could either make a new section that only consists of questions, or add them at the beginning of the Table of Contents.

To make non-printing text:

1. Make new paragraphs, typing in the text that belongs in them - questions, answers, directions, etc.
2. For paragraphs that are questions or directions that you don't want users to be able to accidentally de-select, apply the tag NS (non-selectable).
3. For paragraphs that are answers that you do not want to print, but you do want users to be able to select, apply the tag NP (non-printing).
4. Build links from the answers to the appropriate sections, paragraphs, and/or choices.

No text with the tags NS or NP will print in the final specification.

**Tips:**

- To apply the NP or NS tag to master paragraphs, use the User Defined Tag column.
- If you apply NP to a section title, not only will the section not print, but neither will it be listed in the Table of Contents report.
- If you apply NP or NS to a section title or a paragraph that has sub-paragraphs, SpecLink-E will apply the NP or NS tag to the children as well. If you realize you did not mean to apply the tag to ALL the subparagraphs, you must change the tag to NA (none) for each paragraph. Once you have changed one tag to NA, you can simply click on additional tags to remove them.
View and Build Links

Link Concepts

Links are the way SpecLink-E changes the system status of related paragraphs when you select text. Links are a powerful productivity tool for improving project coordination by automatically adding relevant information and excluding incompatible options. The following are the basic principles of linking:

- Any paragraph may be linked to any number of other paragraphs both within the same section and in other sections.
- Link sources are paragraphs that are connected by links to the current paragraph. **Active** link sources are paragraphs that are currently selected and active in the project, so that their links to all paragraphs, including the current one, are in force.
- Link targets are paragraphs that would be affected by links from the current paragraph if it were active.
- Only one link may exist from any source paragraph to a given target paragraph, except to create multiple links to choices within a paragraph.
- A paragraph may be the target of any number of links from multiple source paragraphs.
- Links act in one direction only and do not result in reciprocal linkage. For example, a paragraph that automatically selects another paragraph is not selected automatically if its target is chosen first; a separate link acting in the opposite direction would be necessary, and this may not always be appropriate.

Because a given target paragraph may be acted upon by several links of different types (from a number of source paragraphs), the text status and related display modes are governed by a hierarchy of consequences:

- Any text may be selected manually at any time, which overrides any links.
- Any text may be excluded manually at any time, which also overrides any links.
- If not selected or excluded manually but acted upon by one or more links of the same type, the status corresponds to that associated with the link type (Green (Yes), Red (No), or Yellow (Maybe)).
- If not selected or excluded manually but acted upon by more than one type of link, text status is determined by the following hierarchy, from most to least controlling: Red (No), Green (Yes), Yellow (Maybe). In other words, one red link will override any number of green or yellow links; one green link will override any number of yellow links.
- If not selected, excluded, or acted upon by any links, the text is available for selection by the user.
- Because the status of a particular paragraph is dependent upon the net effect of all currently active links, removal of a particular link by deselection of the source text may result in a change in the status of the target paragraph. The software calculates the current status of each paragraph after each user action and displays the active paragraphs on a white background for ease of identification.
Open the Links dialog box by first clicking within the paragraph that you want to view the links of, then choose SpecLinks from the Insert tab / Links group.

**Source Links Tab:** This tab shows paragraphs or choices connected by links to the current paragraph. Active links (those currently in force because the source paragraphs are active) are indicated by bold font.

**Target Links Tab:** This tab shows paragraphs or choices connected by links from the current paragraph that are activated by selection of the current paragraph.

For each link, the following information is displayed on the Source Links tab and the Target Links tab.

**Influence:** The color of the arrow indicates the status type. Green indicates selected, Red indicates excluded, and Yellow indicates highlighted or suggested. Blue arrows indicate that the link originates from LinkMan-E, or from another paragraph that is selected by LinkMan-E.

- The direction of the arrow indicates the type of link (arrows pointing to the right indicate targets; arrows pointing to the left indicate sources).
- A dot on either or both sides of the arrow indicates the involvement of a choice. More detail about the choice appears in the Source or Target window below.

**Paragraph:** In the Paragraph column, the following information appears:

- **Section Number:** The target or source may be in a different section, so the section ID and acronym are indicated.
- **Sequence Number:** The sequence number of the target or source is listed as an aid to locating the paragraph.

**Specification:** The text of the target or source is shown to aid in verifying whether the link is appropriate or not.

**Source:** The Source information at the bottom of the Links window indicates whether the source of the current link is a paragraph or a choice. If the source is a choice, the window includes a diagram that identifies the choice group, the values of the choice group, and the value of the source choice.

**Target:** The Target information at the bottom of the Links window indicates whether the target of the current link is a paragraph or a choice. If the target is a choice, the window includes a diagram that identifies the choice group, the values of the choice group, and the value of the target choice.
Tips:

- The sequence numbers in the Links window correspond to the sequence numbers in the Document window. If sequence numbers are not currently displayed in the Status Columns portion of the Document Panel, click on Sequence Number from the View tab / Status Column group.
- To see the entire text of the source or target paragraph, use your mouse to "grab" the edge of the Links window and enlarge it. You can also click on Autosize.
- You can move the Links window by clicking on its title bar, holding the left mouse button down, and dragging it to a new location. You can also resize it.
- Click on the Close button to hide the Links window. The next time you open it, the window will open in the same size and location on the screen.

Basic Master Links in SpecLink-E

Within each SpecLink-E specification section:
- Product specification text in Part 2 makes Yes links to appropriate installation requirements in Part 3 and relevant Part 1 requirements, such as submittals and quality assurance provisions.
- Mutually exclusive choices among products or installation methods each have No links to the conflicting options, so that selection of any one of them automatically excludes the others.
- Selection of text that contains a reference to a reference standard citation in Part 1 makes a Yes link to the reference citation.

Between sections:
- Each cross-reference within a section makes a Maybe link to the title of the referenced section.
- Each paragraph that refers to requirements in another section makes the appropriate links to change the status of paragraphs in the related section.
- The Table of Contents for the project is updated automatically as sections are completed, including page counts.

Viewing Links

It is not necessary to view the links to have them do their job. However, viewing the links can be very instructive and useful when you are trying to determine why a paragraph changed status unexpectedly.
The Links window is a "floating" window that can be resized and relocated on the screen. To open the Links window:

1. From the Insert tab, Links group, click on the SpecLinks icon.
2. The links for the current paragraph are displayed.
3. To see the links for a different paragraph, click on the appropriate paragraph in the Document window.

The default tab in the Links window displays the Source Links; a second tab displays Target Links.


**Link Targets**

The Target Links Tab shows paragraphs or choices connected by links *from the current paragraph* that are activated by selection of the current paragraph. For Targets, there are the following types of influences:

- ➩ This paragraph selects the target.
- ➩ This paragraph excludes the target.
- ➩ This paragraph recommends the target.
- ➩ This paragraph toggles on a choice in the target.
- ✷ A choice in this paragraph selects the target.
- ✷ A choice in this paragraph excludes the target.
- ✷ A choice in this paragraph recommends the target.
- ✷ This paragraph toggles on a choice in the target.
- ➩ This paragraph is the parent (or parent of a parent) of a paragraph activated by LinkMan-E.

For paragraphs that are active, all targets are in effect (displayed in **bold** type). For paragraphs that are inactive, no targets are in effect (all are potential).

**Link Sources**

The Source Links Tab shows paragraphs or choices connected by links *to the current paragraph*. For Sources, there are the following indications of influences:

- ← This paragraph has been selected by the source.
- ← This paragraph has been excluded by the source.
- ➩ This paragraph has been recommended by the source.
- ➩ This paragraph has been selected by a choice in the source.
- ← This paragraph has been excluded by a choice in the source.
- ➩ This paragraph has been recommended by a choice in the source.
- ✷ ← A choice in this paragraph has been toggled on by the source.
- ✷ ← A choice in this paragraph has been toggled on by a choice in the source.
- ← This paragraph has been selected by a link from LinkMan-E.

**Tips:**

- There may be many links shown, but only those that are **bold** are active - the others are links that have not been activated since the source paragraph is not itself active.
- For paragraphs that have been selected, recommended, or excluded by the software, at least one source is in effect.
- For paragraphs whose status box is still neutral ☐, no sources will be active.

**Rebuild Links**

**Single Document**: You can rebuild links for a single document, using the Rebuild Document Links command, from the Manage group on the Documents tab. This is available when the document is open.

**Entire Project**: You can rebuild links for the entire project, using the Rebuild Project Links command, from the Projects group on the Tools tab. This will erase and rebuild all links in the project.
If Rebuild Project Links takes as long as 10 minutes, the process may have timed out, even if you receive a message that the process is complete. A possible solution is to restart Windows if you have a standalone version of SLE, or have your IT Manager restart the SQL Server (BSDSOFTLINK$DATA) on the server where the SLE server installation resides. If that does not resolve the issue contact BSD Technical Support.

Adding Links

Power users of SpecLink-E may want to add more intelligence to a Master Project File by adding links. Technically, you can add links to any project, but it is not practical to do so unless you plan to reuse the project. The reason is that it takes more time to create a link than to simply make a manual selection or exclusion. In a Master Project File, however, especially one that is used by several people for different project types, adding links makes a great deal of sense. You can increase the density of links in the master database, making the existing data more intelligent. You may also want to add links whenever you add new products to an existing section, connecting the product choices to appropriate installation requirements.

There are some rules about when to add a link in a Master Project File project, but often it is a matter of judgment. For instance, it is almost always a good idea to add links under the following circumstances:

- Whenever you add a paragraph that mentions a reference standard, add a green link to the appropriate citation in Section 01-4219. If it is a new standard, be sure to add the full citation to Section 01-4219, then add the link.
- Whenever you add a cross reference to another section, add a yellow link to the title of that section to highlight it, or add a green link to include it in the project. Depending on the context of the paragraph, you may also want to add other links to specific paragraphs within the cross-referenced section.

If more than one person is going to be using the Master Project File, adding links under the following circumstances is frequently desirable:

- If you add a new requirement that may or may not be needed, add a green link to other relevant requirements, but leave the original paragraph unselected.
- If you add incompatible options, add a red link from each option to each of the alternatives, so selection of any one excludes the others.
- If you add an optional paragraph with subparagraphs that are always needed if the option is selected, add green links from the added paragraph to each of the subparagraphs.

If your Master Project File contains few alternatives and is intended to be used as edited, the effort of adding links is probably not justified.

Adding Links from Paragraph to Paragraph

If the master links do not provide the intelligence you need, you can add links. Each paragraph and each choice in a paragraph can have a link to any other paragraph or choice.

To make a link from one paragraph to another:

1. In the Document Panel, position the cursor on the paragraph that is to be the link source.
2. Open the Links Window by clicking on SpecLinks in the Insert tab, Links group.
3. Click on the Target Links tab.
4. Click on Lock Source on the bottom left corner of the dialog box if you are creating links between sections.
5. Scroll the Document panel to show the paragraph that is to be the link target.

The target can be anywhere in the project, including a different section. You can open two sections concurrently by checking out another section. To display the two sections neatly, create a new Vertical or Horizontal Tab Group. Remember, when two sections are open, one is always the "current" window; the section number is blue rather than grey. You can switch back and forth between them.

6. When the target paragraph is visible, using the mouse, position the cursor over the status columns to the left of the text, hold down the left or right mouse button, and start to drag with the mouse. The cursor arrow changes to a circle and bar symbol.
7. Continuing to hold the mouse button down, drag the cursor to any position within the upper window in the Target Links tab of the Links Window, and release the mouse button.

The link is built automatically and appears in the Target Links listing.

**NOTE:** User-added links appear with underlining, to differentiate them from master links. If the parent of the target paragraph is active, the new link will be activated immediately and will appear in bold font in the Links Window.

8. To change the type of link, double-click on the green arrow in the Influence column. It toggles to red. Another double-click toggles it to yellow.

**Adding Links from Section to Section**

Creating links between sections is the exact same process as Adding Links between Paragraphs. The primary difference is that you need to have two windows open, one for each section.

1. With both sections checked out, right click on the tab of one of the sections and choose New Vertical Tab Group from the View tab.
2. Create links as described in Adding Links between Paragraphs.
3. You must click on the Lock Source button (on the SpecLinks dialog box) when creating links between 2 sections.

**Adding Links from and to Choices**

You can also add links:

- from Choices to Paragraphs ,
- from Paragraphs to Choices , and
- from Choices to Choices.

With paragraphs that have embedded choices, you can link a choice value within the choice to another paragraph. For example, if the choice set has two values, you can link the first value to one paragraph and the second value to a different paragraph. Click on a link in either the Source Links or Target Links to see detailed information about choice links in the bottom half of the Links window. The title bar of the Links window will indicate which link's information is currently displaying in the bottom half of the Links window.
Adding a Link from Paragraph to Choice

The process is similar to adding links from choices to paragraphs, except that you cannot alter the influence of this type of link. Links to choices only select the choice, they can not change the status of the target paragraph.

Put your cursor on the source paragraph.

1. Add a link to a target paragraph containing the choice group you wish to influence.
2. Click on the link you just established in the Links Window. Detailed information on the source and target paragraphs for the selected link appears in the lower part of the window.
3. In the Target panel, click on the choice group containing the link you want to toggle, then click on the choice value. A dot appears to the right of the arrow in the Influence column, and the arrow turns black, indicating that a choice value has been toggled by a link from a paragraph.
4. To also activate the paragraph, or recommend it, add a second link to the paragraph (the same way you added the first one in step 2) and double click on its influence arrow until it is the right color.

Adding a Link from a Choice to a Choice

The process is similar to adding links from paragraphs to choices, including the fact that you cannot alter the influence of this type of link, which is always a toggle.

1. In the Document Panel, put your cursor on the source paragraph.
2. Add a link to a target paragraph containing the choice group you wish to influence.
3. Click on the link you just established in the Links Window. Detailed information on the source and target paragraphs for the selected link appears in the lower part of the window.
4. In the Source panel of the Links Window, click on the choice group containing the choice you want to initiate the link, then click on the appropriate choice value. A black dot appears to the left of the arrow in the upper panel, indicating that a choice is the source of the link.
5. In the Target panel, click on the choice group containing the link you want to toggle, then click on the appropriate choice value. A dot appears on either side of the arrow in the Influence column and the arrow turns black, indicating a choice-to-choice toggle has been added.
6. To also activate the paragraph, or recommend it, add a second link to the paragraph (the same way you added the first one in step 2) and double click on its influence arrow until it is the right color.

Adding a Link from Choice to Paragraph

Put your cursor on the paragraph with the embedded choice group.

1. Add a link to a target paragraph.
2. Click on the link you just established in the Links Window. Verify that the title bar says it is displaying the correct link. Detailed information on the source and target paragraphs for the selected link appears in the lower part of the window.
3. In the Source panel, click on the choice group containing the choice you want, then click on the choice value to become the source of the link. A black dot appears to the left of the arrow in the upper panel, indicating that a choice is the source of the link.
4. Double-click on the arrow to change the influence.
Overriding Master Links

- You cannot delete Master Links, but you can override them by changing the status manually. You should be cautious about doing so, however, since there usually is a good reason for the link. Prior to overriding a link you should examine the links to discover why the link was activated. If it was activated by an erroneous selection elsewhere, make necessary changes to other selections.

Links can always be overridden. To override a link, click in the status box. If you want override a red link to make the paragraph active, select the paragraph by clicking in the status box so that it has a checkmark ✅. If you want to override a green link to make the paragraph inactive, exclude that paragraph by clicking in the status box so that it has an ✗.

Deleting User-Added Links

You can delete a user-added link by selecting the user-added link you want to delete in the Links window and pressing the Delete key on your keyboard.

You are prompted to verify that you want to delete the link. (Before clicking OK, make sure the prompt states it will delete the link that you want to delete. You will not be able to Undo if it deletes the wrong thing.)

NOTE:

- You cannot delete Master Links - you can only override them.

Create Choices

About User-Added Choices

In user-added, user-modified master paragraphs and copied paragraphs, you can add embedded choice options similar to those in master paragraphs. As soon as you edit a master paragraph, a copy is made of the master choices, creating a user version. You can edit this user choice list to suit your needs. Building choice options is more time-consuming than simply adding the text that is needed and therefore is principally useful in an office master.

Links can be added to user-added choices.
Adding User Choices

To add choices to a user-added or user version of a master paragraph (except the section title):

1. Add a space or otherwise edit an existing master paragraph or add a new paragraph.
2. Position the cursor in the paragraph text at the location where the new choice options are to be inserted.
3. From the Insert tab, Choice Fields group, click on Insert. The Add Choice dialog box will open.
4. Click the pull-down arrow at the right end of the Choice Group Type field. The pull-down list shows the same types as those that appear in master paragraphs, plus special types for global terms ("architect," etc.) and units of measure. "Optional" types will automatically insert the choice "None - N/A" at the end of the option list. Choice types can be combined. For example, an entire choice group can be exclusive multiple choice, but individual choice options can be fill-in-the-blank or unit of measure.
5. Select the Choice Group Type for the overall group and click Insert.
6. The Choice Group Type selected appears in the Choice Group Type box and the cursor appears in the Current Option box. If you selected an optional choice type, the words "None - N/A" appear in the Choice Options list. If the choice is to include units of measure, check the UOM box. Three individual text boxes will appear, one for English, one for metric, and one for both. For unit of measurement choices, enter the English and metric and the combination field will fill in.
7. Enter the text of the first choice option in the Current Choice box(es) and then click on Add. The new choice text will appear in the box above.
   - To make a choice option with a fill-in-the-blank, enter a blank [____] by typing a single left bracket, several underscores, and a single right bracket, with no spaces. The blank may be combined with other words.
   - To make a choice a Section ID Format type, select Section ID Format as the choice type. This will allow you to change the spacing of the section numbers by making that change in the Summary Info dialog box. You can also include the MF95 Section ID and title by filling in the options in the MasterFormat Version Choice Type.
   - If creating a Reference Edition Date choice type, be sure to tag the paragraph as RS. See Applying Paragraph Tags.
• The global terms cannot be embedded in choice options -- instead insert them directly into the paragraph text as a choice group.

8. To add another choice option, fill in the Current Option again and click Add.
9. Continue in this manner until all the choice options have been entered. Use the Move Up and Move Down buttons to change the order of the options. If there is a fill-in-the-blank option, it is recommended that you leave it at the bottom of the list.
10. When the choice group is complete, press OK. Now, the new choice group with the first option as the default appears in the paragraph. If you click on the words inside the brackets the choice list pulls up just as it does on master paragraphs.

Tip: Check the spacing in the sentence after inserting your choice. There should be a space before and after the choice group, separating it from the preceding and following words. If your choice group is optional (it might not be selected at all), don't worry about the extra space in the sentence -- when the text is printed extra spaces between words and before periods, commas, and semi-colons are always removed.

Note: If you need to make any changes to a choice in a user-added or copied paragraph, edit the choice or delete the choice.

MasterFormat Version (MFV) Type Choice

This function allows you to create choices with both MasterFormat 2004 and MasterFormat 1995 section IDs and section titles. The Section ID Format choice will always include this functionality, and the MFV option can also be used with all four multiple choice types.

• When using the MFV feature, you can select from the list of section IDs for either MF04 or MF95 and the other will be automatically filled in.
• If you also want to include the section title select Append Title.
• Alternatively you can type your own Section IDs and titles in. You can include the Section title along with the Section ID by just typing one and then the other. Or you can make them separate choices.

To edit the MF95 Section ID and/or Section title for a user section, have the section checked in and right-click on the Section title in the Project Tree. The MF95 Parent field will be filled in automatically.

Note that you will still only see the MF04 Section ID and title in the Document Panel. The MF95 Section ID and Section title will be in the printed output when you select Output MF95 in the Print dialog box. If you never use the MF95 Output option, you can ignore the MF95 fields.
Editing Choices

To edit an existing set of choices in a user-added or user-edited master paragraph:

1. Click on the Insert tab.
2. Position the cursor on the colored text denoting an embedded choice group.
3. The choice list will open.
4. From the Insert tab, Choice Fields group, select Edit.
5. Click on the choice option to edit and make the changes in the Current Option box.
   Multiple changes can be made. (The choice type cannot be changed -- if that is necessary, remove the existing choice and build a new one.)
6. If a choice option must be removed, select it and click the Remove button. If links are attached to this choice they will also be removed.
7. If desired, use the Move Up and Move Down arrows to change the order of the choices. It is best to leave any fill-ins at the bottom of the list.
8. When the changes are complete press OK.

Removing User-Added Choices

To remove an entire choice group from a user-added or copied paragraph:

1. Position the cursor on the choice text (the colored text or the fill-in blank).
2. From the Insert tab, Choice Fields group, select Choice Fields and then Delete. (Alternatively you can simply click twice on the choice box, and then use the Delete key on your keyboard.)
3. You are prompted to verify that you wish to remove the choice group. When you click OK, the choice group is removed.
Update a Project

About Updating

A key feature of SpecLink-E is frequent updating of the master data. When we update the master data and our update has been transmitted to your site any new project you create uses the updated database as its foundation. When you open an existing project, the software automatically detects a new master database and compares the project to the updated master, unless you elect to Open it Read-Only. You can then choose whether or not to apply the updates to the project.

Here are some facts about updating:

- With SpecLink-E, changes you make in the project do not affect the master database.
- Each project file is an "overlay" containing all your changes and the current status of each section and each paragraph.
- This project file overlays the master database each time the project is opened.
- When the master database is updated, all the original master text is retained in the database, so it continues to be available for projects the user does not wish to update.
- Existing projects are not affected by updates unless the user specifically elects to incorporate them.
- Updates can be globally or selectively incorporated, and project-customized text is not lost even if the master updates are accepted.
- Updating to a new master never erases any project information, whether these are text modifications, choices, links, or notes.
- The system reports on paragraphs that are added, deleted, and modified in active sections; you can print this log report.

Online BSD Master Data Updating

Online Master Data Updating is to be enabled in early 2014.

Using the Update BSD Master tab in the SLE Support Utilities application, you can now update the data in your version of the BSD Master. This process has historically been accomplished during the quarterly update of the software and master, but will now be available via an Online Master Updating process. This is not to be confused with updating your project to the current master. You can determine how often you want your system to check the BSD server for any available updates to your BSD master. This can occur as often as every day, or as seldom as once a quarter. You must update your BSD master at least once per quarter. You can also check for any master updates right now by clicking on Update Master Now. Updating the data in your BSD Master may be done while users are working in the software.

The default schedule is to check for updates once a month. To change the schedule for checking for updates:

1. Start the SLE Support Utilities application by sitting at the server or standalone machine, and clicking on Start | All Programs | Building Systems Design Inc. and then right-clicking on SLE Support Utilities and choosing Run as Administrator.
2. Click on the Update BSD Master tab.
3. Set the Recurrence as either Weekly or Monthly.
4. If Weekly, set the day or days of the week to check for updates. You can set it to check multiple times per week or every other week, for example.
5. If Monthly, set the day of the month to check for updates. If you always want to have the check occur on a Saturday or Sunday, set it to Weekly, and set it for every 4, 6 or 8 weeks, for example.

6. Set the Start time to be the time when you want the server to check for updates.

7. When the schedule has been set, click on Apply and then Close.

8. The Next Scheduled Update should now reflect the next time updates will be downloaded, per your schedule.

9. Alternatively, you can click on Update Master Now to check for updates as soon as possible. If you choose Update Master Now, wait for at least 5 minutes and then look at the server trace log to check the progress.

Once the updates have been applied to your master, then the next time you open an existing project, it will check to see if any updates need to be reflected in your project. New projects will reflect the most up to date master data.

**Update Master Now**

Online Master Data Updating is to be enabled in early 2014.

Using the Update tab in the SLE Support Utilities application, you can now update the data in your version of the BSD Master. This process has historically been accomplished during the quarterly update of the software and master, but is now available via an Online Master Updating process. This is not to be confused with updating your project to the current master. You can check for any available master updates right now by clicking on Update Master Now.

Update Master Now starts a process (within five minutes) during which your system checks our server to see if there are any updates to the master database that have not already been downloaded to your system. If there are, those changes to the BSD Master will be downloaded and applied to your version of the BSD Master. You can check the progress by looking at your Server Trace Log. Once the updates have been applied to your BSD Master, then the next time you open an existing project, it will check to see if any updates need to be reflected in your project. New projects will reflect the most up to date master data.

**Updating Project to Current Master**

The Update Reminder dialog box opens automatically each time you open a project that includes sections with updates. The dialog box tells you how many paragraphs in your project will be changed by the update.

1. Select the desired update option
   - Update all Master paragraphs (Uncheck this option to check one of the other options)
   - Update Manufacturer References
   - Update Publication References
• Then click on Apply Selected Updates to accept the updates or
  • Click on Ignore Updates to simply see the marked changes.

2. To see a log of all changes see Update log.
3. If any active sections have been removed from the BSD master, they will be automatically copied as user sections.
4. Once you have opened the project, you can choose to update the entire project or section by section, using Update Selected Documents.
5. You can choose to update one paragraph at a time using Compare to Update.
6. You can also choose to Update Manufacturer References and/or Publication References using the options on the Tools tab/Update to Master group.
7. If you do not update the project, you will continue to see the magenta color in the Project Tree for sections that would change when and if you do accept the update. You will also see the rust color in the Document Panel for paragraphs that would change if you accept the update.

**Accepting the Updates**

When you choose to accept all master updates in your project the following happens:

- All master paragraphs with updates will be changed to reflect those updates. If you have edited this master paragraph, your version will remain and will print, if that is the version that is currently active. If you have not edited the master paragraph and it is active, the updated version is what will print.
- All new master paragraphs will be added to your project. If those paragraphs are activated by a link from another master paragraph, they may be active in your updated project. If you want to exclude a newly added master paragraph, accept the update first and then use an X in the Status Column to exclude the paragraph.
- All paragraphs that have been removed from the master will be removed from your project. If the deleted master paragraph is active in your project, it will be copied to a user paragraph and the sequence number box will have an olive green background.

If you are beginning a new project by copying an older project, you should probably accept all the updates in the copy and then review each section.

For more control in reviewing the updates before accepting them, do not accept the updates, and then review the changes that would be made.
Compare to Update

Use Compare to Update to see what the updated master paragraph text is for an individual paragraph. To use Compare to Update, after not accepting the update, either

- Right click on the paragraph with rust in the Document Panel, or
- Click on the paragraph and then choose the Tools tab, Update to Master Group, Compare to Update.

The Compare Paragraph To Update in Master dialog box appears.
If you want to apply the master updated paragraph, choose Update, Insert or Remove. Otherwise, choose Close.

The Compare Paragraph to Update in Master dialog box will remain open as you click from one paragraph to the next. This will make it faster to review all of the individual paragraphs in a section that has not been fully updated to the latest master. The dialog box will stay open until you close it, or until you close your project.

Note: If you cannot see all the text in either paragraph, drag the border of the dialog box to display more of the text.

Update Current Document

This allows you to accept the updates for the section you are in. While in the section, click on the Tools tab / Update to Master group and select Update Current Document. It will accept all updates for the current section only.
**Update Selected Documents**

This allows you to accept the updates section by section or for all sections in your project at once. This can be done at the opening Update Reminder dialog box (all sections at once) or from the Tools tab/Update to Master group. When there are changes pending, you will see the list of affected sections in the Update Selected Sections dialog box. You can use Select All or you can select individual sections to be updated. Checked out sections need to be checked back in before they can be updated in this way. You can update the section you have open by using Update Current Document.

Once you have selected the sections to be updated, click on Update.

**Update Manufacturer References**

This allows you to accept the updates for all Manufacturer Listings (tagged ML) section by section or for all sections of your project at once. This can be done at the opening Update Reminder dialog box (all sections at once) or from the Tools tab/Update to Master group. With this option, you can accept the Manufacturer changes quickly, and then review the other updates individually. When there are Manufacturer Reference changes pending, you will see the list of sections in the Update Manufacturer References dialog box. You can use Select All or you can select individual sections to be updated. Checked out sections need to be checked back in before they can be updated in this way.

Once you have selected the sections to be updated, click on Update.

**Update Publication References**

This allows you to accept the updates for all Publication References (tagged RS) section by section or for all sections of your project at once. This can be done at the opening Update Reminder dialog box (all sections at once) or from the Tools tab/Update to Master group. With this option, you can accept the Reference Standards changes quickly, and then review the other updates individually. When there are Publication References changes pending, you will see the list of sections in the Update Publication References dialog box. You can use Select All or you can select individual sections to be updated. Checked out sections need to be checked back in before they can be updated in this way.

Once you have selected the sections to be updated, click on Update.

**Do Not Apply Master Paragraph Updates to Project**

If you choose to Ignore Updates in the Update Reminder dialog box, your project is not affected, but any sections that would be affected by the update are highlighted by magenta titles in the Tree Panel. Within each affected section, the paragraphs that would be affected if you accept the
Updates are highlighted by a change in background color of the status columns in the Document Panel. You can open a dialog box at each affected paragraph to see the updated text and decide whether to keep the current text or replace it with the updated version. You can also decide at any time to accept updates for the entire section or for the entire project.

- Affected (added, changed or deleted) paragraphs are identified by a rust color in the status columns.

It is best to scan through the tree panel for active updated sections (they will be magenta and bold).

Look at the active sections first, and within those, scan for updated active paragraphs (with rust status columns). If the paragraph or section is not active, the updates will not affect the content of your project, and so you can skip those.

When you find active updated paragraphs, do the following:

1. With your cursor on a rust-marked paragraph, right click on the paragraph and choose Compare to Update.
2. Click on Insert, Update or Remove to accept the update.

If you do not want to update a paragraph, copy the paragraph. Then update and exclude the master paragraph. Attach a note explaining why you do not want to use the updated paragraph to remind yourself and to inform others who may use the project. This way when you do the next step below, you will still have the un-updated copy of the paragraph to use.

After you have updated all individual paragraphs that you want to update, then choose Update to Master to incorporate any remaining pending updates in this section. To update all remaining sections, click on the Tools tab/Update to Master group and select Update Selected Documents. This removes the rust and magenta from all paragraphs and sections so that the project is completely updated.

**Tips:**

- To speed up the process of accepting the updates, see Update Publication References and Update Manufacturer References.
- You can customize your Quick Access Toolbar to add the button for Compare to Update. When the button is available (not grayed out) your cursor is in a paragraph with an update available.
• To quickly identify sections that have magenta text, print the Update Log.
• Updates in sections that are not in the project (those with no edits, selections or exclusions) automatically take effect.
• The changes in some paragraphs may be within the embedded choices. You may not see the difference between paragraph and the updated modifications until you accept the update.

Apply Master Paragraph Updates to Project

If you choose to update everything, the revisions in the master are used instead of the old master data.

• If you have edited a paragraph that has been modified by the update, your edited text remains in the project, concealing the updated master text. You can subsequently toggle these paragraphs to see the new master text and decide which to keep.
• Added paragraphs are inserted in the proper location.

Tip:

• If you print the Update Log, you can identify updated paragraphs after applying all updates.

Update Log

SpecLink-E automatically creates a log file of all the changes in your project that are due to an update. This file gets created when the project is compared to the master after a new master is installed.

• For a standalone installation, this log file is saved automatically to the C:\ProgramData\BuildingSystemsDesign\SLE\logs\updates20130907 folder, where the last folder is the date when the project was compared to the new master.
• For a server installation, the log file is saved to C:\ProgramData\BuildingSystemsDesign\SLE\logs\updates20130907 folder on the server (assuming the server is installed on the C: drive) where the last folder is the date when the project was compared to the new master. The UNC path depends on if and how the server administrator shares the server log location.

The log file will have the same name and system generated project ID as the project.

This log lists all the updates that apply to sections in the project. Use this log to identify sections you want to review and specific paragraphs you wish to check.
Corporate Edition

The Corporate Edition includes the following features:

- Includes Microsoft SQL Server 2008 R2 Standard edition, rather than SQL Express, which can use unlimited memory and unlimited database sizes providing superior performance and response times.
- The ability to assign roles to each user. See Assign System Roles.
- The ability to define each role. See Define System Roles.
- The ability to protect your office master.
- The ability to display and print the last editor and the last edited date for paragraphs in the Document Panel using the Audit Trail function.
- A Section Listing with Last Edit Date.

Assign System Roles (Corporate Edition)

An appointed System Manager assigns a role to each user, whose name is the login name they use to access their computer. Each role represents a rank that has a certain level of rights and restrictions. Users are added to the list by starting SLE. In this dialog box, a System Manager can change a user's role or delete a user. To change a user to a new user name or computer, delete the user and have that user start SLE to be re-added to the list.

With the default settings which may be changed by using Define System Roles:

- The Reviewer Role can print documents but, with read-only access to the system, cannot edit documents. Note that accessing a section as a Reviewer does use one of your available licenses.
- The Standard User Role can check documents out and in, and has access to basic editing functionality.
- The Expert User Role has all the permissions of the Standard User and in addition has advanced editing access to allow accepting Master updates into a project, as well as creating links.
- The System Manager Role is all powerful and designates the role for each user.

To change the functions each role can perform, see Define System Roles

The Roles functionality is optional and is included in the Corporate Edition for those who want to implement it. When the Roles functionality is not implemented, every user is essentially a System Manager.
To enable System Roles:

- Click on the Tools tab and choose Assign System Roles from the System Manager group.
- Click on the check box to Enable System Roles.
- Use the drop down menu to select the role for each user.
- Once roles have been enabled, a new user will automatically be added as a Standard User, until changed by the System Manager.

To delete a user, click on the box to the left of the user's name and press the Delete key on your keyboard.

Note: To sort the users by any column, click on the name of the column. To reverse the order, click on the name of the column again.

Note: When restoring your Projects Database to a new location, you can click on Restore System Roles to restore the roles that you have already defined and assigned (to the status they had when the backup was created.)

Define System Roles (Corporate Edition)

A System Manager can change the functions that each role can perform.

To define system roles:

- Make sure that System Roles have been enabled.
- Make sure that you have the role of System Manager.
- Close any open project.
- From the Tools tab, System Manager group, select Define System Roles.
- A dialog box opens with the same tabs that are in the SLE ribbon menu, along with a Miscellaneous tab.
- As you click on each tab, you will see the groups on the left side of the dialog box.
- When you click on a group, the commands in the group are displayed in the right side of the box.
- To make a change, select the lowest role that should be able to perform each command.
- When all changes have been made, click on Save.
- You will see a confirmation box displaying the changes that are about to be made.
- Click on Yes to confirm.
- You will receive a confirmation that your changes have been saved.
- Users must exit and restart the software for those changes to be in effect.
Clicking on Restore Default, followed by Save returns all settings to those set by BSD.

As new functionality is added to the software, you may have to revisit the settings you have chosen.

**Restricting Access to your Office Master (Corporate Edition)**

Corporate Edition users may designate a project as an Office Master so that users who are not at the System Manager level cannot make edits to the project.

To protect a project from unwanted edits:
1. Enable System Roles.
2. Be a System Manager unless that function is changed in Define System Roles so that a lower role may designate a project as an Office Master.
3. Open the project you want to designate as an Office Master.
4. Open the Summary Info dialog box.
5. In the Project Access Level field, click on the drop down menu and change Standard Project to Office Master. The font in the Summary Info dialog box changes to red.
6. Click OK.
7. From this point forward, Expert Users (and lower) starting the software will not be able to open the project for editing, unless that function is changed in Define System Roles so that a lower role may edit an Office Master. Sections may be checked out for viewing only.
8. Users who can copy projects can copy the Office Master and work in the copy.
9. Users who can Import from Project can import sections from the Office Master and can work on the imported sections.
10. To change the project back to a Standard Project, open the Summary Info dialog box and select Standard Project in the Project Access Level field and click OK.
11. Users must close and restart SLE to see the changes in project status.

**Audit Trail (Corporate Edition)**

The Corporate Edition includes a feature called Audit Trail that allows you to display the name of the person who last edited a paragraph and the date of the last edit.

There are two commands for this feature:

**Show All Editors** - Click on Show All Editors in the Documents Tab to toggle the display of the editor information on and off. Older projects and those copied in from SL+ will not have any editor information until it is edited in SLE. The Document Panel is read-only while you are viewing the editor information.

**Select Editors** - Click on Select Editors in the Documents Tab to bring up a dialog box. In this dialog box you can:

- **Select which editors to display in the Document Panel.** When you click on Select Editors, a dialog box opens that displays the list of all users who have made edits in the section that you have open. To display the editor information for certain editors:
  1. Put a checkmark in the Display checkbox before each editor’s name that you wish to see.
  2. Click on Display edit info for checked editors in document panel on close
  3. Click on Close.

  This will display the edits in the Document Panel for only the editors you have checked. Note that using the Show All Editors toggle will display all editor information.
and is not restricted to the specific editors selected in this dialog box. The Document Panel is read-only while you are viewing editor information.
4. Click on Select Editors again to turn the display off.

- **Display all edits in the dialog box for the selected editors.** To see a list of all the edits that have been made in this section by selected editors:
  1. Put a checkmark in the Display checkbox before each editor's name that you wish to see.
  2. Click on List Edits.
     This will display in the dialog box the edits for only the editors you have checked.
  3. Click on the field names to sort the list by User, Last Edit date, Sequence or Paragraph Text.
  4. Click on Close when finished.

Once edits have been made, the editor information can be printed in reports by clicking on Show Editors in the Reports Options section of the Print dialog box.

**Section Listing with Last Edit Date (Corporate Edition)**

![Section Listing with Last Edit Date](image)

This listing is part of the Audit Trail functionality and is available in the Corporate edition. To see the section listing, click on the Documents tab and then on Section Listing with Last Edit Date in the Audit Trail group. The following fields are displayed:
- **Section** - Section ID
- **Author** - Acronym of the section
- **Title** - Title of the Section
- **Last Modified** - The date that any changes were made to this section, either by BSD or by the user.
- **Last Edited** - The date that a change was made by the user in SLE, starting with the fall 2010 version when changes began to be tracked. Note that paragraph selections and choice changes do not constitute edits.
- **Last Editor** - The user who made the last change to the section, excluding choice changes, selections or deselections.

Click on the column label to sort by any of the above columns.

**Display Selected Sections Only** - Check this to see the listing only for active sections.
**Display Edited Sections Only** - Check this to see the listing for the sections that include edits that have been made and tracked in SLE starting in fall 2010.
**Section Count** - This displays the sections in the listing, based on the checkboxes above.
**Print** - Click on this to print the listing to the printer.

**Export to Excel** - Click on this to export this information to an Excel spreadsheet.
Accessing and Using Help

Help is right at your fingertips. There are two ways to access Help:

**F1:** At any time press F1 to open Help. In certain dialog boxes, the Help Topic will be specific to the dialog box you are in. Otherwise, use one of the three tabs to find the appropriate topic.

**Help Icon:** Click the Help icon at the top right of the application window.

Help has three tabs:

- **Contents:** Displays the Help contents. From the Contents list, choose the topic closest to what you need. Click on a topic to read it.
- **Index:** Displays a list of all Help topics in alphabetical order.
- **Search:** Type any word or phrase and then click on List Topics. All topics containing the word or phrase will be listed in the window below.

If you can't find what you need in the Help file, call Tech Support at 800-266-7732.

**Toolips**

You can let your mouse hover over menus and some icons in the Document Panel for more information about that menu choice or icon. Each menu item should have a tooltip and the labels for the columns on the left side of the Document Panel have tooltips. If the Sequence column square has a colored background, there is a tooltip to explain what the background color means.
SLE System Monitor

On the right side of the Home tab, there is a function called Show System Monitor.

The following information is available in the System Monitor:

- SpecLink-E Version - This lists the version of SLE that is on your computer
- Renewal Date - This is the date when your SLE subscription will expire
- SQL Server Service - This will show as green when the server part of the application is running and available.
- Available Disk Space - This displays the available disk space on the machine where the server part of the application is installed.
- Available memory - This displays the available memory on the machine where the server part of the application is installed.
- Number of projects - This displays the number of projects in your Projects Database.
- Active Users - This displays the number of users who have sections checked out.
- Critical Warnings - This is under development. It will let you know when you have had errors that might affect your specification, specifically timeouts due to Rebuild Project Links or the marking of updates in a project.

Note: If you are using the Corporate Edition, you can limit access to the System Monitor using Define System Roles.

View Log Files

SpecLink-E generates a number of log files. To find the logs for the current day, click on the File menu and choose About SpecLink-E. On the top left of the dialog box is a link that says View Log Files. Click on the link to see log files. All log files will be in this folder unless specified as being elsewhere.
• **Trace Log** for the Client and the Client part of a Standalone application: During the normal use of the software, certain functions will be logged into a trace log. The Trace Log will begin with the date followed by SLEClient_Trace.log, such as 20130620_SLEClient_Trace.log.

• **Error Log** for the Client and the Client part of a Standalone application: In the same location you will find logs that list some of the errors that have occurred in the software. Example: 20130620_SLEClient_Error.log. Not all errors can be entered into the log.

• **Trace and Error Logs for the Server application**: When you are running the application as a Client with the database on the server, there will be Trace and Error logs maintained on the server. The logs on the server will be in the C:\ProgramData\BuildingSystemsDesign\SLE\logs folder (assuming the server is installed on the C: drive). The UNC path depends on if and how the server administrator shares the server log location. When you are running standalone, you will also have logs for the Server part of your Standalone installation. Example: 20130620_SLEServer_Trace.log and 20120620_SLEServer_Error.log.

• **Update Log**: When a project has been marked after the master database has been updated, a log will be created listing the paragraphs that would be changed if you accepted the update. These logs are stored in folders named by date. For example, if you open a project (and it gets marked for changes) on June 25, 2013, the update log for that project will be in a folder named updates20130625, under the logs folder. These logs are created on the server or on the standalone computer.

• **Verify Sequence Log** lists the section number, section title and paragraph sequence number of any paragraphs that have been promoted as a result of running Verify Document Sequencing. This log is saved at both the server and the client log locations.

• **User Tag Usage** - A log is generated if you try to delete a User Defined Tag that is in use in any checked out sections. This will list the Project ID, Project Title and Section ID for each checked out section using the User Defined Tag that you are trying to delete. This log is saved at the Client or Standalone log location.

• **Verify Spec Type Tags** - A log is generated if you run Verify Spec Type Tags and there are some issues that need to be addressed. This log is saved at the Client or Standalone log location and will be named according to the date: VerifySpecTypeTags20130827.

• **Installation log** - A log will be generated during the Server or Standalone installation identifying the status of installed components.

• **SLE Support Utilities logs** - are available via the Windows Event Viewer.

### Event Viewer

The Windows Event Viewer allows you to see information about significant events in Windows. Our scheduled backups are included in the events logged in by the Event Viewer.

To view the logs in the Event Viewer:

- Open Control Panel.
- Select Administrative Tools.
- Select Event Viewer.
- Expand Windows Logs.
- Select Application.
- Click on events with MSSQL$BSDSOFTLINK$DATA or BSD Data Server in the Source column.
- You can click on each record and read the log for each specific event.
Verify Document Sequencing

This command is available on the Tools tab/Projects group. On occasion a section can become corrupt (e.g. power failures). This process will attempt to fix the corruption in all sections of the currently open project or in one individual section.

- To run Verify Document Sequencing for just one section:
  - Check out the section and have it open and highlighted in the Document Panel.
  - Do not have two or more windows open for this section.
  - Click on the Tools tab and Verify Document Sequencing.
  - Choose Verify Sequence on Current Document and then click on Run.
  - Click Yes to the confirmation.
  - The section will be closed, Verify Document Sequencing will run, and the section will reopen.

When it is finished, you will receive a confirmation. If any changes were made, check the log starting with Verify Sequence in the same location as other logs so that you can view the changes that have been made.

- To run Verify Document Sequencing for the entire project:
  - Make sure that all sections have been checked in.
  - Click on the Tools tab and Verify Document Sequencing.
  - Choose Verify Sequence on Project and then click on Run.
  - Click Yes to the confirmation.

When it is finished, you will receive a confirmation. If any changes were made, check the log starting with Verify Sequence in the same location as other logs so that you can view the changes that have been made.

This process will also optimize the tables in the project. It is best to check in all sections before running this command for the entire project. Checked out sections will not be included in the process. If you run this process unnecessarily, it will not harm your project.

Verify Document Sequencing will also fix any "bad hierarchies" which sometimes result from pasting information in from a word processing document. If there is a level 4 paragraph directly under a level 2 paragraph, for example, that is considered a bad hierarchy. If any paragraphs have been promoted as a result of running Verify Document Sequencing, any promoted or demoted paragraphs will be listed in the log.

Verify Spec Type Tags

Verify Spec Type Tags is on the Tools tab to check your project for Spec Type Tags that are not valid. All Outline (OL/UO) tagged paragraphs must have OL tagged parents. All Short Form (SF/US) tagged paragraphs must have OL or SF tagged parents. This hierarchy is not enforced in SpecLink+ and has not always been enforced in SLE, so it is possible to have paragraphs tagged incorrectly, which can cause a problem when switching to those views. This function will generate a list of all paragraphs whose parent is not tagged appropriately. You can paste the list into a Word document for printing, if desired. A text file is created with the list, which can be found where your log files are. You will need to tag the parents appropriately. If you never use Outline or Short Form view, then you do not need to worry about this issue.
Disk Space

If you are running low on disk space, you may have some old SpecLink-E files that you can safely remove. You also may be able to change the drive where the SpecLink-E backups are saved to. Here are some suggestions:

- Remove the "old" version backups: Early versions of SpecLink-E saved backups to a different folder than the newer versions. Check the path "C:\Program Files\Building Systems Design\Data\Backup". If there are any backup files there, they would have a date stamp that is several years old. You should be able to safely delete them.
- Monitor Auto-Backups: SpecLink-E generates automatic backups. You can check the drive and path where the backups are saved to by using the SLE Support Utilities. As newer backups are created, the older ones get deleted. If you continue to see backups older than 1 week in the folder, you can 1) delete them; and 2) contact Tech Support to discuss managing backups on your system.
- Delete Other Backups: Whenever you install a quarterly update for SpecLink-E, a backup is created in this folder: C:\ProgramData\BuildingSystemsDesign\SLE\backup; for Windows XP or Server 2003, the folder may be "C:\Documents and Settings\All Users\Application Data\BuildingSystemsDesign\SLE\backup". These backups will add up over time. Once an update for SpecLink-E is running and the auto-backups are still working, you can delete these quarterly backups.
- Manage "Manual" Backups: The SLE Support Utilities has a button for "Backup Now". If you create a backup using this button, you will need to delete it once you no longer need it.
- Change the Drive for Auto-Backups: You can also change the location of these backups. In SLE Support Utilities, click the three dots … in the utility next to the path of the backups. From the pull-down list you can select another local drive or partition that has more room. This will cause the Auto-Backups to be saved to that other drive. You will still need to monitor the original location, on occasion, for removal of older backups that are generated manually or via a quarterly update.
- Remove old log files: SpecLink-E does not remove old log files. After several years these files combined can become fairly large. They exist on the server if you have a network install as well as on a client’s computer. You may remove very old logs from the following folder: C:\ProgramData\BuildingSystemsDesign\SLE\logs.
- Send some of your SLE projects to the Archive Database where they may take less space than they do in the Projects Database.
- After removing projects by deleting them or archiving them, run Shrink Now from the SLE Support Utilities.

Speed Issues

The speed of various functions in the software depends on your system configuration, what other SLE users are doing and the size of your Projects Database.

Some ways to improve your speed are:

- Perform Copy from SpecLink+ when other users are not using SLE.
- Perform Import from Project (if importing many sections) when other users are not using SLE.
- Archive and remove finished projects to reduce the size of the Projects Database.
- Perform Server Maintenance periodically if running standalone, and your computer is not generally on overnight.
• If Rebuild Project Links takes as long as 10 minutes, the process may have timed out, even if you receive a message that the process is complete. A possible solution is to restart Windows if you have a standalone version of SLE, or have your IT Manager restart the SQL Server (BSDSOFTLINK$DATA) on the server where the SLE server installation resides. If that does not resolve the issue contact BSD Technical Support.

**Not Responding**

There may be times when the SpecLink-E application window says that it is Not Responding. This may occur when the client application is waiting for a response from the server application (even if the server is installed as part of a standalone installation). If the server application is performing a lengthy operation, it may not be able to make a response to the client for some time. Certain processes, such as Copy from SpecLink+, comparing a project to the master, and printing an entire project can take a long time, depending on what other demands are being made on the server and on your system specifications.

**Technical Support**

For assistance in installing or using SpecLink-E, contact technical support at:

• Call toll free: 1-800-266-7732 or 404-365-9226
• FAX: 1-404-365-8912
• Email: support@bsdsoftlink.com

**Tips:**

• Support is located in Atlanta (Eastern Time [ET]), and office hours are 8:30 a.m. to 5:30 p.m., on normal business days. If you call at other times, it is unlikely you will be able to obtain an access key.
• You can also download the latest copy of the software and the user manual from our Download Center.
Index

2
2010 Microsoft Office ribbon bar menu .................. 14
A
A4 Paper size ............................................. 103
About Box .................................................. 15
About updating ........................................... 157
Accepting the Updates .................................. 159
Access ID ................................................. 30
Access key ............................................... 30
Active ..................................................... 66
Active paragraphs ........................................ 66
Active text ............................................... 65
Add links .................................................. 150
Add links from choice to choice ....................... 152
Add links from paragraph to choice ................. 152
Add links from paragraph to paragraph .............. 150
Add links from section to section ................... 151
Add new paragraph ...................................... 67
Add new section ........................................... 56
Add new section from doc ............................... 58
Add new section from RTF file ......................... 57, 58
Add new section from template ....................... 56
Copy an existing section ................................ 61
Import a section from another project ............... 61
Add reference citations ................................ 139
Add section to project .................................... 52
Add tags ................................................... 140
Add user choices ......................................... 154
Adding a project note .................................... 19
All levels .................................................... 25, 64
All text draft report ................................... 108
Alternate header or footer .............................. 94
Applying master paragraph updates to project ...... 163
Applying paragraph tags ................................ 140
Architect ..................................................... 46
Archive Database ......................................... 131
Archiving a project ...................................... 125
Ask before Check Out .................................. 51
Assign system roles ..................................... 164
Audit Trail ................................................... 166
Audit Trail Section Listing .............................. 167
Auto Check-ins .......................................... 133
Autohide ..................................................... 16
Automatic table of contents format ................. 111
Automatic table of contents format .................. 111
AutoNumbers .............................................. 86
Autosave ................................................... 84
Auto-select new paragraphs ............................ 59
B
Back button ................................................ 22
Backing up your project .................. 127
Backup databases ....................................... 128
Basic steps .............................................. 35
Benefits of automation ................................. 12
Blanks ...................................................... 72, 73
Block format .............................................. 89
Block format layout ..................................... 85
Block style paragraph format ......................... 87
Blue text .................................................... 72
Bookmark .................................................... 64
Borders (table) .......................................... 80
Brackets ..................................................... 72
Build the structure first ............................... 36
C
Cascading windows ....................................... 54
Catalog listing of sections ............................. 10
Catalogs ..................................................... 8
Change hierarchy level ................................ 70
Changing OL and SF tags .............................. 121
Changing the style of a single paragraph .......... 93
Check in ................................................... 51, 84
Check out .................................................. 51, 84
Checklist document .................................... 145
Checklist of sections ................................... 10
Choices ..................................................... 72, 73
Adding ..................................................... 154
User-added .............................................. 153, 156
User-added, editing ..................................... 156
Clicking on a section in the project tree .......... 52
Clipboard, using ......................................... 71
Close and Lock .......................................... 84
Closing a project ........................................ 41
Closing a section ........................................ 85
Closing the software .................................... 85
Collapse .................................................... 25, 64
Colored text .............................................. 72
Colors in tree .............................................. 23
Columns (as in tables) .................................. 78
Compare to Update ...................................... 160
Comparing two projects ............................... 123
Generating the comparison file ...................... 124
Content, organization of ................................. 5
Contractor ................................................. 46
Copies ..................................................... 104
Copy ......................................................... 77
Copy from SpecLink+ ................................… 42
Copy Note .................................................... 21
Copy paragraph .......................................... 69
Copy project ............................................... 125
Copy project template .................................. 90
Copy section .............................................. 60, 61
Copy sections between projects ...................... 61
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corporate Edition</td>
<td>164</td>
</tr>
<tr>
<td>Cover Sheet Report</td>
<td>116</td>
</tr>
<tr>
<td>Create a new project template</td>
<td>90</td>
</tr>
<tr>
<td>Create hyperlinks</td>
<td>82</td>
</tr>
<tr>
<td>Create PDF files</td>
<td>119</td>
</tr>
<tr>
<td>CSI format</td>
<td>6, 85</td>
</tr>
<tr>
<td>CSI style paragraph numbering</td>
<td>86</td>
</tr>
<tr>
<td>Cursor movement in sections</td>
<td>64</td>
</tr>
<tr>
<td>Customizing styles</td>
<td>89</td>
</tr>
<tr>
<td>Cut</td>
<td>78</td>
</tr>
<tr>
<td>D</td>
<td></td>
</tr>
<tr>
<td>Database</td>
<td>5</td>
</tr>
<tr>
<td>Database integrity</td>
<td>11</td>
</tr>
<tr>
<td>Database maintenance</td>
<td>132</td>
</tr>
<tr>
<td>Default printer</td>
<td>108</td>
</tr>
<tr>
<td>Define system roles</td>
<td>165</td>
</tr>
<tr>
<td>Delete</td>
<td>78</td>
</tr>
<tr>
<td>Delete Note</td>
<td>21</td>
</tr>
<tr>
<td>Deleting a choice</td>
<td>156</td>
</tr>
<tr>
<td>Deleting a hyperlink</td>
<td>82</td>
</tr>
<tr>
<td>Deleting a paragraph</td>
<td>68</td>
</tr>
<tr>
<td>Deleting a project</td>
<td>134</td>
</tr>
<tr>
<td>Deleting a section</td>
<td>52, 63</td>
</tr>
<tr>
<td>Deleting user-added links</td>
<td>153</td>
</tr>
<tr>
<td>Demote</td>
<td>70</td>
</tr>
<tr>
<td>Deselection of a paragraph</td>
<td>67</td>
</tr>
<tr>
<td>Deselecting a section</td>
<td>52</td>
</tr>
<tr>
<td>Deselecting paragraphs</td>
<td>65</td>
</tr>
<tr>
<td>Design Criteria</td>
<td>10</td>
</tr>
<tr>
<td>Design professional</td>
<td>46</td>
</tr>
<tr>
<td>Design-Builder</td>
<td>46</td>
</tr>
<tr>
<td>Differences between SpecLink-E and SpecLink+</td>
<td>3</td>
</tr>
<tr>
<td>Dimensions</td>
<td>49</td>
</tr>
<tr>
<td>Disk Space</td>
<td>173</td>
</tr>
<tr>
<td>Displaying multiple windows</td>
<td>54</td>
</tr>
<tr>
<td>Displaying two sections side-by-side</td>
<td>54</td>
</tr>
<tr>
<td>Do not apply master updates to project</td>
<td>161</td>
</tr>
<tr>
<td>Document panel</td>
<td>17</td>
</tr>
<tr>
<td>Navigating</td>
<td>25, 64</td>
</tr>
<tr>
<td>Double sided printing</td>
<td>103</td>
</tr>
<tr>
<td>Downloading the software</td>
<td>29</td>
</tr>
<tr>
<td>Draft copy</td>
<td>35, 108</td>
</tr>
<tr>
<td>E</td>
<td></td>
</tr>
<tr>
<td>Edit Section Title</td>
<td>69</td>
</tr>
<tr>
<td>Edit templates</td>
<td>91</td>
</tr>
<tr>
<td>Editing</td>
<td>1</td>
</tr>
<tr>
<td>Editing a paragraph</td>
<td>68</td>
</tr>
<tr>
<td>Editing user-added choices</td>
<td>156</td>
</tr>
<tr>
<td>Effective dates</td>
<td>30</td>
</tr>
<tr>
<td>Electronic Invoice ID</td>
<td>33</td>
</tr>
<tr>
<td>Electronic user manual</td>
<td>14</td>
</tr>
<tr>
<td>Eliminating paragraph numbers</td>
<td>93</td>
</tr>
<tr>
<td>Engineer</td>
<td>46</td>
</tr>
<tr>
<td>Enhance Competitive Bidding</td>
<td>45</td>
</tr>
<tr>
<td>Error log</td>
<td>170</td>
</tr>
<tr>
<td>Evaluation sections</td>
<td>29</td>
</tr>
<tr>
<td>Event Viewer</td>
<td>171</td>
</tr>
<tr>
<td>Excluded</td>
<td>65</td>
</tr>
<tr>
<td>Excluding a paragraph</td>
<td>67</td>
</tr>
<tr>
<td>Excluding a section</td>
<td>52</td>
</tr>
<tr>
<td>Excluding paragraphs</td>
<td>65</td>
</tr>
<tr>
<td>Exclusive multiple choices</td>
<td>72</td>
</tr>
<tr>
<td>Exiting the software</td>
<td>85</td>
</tr>
<tr>
<td>Expand</td>
<td>25, 64</td>
</tr>
<tr>
<td>Expand on Refresh</td>
<td>5</td>
</tr>
<tr>
<td>Expand to Show Project Tree</td>
<td>5</td>
</tr>
<tr>
<td>Export to RTF</td>
<td>118</td>
</tr>
<tr>
<td>Exporting your documents</td>
<td>116</td>
</tr>
<tr>
<td>F</td>
<td></td>
</tr>
<tr>
<td>File menu</td>
<td>14</td>
</tr>
<tr>
<td>File Name Formats</td>
<td>117</td>
</tr>
<tr>
<td>Fill-in-the-blanks</td>
<td>72, 73</td>
</tr>
<tr>
<td>Find</td>
<td>76</td>
</tr>
<tr>
<td>Find/replace in project</td>
<td>76</td>
</tr>
<tr>
<td>Finding a section</td>
<td>10</td>
</tr>
<tr>
<td>First</td>
<td>64</td>
</tr>
<tr>
<td>First page header or footer</td>
<td>94</td>
</tr>
<tr>
<td>First page section number and title format</td>
<td>89</td>
</tr>
<tr>
<td>Folders</td>
<td>5</td>
</tr>
<tr>
<td>Fonts</td>
<td>91</td>
</tr>
<tr>
<td>Change font for header and footer</td>
<td>94</td>
</tr>
<tr>
<td>Change font for specification</td>
<td>91</td>
</tr>
<tr>
<td>Footer</td>
<td>94</td>
</tr>
<tr>
<td>Force upper case</td>
<td>91</td>
</tr>
<tr>
<td>Formatting</td>
<td>89</td>
</tr>
<tr>
<td>Graphics</td>
<td>83</td>
</tr>
<tr>
<td>Government, as an owner</td>
<td>46</td>
</tr>
<tr>
<td>Graphics</td>
<td>83</td>
</tr>
<tr>
<td>Green in tree</td>
<td>23</td>
</tr>
<tr>
<td>Green text</td>
<td>72</td>
</tr>
<tr>
<td>G</td>
<td></td>
</tr>
<tr>
<td>Generating the project comparison</td>
<td>124</td>
</tr>
<tr>
<td>Global options</td>
<td>46</td>
</tr>
<tr>
<td>Go to first or last</td>
<td>64</td>
</tr>
<tr>
<td>Government, as an owner</td>
<td>46</td>
</tr>
<tr>
<td>Graphics</td>
<td>83</td>
</tr>
<tr>
<td>Green in tree</td>
<td>23</td>
</tr>
<tr>
<td>Green text</td>
<td>72</td>
</tr>
<tr>
<td>H</td>
<td></td>
</tr>
<tr>
<td>Handling updates</td>
<td>140</td>
</tr>
<tr>
<td>Hanging indent</td>
<td>91</td>
</tr>
<tr>
<td>Hardware and software requirements</td>
<td>28</td>
</tr>
<tr>
<td>Header</td>
<td>94</td>
</tr>
<tr>
<td>Header Row (table)</td>
<td>79</td>
</tr>
<tr>
<td>Header/footer keywords</td>
<td>100</td>
</tr>
<tr>
<td>Header/footer layout</td>
<td>99</td>
</tr>
<tr>
<td>Header/Footer Table Properties Dialog Box</td>
<td>98</td>
</tr>
<tr>
<td>Header/footer</td>
<td>95, 99, 102</td>
</tr>
<tr>
<td>Alternating sides</td>
<td>99</td>
</tr>
<tr>
<td>Distance from edge of paper</td>
<td>102</td>
</tr>
<tr>
<td>Formatting</td>
<td>94</td>
</tr>
<tr>
<td>Tables</td>
<td>95</td>
</tr>
</tbody>
</table>
# Index

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Renaming</td>
</tr>
<tr>
<td>Promote</td>
</tr>
<tr>
<td>Proprietary specs</td>
</tr>
<tr>
<td>Q</td>
</tr>
<tr>
<td>R</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>S</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>T</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

| S | Show updates .................................................. 158 |
|   | Showing all text .................................................... 25, 64 |
|   | Shrink Database ..................................................... 130 |
|   | Shrink Now ............................................................ 130 |
|   | SI units ................................................................. 49 |
|   | Single Click to Open ............................................ 51 |
|   | Size limitation of projects database ......................... 39 |
|   | Skip to next at current level .................................... 64 |
|   | SLE Support Utilities ............................................. 127 |
|   | SLE System Monitor ................................................ 170 |
|   | Specific terms ....................................................... 46 |
|   | Speed Issues ......................................................... 173 |
|   | Spell check ............................................................. 74 |
|   | Start document on odd page .................................... 103 |
|   | Start Page .............................................................. 22 |
|   | Starting a new project ............................................ 39 |
|   | State in which project is located .............................. 46 |
|   | Status ...................................................................... 65, 66 |
|   | Changing ................................................................... 65 |
|   | Styles ...................................................................... 89, 91 |
|   | Changing a single paragraph .................................... 93 |
|   | Customizing ............................................................. 89 |
|   | Sequential numbering .............................................. 88 |
|   | Submittals Log export ............................................. 115 |
|   | Subscription ............................................................ 8 |
|   | Summary Info dialog box ........................................... 44 |
|   | Synonyms .................................................................. 12 |
|   | System Monitor ....................................................... 170 |
|   | System Project ID .................................................... 45 |
|   | System requirements ................................................ 28 |
|   | System roles ........................................................... 164, 165 |
|   | SLE Support Utilities ............................................. 127 |
|   | Specific terms ....................................................... 46 |
|   | Spell check ............................................................. 74 |
|   | Start document on odd page .................................... 103 |
|   | Start Page .............................................................. 22 |
|   | Starting a new project ............................................ 39 |
|   | State in which project is located .............................. 46 |
|   | Status ...................................................................... 65, 66 |
|   | Changing ................................................................... 65 |
|   | Styles ...................................................................... 89, 91 |
|   | Changing a single paragraph .................................... 93 |
|   | Customizing ............................................................. 89 |
|   | Sequential numbering .............................................. 88 |
|   | Submittals Log export ............................................. 115 |
|   | Subscription ............................................................ 8 |
|   | Summary Info dialog box ........................................... 44 |
|   | Synonyms .................................................................. 12 |
|   | System Monitor ....................................................... 170 |
|   | System Project ID .................................................... 45 |
|   | System requirements ................................................ 28 |
|   | System roles ........................................................... 164, 165 |

| U | Unassigned sections folder ....................................... 6 |
|   | Undo ........................................................................ 75 |
|   | Undocking and autohiding ....................................... 16 |
|   | Uninstalling the software ......................................... 33 |
|   | Units of Measure ..................................................... 49 |
|   | Changing ................................................................... 44 |
|   | Update BSD Master .................................................. 157 |
|   | Update Current Document ......................................... 160 |
|   | Update log .............................................................. 163 |
|   | Update Manufacturer References Only .......................... 161 |
|   | Update Master Now ................................................... 158 |
|   | Update Publication References Only ............................ 161 |
|   | Update Selected Documents ....................................... 161 |
|   | Updates ..................................................................... 140, 157 |
|   | Updating a project .................................................... 158 |
|   | Updating options ..................................................... 13, 161 |
|   | Updating the BSD Master .......................................... 158 |
|   | Updating ............................................................... 158, 161 |
|   | Accept updates ....................................................... 163 |
|   | Mark updates for review ............................................ 161 |
|   | Upper case, printing .................................................. 91 |
|   | Use Project Template for one section only ................... 89 |
|   | User count ................................................................ 30 |
|   | User defined global terms ......................................... 49 |
|   | User defined tag reports .......................................... 142 |
|   | User defined tags .................................................... 141 |
|   | User-added paragraph ................................................ 67 |
|   | User-added section ................................................... 56 |
|   | User-modified paragraph .......................................... 68 |
|   | Using a Separate Projects Database ............................. 40 |
|   | Using SpecLink-E effectively ..................................... 35 |
|   | Using text levels to aid navigation .............................. 25, 64 |
|   | Using the bookmark to aid navigation ......................... 64 |

| V | Verify Document Sequencing ..................................... 172 |
|   | Verify Spec Type Tags ............................................... 172 |
|   | View Editor Names and Dates ...................................... 166 |
|   | View Log Files .......................................................... 170 |
|   | Viewing all text ....................................................... 25, 64 |
|   | Viewing links ........................................................... 148 |
|   | Viewing text levels .................................................... 25, 64 |
|   | Views ....................................................................... 25 |
|   | Visible links ............................................................. 12 |

<p>| W | Welcome .................................................................. 1 |
|   | Wide Area Network ................................................... 29 |
|   | Widow/Orphan protection .......................................... 102 |
|   | Word processing features .......................................... 12 |
|   | Word processing files ............................................... 71, 118, 139 |
|   | Word processing ....................................................... 35 |
|   | Transitioning from ...................................................... 35 |</p>
<table>
<thead>
<tr>
<th>Index</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workflow</td>
<td>36</td>
</tr>
<tr>
<td>Workflow tactics</td>
<td>36</td>
</tr>
<tr>
<td>Working from home or on the road</td>
<td>32</td>
</tr>
<tr>
<td>Z</td>
<td></td>
</tr>
<tr>
<td>Zeros in Table of Contents</td>
<td>112</td>
</tr>
<tr>
<td>Zoom view</td>
<td>27</td>
</tr>
</tbody>
</table>