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Preface 

About This Manual 
This manual is an introduction to CostLink/AE and an aid to learning its use. Each chapter 
provides detailed information about the functions of the software. Step-by-step instructions 
guide you through using the features, and a tutorial walks you through creating a small 
estimate. 

NOTE: For installation instructions, directions for moving the software, and system 
requirements information, see the Installation document available on the Install BSD 
Products screen of the latest version of the BSD SoftLink CD-ROM. 

Chapter Summary 
While the Table of Contents and the Index contain detailed information to aid you in finding 
information in this manual, in general the following is what you will find in each chapter: 

Chapter 1: Introduction 

Contains an overview of CostLink/AE and the R.S. Means data. 

Chapter 2: Tutorial 

Follow the instructions in this chapter to learn CostLink/AE by creating a small estimate. 

Chapter 3: About the CostLink/AE Display 

If you are not familiar with arranging multiple windows on your computer, read this 
chapter for information on tiling windows. This is an essential skill when working with 
CostLink/AE. The chapter also contains information on arranging panels, a list of the 
icons in the software and their meanings, how to customize the toolbars, and how to 
use the online help. 

Chapter 4: Projects, Models, Tasks, & Markups 

Provides detailed information on how to create and open estimates, use models, add 
tasks (assemblies and line items), and apply markups. 
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Chapter 5: Reports 

Describes the process of creating reports and the options available when printing 
reports. 

Chapter 6: Tools and Techniques 

Provides detailed information on using most of the features of the software that were not 
covered in the previous chapters. These include ways to: 

find information (Find) 
attach additional information to an estimate (Notes and Pictures) 
copy and move folders and tasks (tips on right-click, copy and paste, etc.) 
remove extra (empty) folders easily 
reuse existing estimates (Copy Project) 
fix technical problems with projects (Compact Database) 
save backup copies of projects or save a copy you can fit in an email (Save To and 
Load From Compressed) 
add commands to the Tools menu so that you can open other programs from 
within CostLink/AE 

Chapter 7: Linking 

Contains information and directions for linking the quantities of tasks to the quantities of 
folders so that you can change the quantity on a folder and automatically recalculate 
how much of each task is needed for the new quantity. You can also link an estimate to 
an Excel workbook.  

Appendix A: Toolbar and Menu Reference 

Lists all toolbar buttons and menu commands along with a short description of each. 

Appendix B: R.S. Means Abbreviations 

Lists abbreviations used in the R.S. Means databases. 

Suggestions and Corrections 
If you have suggestions or corrections for this User Manual, please email them to 
support@bsdsoftlink.com. Please be sure to include the name of the manual and the page 
number. We appreciate your feedback. 
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Introduction To BSD CostLink/AE 

This chapter introduces BSD CostLink/AE and the included RS Means data. In this chapter, 
you will find: 

• An overview of BSD CostLink/AE, 

• An overview of the RS Means costs, and 

• An overview of estimating using assemblies. 
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BSD CostLink/AE Overview 
Welcome to a cost-estimating package specifically designed for architects, engineers, and 
others who are doing budgets, cost plans, and design development estimates. 
CostLink/AE® is also useful to subcontractors preparing proposals and quotes who want to 
be able to reference a significant library of RS Means data. 

BSD CostLink/AE is a subscription service that includes annually updated cost data from 
industry leader RS Means. CostLink/AE combines unlimited telephone support and regular 
software updates with over 11,000 systems and assemblies, 22,000 line items, 75 
parametric cost models, and cost indices for 700 U.S. and Canadian locations in a single 
subscription. 

The RS Means data is derived from material, labor, and equipment components. The data 
is formatted as a single unit cost that includes the pre-computed RS Means subcontractor 
overhead and profit. This data is described in more detail later in this chapter. 

Building an Estimate 
The simplest way to create an estimate is to start with one of the 75 parametric models 
provided with the software. Alternatively, you can construct an estimate by using drag-drop 
or copy-paste of entire building systems, assemblies, and line items into a project hierarchy, 
either pre-defined or constructed on the fly. AE makes it easy to place project and data 
windows side-by-side, assigning cost items to appropriate project folders. 

Estimate Structure, Adjustments, and Markups 
Templates for Uniformat II, MasterFormat, and a User-Defined hierarchy are provided along 
with a useful sample project. A single tab on the Summary Info dialog box allows you to 
choose a location (by selecting your state and city) that automatically adjusts your estimate. 
You can also add sales tax and modify the default prime contractor markups. The same tab 
lets you assign percentage markups for other costs such as contingency, escalation, and 
A/E design. 

Modeling 
The 75 commercial building cost models provided with the software provide a convenient 
way to build an estimate early in a project, before any of the major systems have been 
selected. This model estimate can then be refined as the project design is developed, by 
adjusting quantities and by substituting assemblies and line items for those assumed by the 
model. A single tab on the Summary Info dialog box allows you to select a model from the 
three available categories: Commercial, Institutional, and Industrial. You then enter the 
gross building area and the length of the building perimeter, select one of six exterior 
closure and framing systems provided for each model, and review or modify the main 
model building parameters that serve as the basis for all model cost computations. 
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Linking 
Within an estimate, you can link the quantities of assemblies and line items to the quantities 
of the folders that contain them. You can even link the quantities of the folders to the 
quantities of the folders above them. For example, if you are estimating a room that is 250 
square feet, then you need 250 square feet of flooring and 250 square feet of ceiling tile. 
You can create a folder called “room” and give it a quantity of 250 square feet (SF). Then 
add line items to the folder for flooring and ceiling tiles, linking their quantities to the quantity 
of the parent folder. If the size of the room changes during the design process, you only 
need to change the quantity on the folder, and the line items will change automatically. 

CostLink/AE also supports dynamic linking to Microsoft Excel. Create a space program or 
building parameters model and link cells directly to CostLink/AE quantities. Once linked, 
quantities in CostLink/AE update as the space program and other parameters change. 

Simple but Powerful Reports 
Simple but powerful report formatting and presentation lets you choose and format your 
reports in a variety of ways. The report is organized by the folders you create for your 
estimate. The costs in each report can either include markups in the individual line items, or 
summarize markups at the end of the report – your choice. You can choose the level of 
summarization, include or exclude a “percent of total” column, unit cost column, quantity 
column, and the total cost column. You can specify a report title and footer, apply a 
company logo to the report, and choose whether to include notes in the report. (AE lets you 
annotate any or every line of your cost estimate.) Reports can then be printed or exported 
to a number of formats including PDF, Excel, and Word. 

Foundations of CostLink/AE 
CostLink/AE is mature. AE is solidly founded on the CostLink/CM framework, which has 
been tested and improved through three generations of release. BSD has big plans for 
CostLink/AE as the new vanguard of its cost estimating product line. We know you will be 
pleased, both with the initial release and the ongoing subscription updates that hallmark our 
other successful products. We look forward to your productive use of CostLink/AE, and as 
always, we welcome your feedback.  

About the RS Means Cost Data 
Your subscription to BSD CostLink/AE includes the current RS Means cost data in the AE 
Assemblies database and the Building Construction Cost Data database. The following is 
how RS Means explains what is behind their costs. 
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The Development of Cost Data 
The staff at RS Means continuously monitors developments in the construction industry in 
order to ensure reliable, thorough, and up-to-date cost information. While overall 
construction costs may vary relative to general economic conditions, price fluctuations 
within the industry are dependent upon many factors. Individual price variations may, in fact, 
be opposite to overall economic trends. Therefore, costs are continually monitored and 
complete updates are published yearly. Also, new items are frequently added in response 
to changes in materials and methods. 

Costs - $ (U.S.) 
All costs represent U.S. national averages and are given in U.S. dollars. The Means City 
Cost Indexes (Location Adjustment) should be used to adjust costs to a particular location. 
The City Cost Indexes for Canada can be used to adjust U.S. national averages to local 
costs in Canadian dollars. No exchange rate conversion is necessary. 

For information on applying Location Adjustments, see chapter 4. 

Model Costs 
The base building cost for each of the 75 model buildings is computed from a small number 
of variables, including total area, perimeter, number of floors, and exterior wall and framing 
systems. Each of these variables is linked by formulas to assemblies and line items that are 
added to compute the total base building cost. A number of optional additives are provided 
for each building model, allowing the user to select appropriate added items and insert 
required quantities. Each model is based on specific parameters that cannot be varied 
significantly without invalidating the resulting cost estimate. For example, a building model 
of two stories cannot be used for a cost estimate of a similar building type of five stories, 
since many of the systems used and some of the computations would be inappropriate for 
the taller building. 

Material Costs 
The RS Means staff contacts manufacturers, dealers, distributors, and contractors all 
across the U.S. and Canada to determine national average material costs. Included within 
material costs are fasteners for a normal installation. RS Means engineers use 
manufacturers’ recommendations, written specifications and/or standard construction 
practice for size and spacing of fasteners. Adjustments to costs may be required for your 
specific application or location. Material costs do not include sales tax, but can be adjusted 
in the Cost Tab of the Summary Info in CostLink/AE as described in chapter 4. 
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Labor Costs 
Labor costs are based on the average of wage rates from 30 major U.S. cities. Rates are 
determined from labor union agreements or prevailing wages for construction trades for the 
current year. Rates, along with overhead and profit markups, are listed on the inside back 
cover of the appropriate RS Means cost book. If rate increases are expected within a given 
year, costs should be adjusted accordingly.  

Labor costs reflect productivity based on actual working conditions. These figures include 
time spent during a normal workday on tasks other than actual installation, such as material 
receiving and handling, mobilization at site, site movement, breaks, and cleanup. 
Productivity data is developed over an extended period so as not to be influenced by 
abnormal variations and reflects a typical average. 

Equipment Costs 
Equipment costs include not only rental, but also operating costs for equipment under 
normal use. The operating costs include parts and labor for routine servicing such as repair 
and replacement of pumps, filters, and worn lines. Normal operating expendables such as 
fuel, lubricants, tires, and electricity (where applicable) are also included. Extraordinary 
operating expendables with highly variable wear patterns such as diamond bits and blades 
are excluded. These costs are included under materials. Equipment rental rates are 
obtained from industry sources throughout North America—contractors, suppliers, dealers, 
manufacturers, and distributors. 

General Conditions 
Prices given in this software include the Installing Contractor’s overhead and profit (O&P). 
General Conditions, when applicable, should also be added to the Total Cost including 
O&P. The costs for General Conditions are listed in the Reference Section of the 
appropriate RS Means cost book. General Conditions for the Installing Contractor may 
range from 0% to 10% of the Total Cost including O&P. For the General or Prime Contractor 
costs for General Conditions may range from 5% to 15% of the Total Cost including O&P, 
with a figure of 10% as the most typical allowance. 

Overhead and Profit 
The costs in this software include O&P for the Installing Contractor. This figure is the 
arithmetic sum of Material (which is the bare material cost plus 10% for profit), Labor (the 
base labor cost plus total overhead and profit), and Equipment (the bare equipment cost 
plus 10% for profit). Details for the calculation of Overhead and Profit on labor are shown on 
the back cover of the appropriate RS Means cost book. 

Factors Affecting Costs 
Costs can vary depending upon a number of variables. Here is how RS Means has 
handled the main factors affecting costs. 
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Quality 
The prices for materials and the workmanship upon which productivity is based represent 
sound construction work. They are also in line with U.S. government specifications. 

Overtime 
RS Means has made no allowance for overtime. If you anticipate premium time or work 
beyond normal working hours, be sure to make an appropriate adjustment to your costs. 

Productivity 
The productivities used in calculating labor costs are based on working an eight-hour day in 
daylight hours in moderate temperatures. For work that extends beyond normal work hours 
or is performed under adverse conditions, productivity may decrease. 

Size of Project 
The size, scope of work, and type of construction project will have a significant impact on 
cost. Economies of scale can reduce costs for large projects. Costs can often run higher for 
small projects. Costs in this database are intended to represent costs for commercial and 
industrial projects costing $1,000,000 and up, or large multi-family projects. Costs for 
projects of a significantly different size or type should be adjusted accordingly. 

Location 
Material prices are for metropolitan areas. However, in dense urban areas, traffic and site 
storage limitations may increase costs. Beyond a 20-mile radius of large cities, extra 
trucking or transportation charges may also increase the material costs slightly. On the 
other hand, lower wage rates may be in effect. Be sure to consider both of these factors 
when preparing an estimate, particularly if the job site is located in a central city or remote 
rural location. In addition, highly specialized subcontract items may require travel and per 
diem expenses for mechanics. 

For information on applying location adjustments, see chapter 4. 
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Other factors: 
• season of year 
• contractor management 
• weather conditions 
• local union restrictions 
• building code requirements 
• availability of: 

- adequate energy 

- skilled labor 

- building materials 
• owner’s special requirements/restrictions 
• safety requirements 
• environmental considerations 

Unpredictable Factors 
General business conditions influence ‘‘in-place’’ costs of all items. Substitute materials and 
construction methods may have to be employed. These may affect the installed cost and/or 
life cycle costs. Such factors may be difficult to evaluate and cannot necessarily be 
predicted based on the job’s location in a particular section of the country. Thus, where 
these factors apply, you may find significant, but unavoidable cost variations for which you 
will have to apply a measure of judgment to your estimate. 

Contingencies 
Estimates that include an allowance for contingencies have a margin to allow for 
unforeseen construction difficulties. On alterations or repair jobs, 20% is not an 
unreasonable allowance to make. If drawings are final and only field contingencies are 
being considered, 2% to 3% is probably sufficient, and often nothing need be added. As far 
as the contract is concerned, future changes in plans can be covered by extras. 

The contractor should consider inflationary price trends and possible material shortages 
during the course of the job. Escalation factors are dependent upon both economic 
conditions and the anticipated time between the estimate and actual construction. If 
drawings are not complete or approved, or if a budget is required before proceeding with a 
project, it is wise to add 5% to 10%. Contingencies are a matter of judgment. 

Final Checklist 
Estimating can be a straightforward process provided you remember the basics. Here is a 
checklist of some of the items you should remember to do before completing your estimate. 
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Did you remember to . . . 

• factor in the City Cost Index (Location Adjustment) for your locale 
• take into consideration which items have been marked up and by how much 
• mark up the entire estimate sufficiently for your purposes 
• read the background information on techniques and technical matters that could impact 

your project time span and cost 
• include all components of your project in the final estimate 
• double check your figures to be sure of your accuracy 
• call RS Means if you have any questions about your estimate or the data you’ve found 

in our publications 

Remember, RS Means stands behind its publications. If you have any questions about your 
estimate . . . about the costs you’ve used from their data . . . or even about the technical 
aspects of the job that may affect your estimate, feel free to call the RS Means editors at 1-
800-334-3509. 

Assemblies Estimating 
BSD CostLink/AE is designed for Assemblies Estimating. The following information about 
Assemblies Estimating is provided by RS Means. 

What Is Assemblies or Systems Estimating? 
The grouping of several different trades into building components or broad building 
elements is the ‘‘Systems’’ or ‘‘Assemblies’’ method of estimating. This method allows the 
estimator or designer to make quick comparisons of systems in various combinations within 
predetermined guidelines. Systems, which are best suited to accommodate budget, code, 
load, insulation, fireproofing, acoustics, energy considerations, and the owner's special 
requirements can quickly be determined. This method can also be used to help match 
existing construction. 

Systems Estimates vs. Unit Price Estimates 
In order to understand how a Systems estimate is assembled, it is a good idea to compare 
a Unit Price estimate with a System estimate. In a Unit Price estimate, each item is 
normally included along the guidelines of the 16 (or newer 50) division MasterFormat of the 
Construction Specifications Institute, Inc. In a Systems estimate, these same items are 
allocated to one of seven major group elements in the UNIFORMAT II organization of a 
Systems estimate. Certain items that were formerly grouped into a single trade breakdown 
must now be allocated among two or more systems. 
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An example of this difference would be concrete. In a Unit Price estimate, all the concrete 
items on a job would be priced in the Concrete section of the estimate, CSI Division 3. In a 
Systems estimate, concrete is found in a number of locations. For instance, concrete is 
used in all of these systems: Division A10, Foundations; Division A20, Basement 
Construction; Division B10, Superstructure, and Division B20, Exterior Closure. 

Conversely, other items that are listed in separate trade breakdowns in a Unit Price 
estimate are combined into one division in the Systems estimate. For example, interior 
partitions might include two CSI divisions: Division 6, Wood Stud Wall; and Division 9, Lath, 
Plaster and Paint. In the UNIFORMAT II Systems Estimate, these items are all combined in 
Division C, Interior Construction. 

This re-allocation of the familiar items from the CSI format may at first seem confusing, but 
once the concept is understood, the resultant increase in estimating speed is well worth the 
initial familiarization required. 

When Systems or Assemblies Estimating Is Appropriate 
Systems or Assemblies estimating is not a substitute for Unit Price estimating. It is normally 
done during the earlier conceptual stage before plans have been completed or when 
preparing a budget. This enables the designer to bring in the project within the owner's 
budget. 

During the actual initial design process, the designer will be forced to make important 
decisions and ‘‘trade-offs’’ for each of the various systems. Some of the trade-offs can 
include: 

a. Price of each system   
b. Appearance, quality and compatibility  
c. Story height  
d. Clear span  
e. Complications and restrictions  
f. Thermal characteristics  
g. Life cycle costs  
h. Acoustical characteristics  
i. Fireproofing characteristics  
j. Special owner’s requirements in excess of code requirements  
k. Code  
l. Load 
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Gathering Information For a Systems Estimate 
Before starting a Systems Estimate, gather all the information possible pertaining to the 
project. Information can be gathered from: 

1. Code Requirements  
2. Owner’s Requirements 
3. Preliminary Assumptions 
4. Site Inspection and Investigation 

Since the Foundation and Substructure design and price is a function of the Superstructure 
and the site, it is advisable to start the estimate with the Superstructure. Follow this with the 
Foundation and Substructure, and then the other Systems in the sequence as applicable to 
your project. 
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Tutorial 

This chapter contains a tutorial that will walk you through creating a small estimate in 
CostLink/AE. Where helpful, references to later chapters in this manual are made so that you 
can look up information that is more detailed. 

Tasks you will perform include: 

• Creating a project using one of the RS Means building models 

• Creating another project, copying costs from the RS Means Assemblies and Line 
Items databases 

• Adding assemblies and line items to your estimate 

• Adding folders 

• Creating a new line item in your estimate 

• Copying costs from another estimate 

• Applying markups 

• Printing reports 

NOTE: For installation instructions, directions for moving the software, and system 
requirements information, see the Installation document available in the Download 
Center at www.bsdsoftlink.com. 
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Creating an Estimate Using a Model 

To create the estimate, open CostLink/AE - from the Windows Start menu, choose 
Programs, then BSD SoftLink Products, then CostLink AE. An empty CostLink/AE screen 
opens. Do not open any projects. 

Create the Model Project File 

To create a model estimate in CostLink/AE, you create a new project using the following 
steps. 

1. Choose File > New Project, or click the Create New Project toolbar button  . 

 The New dialog box opens, showing the available project templates. 

 

New dialog box 

For more information on creating new projects and choosing templates, see chapter 4. 

2. Click the template called Uniformat II Project Template with Models.mpj, and then click 
the New button. 

 The Save New AE Project Database As dialog box opens. 
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Save New AE Project Database As dialog box 

3. In the File name field, type Model Project. 

NOTE: For later estimates you can use the Save in drop-down box to save your project in any 
folder on your computer or network. 

4. Click Save. 

 BSD CostLink/AE creates the new Project Database using the template. When the Save 
operation is finished, the Summary Info dialog box opens. 
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Summary Info dialog box 

 The General tab is used to display and edit general information about the estimate. 

 For more information on the Summary Info dialog box, see chapter 4. 

5. In the Project Title field type Model Project. 

 The Project Title can be different from the File Name. The Project Title prints in the 
reports, whereas the File Name does not. 

6. Using the Tab key to go from field to field, fill in the following fields: 

Preparation Date: (Today’s Date) 

Escalation Index Date: 1/1/2012 

Effective Pricing Date 1/1/2012 

Estimated Construction 
Time 

240 Days 

Project No. 2012-5-10 

Project Size and UOM 11000 SF 

Project Description: Fire Station Model 

Designed By: Architect's Name 
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Estimated By: Your Name 

Prepared By: Consulting Firm Name and Location 

Leave the Summary Info dialog box open for the next exercise. 

Creating the Model Estimate 

You use the Cost Models tab of the Summary Info dialog box to choose the model 
and enter key parameters about the building. 

1. Click the Cost Models tab.  

 BSD CostLink/AE displays the tab. 

2. Under Cost Models, click the button for Commercial.  Then, from the drop-down list, 
select Fire Station, 2 Story.  

3. The building size has been automatically filled in from the information you entered on the 
General tab, although you can also enter or edit the area here. For the Building 
Perimeter, type in 310. 

NOTE: The model building parameters are listed at the bottom of the Cost Models tab. If the 
building being designed differs drastically from the parameters listed, the cost 
estimate is unlikely to be highly accurate.  

4. Select exterior closure and framing assemblies by clicking on the arrow for the pull-down 
list and choosing Decorative Concrete Block / Steel Joists. 

5. Review other model building parameters at the bottom of this tab. Note that several of 
these parameters may be adjusted, but RS Means strongly suggests that these not be 
modified, because significant alterations may invalidate the cost estimate results. For 
example, changing the number of floors from 2 to 3 could change the model results in 
unpredictable ways. 

Model Additives 

Next, you use the Model Additives tab of the Summary Info dialog box to select additional 
cost items for this Cost Model. 

1. Click the Model Additives tab.  

2. Select appropriate additives for this project by inputting a quantity in the quantity field. For 
example, you may want to add kitchen appliances, clothes lockers, and an elevator. Note 
that the cost for each additive is automatically computed. 
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Applying Cost Markups and Adjustments 

Markups are the estimated costs beyond the direct costs. The direct costs copied from the 
R.S. Means Assemblies and Unit Prices resource windows already include overhead and 
profit for the installing contractor. All other markups including Location Adjustments, Sales 
Tax, and Prime Contractor markups are applied on the Cost Summary tab of the Summary 
Info dialog box. For more information on markups, see Chapter 4. 

In the following exercise, you will apply a location adjustment and additional markups to the 
Model Project: 

1. Click the Cost Summary tab. 

 The Cost Summary displays with markup percentages that have been copied from the 
template and extended costs that have been computed by the model. 

 

Summary Info dialog box, Cost Summary tab for Model project 

2. Next to the State field, click the pull down arrow and choose PA for Pennsylvania. 
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NOTE: Instead of scrolling through entire list of states, after clicking the pull down arrow, type 
the first letter of the state or province. The list will scroll to the first state or province 
with that letter.  

 The City field updates to list cities in Pennsylvania. 

3. To the right of the City field, click the pull down arrow and choose Pittsburgh. 

 Using the RS Means Location Adjustment factors, the software calculates a location 
adjustment for that location and will adjust all of the RS Means costs by that percentage. 

4. Click in the percent field for Sales Tax.  Change the sales tax to 7.00%. 

5. Change the Architect’s Fees to 8%, in accordance with the suggested architectural fees 
on the Cost Models tab. 

6. Click in the percent field for Contingency, enter 4.0, and press Tab to change the 
Contingency to 4.0%. 

7. Click the Apply button. 

 The project costs are recalculated and the Cost Summary tab updates. 

8. Click OK to close the Summary Info dialog box. 

 The costs in the Sheet panel update to show the building costs with the adjusted 
markups. 

9. Click on the Tree menu, and then click on Show Data in Tree to add a cost breakdown 
view to the Tree panel. 

10. Right click on the Fire Station Folder and choose Expand Branch to fully expand the 
folders for an overall view the building project costs. You can also click on Preview to take 
a look at the completed cost estimate report. 

11. For a more detailed look at any folder, click on the folder in the tree, then double click on 
any of the assemblies that show up in the sheet panel below. For example, click on 
Standard Foundations and double click on the Strip Footings assembly in the sheet panel 
to open the Tasks form for that assembly. You can stretch the Tasks form to see all of the 
Assembly members. In this case, note that the single assembly includes ten separate 
tasks. 

12. Unlike other "square foot" cost estimating systems based on historical data or simple 
relationships, BSD CostLink/AE provides a fully detailed model-driven cost estimate that 
can be modified and updated all the way through the Construction Documents phase of 
the project. See the next section for instructions on modifying your model estimate by 
copying assemblies and line items from the RS Means databases included with BSD 
CostLink/AE. 
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Creating an Estimate Without Using a Cost Model and 
Modifying Estimates of All Types 

Create the Sample Project File 

To create an estimate in CostLink/AE without using a model, create a new project using the 
following steps. 

1. Close any open projects. 

Choose File > New Project, or click the Create New Project toolbar button . 

2. The New dialog box opens, showing the available project templates. 

 

New dialog box 

3. Click the template called Uniformat II Project Template with Models.mpj, and then click 
the New button (or double click on the template). 

 The Save New AE Project Database As dialog box opens. 
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Save New AE Project Database As dialog box 

4. In the File name field, type Sample Project. 

5. Click Save. 

6. Complete the General tab and the Cost Summary Tab using your own location. 

7. Input 18,555 as the Project Size. 

Adding Project Notes 

You use the Project Notes tab of the Summary Info dialog box to add any global 
descriptive notes for the estimate. Notes on specific folders or tasks can be added 
either here or within the estimate. You can also update the notes at different phases 
of the project as you save different versions of the estimate. If you choose to print 
them, Project Notes print after the Title Page in the reports. 

1. In the Summary Info dialog box, click the Project Notes tab.  

 BSD CostLink/AE displays the tab. 

2. Click in the Notes area and enter the following: Sample Project Notes.  

NOTE: In addition to typing notes directly into the Notes area, you can copy text from a word 
processor, or copy notes from the Notes tab of a different CostLink/AE project. 
CostLink/AE does not have spell check, so you may want to copy text to your word 
processor and use your word processor's spell check. To copy the text, drag across it 
with your mouse and press Ctrl+C on your keyboard. Then click in the Notes area 
and press Ctrl+V on your keyboard to paste.  
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3. Click OK to save all of your changes and close the Summary Info dialog box. 

 Your Project window should look similar to the following picture. The Tree Panel is the top 
half of the screen where the folders are shown. The bottom half of the screen is the 
Sheet Panel. The Sheet Panel displays the contents of the folder you click on in the Tree 
Panel. 

 

Sample Project window with Tree and Sheet Panels labeled 

Adding Folders 

The folders in the Tree panel represent the cost breakdown. The folders will print in the 
reports, summarizing the costs at each folder. Most of the folders needed for this estimate 
were copied from the Uniformat II template. However, not all the needed folders are there. In 
the following steps, you will add two new folders to the Tree panel. 

For more information on adding folders, see chapter 4. 

1. In the Sample Project window, right-click on the Substructure folder in the Tree 
Panel. From the context menu, choose Expand Branch. 

NOTE: If you do not see a Substructure folder, from the Tree menu choose Use Single Tab. 
Then perform step 1. 

 The Substructure folder expands to show all its subfolders. 

Tree Panel 

Sheet Panel 
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2. Click on the folder Standard Foundations. 

3. With Standard Foundations highlighted, from the Insert menu choose Child Folder. 

 A new folder appears below Standard Foundations. You could type a name for the folder 
in the Tree Panel. Instead, use the next step to open the folder’s item form. 

4. From the View menu, choose Tree Items Form, or click the button on the toolbar . 

 The item form opens. 

 

Item form for New Folder 

5. Using tab to move from field to field, enter the following information: 

Tag: 1 

Title Strip Footings 

 

6. Leaving the item form open, click on the Standard Foundations folder. 

NOTE: If you cannot see the Standard Foundations folder, move the folder form by dragging 
the title bar (the bar across the top of the form that shows the name of the form) with 
your mouse. To drag the form instead of resizing, the mouse pointer should be a 
white arrow, not a double-headed arrow. 

 The item form displays the information for the Standard Foundations folder. 

7. From the Insert menu, choose Child Folder. 
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 A new folder appears in the Tree panel after the Strip Footings folder, and the item form 
displays the information for the New Folder. 

8. Fill in the following information: 

Tag: 2 

Title Spread Footings 

 

9. Close the Form by clicking on the Close button. 

 

Sample Project with two new folders added under Standard Foundations 

Adding Costs 

There are five methods of adding tasks and their associated Direct Costs to an estimate in 
BSD CostLink/AE: 

• Begin with a model, which automatically includes multiple assemblies and line items. 

• Copy assemblies from the Assemblies resource window. 

• Copy individual line items from the Unit Prices resource window.   

• Create your own line items and enter the costs directly. 

• Copy costs from one project to another. 
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The Assemblies resource window contains assemblies, which are groupings of line items that 
are defined in the estimate as individual tasks. The Unit Prices resource window contains line 
items. The assemblies and line items are from RS Means. 

For more information on the RS Means cost data, see chapter 1. 

NOTE: The RS Means models included in CostLink/AE generally include all the assemblies 
and line items required for the base building. The quantities required for all these cost 
items are driven by a small number of parameters, such as the total square footage 
and the number of floors. 
 

For more information on Models, see chapter 4. 

In the following steps you will open the Assemblies resource window, use Find to locate a 
particular assembly, and use drag and drop to copy the assembly to your project: 

NOTE: Assemblies contain all the line items required to perform a particular piece of the job. 
For example, an assembly representing 6-inch concrete slab on grade includes all 
the tasks required to prepare for, form, pour, and finish the slab. The assembly unit of 
measure is square feet. The Assemblies resource window stores the unit costs 
(Labor, Equipment, Material, and Total) and quantities of each task required to 
construct one square foot of 6-inch slab. 
 

After copying the assembly into the Project, enter the quantity of square feet of slab 
needed for the estimate. CostLink/AE then computes the total quantities and resulting 
costs of all items required for slab on grade construction. 
 

For more information on Assemblies, see chapter 4. 

1. Click the Open Assemblies resource window button on the toolbar  . 

 The Assemblies resource window opens in a separate database window within BSD 
CostLink/AE. 

2. Click the Tile windows vertically button on the toolbar  . 

 The Project and Assemblies resource windows appear side-by-side. It is easier to copy 
assemblies if the windows are positioned side-by-side. 

 

NOTE: If you are still displaying the cost data in the project Tree Panel, the numbers may 
overwrite the folder names in your project.  To change this, click on the title bar of your 
project window, click on the Tree menu and then Show Data in Tree to hide the cost 
data in the tree. 
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Assemblies resource window and Sample Project tiled side-by-side 

For more information on managing multiple windows, see chapter 4. 

NOTE: When you have more than one window open, the window with the more brightly 

colored title bar ( ) is the active window. When 
you choose commands from the menus or toolbars such as Show Folder Tags, 
folder tags will toggle on or off in the active window. In step 3 below, make sure the 
Assemblies window is active before choosing the command. To make a window 
active, click anywhere in the window or on the window's title bar. 

3. With the Assemblies resource window active (its title bar is more brightly colored 
than that of the Sample Project), from the Tree menu, choose Show Folder Tags, 

or click the button on the toolbar  . 

 The folder tags are the numbers and letters displaying between the folder icons and the 
folder names in the Assemblies resource window. If you are familiar with Uniformat II, 
you may find it easier to navigate with the folder tags turned on. 

NOTE: Show Folder Tags is a toggle. Click it again to turn the folder tags off, and again to 
turn them back on. For this tutorial, leave the folder tags on. 
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4. From the Edit menu, choose Find, or click the button on the toolbar  .  

 The Find dialog box opens.  

 

Find dialog box 

 You will use the Find dialog box to search the Assemblies resource window for Strip 
Footings to add under Standard Foundations. 

5. Type strip footings in the Find What field. 

6. Make sure the following default selections are set:  

Search All Tasks Not selected  

Match Any Part of Field Folders Selected 

Field Description   

NOTE: You will usually have better results if you search for Folders rather than Tasks. Tasks 
have many more abbreviations than folders. For information on the RS Means 
abbreviations, see Appendix B. 

7. Click the Find First button or press Enter on your keyboard. 

 CostLink/AE searches the Assemblies resource window from the beginning. The first 
folder containing strip footings in its Description field is selected in the Tree panel. This 
folder should be 110 Strip Footings. 

NOTE: Find searches for exactly the characters you type, but it is not case sensitive. If the 
database you are searching does not spell the word the same way as you typed it in 
the Find dialog box, Find will not locate the item. 

8. Click Close to close the Find dialog box. 

 Note that there are many assemblies in the Sheet panel. 

9. In the Sheet panel of the Assemblies resource window, scroll to locate the assembly with 
the following description: 

 Strip footing, concrete, reinforced, load 11.1 KLF, soil bearing capacity 6 KSF, 12" 
deep x 24" wide 
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10. Drag the assembly to the Strip Footings folder in the Sample Project.  

NOTE: To drag the assembly, hold your mouse pointer over any part of the assembly in the 
Sheet panel. Click and hold the left mouse button while you move your mouse to the 
Strip Footings folder in your project.  Between the Sheet panel and the folder, the 

mouse pointer becomes a circle/bar symbol . When the Strip Footings folder is 

highlighted, the mouse pointer becomes a hand with a sheet of paper symbol . 
Release the mouse button to drop the task on the folder.  

 Click OK if BSD CostLink/AE prompts you to confirm copying the task. 

11. In the Sample Project click on the Strip Footings folder. 

 The copied assembly is in the Sheet panel. 

12. In the Quantity field for the copied assembly in the Sheet Panel, type 580, and then 

press Tab. 

NOTE: If necessary, scroll the Sheet panel to the right to see the Quantity field. You can also 
make the Description column smaller by holding your mouse over the line between 
the Description and Quantity column headings so that your mouse pointer becomes a 
double-headed arrow. Then click and hold while you drag the line to the left. 

 Scroll to the right in the Sheet panel to see that the cost fields updated. 

13. Click the title bar of the Assemblies resource window to make it the active window. 

NOTE: If you do not make the Assemblies resource window active, then in the next step 
when you open the Find dialog box, Find will be searching the Sample Project 
window instead of the Assemblies resource window. 

14. Referring to steps 4-7 above as necessary, use Find to locate the folder Spread 
Footings, which contains the assembly with the following description: 

 spread footings, 3000 PSI concrete, load 50K, soil bearing capacity 3 KSF, 4' - 6" 
square x 12" deep 

NOTE: You will probably need to scroll to the left in the Assemblies resource window Sheet 
panel to see the name of the assembly. Drag assemblies with the right mouse button 
instead of the left, or drag from the gray box to the left of the assembly in the Sheet 
panel so that the Sheet panel will not scroll. 
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15. Referring to step 9 above, drag the assembly to the Spread Footings folder in your 
project. 

16. Referring to steps 10-11 above, enter a quantity of 20 for the Spread ftgs assembly. 

17. In the Assemblies resource window, find the assembly with the following description (it 
should be in the same folder as the last assembly you copied): 

 spread footings, 3000 PSI concrete, load 50K, soil bearing capacity 6 KSF, 3' - 0" 
square x 12" deep 

18. Drag the assembly to the Spread Footings folder in the Sample Project. 

19. Enter a quantity of 35 for the assembly. 

Reviewing Adding Folders and Copying Assemblies 

The following exercise contains less step-by-step directions than the previous exercises. As 
necessary, refer to the exercises on Adding Folders and Copying Assemblies to create the 
following folders and copy the Assemblies to them. 

1. Click on the Slab on Grade folder in the Tree panel. 

2. Add the following folders as subfolders of Slab on Grade (make sure you click on the 
Slab on Grade folder before choosing Insert > Child Folder for each folder): 

 Tag Title  

  1 4” Slab  

  2 8” Slab  

 When done, your Tree Panel should look similar to the following picture. 

 

Sample Project with new folders under Slab on Grade 

NOTE: If you add a folder in the wrong location, move the folder to the correct location by 
dragging it with your right mouse button (not the left) to the folder that it should be 
before. Then choose Move Above Folder from the context menu. 
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3. Locate the following assembly in the Assemblies resource window, drag it to the 4” slab 
folder, and enter the quantity. 

 Slab on grade, 4" thick, industrial, reinforced 14,755 SF 

4. Locate the following assembly in the Assemblies resource window, drag it to the 8” slab 
folder, and enter the quantity. 

 Slab on grade, 8" thick, heavy industrial, reinforced  3,400 SF 

Adding User-Defined Costs 

If cost items you need are not included in the resource windows, add your own. To create 
user-defined tasks, in the Tree Panel of your project, click on the folder that the task belongs 
in. Then from the Insert menu choose Task. Enter the description, quantity, unit of measure, 
and unit cost in the sheet panel or in the item form. 

In the following exercise, you will add an additional cost to the 8” Slab folder: 

1. With 8” Slab highlighted in the Tree panel, from the Insert menu choose Task. 

 A task called New Item appears in the Sheet panel. 

2. Click once on the Description (New Item) so that the words are highlighted and then type 
the new description below. Click in each of the following fields in the same manner to 
enter the following information. The Unit Cost field will display $10.00 after you enter the 
10 and press Tab. 

 Description Quantity UOM Unit Cost 

 Add for Turndown 240 LF 10 

NOTE: You can also open the item form for the new task by double-clicking on it, to enter the 
information there. The difference is that you can use the Tab key to move from field to 
field in the item form (instead of having to click in each field before typing). For more 
information on user-defined tasks, see chapter 4. 

Adding Line Items From the Unit Prices Resource Window 

If you do not find an assembly to suit your needs, you can search the Line Items in the Unit 
Prices resource window. The Line Items are from RS Means and are categorized in the 50 
Division CSI 2004 MasterFormat. For more information on the supplied RS Means data, 
see chapter 1. 

In the following exercise, you will copy several line items from the Unit Prices resource 
window to the Sample Project, adding new folders as necessary: 
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1. Close the Assemblies resource window by clicking the Windows close button on the 
Assemblies window title bar . 

2. Use Find to locate the Floor Construction folder in the Sample Project. 

3. Click the Open Unit Prices resource window button on the toolbar  . 

 The Line Items from the Means AE Assemblies resource window opens in a separate 
window within CostLink/AE.  

4. Click the Tile Windows Vertically button on the toolbar  . 

 The Line Items resource window displays side-by-side with your project. 

5. In the Line Items resource window, use Find to locate the following line item: 

 Column, structural tubing, heavy section, 7" to 10" W, incl shop primer, cap & base plate, 
bolts 

HINT: Search for Columns. The first folder located will not be the correct folder. Click Find 
Next to locate the next folder. Continue to click on Find Next until you find the correct 
folder. 

6. Drag the line item to Floor Construction in your project and enter a quantity of 8600. 

7. Find the Roof Construction folder in your project. 

8. In the Line Items window, find and copy the following line items ( ) into the Roof 
Construction folder and input the following quantities: 

 Structural steel project, industrial buildings, steel bearing, 100-ton project, 1 story, A992 
steel, shop fabricated, incl shop primer, bolted connections 41.6 TON 

HINT: Search for Steel Projects. The folder has 55 tasks in it. Instead of looking 
through the folder task by task, you can use Find to search within the folder. To 
search within the folder, in the Sheet panel, click on the first task in the folder (this is 
just so CostLink/AE’s focus is in the Sheet panel, not the Tree). Then open Find 
again, deselect Folders, and select Tasks. Search for Industrial. Use Find Next 
(not Find First). Keep clicking Find Next until you locate the correct item. 

 Open web bar joist, 40-ton job lots, spans up to 30', K series, shop fabricated, incl shop 
primer, horizontal bridging, average 4.3 TON 

HINT: Search for Web Joists. Make sure you deselect Tasks and re-select Folders. 

 Open web bar joist, 40-ton job lots, spans to 96', LH series, shop fabricated, incl shop 
primer, bolted cross bridging, average 8.8 TON 

HINT: There are two tasks with the same description. Use the one with a UOM of TON. 

 Metal decking, steel, open type, wide rib, galvanized, under 50 Sq, 1-1/2" D, 20 ga
 3,420  SF 
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HINT: Once you locate the Steel Decking folder, notice that it contains 3 subfolders. Look in 
the Steel Roof Decking folder for this task. 

 Metal decking, steel, open type, wide rib, galvanized, 50 to 500 Sq, 1-1/2" D, 22 ga
 15,481 SF 

9. Use Insert > Task to add the following user-added line item to the same folder: 

 Description Quantity UOM Unit Cost 

 Misc. Plates and Angles 7 TON 1300.00 

Copying Costs From One Project To Another 

If a previously created CostLink/AE estimate is similar to a new estimate you are creating, 
you can copy folders and tasks from the older project to the new project. In the following 
steps you will first remove the empty folders from the Sample Project, and then copy folders 
and tasks from the Fire Station Sample project that is installed with the software. 

1. Close the Unit Prices resource window by clicking the Windows close button on the Unit 
Prices window’s title bar . 

2. From the Tools menu, choose Delete Empty Folders. 

 A confirmation message opens asking if you want to delete the folders. 

3. Click Yes. 

 All empty folders, except those at Level One, are removed. 

 Up to this point, the project has been displaying Level One folders on separate tabs: 
Building and Sitework. In the next step, you will display all folders on one tab. 

4. From the Tree menu, choose Use Single Tab, or click the Use single tab for table button 

on the toolbar . 

 There is now only one tab – Sample Project. BUILDING and SITEWORK are subfolders 
beneath the Sample Project folder. 

 

Sample Project in single tab mode 
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NOTE: Use Single Tab is a toggle. Click it again to return to multi-tab mode, and again for 
single tab mode. Multi-tab mode can help when navigating complicated estimates. 
For the rest of this sample, remain in single tab mode. 

 The SITEWORK folder is empty. It was not deleted by the Delete Empty Folder 
command because it is a Level One folder. 

5. Click on the SITEWORK folder and then click the Delete Selected Item button on the 

toolbar . 

 A message opens asking you to confirm deleting the folder. 

NOTE: Read confirmation messages when deleting to make sure CostLink/AE is deleting 
the correct item. You cannot Undo to restore an accidentally deleted folder or task. 

6. Click Yes. 

 The SITEWORK folder is deleted. 

7. From the File menu, choose Open, and then choose Open Project Database. 

 The Open Database dialog box opens. 

8. Select and Open the Fire Station Sample Project. 

 The Fire Station Sample project opens in its own database window. 

9. If necessary, click the Tile Windows Vertically button on the toolbar  . 

10. In your project (the title bar says Sample Project or Project Title if you have not yet closed 
and reopened your project), click the plus sign next to BUILDING. 

 The subfolders, SUBSTRUCTURE and SHELL, display. 

11. Click the plus sign next to SHELL. 

 The subfolder SUPERSTRUCTURE, completed in the previous exercises, displays. 

12. In the Fire Station Sample Project, click the plus sign next to FIRE STATION. 

 The subfolders display. 

13. Click the plus sign next to SHELL. 

 The subfolders display. 

14. From the Fire Station Sample project, with your right mouse button, drag the 
EXTERIOR CLOSURE folder to the SHELL folder in your project (Sample Project). 

 When you release the mouse button, a context menu opens. 

15. From the context menu, choose Copy All Here. 
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 The EXTERIOR CLOSURE folder and all its subfolders and tasks are copied under the 
SHELL folder in your project. 

NOTE: Additional options in the context menu were Copy Folders Here and Copy Tasks 
Here. Copy Folders Here copies only folders, not tasks. Copy Tasks Here copies all 
tasks (assemblies and line items). These options can only be accessed by dragging 
with the right mouse button. 

16. Using the same technique, copy the ROOFING folder from the Fire Station Sample 
project to the SHELL folder in your project (Sample Project).   

17. Using the same technique, copy the following folders to the BUILDING folder: 

 INTERIORS 
SERVICES 

18. Copy the SITEWORK folder to the Sample Project folder at the top of your project. 

19. Close the Fire Station Sample project. 

20. Maximize your project (by clicking the Maximize button on the project’s title bar  ). 

21. Click the Show folder data in tree button on the toolbar , or choose the same 
command from the Tree menu. 

 Your project will look something like the following picture. 
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Sample Project showing costs in Tree Panel 

The Project Cost column shows a higher dollar amount than the Base Cost column since 
there are already some markups being applied to the project’s costs by the default cost 
markup and adjustment settings in the Summary Info dialog box.  

Selecting and Printing Reports 

The Sample Project is now complete. The next step is to print reports. 

1. From the File menu choose Reports Setup or click the Select and format reports button 

on the toolbar . 

 The Reports dialog box opens to the Select Reports tab. 

2. Leaving the Organization Name the same (this defaults to the Company Name that was 
filled in by the person who installed the software), change the Report Header to say 65% 

Submittal. 
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3. Change Levels to show in Summary to 3, if not already set to 3. 

4. Leave both Show Summary Costs and Show Detail Costs as Excluding Markups. 

 This will display the Direct Costs in the body of the report, with the Contractor and Other 
Markups added at the end of the report. 

5. Click to select Print Title Page and Detailed Estimate, if they are not already selected and 
Deselect Table Of Contents. 

 The Select Reports tab should now look like the following picture, except for the 
Organization Name. 

 

Reports dialog box with reports selected for tutorial 

6. Click the Preferences Tab. 

7. Make sure that all options are checked under Detail and Summary Report Options, 
Summary Report Options, and Print Detail Options. 

8. Make sure that no options are checked under Print Notes and Footer. 

 Notice that the Print and Preview buttons are grayed out on this tab. 

9. Click the Select Reports tab. 

10. Click Preview. 

 CostLink/AE creates the reports and displays them in a Print Preview window. 
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11. Once the reports appear, maximize the Print Preview window either by double-clicking on 
the title bar of the window, or click the Maximize button . 

12. To zoom in, click the arrow on the zoom selector and choose 100% . 

13. Click the Next Page button on the toolbar , to view the report page by page.  

14. To export your reports to Adobe Acrobat portable document format (PDF), Word, or 

Excel file format, click on the Envelope button on the toolbar . 

 For more information on exporting your reports, see chapter 5. 

15. To print the reports to your default Windows printer, click the printer button in the Print 

Preview window . 

16. To close the Print Preview window click the Windows close button on the preview 
window’s title bar . 

17. Open the Reports Setup dialog box, and select or deselect other options. Preview to see 
how the options change the report. 

 For more information on reports and report options, see chapter 5. 

18. When finished, close the Sample Project by going to the File menu and choosing Close. 
To close BSD CostLink/AE, from the File menu choose Exit. 

You have now completed the BSD CostLink/AE tutorial. See the other chapters in the User 
Manual, or use the Help in the software for additional information on other options. 
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About the CostLink/AE Display 

BSD CostLink/AE provides some flexibility in how data is displayed. You can configure the 
display of projects and resource views using multiple panels, windows, and tabs. 

This chapter explains how to: 

• Configure panels and windows 

• Recognize icons on the tree and sheet panel 

• Control the information in the tree and sheet panel 

• Customize the toolbars 

• Use the online Help 
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Configuring Panels and Windows 
BSD CostLink/AE displays your estimates, assembly resources, and unit price resources in 
database windows within the main program window, and in panels within these windows. 
The default display for each window is with the Tree Panel on top and the Sheet Panel on 
the bottom. 

 

CostLink/AE default display 

To change the display of the panels use the following commands: 

• To arrange the panels side-by-side, choose View > with Vertical Panels. 

• To return to the default display, choose View > with Horizontal Panels. 

Configuring Multiple Windows 
You will often have multiple windows displayed in BSD CostLink/AE to show your estimate 
and resource windows at the same time, or to show multiple estimates at the same time. 
This allows you to copy folders and tasks into your project from resource windows and 
other projects.  

Tree Panel 

Sheet Panel 
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When you have more than one window displayed, use the following menu and toolbar 
commands to arrange the windows. 

• To tile windows vertically, click the Tile windows vertically toolbar button , or 
choose Window > Tile Vertically. 

• To tile windows horizontally, click the Tile windows horizontally toolbar button , or 
choose Window > Tile Horizontally. 

• To cascade the open windows, click the Stack windows in cascade toolbar button 
, or choose Window > Cascade Windows. 

Tips For Using Tile and Cascade: 

• When you choose one of the Tile or Cascade options, the currently active window will 
be on the left (if you choose Tile Vertically) or on the top (if you choose Cascade or Tile 
Horizontally). If you want a different window on the left or top, make the desired window 
the active window (by clicking its title bar) and choose the Tile or Cascade command 
again. 

• If you minimize a window, it will not be tiled or cascaded. 

• When you have multiple estimates open, the prompt on the bottom left of the screen 
displays the drive, path, and filename of the currently active project. This is true 
whether the project window is active or one of its resource windows. 

• When you have multiple windows open, the bottom of the Window menu lists all the 
open windows. The currently active window is marked with a checkmark. To make a 
different window active, click on the window or choose it from the Window menu. 

Choosing Single or Multiple Tabs 
By default, BSD CostLink/AE divides the display of each project and resource window into 
multiple tabs, one tab for each main division as represented by the folders at Level 1. You 
can show all of the folders on a single tab. 

• To display all folders on one tab, click the Use single tab for tree button on the toolbar 
 or choose Tree > Use Single Tab. 

 

CostLink/AE display with all data on a single tab 
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• To display the folders on multiple tabs, click the Use single tab for tree button on the 
toolbar  or choose Tree > Use Single Tab again. (The Use Single Tab command 
and button are toggles.) 

 

CostLink/AE display with data on multiple tabs 

Icons On the Tree and Sheet Panels 
BSD CostLink/AE displays many icons in the Tree and Sheet panels to identify the kinds of 
data and its position and status in the database. 

Tree Panel Icons 
 Folder: Indicates that the item is a folder. 

 Plus sign: Indicates that the folder has folders below it in the hierarchy that are 
not currently displayed. The view is collapsed. Click the plus sign to expand the 
view. 

 Minus sign: Indicates that the folder has folders immediately below it which 
are already being shown. The view is expanded. Click the minus sign to 
collapse the view. 

 Folder/Task: Indicates that the folder has tasks (assemblies or line items) 
directly inside it. To view the tasks, click on the folder and the tasks will show in 
the Sheet panel. 

 Notes: Indicates that the folder has Notes attached to it. To view the notes, 
click on the folder, and then click the Open the Notes form button on the 
toolbar . 

 Folder with Link: The green Excel icon in the upper right corner indicates that 
the quantity of the folder is linked to the quantity of the parent folder or to Excel. 
Linking to Excel automatically inserts a note as indicated by the blue in the 
bottom left. 

See Chapter 7 for information on linking. 
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Sheet Panel Icons 
 Folder: Indicates that the item is a folder. 

 Folder/Task: The item is a folder with tasks directly inside it. To view the tasks, 
click on the folder in the Tree panel and the tasks will display in the Sheet 
panel. 

 Folder with Link: The green Excel icon in the upper right corner indicates that 
the quantity of the folder is linked to the quantity of the parent folder or to Excel. 
Linking to Excel automatically inserts a note as indicated by the blue in the 
bottom left. 

 Assembly: The item is an assembly. 

 Assembly/Note: The assembly has a note as indicated by the blue in the 
bottom left. 

 Assembly with Link: The green Excel icon in the upper right corner indicates 
that the quantity of the assembly is linked to the quantity of the parent folder or 
to Excel. Linking to Excel automatically inserts a note as indicated by the blue 
in the bottom left. 

 Line Item: The item is a line item. 

 Line Item/Note: The line item has a note as indicated by the blue in the bottom 
left. 

 Line Item with Link: The green Excel icon in the upper right corner indicates 
that the quantity of the line item is linked to the quantity of the parent folder or 
to Excel. Linking to Excel automatically inserts a note as indicated by the blue 
in the bottom left.  

Working with the Tree Panel 
The Tree Panel shows the hierarchy of data in the project or resource window, illustrated as 
a tree structure of folders. BSD CostLink/AE gives you options for configuring the display of 
the Tree Panel. 

Expanding and Collapsing the Tree 
To expand the view of any collapsed folder: 

• Click on the plus sign  beside the folder. 

To collapse the view of any expanded folder: 

• Click on the minus sign  beside the folder. 
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To expand a branch to show all folders in that part of the project or resource 
window: 

1. Position the cursor in any part of the branch. 

2. Click the Expand Branch toolbar button . (You can also right click on a folder in the 
branch and choose Expand Branch from the context menu.) 

To expand the tree to show all folders: 

• Click the Expand All toolbar button . 

To show folder tags of folders in the Tree Panel: 

• Choose Tree > Show Folder Tags. Or click the Show folder tags button on the toolbar 
. This command acts as a toggle. Click it again to turn off the folder tags. 

To show summarized cost information: 

In the project window, you can show summarized costs for each folder in the tree panel. 

• Choose Tree > Show Data in Tree. Or click the Show folder data in tree button on the 
toolbar . This command acts as a toggle. Click it again to turn off the data display. 

Working With the Sheet Panel 
The Sheet Panel shows the folders or tasks that are one level below the folder selected in 
the Tree Panel. Information about the folders or tasks is displayed in a spreadsheet format. 
BSD CostLink/AE lets you modify the way the information is displayed. 

To change the width of a column: 

1. With the mouse, point to the border between two column headings. 

 The mouse pointer turns into a double arrow. 

2. Click and drag to resize the column. 

To autosize rows: 

Autosize is a toggle that changes the height of all rows. When Autosize is on (the default), 
all the information in the description field is displayed. When off, only the first line of the 
description is displayed. 

• Point to any row in the sheet panel and click the right mouse button. Choose Autosize 
Rows from the context menu. 

• This command acts as a toggle. Choose it again to turn Autosize back on. 
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To sort data in the sheet panel: 

You can sort the folders or tasks in ascending or descending order, based on any column 
of information. 

• Click on the heading for the column you want to sort by. The folders and/or tasks are 
sorted in ascending order by that column. Click again to sort by descending order. 

To freeze the display at a column: 

As with a spreadsheet, you can freeze the sheet panel so that certain columns of 
information remain displayed while you scroll right or left.  

1. Right-click on any folder or task in the column of information that you want to freeze. 
A context menu opens. 

2. From the context menu, choose Freeze Columns to (name of the column). 

 This command is a toggle. Choose it again to Unfreeze the column. 
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Online Help 
BSD CostLink/AE includes an online Help system. 

 

BSD CostLink/AE Help, Contents Tab 

Contents Tab 
The Contents tab is similar to the table of contents in a book. Each book icon represents a 
subheading in the Help file. Each page icon represents a topic. 

To access the Contents tab: 

1. Choose Help > Contents. The Contents tab opens. 

2. Select a book and double-click it to view more topics.  
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To access a topic, select any page icon. 

To print a topic or range of topics, select any book or page icon and click the Print button. 
Windows Help displays the Print dialog box. Click OK. Windows Help prints the selected 
topic or the selected heading and all subtopics. 

Print individual topics by viewing the topic, clicking Options, and choosing Print. 

 

BSD CostLink/AE Help, Index Tab 

Index Tab 
The Index tab is used to search Help by keywords for each topic. 

To access the Index tab, from the Help menu choose Use Index for Help On, or click the 
Index tab on any Help window. To Search by Keyword, follow the instructions. 
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RS Means Abbreviations and Symbols 
For a printable list of the abbreviations used in the Assemblies and Unit Prices resource 
windows, download Appendix B of the CostLink/AE User Manual from Building Systems 
Design, Inc.'s website. Click on Support and then User Manuals.  The R.S. Means 
abbreviation list is also available as appb-abbreviations.doc on the BSD SoftLink CD in the 
AE_Doc folder. 

Search Tab 
The Search tab is used to conduct a full-text search of all Help topics. Use the Search tab if 
you cannot find the Help you need using the Contents or Index tabs. 

To access the Search tab, choose Help > Search for Keyword in Help. 

To Search, follow the instructions on the tab. 

 

BSD CostLink/AE Help, Search Tab 
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Projects, Models, Tasks, & Markups 

This chapter describes all of the components of projects that you see in the BSD 
CostLink/AE interface. It also provides explanations and instructions for working with 
projects, adding tasks to your estimate, and applying markups. 

• Working with projects 

• Summary Info dialog box 

• Using cost models 

• Folder form 

• Task form 

• About the supplied cost data 

• About assemblies 

• About line items 

• Copying tasks into projects 

• Creating line items 

• Applying markups 
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Working with Projects 
Project databases are used to build estimates. Each estimate that you create in BSD 
CostLink/AE is a separate project database, which is a file with the extension .mpj. 

Opening a Project 
Use these instructions to open an existing estimate. To open a project: 

1. Choose File > Open > Open Project Database. 

 The Open Database dialog box opens, showing the projects in the Projects folder.  

2. Select a project in the folder, or use the dialog box to navigate to a different folder. 

3. Click Open. 

 The project database opens. 

Opening a Recently Used Project 
The bottom of the File menu lists the last four projects that were opened. Click the name of 
the project to open it. 

Existing projects can also be opened using the Recently Used dialog box. To open a 
recently used project using the Recently Used dialog box: 

1. Choose File > Open > Recently Used Window, or click the Open recently used project 

dialog toolbar button . 

 The Recently Used dialog box opens, showing the projects that have been opened on 
this computer.  

2. Select a project and click Open. 

 The project opens. 

Tips on using the Recently Used dialog box: 

• If the project you want to open is not listed, click the Browse button. 

• If you are not sure which project you edited last, or if you would like to know where 
each project is located, under View, click the Details option. You can scroll to the right 
to view additional information about each project, and/or resize the Recently Used 
window. 
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• If there is a project in this window that you no longer want listed here, click once on the 
name of the project, and then click the Remove button. This does not remove the 
project from your computer; it removes it from the list of Recently Used projects. 

Creating a New Project 
You can create a new project based on one of the templates supplied with BSD 
CostLink/AE or based on any existing project. Your new project inherits the folders, tasks, 
and Summary Info from the selected template or existing project. You can change this 
information once the project is created. 

1. Choose File > New, or click the Create a new project toolbar button . 

 The New dialog box opens, showing the available project templates.  

2. Choose a template from the list area, or click the Browse button to select a different 
template or existing project. 

3. Click New. 

 The Save New Project Database As dialog box opens. 

4. If desired, select a different folder to save your project in, and type a filename for your 
project in the File name field. Click Save. 

 BSD CostLink/AE creates and opens the new project and its Summary Info dialog box. 
(See the next topic for information on the Summary Info dialog box.) 

CostLink/AE comes with four templates for starting new projects. The templates are located 
in the CostLink AE\system\templates folder. 

• Uniformat II Project Template with Models 

• MasterFormat 2004 Project Template.MPJ 

• MasterFormat (16 division) Project Template 

• No WBS Project Template 

NOTE: WBS stands for Work Breakdown Structure. In projects, folders represent the WBS. 
Therefore, the Uniformat II template contains folders that match Uniformat II, the 
MasterFormat templates contains folders that match CSI’s (Construction 
Specification Institute’s) MasterFormat-95 16 divisions and the MF-2004 50 
divisions.  The No WBS template has no folders.  

If you are creating an estimate for a client who requires a specific WBS that does not follow 
Uniformat II or MasterFormat, then create the new project using the No WBS Project 
Template and add folders that match the client’s WBS. The folders will be the major 
headings in the reports. 



 C h a p t e r  4  :  P r o j e c t s ,  M o d e l s ,  T a s k s ,  &  M a r k u p s  

5 0  B S D  C o s t L i n k / A E  U s e r  M a n u a l  

Summary Info Dialog Box 
Use the Summary Info dialog box to display and edit information about the project. This 
includes descriptive information that will print on the report title page, cost markup 
information, cost models, model additives, and notes about the project as a whole. 

The Summary Info dialog box opens automatically when you create a new project. To 
display the Summary Info dialog box for the current project at any other time: 

• Choose File > Summary Info or click the Open the summary info dialog toolbar 

button . 

General Tab 
Use the General tab to display and edit general information about the estimate. 

 

Summary Info dialog box, General tab 
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NOTE: The tabs available on the Summary Info dialog box will vary, 
depending on the project template used. If the Uniformat II Project 
Template with Models is selected, the Summary Info dialog box 
will have two tabs in addition to those shown on the preceding 
page. All other templates will open a Summary Info dialog box 
with the three tabs shown. 

Estimate Identification 

File Name File name for the project that was entered when you created 
the project. (This cannot be changed here. To change the 
filename of a project, close the project and change the 
name in Windows Explorer.) 

File Path Drive and directory where the project is stored. (This cannot 
be changed here. To change the File Path, close the project 
and use Windows Explorer to move the project.) 

Project Title Name of the project that appears on reports and on the 
folder at the top level of the tree panel. 

Estimate Timeline 

Preparation Date Date of preparation of the estimate. 

Escal. Index Date The date of publication of the escalation index table used in 
the project. 

Eff. Pricing Date Date for which the pricing in the project is effective. 

Est. Const. Time Estimated number of workdays to complete the project. 

Cost Database 

This area displays the Title, Filename, and Path of the cost database being 
referenced by the project. 

Project Information 

Project No. Number to identify project. Will be the folder tag on the level 
0 folder (visible only when you are viewing the project with 

single tab turned on - ). On reports, this number appears 
on the left side of the footer and as a folder tag for the top-
level folder in summary reports. 

Project Size and 
UOM 

The estimated size and unit of measure of the project that is 
being estimated. This displays a unit cost for the project on 
the top-level folder in the tree panel, on the Cost Summary 
tab, and on the bottom line of the reports. 

Project Description A description of the project. Can be up to 255 characters. 
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Designed By The architect's or engineer's name or the firm's name. 

Estimated By The estimator's name or firm's name. 

Prepared By The estimator's firm or consulting firm and location. 

Cost Summary Tab 
The fields on the Cost Summary tab and how to enter the markups are explained in the last 
section of this chapter under Applying Markups. 

Project Notes Tab 
Use this tab to enter any project level descriptive notes that you want to include with the 
estimate. Project Notes can be printed on reports. 

 

Summary Info dialog box, Project Notes tab 
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NOTE: If you would like to spell check your notes, type them in your word processor using 
its spell checker. Then use your word processor’s Copy command to copy your 
notes, click in the Project Notes tab, and use CTRL+V to paste the notes.  

Cost Models Tab 
Use this tab to select an RS Means cost model to use as the basis for your project cost 
estimate. This tab also allows you to enter critical data about your project, to select an 
exterior closure and framing option, and to make adjustments to the model building 
parameters that drive the formulas embedded in the cost model. 

 

Summary Info dialog box, Cost Models tab 

NOTE: This tab is available only if you started your project by using the Uniformat II Project 
Template with Models.  
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Select Model 

None Selecting this option nullifies the modeling template. 

Commercial Selecting this option changes the models available in the 
adjacent pull-down to all available commercial models. Click 
on arrow to pull down list and click on list to choose model. 

Industrial Selecting this option changes the models available in the 
adjacent pull-down to all available industrial models. Click on 
arrow to pull down list and click on list to choose model. 

Institutional Selecting this option changes the models available in the 
adjacent pull-down to all available institutional models. Click 
on arrow to pull down list and click on list to choose model. 

Enter Dimensions 

Building Size Enter total gross square footage of project. Note that model 
cost estimate may not be accurate if area entered here is 
significantly greater or smaller than default (baseline) 
building area indicated under Model Building Parameters. 

Building Perimeter Enter total linear feet of building perimeter. Note that model 
cost estimate may not be accurate if length entered here is 
significantly greater or smaller than default (baseline) 
building perimeter indicated under Model Building 
Parameters. 

Select Exterior Closure and Framing 

Pull-Down List Click on arrow to pull down list of six possible exterior 
closure and framing options available for specific model 
selected. Click on option to select exterior closure and 
framing. 

Model Building Parameters 

Fixed Parameters Default (Baseline) Building Area (GSF) is the gross area of 
the building on which the model is based. Default (Baseline) 
Building Perimeter is the length of the perimeter of the 
building on which the model is based. These two 
parameters are stated for informational purposes and 
cannot be adjusted here, but alternative size and perimeter 
may be entered above in the same dialog box (see Enter 
Dimensions, above). Suggested Architectural Fees also 
cannot be altered here but may be adjusted on the Cost 
Summary tab of the Summary Info dialog box. 
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Adjustable 
Parameters 

The remaining building parameters -- Number of Floors, 
Average Floor to Floor Height, Partition Density, Average 
Partition Height, and Door Density may be adjusted here by 
entering alternative numbers for the default values used in 
the model. However, caution is advised in making significant 
changes to model building parameters.  

Model Additives Tab 
After you have selected a model, use this tab to enter quantities for special items not 
included in the base building cost estimate. The items that appear on this tab will vary with 
the model chosen. Entering a quantity adjacent to any item automatically adds the cost of 
the item to your model cost estimate. 

 

Summary Info dialog box, Model Additives tab 

NOTE: This tab is available only if you started your project by using the Uniformat II Project 
Template with Models. The tab will be blank until you have chosen a model from the 
Cost Models tab.  
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Folder Item Form 
The folder item form shows information for the folder currently selected in the Tree or Sheet 
panel. 

Use any of the following methods to open a folder item form: 

• Select a folder in the tree panel, and then choose View > Tree Items Form, or click the 
Open item form on the Tree panel toolbar button . 

• Select a folder in the sheet panel, and then choose View > Sheet Items Form, or click 
the Open item form on the Sheet panel toolbar button . 

• Right-click on a folder in the tree panel and from the context menu choose Edit Folder. 

• Right-click on a folder in the sheet panel and from the context menu choose Edit Item. 

• Double-click on a folder in the tree panel. 

• Double-click on a folder in the sheet panel. 

 

A project folder item form 
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General Tab 
Folder Definition 

Tag Optional ID for the folder. The tag is sometimes used to specify the 
folder's position or sequence in the group of folders at this database 
level, although the Folder Tag does not affect the position or 
sequence of the folder. Can be displayed in the Tree panel by 
choosing Tree > Show Folder Tags. 

Title Description you assign to the section of the project represented by 
this folder. 

Qty Quantity associated with this element of the project. Entering a 
quantity value here enables BSD CostLink/AE to compute a unit 
cost for this project element. If a Quantity is not entered, then the 
unit and extended costs shown in the cost grid below are the same.  

UOM Unit of measure associated with the Quantity. 

Use 
Quantity 
Entered 

Select this option (the default) to enter a quantity in the Qty field to 
calculate the Unit Cost. 

Use MS 
Excel 
Value 
times 

Select this option to link the quantity to a value in an MS Excel 
spreadsheet. When selected, the grayed out ‘times’ field becomes 
available and turns white. The default value is 1. For more 
information on linking, see Chapter 7. 

Use Parent 
Quantity 
times 

Select this option to link the quantity to the quantity of the folder that 
contains the current folder. When selected, the grayed out ‘times’ 
field becomes available and turns white. The default value is 1. 
Enter a different factor if necessary to calculate the quantity. As the 
quantity is changed on the parent folder, the quantity on this folder 
will change. For more information on linking, see Chapter 7. 

Cost Summary 

The grid shows the unit and extended costs for all tasks beneath this folder. 

Base Cost The Base Cost is the Direct Cost. Cost of the tasks beneath this 
folder before any of the adjustments or markups are applied from 
the Cost Summary tab of the Summary Info dialog box. 

Cost To 
Prime 

Cost To the Prime Contractor. The Unit Cost plus the Location 
Adjustment and Sales Tax (as set in the Summary Info dialog box 
on the Cost Summary tab) for this element. 

Cost To 
Owner 

Cost To the Project Owner. The Cost To Prime plus the Contractor 
Fees (as set in the Summary Info dialog box on the Cost Summary 
tab) for this element. 
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Project 
Cost 

Total Cost. The Cost To Owner plus any Other Costs (as set in the 
Summary Info dialog box on the Cost Summary tab) for this 
element. 

Buttons on the Folder Form 
These buttons and controls appear at the bottom of the form. 

Insert Clicking this button adds a new folder at the same level as and 
above the current folder. It also displays a blank folder form for the 
new folder. 

Lock  Select this option to lock the form on the current folder. You can then 
click in a different window without the form disappearing. 

Back Displays the form for the previous folder displayed in the tree or 
sheet panel. 

Next Displays the form for the next folder displayed in the tree or sheet 
panel. 

Close Applies any changes you have made on the form, and closes the 
form. 

Task Item Form 
The task item form shows information for the project task currently selected in the sheet 
panel. 

To open a task item form for an assembly or line item use one of the following methods: 

• Select the task in the sheet panel, and then choose View > Forms > for Sheet Items, or 
click the Open item form on the Sheet panel toolbar button . 

• Right-click on the task in the sheet panel, and from the context menu choose Edit Item. 

• Double-click on the task in the sheet panel. 

The task item form shown and described below is for a task located in a project. Tasks in 
resource windows are described later in this chapter. 
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A task item form 

NOTE: In order to see more information on the form, you can resize the form, change the 
location of the splitter bar between Task Cost Data and Assembly Members, and 
change the width of the fields. 

Description 

Task Description Description of the task. 

Quantity/UOM Quantity and unit of measure associated with the task. 

Task Type Indicates whether the task is an Assembly or a Line Item. 
(This corresponds with the icon in the first column of the 
Sheet panel:  for assembly;  for line item.) 

Source Indicates the source of the task: 

ADD – Additive line item from model 
ASM – Assembly copied from Assemblies resource window.
MDL – An assembly or line item from the base model. 
RSM – Line item copied from Unit Prices resource window. 
USR – User-added line item. 

Source Tag Displays a code that is used as a unique identifier for the 
task. 
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Use Quantity 
Entered 

Select this option (the default) to enter a quantity in the Qty 
field to calculate the Extended Cost. 

Use MS Excel 
Value Times 

Select this option to link the quantity to a value in an MS 
Excel spreadsheet. When selected, the grayed out ‘times’ 
field becomes available and turns white. The default value 
is 1. For more information on linking, see Chapter 7. 

Use Parent 
Quantity Times 

Select this option to link the quantity to the quantity of the 
folder that contains the current folder. When selected, the 
grayed out ‘times’ field becomes available and turns white. 
The default value is 1. Enter a different factor if necessary to 
calculate the quantity. As the quantity is changed on the 
folder, the quantity on this task will change. For more 
information on linking, see Chapter 7. 

Use Formula 
Value Times 
(Model Building 
Parameter) 

This is the default option for any project that uses a model 
as the basis for the project estimate and does not appear if 
any of the other templates are used. You can select one of 
the other options to establish a quantity, but in so doing, you 
will disconnect the assembly or item from the model after 
receiving a warning message. 

NOTE: Be absolutely certain you want to disconnect the task from the model before 
choosing one of the other options, because you will not be able to reconnect them. 

Task Cost Data 

This grid shows the unit and extended costs for the task. 

Base Cost Unit and extended direct costs. Type a new value in the Unit 
Cost column to override the cost of the assembly or line 
item. Changing this value in a model task will permanently 
disconnect it from the model and will change the Source. 

Cost To Prime Cost To the Prime Contractor. The Total Bare plus the 
Location Adjustment and Sales Tax (as set in the Summary 
Info dialog box on the Cost Summary tab) for this task. 

NOTE: If the task is a user-added line item, Cost To Prime will be the same as Base Cost. 
Location Adjustments and Sales Tax do not get added to user-added line items. 

Cost to Owner Cost To the Project Owner. The Cost To Prime plus the 
Contractor Fees (as set in the Summary Info dialog box on 
the Cost Summary tab) for this task. 
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Project Cost Total Cost. The Cost To Owner plus any Other Costs (as set 
in the Summary Info dialog box on the Cost Summary tab) 
for this task. 

Assembly Members 

If the task is an assembly, this area lists the line items in the assembly. If the task 
is a line item, this area is blank. 

Description Description of the line item. 

Quantity Quantity of the line item. 

Units Unit of measure of the line item. 

Total Cost Total direct cost of the line item. 

Buttons on the Task Item Form 
The task item form has the same buttons as the folder item form as described earlier in this 
chapter, with the Addition of the Apply button. If you change the quantity or Base Cost, you 
can click Apply to view the changes in the form. Clicking Apply is not required. You can just 
change the quantity or Base Cost and then click on a different task or close the form. Your 
edits will be saved and applied whether you click Apply or not. The Insert button will add a 
new user-defined line item. 

Adding Direct Costs to the Estimate 
BSD CostLink/AE gives you four options for entering Direct Cost data in an estimate. You 
can create an estimate using a cost model, copy assemblies from the assemblies resource 
window, copy line items from the unit prices resource window, and insert user-defined line 
items directly into the project. 

NOTE: Tasks may also be copied from another BSD CostLink/AE project. 

About the Supplied Assemblies and Line Items 
The assemblies and line items that come with your subscription are the current year’s R.S. 
Means AE Assemblies and Building Construction Cost Data. See Chapter 1 for R.S. 
Means’ explanation of what is included in the costs. 
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Working With Resource Windows 
Each project you create has two resource windows from which you copy assemblies and 
line items into your estimate. The resource windows are: 

• Assemblies resource window  - stores assemblies 

• Unit Prices resource window  - stores line items. 

Opening Resource Windows 
In order to copy assemblies or line items into your project, you will need to open the desired 
resource window. To open a resource window, first open your project, and then use one of 
the following methods: 

• Click the appropriate button on the toolbar: 

 Open Assemblies resource window 

 Open Unit Prices resource window 

• Or, from the File menu, choose Open, and then choose the appropriate resource 
window. 

The resource window will open in a separate window. Depending on whether or not your 
project window is maximized, the resource window may cover up your project window. In 
order to view both windows at the same time (which makes it easier to copy tasks from the 
resource window to the project), tile the windows side-by-side using one of the following 
methods: 

• Click the Tile windows vertically button on the toolbar , 

• Or, from the Window menu, choose Tile Vertically. 

The resource window and the project window will display side-by-side. 

NOTE: You can also tile the windows horizontally or cascade the windows; however, in 
most cases it is easier to copy tasks with the windows tiled vertically. 

If more than two windows are open, the extra windows will also be tiled. If you do not need 
the extra windows, close them by clicking their close buttons . If you do not want to close 
the extra windows, minimize them and Tile Vertically again. 
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Copying Tasks From Resource Windows Into Projects 
Once you have both a resource window and your project open side-by-side, copy the task 
into your project using the following steps: 

1. Use Find to locate the task you want to copy, or if you know where the desired task is 
located, click the plus signs on the folders to navigate to it. 

 The assemblies and line items have many abbreviations in their descriptions. Because 
of this, it is usually easier to locate items by searching for the folder that would contain 
the task rather than for the description of the task. 

 To find out what the abbreviations stand for, enter the abbreviation into the Index tab of 
the Help dialog box. You can also enter a term in order to find out what its abbreviation 
is. 

 For more information on using Find, see Chapter 6. See Chapter 3 for information on 
using Help.  

2. Click on the folder that contains the task so you can see the task in the sheet panel. 

NOTE: Make sure the task you want to copy is a task, not a folder. Folders will show a 
folder icon (  or ) in the first column in the sheet panel, and tasks will show an 
assembly ( ) or line item ( ) icon. If you copy a folder, you will not only be 
copying the folder into your project, but also all of that folder’s subfolders and tasks. 

3. Copy the task into your project using one the following methods: 
• Drag and Drop: In the sheet panel of the resource window click and hold your left or 

right mouse button on any field for that task and, still holding down the mouse button, 
drag to the folder in your project where that task belongs. When the folder where you 
want to place the task becomes highlighted and your mouse pointer is a hand holding 

a sheet of paper ( ), release the mouse button. If you use the left mouse button, a 
confirmation message may open asking if you want to copy the task – click OK to copy 
the task. If you use the right mouse button, a context menu will open – click Copy 
Tasks Here to copy the task. 

NOTE: If the resource window is located on the left side of the screen and you drag the 
task with the left mouse button, the sheet panel may scroll to the right as you drag. 
Dragging with the right mouse button, or dragging from the gray box to the left of 
the task, does not cause the sheet panel to scroll. 
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• Copy and Paste: In the sheet panel of the resource window, copy the task as follows: 

- Left-click anywhere on the task. The current record indicator (an arrow ) will 
appear to the left of the task you clicked on. Then either click the Copy button on 
the toolbar , or from the Edit menu choose Copy. 

Then in the Tree Panel of the project, paste the task using one of the following methods: 

- Left-click on the folder in the Tree Panel where you want the task located. Then 
either click the Paste button on the toolbar , or from the Edit menu choose 
Paste. 

- Or, right-click on the folder in the Tree Panel where you want to paste the task, and 
from the context menu choose Paste. 

A confirmation message may open asking if you want to copy the task – click OK to 
copy the task. The task will be added to the folder. 

NOTE: You can also use CTRL+C to Copy and CTRL+V to Paste. 

4. After you copy a task into your project, if necessary click on the folder that contains the 
task so that you can see the task in the Sheet Panel. Then enter the quantity in the 
quantity field. 

About Assemblies 
In BSD CostLink/AE, an assembly is a group of line items that represent all the costs 
required to accomplish some piece of a project. The quantities for each of the component 
tasks in the assembly are linked to the assembly quantity. When you copy an assembly into 
a project and then supply the assembly quantity, BSD CostLink/AE automatically computes 
the quantities and costs for all of the line items in the assembly. 

Example of Use 
An assembly representing 6-inch concrete slab on grade includes all the line items required 
to prepare for, form, pour, and finish the slab. The assembly unit of measure is square feet. 
The assembly contains the unit costs and quantities of each line item required to construct 
one square foot of slab.  

When you copy the assembly into the project, you supply the square feet of slab needed 
for your estimate. BSD CostLink/AE then computes the total quantities and resulting costs 
of all the line items in the assembly for slab on grade construction. 
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How Assemblies Are Stored 
In projects and in Assemblies resource windows, assemblies are tasks and can be viewed 
in the sheet panel. The first column of an assembly in the sheet panel will show an 
assembly icon . The line items in the assembly can be viewed in the Members grid of 
the assembly’s task item form. 

Assembly Task Item Form 
The Assembly task item form shows information for the assembly currently selected in the 
sheet panel. It is similar to the task forms in the project and is opened using the same 
methods as described earlier in this chapter. 

 

Assemblies resource window task item form 

Description 

Task Description Description of the assembly. 

Unit Cost The total cost of 1 unit of the assembly. CostLink/AE 
calculates this by adding together the Total Costs of the 
line items listed in the Assembly Members grid. 
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Unit of Measure Unit of measure relevant to the assembly as a whole. 

Task Type 

These fields indicate the original source and type of the task. In order from left to 
right, the fields are as follows: 

Source ASM for assembly. 

Source Tag Displays a code that is used as a unique identifier for the 
assembly. 

Assembly Members grid 

Description Description of the member task. 

Quantity The quantity of the member per unit of the assembly. 

Units Unit of measure associated with the task. 

Total cost  Total cost of the member task per unit of the assembly. 

Buttons on the Assembly Form 
The buttons on the Assembly form are the same as on the folder item form as described 
earlier in this chapter, with the exception of the Insert button. New assemblies cannot be 
added to the Assemblies resource window. 

About Line Items 
To estimate a piece of the project that is smaller than an assembly, use a line item.  

How Line Items Are Stored 
Line items are stored in the Unit Prices resource window. They are tasks and can be 
viewed in the Sheet Panel. The first column of a line item in the Sheet Panel shows a line 
item icon . The unit price of the line item can be viewed in the Sheet Panel. 

NOTE: There are no item forms in the Unit Prices resource window. 
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Adding Your Own Line Items 
If the line item that you need cannot be found in the Unit Prices resource window, add a 
new line item in your project. Line items can be added for vendor or contractor lump sum 
quotes for pieces of the project. To add your own line item: 

1. In the Tree Panel of your project, click on the folder that should contain the new line 
item. 

2. From the Insert menu, choose Task. 

 A New Item is added to the Sheet Panel. 

3. Open the item form for the New Item and Enter the Description, Quantity, Unit of 
Measure, and Unit Cost. 

Cost Adjustments and Markups 
Cost adjustments and markups are applied to your project using the Cost Summary tab of 
the Summary Info dialog box. You can apply a Location Adjustment, Sales Tax, up to three 
types of Contractor Fees, and up to three types of Other Costs. 

Using the Cost Summary Tab 
Use the following steps to apply and edit markups in your project at any time: 

1. Open the Summary Info dialog box by choosing File > Summary Info, or by clicking the 
Open the database summary info dialog button on the toolbar . 

2. Click the Cost Summary tab. 
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Summary Info dialog box, Cost Summary tab 

3. Enter the desired information. (See below for an explanation of the fields and tips on 
entering information.) 

4. Click Apply to update the Cost and Cost per Unit fields. 

5. Click OK to close the Summary Info dialog box. 

6. If necessary, recalculate the estimate ( ) to update the information in the Tree Panel. 

About the Cost Summary Tab 
The following provides a description of the fields on the Cost Summary tab, tips for entering 
information into the fields, and an explanation of how the markups are calculated. 

Construction Priced from R.S. Means 

This line displays the project size and unit of measure that is entered on the 
General tab, the direct cost for R.S. Means cost items (i.e. the cost prior to 
adjustments and markups), and then divides the direct cost by the project size to 
show the project cost per unit. 
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Location Adjustment 

Use this area to adjust the national costs that you copy in from the resource 
windows for the costs where the project is located. The Location Adjustment and 
Sales Tax apply to costs copied from resource windows only. For more 
information on Location Adjustments, see chapter 1. 

State Click the arrow and then type the first letter of the state 
abbreviation to scroll to it quickly. Then click on the state 
abbreviation. The City field updates to the cities in that state. 
For Canadian locations, choose CN for Canada. 

City Click the arrow and then type the first letter of the city to 
scroll to it quickly. Then click on the correct city.  

Location 
Adjustment Cost 
Columns 

The field to the right of the city shows the percentage of the 
adjustment, positive or negative, that results from the 
selected city and state. Negative numbers are shown in red 
with a minus sign. The Cost and Per Unit fields for the 
Location Adjustment show the total dollar adjustment for the 
project and per unit. 

Sales Tax Enter the amount of sales tax that should be applied to 
material costs. 

Est Matl Cost Displays the Material cost of items copied in from the R.S. 
Means resource windows. 

Construction 
Priced Locally 

(The quantity and unit of measure displays from the General 
tab of the Summary Info dialog box.) The Cost field totals all 
user-added line items, and divides that total by the Project 
Size to calculate the Per Unit Cost. 

NOTE: Location Adjustments and Sales Tax do not apply to 
user added line items. 

Cost to Contractor The Cost and Per Unit columns for this line show the 
subtotal of the Construction Priced from R.S. Means plus (or 
minus) the Location Adjustment, plus Sales Tax, plus 
Construction Priced Locally. 

NOTE: If you change the State, City, or Sales Tax, click 
Apply to update these values. 
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Contractor Fees 

Use this area to enter up to three types of contractor fees. If desired, edit the 
existing description or enter a new description for the fee in the first field for each 
row. This description will print on reports. In the second field for each row, enter 
the markup percentage. 

These markups are compounded, meaning that if the Cost to Contractor is 
$100,000 and the first markup is 10%, the first markup will be $10,000, resulting in 
a subtotal of $110,000. If the second markup percentage is also 10%, it will be 
10% of the subtotal resulting in a markup of $11,000. The markup percentages 
are applied to the subtotal of the Cost to Contractor plus the previous markup 
amounts. If you would like the markups compounded in a different order, reenter 
them in the desired order. 

Construction 
Contract 

Click Apply to update the Cost and Per Unit columns for 
each fee, and to update the Construction Contract line. 

Other Costs 

Use this area in the same way as the Contractor Fees area to enter up to three 
other types of markups such as Architect’s Fees or Contingencies. 

Estimated Project 
Cost 

Click Apply to update the Cost and Per Unit columns for 
each Other Cost, and to update the Estimated Project Cost 
line. 
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Reports 

BSD CostLink/AE provides clean reports for presentation to clients. The Summary report 
can display costs at the folder level you choose. A Detailed Estimate is also available to 
itemize the assemblies and line items in your project.  

This chapter describes BSD CostLink/AE's reporting capabilities. 

• Reports overview 

• Reports dialog box 

• Report preview 

• Report descriptions 

• Creating electronic files from reports 
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Reports Overview 
Once the estimate is complete and the markups have been applied, you are ready to print 
your reports using these steps: 

1. If you would like your logo to print on the reports in the top right corner instead of the 
CostLink/AE logo, save a copy of your logo in the CostLink AE\System\Reports folder 
with the name logo.bmp, logo.gif, or logo.jpg.  

2. When you are ready to run reports, select the reports to run and the level for your 
Summary report in the Reports dialog box, Select Reports tab. 

3. Choose options for the reports on the Preferences tab.  

NOTE: Once you have established the report formats for an estimate, CostLink/AE 
remembers the last settings you used so that you can use the same formats 
repeatedly. You can make adjustments at any time. 

4. Click the Preview button to look over your selections and click the Print button to print 
the reports. 

The options, reports, and methods of producing paper and electronic copies of reports are 
described in this chapter. 

Reports Dialog box 
Use the Reports dialog box to choose the reports you want to print and to define settings for 
those reports. 

To open the Reports dialog box: 

• With a project open, from the File menu choose Reports Setup, or click the Select and 
format reports  toolbar button. 

Buttons on the Reports Dialog Box 
These buttons and controls appear at the bottom of dialog box. Their actions apply 
regardless of the tab you have selected. 

Print Prints the reports as currently selected and configured (not 
available on Preferences tab). 

Preview Opens a print preview window showing how the currently 
selected reports will look when printed on the default Windows 
printer (not available on Preferences tab). 

Setup Opens the Print Setup dialog box, which you can use to choose 
a different default printer or change printer settings. 
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Save as 
Default 

Saves current configuration as default. 

OK Closes the Reports dialog box and saves any changes you have 
entered, but does not print the reports. 

Cancel Closes the Reports dialog box and cancels any changes you 
have entered. 

Select Reports Tab 
Use this tab to select the level of the summary you want to print, and whether or not to print 
the Detail report. 

 
Reports dialog box, Select Reports tab 

For more information on the report types, see “Report Descriptions” later in this chapter. 

Organization 
Name 

Name of your company that will appear in the header on 
reports. 
NOTE: This defaults to the Company Name entered in 
the Permissions dialog box when the software was 
installed. To change the default Company Name, close 
all open projects and from the File menu choose 
Permissions. Enter the new Company Name and click 
OK. 
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Report Header Enter an optional report description in this field (for 
example “Estimate at 60%”). It will print as the second 
line of the header on each page of the report. 

Project Summary Report 

In this area, select options for the Project Summary Report. 

Levels to show in 
Summary 

Select the number of levels of folders that you would like 
to print in the Project Summary Report. Either click the 
up and down arrows, or type the number directly in the 
field. 

Include Level 1 
Summary 

In addition to the report at the number of levels you 
specified above, you may also print a Project Summary 
Report that summarizes the Level 1 folders only by 
selecting this option.  
NOTE: This option is not available if only one level is 
selected for Levels to show in Summary. 

Show Summary 
Costs 

Select how you would like Markups shown in the Project 
Summary Report. If you would like to print the costs 
before markups for each folder in the summary, and 
then have the markups added at the end, select 
Excluding Markups. If you would like the costs for each 
folder to already include the markups, select With 
Markups Included. 

Other Reports 

Use this area to select any other reports you would like to print.  

Print Title Page When selected, prints a title page that includes 
information entered on the General tab of the Summary 
Info dialog box. 

Table of Contents Check this option to include a table of contents for the 
report. The table of contents prints last. After you print 
you can put the table of contents after the title page. 

Detailed Estimate 
Report 

Choose this option to print a detail report of the 
estimate. This report shows the costs for every task and 
folder in the estimate. See the preferences tab for 
options on what to include in the costs. 
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Show Detail 
Costs 

Select how you would like Markups shown in the 
Detailed Estimate Report. If you would like to print the 
costs before markups for each task and folder, and then 
have the markups added at the end, select Excluding 
Markups. If you would like the costs for each task and 
folder to already include the markups, select With 
Markups Included. 

Preferences Tab 
Use this tab to choose options that affect how reports are formatted and printed. 

 
Reports dialog box, Preferences tab 

Detail and Summary Report Options 

Print Folder 
Titles 

Prints the title of each folder on both Detail and Summary 
Reports. 

Print Folder 
Totals 

Prints the subtotals for each folder on both Detail and 
Summary Reports. 

Unit Cost 
Column 

Prints a column showing the Unit Cost for each task and 
folder on both Detail and Summary Reports. 
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Print Percent 
of Parent to 
Level 

Prints a percent at the folder level to indicate what percent 
this folder represents of its parent folder. To leave the 
percentage off altogether, set the Print Percent of Parent to 
Level field to 0. If you set it at level 1, then only the level one 
folders will display the percent field. This option is for 
Summary reports only. 

Summary Report Options 

These options represent additional columns that can be printed for each 
folder on Project Summary reports. Check an option to include that column. 

Print Folder 
Tags 

Choose this option to print the Source Tags for the folders in 
the Summary Reports. 

Print Quantity 
Columns 

Choose this option to print the Quantities for the folders in 
the Summary Reports. 

Print Total 
Cost 
Columns 

Choose this option to print the subtotals for each folder. 

Print Notes and Footer 

Project Level Prints the notes entered in the Summary Info dialog box on 
the Project Notes tab. 

Folder Level Prints the notes entered on folders in the estimate. This 
option is applicable to the Detail report only. 

Task Level Prints the notes entered on tasks in the estimate. This option 
is applicable to the Detail report only. 

Footer Type text in the Footer field that should print at the bottom of 
every page. 

NOTE: The Project Number on the General Tab of the Summary Info 
dialog box prints on the left side of the footer. If you do not want 
the Project Number in the footer, leave that field blank in the 
Summary Info dialog box. 

Print Detail Options 

These check boxes represent optional columns you can include on Detail 
reports. 

Folder Tags Choose this option to print the tags or database IDs entered 
for each folder. 

Source Tags Choose this option to print the source tags (database IDs) 
associated with each task. 
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Custom Reports 
The Custom Reports tab is used to print custom reports. 

 
Reports dialog box, Custom Reports tab 

To modify the existing reports or to create new reports, you will need to use Crystal Reports 
version 8.5. (Alternatively, Building Systems Design, Inc. can create or modify reports for 
you. Call 1-800-266-7732 for a quote for modified or new reports.) Once the reports have 
been modified and/or created, they can be run from the Custom Reports tab. 

To print a custom report: 

1. Open the Reports Setup window from the File menu. 
2. Click on the Custom Reports tab. 
3. Click on the Add button. 
4. Navigate to the report that you have modified or created, highlight it and then click on 

the Open button. It will be added to the Custom Reports window. 
5. To print it, click on the Print or Preview button. 

Once you have printed a report, it will stay in the Custom Reports window, so you will need 
only to open the Custom Report tab and print the report. If you click on the Remove button 
in this window, the report is simply removed from the window; it is not deleted. 
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Report Preview 
The report preview window shows the currently selected reports as they will look when 
printed on the selected printer. 

NOTE: You must have a printer driver installed on your computer in order to preview 
reports. 

Displaying the Window 
You display the preview window by clicking Preview on the Reports dialog box. 

NOTE: If the preview is too small, maximize the preview window using the Maximize button 

in the upper right , and/or zoom in using the zoom selector . 

 
Preview of summary report, with logo added as described later in this chapter 
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Actions 
The report window has a toolbar with the following buttons: 

 Close current view. Available for drill-down only. See below. 

 Prints the report to the default Windows printer. 

 Opens the Export dialog box, which allows you to export the 
report in different formats. See Creating Electronic Copies of 
Reports later in this chapter. 

 
Click the down arrow to zoom in or out. 

 Go to the first page of the report.  

 Go to the previous page. 

 
Type the number of the page you want to view and press 
Enter. 

 Go to the next page. 

 Go to the last page. Click this button to compute and display 
the number of pages in the report. 

 Search text. Click this button to open a Search dialog box. 
Enter text and click Find Next. Matching text on the current 
page will display with a red selection box around it. 

 The standard Windows Minimize and Maximize buttons can 
be used. Use the Close button ( ) to close the preview 
without printing. 

Drill-Down Tabs 
Double-click on any title to create a drill-down tab that includes that title and its subtitles and 
details. The tabs are for on-screen viewing only; they do not affect printout. 

To create a drill-down tab: 

1. Preview a report. 
2. Double-click anywhere on the report. 
 An Estimate Detail or Summary Reports tab is created. 
3. Double-click on a title on the Estimate Detail or Summary Reports tab. 
 A tab is created that shows the title you double-clicked on and its subtitles and details. 
To create more drill-down tabs, click on the Estimate Detail tab and repeat step 3. 
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Preview window with drill-down tabs 

To remove the drill-down tabs, click the Close Current View button . 

Report Descriptions 
BSD CostLink/AE produces a detailed cost report and a presentation-style summary report. 

Project Summary 
The Project Summary Report summarizes cost information at each folder in an estimate, 
and does not list the tasks. Choose to include the markups in the costs for each folder, or to 
print the direct costs for each folder with the markups listed at the end. Select the level of 
breakdown using the Select Reports tab. 

Detailed Estimate Report 
The Detailed Estimate Report provides a complete listing of all tasks in an estimate. The 
costs are totaled at each folder in the estimate, with the tasks and their totals listed below 
each folder. Specify the formatting of this report using the Preferences tab of the Reports 
dialog box. The Detailed Estimate Report can print the notes you attach to tasks and folders 
if you select the Folder Level or Task Level options in the Preferences tab of the Reports 
dialog box.  

The detail report contains the following information: 

• Quantity, Unit of Measure, Unit Cost, and Total Cost for each task 

• Markups “Tail” at the end of the report, adding the Contractor Fees and Other Costs 
(optional) 

• Detail costs as either Cost to Prime (Excluding Markups, the default) or Total Project 
Cost (Including Markups), using the Show Detail Costs options on the Select Reports 
tab 

• Assemblies as a single task, rather than line listing each assembly member 

• Folder Tags and/or Source Tags (optional) 

• Notes added to folders and/or tasks (optional) 
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Inserting Your Company Logo 
Customize your reports by inserting a logo in the upper right corner of the reports. When 
you do not have a logo, the time that you printed the reports prints in the upper right. 

To insert a logo, save a copy of the logo in your CostLink AE\System\Reports folder with the 
name logo.bmp, logo.gif, or logo.jpg and print the report(s). 

Creating Electronic Copies of Reports 
Reports can be exported to a number of file formats using the Export button in the Print 

Preview window . Exported files can be emailed to individuals who do not have 
CostLink/AE, saved as archive copies of estimates, published on websites, or edited. 

NOTE: If someone wants you to email an electronic copy of the estimate and they have 
CostLink/AE, you can use the File > Save to Compressed feature (described in 
Chapter 6) to create a zipped file that you can attach to an email. They can then 
open the estimate in CostLink/AE, make edits, and send it back. 

Some of the more popular export options include: 

• Adobe Acrobat Portable Document Format (PDF) - can be opened and viewed in 
Acrobat Reader which can be downloaded for free from Adobe Acrobat's website 
www.adobe.com. PDF files can be minimally edited in the full version of Adobe Acrobat 
which is available for purchase at the same website.  

NOTE: If you own the full version of Adobe Acrobat, you can choose Acrobat as your printer 
in the Print Setup dialog box (available on the File menu). Print to the Acrobat 
printer to generate pdf files instead of using the Export button in the Preview 
window. 

• Excel (XLS) - can be opened and edited in Microsoft Excel. Formulas do not export, 
just text and dollars. 

• Rich Text (Exact) Format - can be opened and edited in any word processor except 
WordPerfect 5.1. 

• Word for Windows Format - can be opened and edited in Microsoft Word. 
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Tools and Techniques 

This chapter describes tools and techniques to help you work more efficiently and 
productively. 

• Use Find 

• Work with notes and pictures 

• Techniques for copying and moving folders and tasks 

• Delete empty folders 

• Copy projects 

• Compact databases 

• Save and load in compressed format 

• Customize Tools menu 

• Update to the current RS Means database 
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Using Find 
Use Find to search for folders and tasks in resource windows and in projects. The tasks in 
the resource windows contain many abbreviations. Because of this, it is often easier to 
search for the folders that would contain the tasks, rather than for the specific task. A 
complete list of the abbreviations and their meanings is provided in Appendix B. You can 
also type the abbreviation into the Index tab of the Help dialog box in order to find the term. 
Or you can type a term in order to find its abbreviation. 

For more information on Help, see Chapter 3. 

Find Dialog Box 

To open Find, from the Edit menu choose Find or click the Find button on the toolbar . 

 

Find dialog box 

Find What Enter the word(s) you expect to find in the task or folder 
description exactly as you expect it to be spelled. It is not case 
sensitive.  

Search Choose an option to search: 

All: searches the entire database starting at the beginning 
Up: in conjunction with Find Next, searches from your current 
position to the beginning 
Down: in conjunction with Find Next, searches from your 
current position to the end 

NOTE: To search from your current position to the end for tasks: 1. Click 
on a task in the sheet panel; 2. Open the Find dialog box; 3. Enter 
your search criteria; 4. Change the Search option to Down; 
5. Click Find Next. 
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Match Select the portion of the field that must match the Find What 
string. The options are: Any Part of the Field, Whole Field, or 
Start of the Field. 

Field Select to search the Description or Source Tag field. 

Tasks/ 
Folders 

Select one or both options to search for - tasks, folders, or 
both. 

Find First Click this button to find the first item matching your criteria, 
based on your selection in the Search field. 

Find Next  Click this button to find the next item after finding the first. 

Close Closes the Find dialog box. 

To search using the Find dialog box: 

1. If you have more than one window open, click in the window that you want to search. 

2. From the Edit menu choose Find, or click the Find toolbar button .  

 The Find In dialog box opens.  

3. Fill in the fields as described above. 

NOTE: Find searches for exact words. If you misspell a word, Find probably will not find it.  

4. Click the Find First button if the Search option is set to All. Other wise click Find Next. 

 BSD CostLink/AE performs the search and highlights the first found item in the sheet 
panel by placing an arrow to the left of it ( ) if it is a task. If the first found item is a 
folder on the tree, it opens the folder. 

NOTE: If a message opens reporting that “The search item was not found,” check the 
following:  
• Verify the Find title bar says it is searching the correct window; 
• Verify that the Find What field has no typos; 
• Verify that Field is set correctly; 
• Verify that Tasks or Folders is set correctly. 
If all is correct, try different words in the Find What field. 

5. If the correct item is located, click Close. If it is not the correct item, click Find Next. 
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Working with Notes and Pictures 
You can attach text notes and pictures to any folders and tasks in a project. When a folder 
or task has a note or picture attached, a cyan indicator is added to the bottom left of the 

folder or task icon: , , or . 

NOTE: See Chapter 4 for entering project-wide notes using the Summary Info dialog box. 

Attaching Notes or Pictures to a Folder or Task 
Within a project, use the Notes form to attach text notes or pictures to individual tasks or 
folders. The text notes can be printed on the detail report. The pictures are for display in 
CostLink/AE only, and cannot be printed. 

To attach text notes to a task or folder: 

1. Click on the task or folder in the sheet panel. 

2. Choose View > Notes Window, or click the Open the Notes form button on the toolbar 
. 

 The Notes form opens. The name of the folder or task that you clicked on is displayed 
above the white note area. 

 

Notes form, Notes tab 

3. On the Notes tab, type the Notes you want to attach or use CTRL+V to paste text from 
the Windows clipboard. 
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4. Click on another task or folder to enter another note. You do not need to Apply or Close 
before clicking on another task or folder. 

5. Click Close when finished. 

To attach pictures to a task or folder: 

1. Display the Notes form as above (steps 1 and 2). 

2. Click the Pictures tab. 

3. Click New. 

 BSD CostLink/AE opens the Load New Picture dialog box. 

4. Use the dialog box to select the picture file and click Open. 

 The picture is displayed on the tab. Use the field to the right to name the picture. 

5. Repeat step 3-4 to add more pictures to the same task or folder. Use Back and Next to 
navigate through the pictures. 

6. Click on another task or folder to enter a picture on a different folder or task 

7. Click Close when finished. 

Supported Graphics File Types 
BMP and JPG file types can be attached as pictures to a CostLink/AE task or folder. 

Viewing Notes and Pictures on Tasks or Folders 
When you see the cyan note icon on a task or folder, click on the folder or task and then 
display the notes form as described above. To view the note on another folder or task, 
leave the form open and click on the folder or task. 

Printing Notes with Reports 
You can choose to print text notes on the Detail Report of an estimate. 

To print notes on reports: 

1. Choose File > Reports Setup. 

2. Click the Preferences tab. 

3. In the Print Notes and Footer area, select the types of Notes you want to print. 

4. Click the Select Reports tab and click Print or Preview, or click OK to exit. 
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Techniques for Copying and Moving 
Tips and techniques for copying and moving tasks and folders in BSD CostLink/AE are 
described below. Much of this information involves standard mouse and keyboard 
operations for the Microsoft Windows operating systems. 

Using the Standard Windows Cut, Copy, and Paste Commands 
To move or copy tasks or folders from one location to another, use the standard Windows 
Cut, Copy, and Paste commands. These commands are available as buttons on the 
toolbar, in the Edit menu, and in context menus when you right-click.  

You can also cut, copy, or paste text in fields in item forms or while in edit mode on the 
name of a folder or task. To enter edit mode in the Tree Panel, click once on the name of a 
folder and then click again. In the Sheet Panel, click once on the name of a task or folder. 
When in edit mode the background of the text is blocked and a right click results in a 
context menu that contains only Cut, Copy, Paste, and Delete. 

When cutting or copying tasks (not just the description text) in the Sheet Panel, first select a 
task by clicking the selector box to the left of the item in the Sheet Panel so that the whole 
record is selected before using the commands from the Edit menu or the toolbar. You can 
select all the tasks in the Sheet Panel using Edit > Select All Tasks. Or you can select 
multiple tasks using CTRL and Shift as described later. 

You can move and copy tasks and folders by dragging them with your mouse. If you drag 
with the right mouse button you get additional options as described later. 

Be aware that when you cut an item, it may not disappear immediately from view. This is 
because BSD CostLink/AE does not automatically refresh the display when you Cut. If you 
close the window and reopen it, the cut item will be gone. Be sure to Paste the Cut item 
before you close the window. 

Shift-Click and Ctrl-Click 
Select folders and tasks in the Tree Panel or Sheet Panel by clicking the left (or primary) 
mouse button. In the Sheet Panel, hold down the Shift and Ctrl keys in combination with 
clicking to select multiple tasks: 

• Click on the selector box to the left of the first task with the left mouse button, and then 
hold down Shift while you left-click on the selector box for the last task to select a 
continuous range of tasks. 

• Click on the selector box to the left of the first task with the left mouse button, and then 
hold down Ctrl while you left-click on additional tasks to select multiple tasks not in a 
continuous range, or to remove the selection from a group of selected tasks. 
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These commands work the same as in standard Windows programs, such as Windows 
Explorer. 

Dragging and Dropping 
Drag and drop is a powerful tool for copying folders and tasks in BSD CostLink/AE. You 
can drag and drop items between the Tree or Sheet Panels of different windows. 

When you drag an item to a position where you are allowed to drop it, BSD CostLink/AE 
changes the mouse pointer to a hand with a page:  

 

Effects of Dragging and Dropping 
The default effect of dragging and dropping with the left mouse button depends on the 
situation as follows: 

When You Drag and Drop… Then BSD CostLink/AE… 

from a resource window to a project copies the item(s) 

within the same window 

Example:  You copy an assembly 
from the Assembly Resource 
window into your estimate. 

moves the item(s) 

Example:  You move tasks from one 
folder to another in the estimate. 

Left-Click and Right-Click for Drag and Drop 
When you drag and drop using the left mouse button, BSD CostLink/AE performs the 
default operations as listed in the table above. In most cases, BSD CostLink/AE allows 
other options besides the default. You can access these options by dragging with the right 
mouse button instead of the left. In this case, when you release the right mouse button to 
drop the item(s), BSD CostLink/AE opens a context menu with the available options. The 
default option (the one that would happen if you dragged with the left) is shown in bold. 

Tip: While learning to use BSD CostLink/AE, drag and drop using the right-mouse 
button. This helps you learn the effects of drag and drop in different situations. 

Turning off the Confirmation Prompt 
By default, BSD CostLink/AE prompts you to confirm before completing any drag and drop 
operation. You may turn this off from the Tools menu by choosing Prompt before 
completing Drag. When the option is turned on, there is a checkmark next to the command. 
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Deleting Empty Folders 
In your project, use Delete Empty Folders to remove folders that have no tasks. 

1. Choose Tools > Delete Empty Folders. 

 BSD CostLink/AE prompts you to confirm the command. 

2. Click OK. 

 BSD CostLink/AE deletes the empty folders in the project except those at Level 1. To 
delete any empty Level 1 folder, right-click on the folder and choose Delete. 

Copying a Project 
Use the Copy command in the File menu to copy a project database to a different name or 
location. 

To copy a project: 

1. Make sure the project you want to copy is not open. 

2. Choose File > Copy. 

 The Select Unopened File to be Copied dialog box opens. 

 

The Select Unopened File to be Copied dialog box 










































































































